[dpdk-dev] [PATCH v4 0/2] ethdev: add port speed capability bitmap

2015-09-07 Thread Marc Sune
2015-08-29 2:16 GMT+02:00 Marc Sune : > The current rte_eth_dev_info abstraction does not provide any mechanism to > get the supported speed(s) of an ethdev. > > For some drivers (e.g. ixgbe), an educated guess can be done based on the > driver's name (driver_name in rte_eth_dev_info), see: > >

[dpdk-dev] DPDK v2.1.0 with tilegx problem

2015-09-07 Thread Tony Lu
>-Original Message- >From: Mcnamara, John [mailto:john.mcnamara at intel.com] >Sent: Monday, September 07, 2015 4:52 PM >To: Arthas; dev >Cc: Zhigang Lu; Cyril Chemparathy; Zhigang Lu >Subject: RE: [dpdk-dev] DPDK v2.1.0 with tilegx problem > >CCing the Tile-GX maintainers. > >>

[dpdk-dev] DPDK v2.1.0 with tilegx problem

2015-09-07 Thread Arthas
This problem had solved! My tilegx libgxio don't support 'gxio_mpipe_link_enumerate_mac', only provide API ''gxio_mpipe_link_enumerate', add new api 'gxio_mpipe_link_enumerate_mac' for libgxio and compile ok! :) /* typedef struct { /** The address. */ uint8_t mac[6]; }

[dpdk-dev] [PATCH] doc: add missing field in ethertype_filter example in testpmd doc

2015-09-07 Thread Thomas Monjalon
2015-08-26 08:43, Pablo de Lara: > The two examples of ethertype_filter in testpmd documentation > were missing the mac address field, so the example was incorrect. > > Signed-off-by: Pablo de Lara Applied, thanks

[dpdk-dev] [PATCH] librte_eal: Fix wrong header file for old gcc version

2015-09-07 Thread Thomas Monjalon
2015-08-24 17:22, Michael Qiu: > For __SSE3__, the corresponding header file should be pmmintrin.h, > tmmintrin.h works for __SSSE3__. Please could you better explain the difference and what is exactly the bug being fixed? Thanks

[dpdk-dev] [PATCH v2 0/3] clean deprecated code in hash library

2015-09-07 Thread Thomas Monjalon
2015-09-04 15:56, Thomas Monjalon: > This patchset removes all deprecated macros and functions > from the hash library. > Then the DPDK version can be changed to 2.2.0-rc0. > > Changes in v2: > - increment hash library version > - merge hash patches > - increment DPDK version > > Pablo de Lara

[dpdk-dev] [PATCH] ixgbe: prefetch packet headers in vector PMD receive function

2015-09-07 Thread Zoltan Kiss
On 07/09/15 13:57, Richardson, Bruce wrote: > > >> -Original Message- >> From: Zoltan Kiss [mailto:zoltan.kiss at linaro.org] >> Sent: Monday, September 7, 2015 1:26 PM >> To: dev at dpdk.org >> Cc: Ananyev, Konstantin; Richardson, Bruce >> Subject: Re: [PATCH] ixgbe: prefetch packet

[dpdk-dev] [PATCH v3] mbuf/ip_frag: Move mbuf chaining to common code

2015-09-07 Thread Simon Kagstrom
Chaining/segmenting mbufs can be useful in many places, so make it global. Signed-off-by: Simon Kagstrom Signed-off-by: Johan Faltstrom --- ChangeLog: v2: * Check for nb_segs byte overflow (Olivier MATZ) * Don't reset nb_segs in tail (Olivier MATZ) v3: * Describe performance implications

[dpdk-dev] [PATCH v2] mbuf/ip_frag: Move mbuf chaining to common code

2015-09-07 Thread Simon Kågström
On 2015-09-07 14:32, Ananyev, Konstantin wrote: >> +static inline int rte_pktmbuf_chain(struct rte_mbuf *head, struct rte_mbuf >> *tail) >> +{ >> +struct rte_mbuf *cur_tail; >> + >> +/* Check for number-of-segments-overflow */ >> +if (head->nb_segs + tail->nb_segs >=

[dpdk-dev] [PATCH] ixgbe: prefetch packet headers in vector PMD receive function

2015-09-07 Thread Richardson, Bruce
> -Original Message- > From: Zoltan Kiss [mailto:zoltan.kiss at linaro.org] > Sent: Monday, September 7, 2015 3:15 PM > To: Richardson, Bruce; dev at dpdk.org > Cc: Ananyev, Konstantin > Subject: Re: [PATCH] ixgbe: prefetch packet headers in vector PMD receive > function > > > > On

[dpdk-dev] [PATCH] ip_pipeline: enable promiscuous mode configuration

2015-09-07 Thread Jasvinder Singh
This patch allows parser to read promisc entry from the LINK section defined in configuration file. It is an optional parameter: if present, value should be read (yes/no, on/off), else the value is the default value (i.e. 1 = promiscuous mode on) Example of config file: [LINK0] promisc = no;

[dpdk-dev] [PATCH] ip_pipeline: add check on nic's rxq and txq

2015-09-07 Thread Jasvinder Singh
This patch checks that rx queue and tx queue of each link specified in ip pipeline configuration file are used. Signed-off-by: Jasvinder Singh --- examples/ip_pipeline/config_check.c | 6 +- 1 file changed, 5 insertions(+), 1 deletion(-) diff --git a/examples/ip_pipeline/config_check.c

[dpdk-dev] [PATCH v2] mbuf/ip_frag: Move mbuf chaining to common code

2015-09-07 Thread Simon Kagstrom
Chaining/segmenting mbufs can be useful in many places, so make it global. Signed-off-by: Simon Kagstrom Signed-off-by: Johan Faltstrom --- ChangeLog: v2: * Check for nb_segs byte overflow (Olivier MATZ) * Don't reset nb_segs in tail (Olivier MATZ) lib/librte_ip_frag/ip_frag_common.h

[dpdk-dev] [PATCH] ip_pipeline: enable promiscuous mode configuration

2015-09-07 Thread Dumitrescu, Cristian
> -Original Message- > From: Singh, Jasvinder > Sent: Monday, September 7, 2015 3:58 PM > To: dev at dpdk.org > Cc: Dumitrescu, Cristian > Subject: [PATCH] ip_pipeline: enable promiscuous mode configuration > > This patch allows parser to read promisc entry from > the LINK section

[dpdk-dev] [PATCH] ip_pipeline: add check on nic's rxq and txq

2015-09-07 Thread Dumitrescu, Cristian
> -Original Message- > From: Singh, Jasvinder > Sent: Monday, September 7, 2015 3:54 PM > To: dev at dpdk.org > Cc: Dumitrescu, Cristian > Subject: [PATCH] ip_pipeline: add check on nic's rxq and txq > > This patch checks that rx queue and tx queue of each link > specified in ip

[dpdk-dev] [PATCH] ixgbe: prefetch packet headers in vector PMD receive function

2015-09-07 Thread Zoltan Kiss
Hi, I just realized I've missed the "[PATCH]" tag from the subject. Did anyone had time to review this? Regards, Zoltan On 01/09/15 20:17, Zoltan Kiss wrote: > The lack of this prefetch causes a significant performance drop in > OVS-DPDK: 13.3 Mpps instead of 14 when forwarding 64 byte

[dpdk-dev] [PATCH] ixgbe: prefetch packet headers in vector PMD receive function

2015-09-07 Thread Richardson, Bruce
> -Original Message- > From: Zoltan Kiss [mailto:zoltan.kiss at linaro.org] > Sent: Monday, September 7, 2015 1:26 PM > To: dev at dpdk.org > Cc: Ananyev, Konstantin; Richardson, Bruce > Subject: Re: [PATCH] ixgbe: prefetch packet headers in vector PMD receive > function > > Hi, > > I

[dpdk-dev] [PATCH RFC] mbuf/ip_frag: Move mbuf chaining to common code

2015-09-07 Thread Simon Kågström
On 2015-09-07 11:35, Olivier MATZ wrote: >> Wonder why do we need to do that? >> Probably head mbuf is out of space and want to expand it using >> pktmbuf_chain()? >> So in that case seems logical: >> 1) allocate new mbuf (it's pkt_len will be 0) >> b) call pktmbuf_chain() > > By experience,

[dpdk-dev] [PATCH v2] mbuf/ip_frag: Move mbuf chaining to common code

2015-09-07 Thread Ananyev, Konstantin
Hi Simon, Looks good to me, just one nit, see below. Konstantin > /** > + * Chain an mbuf to another, thereby creating a segmented packet. > + * > + * @param head the head of the mbuf chain (the first packet) > + * @param tail the mbuf to put last in the chain > + * > + * @return 0 on

[dpdk-dev] ixgbe: account more Rx errors Issue

2015-09-07 Thread Tahhan, Maryam
> From: Olivier MATZ [mailto:olivier.matz at 6wind.com] > Sent: Monday, September 7, 2015 9:30 AM > To: Tahhan, Maryam; Andriy Berestovskyy > Cc: dev at dpdk.org > Subject: Re: ixgbe: account more Rx errors Issue > > Hi, > > On 09/06/2015 07:15 PM, Tahhan, Maryam wrote: > >> From: Andriy

[dpdk-dev] [PATCH RFC] mbuf/ip_frag: Move mbuf chaining to common code

2015-09-07 Thread Olivier MATZ
Hi, >>> diff --git a/lib/librte_mbuf/rte_mbuf.h b/lib/librte_mbuf/rte_mbuf.h >>> index 8c2db1b..ef47256 100644 >>> --- a/lib/librte_mbuf/rte_mbuf.h >>> +++ b/lib/librte_mbuf/rte_mbuf.h >>> @@ -1801,6 +1801,29 @@ static inline int rte_pktmbuf_is_contiguous(const >>> struct rte_mbuf *m) >>> } >>>

[dpdk-dev] [PATCH 1/1] ip_frag: fix creating ipv6 fragment extension header

2015-09-07 Thread Dumitrescu, Cristian
> -Original Message- > From: Ananyev, Konstantin > Sent: Monday, September 7, 2015 2:23 PM > To: Dumitrescu, Cristian; Azarewicz, PiotrX T; dev at dpdk.org > Subject: RE: [dpdk-dev] [PATCH 1/1] ip_frag: fix creating ipv6 fragment > extension header > > > > > -Original Message-

[dpdk-dev] DPDK v2.1.0 with tilegx problem

2015-09-07 Thread Thomas Monjalon
2015-09-07 08:51, Mcnamara, John: > CCing the Tile-GX maintainers. The TILE-Gx maintainer is Zhigang Lu.

[dpdk-dev] [PATCH v3] librte_cfgfile(rte_cfgfile.h): modify the macros values

2015-09-07 Thread Dumitrescu, Cristian
> -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Jasvinder Singh > Sent: Friday, September 4, 2015 1:59 PM > To: dev at dpdk.org > Subject: [dpdk-dev] [PATCH v3] librte_cfgfile(rte_cfgfile.h): modify the > macros values > > This patch refers to the ABI

[dpdk-dev] [PATCH 1/1] ip_frag: fix creating ipv6 fragment extension header

2015-09-07 Thread Ananyev, Konstantin
> -Original Message- > From: Dumitrescu, Cristian > Sent: Monday, September 07, 2015 12:22 PM > To: Ananyev, Konstantin; Azarewicz, PiotrX T; dev at dpdk.org > Subject: RE: [dpdk-dev] [PATCH 1/1] ip_frag: fix creating ipv6 fragment > extension header > > > > > -Original

[dpdk-dev] [PATCH 1/1] ip_frag: fix creating ipv6 fragment extension header

2015-09-07 Thread Dumitrescu, Cristian
> -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Ananyev, > Konstantin > Sent: Friday, September 4, 2015 6:51 PM > To: Azarewicz, PiotrX T; dev at dpdk.org > Subject: Re: [dpdk-dev] [PATCH 1/1] ip_frag: fix creating ipv6 fragment > extension header > > Hi

[dpdk-dev] [PATCH] ring: add function to free a ring

2015-09-07 Thread Olivier MATZ
Hi Pablo, Please find some comments below. On 08/18/2015 04:00 PM, Pablo de Lara wrote: > When creating a ring, a memzone is created to allocate it in memory, > but the ring could not be freed, as memzones could not be. > > Since memzones can be freed now, then rings can be as well, > taking

[dpdk-dev] ixgbe: account more Rx errors Issue

2015-09-07 Thread Olivier MATZ
Hi, On 09/06/2015 07:15 PM, Tahhan, Maryam wrote: >> From: Andriy Berestovskyy [mailto:aber at semihalf.com] >> Sent: Friday, September 4, 2015 5:59 PM >> To: Tahhan, Maryam >> Cc: dev at dpdk.org; Olivier MATZ >> Subject: Re: ixgbe: account more Rx errors Issue >> >> Hi Maryam, >> Please see

[dpdk-dev] [PATCH RFC] mbuf/ip_frag: Move mbuf chaining to common code

2015-09-07 Thread Olivier MATZ
Hi Simon, I think it's a good idea. Please see some minor comments below. On 08/31/2015 02:41 PM, Simon Kagstrom wrote: > Chaining/segmenting mbufs can be useful in many places, so make it > global. > > Signed-off-by: Simon Kagstrom > Signed-off-by: Johan Faltstrom > --- > NOTE! Only

[dpdk-dev] [PATCH 3/4] virtio: use indirect ring elements

2015-09-07 Thread Thomas Monjalon
General comment after reading this page: http://dpdk.org/dev/patchwork/patch/6905/ Please remove useless context when replying to make answers shorter and easier to read. Thanks

[dpdk-dev] [RFC PATCH 0/6] remove pci driver from vdevs

2015-09-07 Thread Zende, Amruta S
Certain functions like "rte_eth_dev_socket_id" assume the device to be a PCI device and access pointers like rte_eth_devices[port_id].pci_dev->numa_node. Any such assumptions and dependencies should also be removed. Thanks & regards, Amruta Zende +91-20-4305-2969 -Original Message-

[dpdk-dev] CloudNetEngine vSwitch boosts performance

2015-09-07 Thread Thomas Monjalon
Hi Jun Xiao, 2015-09-05 10:01, Jun Xiao: > CloudNetEngine vSwitch boosts performance for both NFV and cloud use cases in > technical preview update 3.For the details, please refer to > http://cloudnetengine.com/en/blog/2015/09/05/cloudnetengine-vswitch-boosts-performance-cloud-an/ > One key

[dpdk-dev] [PATCH RFC] mbuf/ip_frag: Move mbuf chaining to common code

2015-09-07 Thread Ananyev, Konstantin
Hi lads, > -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Olivier MATZ > Sent: Monday, September 07, 2015 8:33 AM > To: Simon Kagstrom; dev at dpdk.org; Zhang, Helin; Gonzalez Monroy, Sergio; > Burakov, Anatoly > Subject: Re: [dpdk-dev] [PATCH RFC]

[dpdk-dev] [PATCH 0/4] RFC virtio performance enhancement and cleanups

2015-09-07 Thread Thomas Monjalon
Hi Stephen, 2015-09-04 13:58, Stephen Hemminger: > These are compile tested only, haven't debugged or checked out the corner > case. Submitted for discussion and future planning. > > Stephen Hemminger (4): > virtio: clean up space checks on xmit > virtio: don't use unlikely for normal tx

[dpdk-dev] DPDK v2.1.0 with tilegx problem

2015-09-07 Thread Mcnamara, John
CCing the Tile-GX maintainers. > -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Arthas > Sent: Saturday, September 5, 2015 2:49 AM > To: dev > Subject: [dpdk-dev] DPDK v2.1.0 with tilegx problem > > Hi, I'm working on tilegx platform. but when I compiled

[dpdk-dev] pcap->eth low TX performance

2015-09-07 Thread Yerden Zhumabekov
tx burst sends, say, 10-15% percent of a supplied array. The tail is being ignored so I have to drop it to avoid overflow. Ethernet device is 82599. In my app, I transmit all traffic through a ring then feed it to eth. That leads to overflow as well. 04.09.2015 20:03, Kyle Larose ?: > Are

[dpdk-dev] X710 : ntuple or flow director filtering problems

2015-09-07 Thread VERDOUX, Sylvain
Hello all, I'm currently trying hardware filtering on an Intel X710 NIC and i face several problems. I will briefly try to present what I want to achieve : I have 2 multicast streams coming on one port of my NIC with 2 different multicast groups/ports, and I want to filter and redirect them to

[dpdk-dev] [RFC PATCH 5/8] lib/librte_vhost:dequeue vhost TSO offload

2015-09-07 Thread Liu, Jijiang
> -Original Message- > From: Ouyang, Changchun > Sent: Monday, August 31, 2015 8:40 PM > To: Liu, Jijiang; dev at dpdk.org > Cc: Ouyang, Changchun > Subject: RE: [dpdk-dev] [RFC PATCH 5/8] lib/librte_vhost:dequeue vhost TSO > offload > > > > > -Original Message- > > From: dev

[dpdk-dev] [RFC PATCH 4/8] driver/virtio:enqueue TSO offload

2015-09-07 Thread Liu, Jijiang
> -Original Message- > From: Ouyang, Changchun > Sent: Monday, August 31, 2015 8:29 PM > To: Liu, Jijiang; dev at dpdk.org > Cc: Ouyang, Changchun > Subject: RE: [dpdk-dev] [RFC PATCH 4/8] driver/virtio:enqueue TSO offload > > > > > -Original Message- > > From: dev

[dpdk-dev] vhost compliant virtio based networking interface in container

2015-09-07 Thread Xie, Huawei
On 8/26/2015 5:23 PM, Tetsuya Mukawa wrote: > On 2015/08/25 18:56, Xie, Huawei wrote: >> On 8/25/2015 10:59 AM, Tetsuya Mukawa wrote: >>> Hi Xie and Yanping, >>> >>> >>> May I ask you some questions? >>> It seems we are also developing an almost same one. >> Good to know that we are tackling the