[dpdk-dev] [PATCH] fix for eth_pcap_tx() can cause mbuf corruption

2014-06-06 Thread Cao, Waterman
Tested-by: Waterman Cao

[dpdk-dev] [PATCHv2 0/5] ACL library

2014-06-06 Thread Cao, Waterman
Tested-by: Waterman Cao This patch has been tested by Intel. Basic functional test has been performed about 'l3fwd-acl', all cases are passed. It includes test_l3fwdacl_acl_rule, test_l3fwdacl_exact_route, test_l3fwdacl_lpm_route, test_l3fwdAcl_Scalar and test_l3fwdacl_invalid. There is one

[dpdk-dev] [memnic PATCH] linux: fix to disable softirq before netif_receive_skb()

2014-06-06 Thread Hiroshi Shimamoto
From: Hiroshi Shimamoto Calling netif_receive_skb() from memnic thread may cause deadlock, if softirq is not disabled. The netif_receive_skb() should be called in softirq context, but memnic thread is not softirq context. That may conflict softirq work like a timer

[dpdk-dev] [PATCH v2 0/4] Link Bonding Library

2014-06-06 Thread Doherty, Declan
> -Original Message- > From: Neil Horman [mailto:nhorman at tuxdriver.com] > Sent: Thursday, May 29, 2014 12:34 PM > To: Doherty, Declan > Cc: dev at dpdk.org > Subject: Re: [dpdk-dev] [PATCH 0/4] Link Bonding Library > > On Thu, May 29, 2014 at 10:33:00AM +, Doherty, Declan wrote: >

[dpdk-dev] [PATCH 0/2] L3FWD sample optimisation

2014-06-06 Thread De Lara Guarch, Pablo
Acked-by: Pablo de Lara Guarch > -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Konstantin Ananyev > Sent: Thursday, May 22, 2014 5:56 PM > To: dev at dpdk.org; dev at dpdk.org > Subject: [dpdk-dev] [PATCH 0/2] L3FWD sample optimisation > > With latest HW

[dpdk-dev] [PATCHv2 0/5] ACL library

2014-06-06 Thread De Lara Guarch, Pablo
Acked-by: Pablo de Lara Guarch > -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Konstantin Ananyev > Sent: Wednesday, May 28, 2014 8:27 PM > To: dev at dpdk.org; dev at dpdk.org > Subject: [dpdk-dev] [PATCHv2 0/5] ACL library > > The ACL library is used to

[dpdk-dev] [PATCH v2 1/4] Link Bonding Library

2014-06-06 Thread Doherty, Declan
> -Original Message- > From: Stephen Hemminger [mailto:stephen at networkplumber.org] > Sent: Thursday, June 5, 2014 4:16 PM > To: Doherty, Declan > Cc: dev at dpdk.org > Subject: Re: [dpdk-dev] [PATCH v2 1/4] Link Bonding Library > > On Wed, 4 Jun 2014 16:18:02 +0100 > declan.doherty at

[dpdk-dev] [PATCH] fix trailing whitespace.

2014-06-06 Thread Neil Horman
On Wed, Jun 04, 2014 at 12:42:50AM +0100, Bruce Richardson wrote: > This commit removes trailing whitespace from lines in files. Almost all > files are affected, as the BSD license copyright header had trailing > whitespace on 4 lines in it [hence the number of files reporting 8 lines > changed in

[dpdk-dev] [memnic PATCH 0/5] support variable frame size

2014-06-06 Thread Hiroshi Shimamoto
From: Hiroshi Shimamoto This patchset provides variable frame size functionality with MEMNIC extra features framework. First, update the memnic.h to synchronise upstream data structure which has extra feature framework. Next, prepare for changing frame size. Finally

[dpdk-dev] [memnic PATCH 1/5] common: update memnic.h to support variable frame size

2014-06-06 Thread Hiroshi Shimamoto
From: Hiroshi Shimamoto Update MEMNIC data structure in common header file. Prepare to support extra features for MEMNIC. Change name reserved to request which will be used to negotiate between host and guest, and add feature flag and other definitions.

[dpdk-dev] [memnic PATCH 2/5] pmd: prepare to support variable frame size

2014-06-06 Thread Hiroshi Shimamoto
From: Hiroshi Shimamoto Add framesz field in adapter structure, and initialized with the current frame size. Replace length check on TX/RX with the above frame size. Signed-off-by: Hiroshi Shimamoto Reviewed-by: Hayato Momma --- pmd/pmd_memnic.c | 10 +++--- 1

[dpdk-dev] [memnic PATCH 3/5] pmd: support variable frame size

2014-06-06 Thread Hiroshi Shimamoto
From: Hiroshi Shimamoto If the MEMNIC framework has the feature MEMNIC_FEAT_FRAME_SIZE and configured frame size, set request bit and frame size to support larger frame size on reset. Don't trust framesz of header in general usage, because host might change the value

[dpdk-dev] [memnic PATCH 4/5] linux: prepare to support variable frame size

2014-06-06 Thread Hiroshi Shimamoto
From: Hiroshi Shimamoto Add framesz field in memnic data structure, and initialized with the current frame size. Replace length check on TX/RX with the above frame size. Signed-off-by: Hiroshi Shimamoto Reviewed-by: Hayato Momma --- linux/memnic_net.c | 7 +--

[dpdk-dev] [memnic PATCH 5/5] linux: support MTU change

2014-06-06 Thread Hiroshi Shimamoto
From: Hiroshi Shimamoto Add the capability to change MTU. On MTU change, remember the corresponding frame size and request new frame size to the host on reset, if the host MEMNIC has that feature. Don't trust framesz of header in general usage, because host might

[dpdk-dev] [PATCH v2 1/4] Link Bonding Library

2014-06-06 Thread Stephen Hemminger
On Fri, 6 Jun 2014 09:07:23 + "Doherty, Declan" wrote: > > -Original Message- > > From: Stephen Hemminger [mailto:stephen at networkplumber.org] > > Sent: Thursday, June 5, 2014 4:16 PM > > To: Doherty, Declan > > Cc: dev at dpdk.org > > Subject: Re: [dpdk-dev] [PATCH v2 1/4] Link

[dpdk-dev] [RFC] librte_pmd_packet: add PMD for AF_PACKET-based virtual devices

2014-06-06 Thread John W. Linville
On Fri, Jun 06, 2014 at 12:47:48PM -0700, Chris Wright wrote: > * John W. Linville (linville at tuxdriver.com) wrote: > > This is a Linux-specific virtual PMD driver backed by an AF_PACKET > > socket. The current implementation uses mmap'ed ring buffers to > > limit copying and user/kernel

[dpdk-dev] [RFC] librte_pmd_packet: add PMD for AF_PACKET-based virtual devices

2014-06-06 Thread Chris Wright
* John W. Linville (linville at tuxdriver.com) wrote: > On Fri, Jun 06, 2014 at 12:47:48PM -0700, Chris Wright wrote: > > * John W. Linville (linville at tuxdriver.com) wrote: > > > This is a Linux-specific virtual PMD driver backed by an AF_PACKET > > > socket. The current implementation uses

[dpdk-dev] [RFC] librte_pmd_packet: add PMD for AF_PACKET-based virtual devices

2014-06-06 Thread Richardson, Bruce
> -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of John W. Linville > Sent: Friday, June 06, 2014 12:57 PM > To: Chris Wright > Cc: dev at dpdk.org > Subject: Re: [dpdk-dev] [RFC] librte_pmd_packet: add PMD for AF_PACKET- > based virtual devices > > On Fri,

[dpdk-dev] Licensing consistency

2014-06-06 Thread John W. Linville
On Fri, Jun 06, 2014 at 08:18:21PM +, Butler, Siobhan A wrote: > > > >-Original Message- > >From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Neil Horman > >Sent: Thursday, June 5, 2014 7:57 PM > >To: dev at dpdk.org > >Subject: [dpdk-dev] Licensing consistency > > > >Hey all-

[dpdk-dev] [RFC] librte_pmd_packet: add PMD for AF_PACKET-based virtual devices

2014-06-06 Thread Neil Horman
On Fri, Jun 06, 2014 at 03:25:54PM -0400, John W. Linville wrote: > This is a Linux-specific virtual PMD driver backed by an AF_PACKET > socket. The current implementation uses mmap'ed ring buffers to > limit copying and user/kernel transitions. The intent is also to take > advantage of fanout

[dpdk-dev] [RFC] librte_pmd_packet: add PMD for AF_PACKET-based virtual devices

2014-06-06 Thread John W. Linville
On Fri, Jun 06, 2014 at 04:30:50PM -0400, Neil Horman wrote: > On Fri, Jun 06, 2014 at 03:25:54PM -0400, John W. Linville wrote: > > This is a Linux-specific virtual PMD driver backed by an AF_PACKET > > socket. The current implementation uses mmap'ed ring buffers to > > limit copying and

[dpdk-dev] [RFC] librte_pmd_packet: add PMD for AF_PACKET-based virtual devices

2014-06-06 Thread Neil Horman
On Fri, Jun 06, 2014 at 04:36:11PM -0400, John W. Linville wrote: > On Fri, Jun 06, 2014 at 04:30:50PM -0400, Neil Horman wrote: > > On Fri, Jun 06, 2014 at 03:25:54PM -0400, John W. Linville wrote: > > > This is a Linux-specific virtual PMD driver backed by an AF_PACKET > > > socket. The current

[dpdk-dev] Licensing consistency

2014-06-06 Thread Neil Horman
On Fri, Jun 06, 2014 at 04:23:47PM -0400, John W. Linville wrote: > On Fri, Jun 06, 2014 at 08:18:21PM +, Butler, Siobhan A wrote: > > > > > > >-Original Message- > > >From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Neil Horman > > >Sent: Thursday, June 5, 2014 7:57 PM > >

[dpdk-dev] [PATCH v2 00/10] igb_uio patches

2014-06-06 Thread Stephen Hemminger
These apply to the current DPDK tree, and are an alternative to the patches from Alan. It provides indication of IRQ mode via sysfs attribute.

[dpdk-dev] [PATCH v2 01/10] igb_uio: use kernel standard log message

2014-06-06 Thread Stephen Hemminger
Use Linux kernel standard coding conventions for console messages. Bare use of printk() is not desirable and is reported as a style problem by checkpatch. Instead use pr_info() and dev_info() to print out log messages where appropriate. Signed-off-by: Stephen Hemminger ---

[dpdk-dev] [PATCH v2 02/10] igb_uio: use standard uio naming

2014-06-06 Thread Stephen Hemminger
Don't put capitialization and space in name since it will show up in /proc/interrupts. Instead use driver name to follow the conventions used in the kernel by other drivers. Signed-off-by: Stephen Hemminger --- a/lib/librte_eal/linuxapp/igb_uio/igb_uio.c +++

[dpdk-dev] [PATCH v2 03/10] igb_uio: fix checkpatch warnings

2014-06-06 Thread Stephen Hemminger
Fix whitespace and other style issues reported by checkpatch. Signed-off-by: Stephen Hemminger --- a/lib/librte_eal/linuxapp/igb_uio/igb_uio.c +++ b/lib/librte_eal/linuxapp/igb_uio/igb_uio.c @@ -1,23 +1,23 @@ /*- * GPL LICENSE SUMMARY - * + * * Copyright(c) 2010-2014 Intel Corporation.

[dpdk-dev] [PATCH v2 04/10] igb_uio: dont wrap pci_num_vf function needlessly

2014-06-06 Thread Stephen Hemminger
It is better style to just use the pci_num_vf directly, rather than wrapping it with a local (but globally named) function with the same effect. Signed-off-by: Stephen Hemminger --- a/lib/librte_eal/linuxapp/igb_uio/igb_uio.c +++ b/lib/librte_eal/linuxapp/igb_uio/igb_uio.c @@ -98,9 +98,8 @@ }

[dpdk-dev] [PATCH v2 05/10] Subjec: igb_uio: msix cleanups

2014-06-06 Thread Stephen Hemminger
Since only one MSI-X entry is ever defined, there is no need to put it as an array in the driver private data structure. One msix_entry can just be put on the stack and initialized there. Also remove the unused backport defines related to MSI-X. I suspect this code was just inherited from some

[dpdk-dev] [PATCH v2 06/10] igb_uio: propogate error numbers in probe code

2014-06-06 Thread Stephen Hemminger
It is good practice to propogate the return values of failing functions so that more information can be reported. The failed result of probe will make it out to errno and get printed by modprobe and will aid in diagnosis of failures. Signed-off-by: Stephen Hemminger ---

[dpdk-dev] [PATCH v2 07/10] igb_uio: make irq mode param read-only

2014-06-06 Thread Stephen Hemminger
The module parameter is read-only since changing mode after loading isn't going to work. Signed-off-by: Stephen Hemminger --- a/lib/librte_eal/linuxapp/igb_uio/igb_uio.c +++ b/lib/librte_eal/linuxapp/igb_uio/igb_uio.c @@ -647,7 +647,7 @@ module_init(igbuio_pci_init_module);

[dpdk-dev] [PATCH v2 08/10] igb_uio: fix IRQ mode handling

2014-06-06 Thread Stephen Hemminger
This pach reworks how IRQ mode handling is done. The biggest code change is to use the standard INTX management code that exists in more recent kernels (and provide backport version). This also fixes the pci_lock code which was broken, since it was not protecting against config access, and was

[dpdk-dev] [PATCH v2 09/10] igbuio: show irq mode in sysfs

2014-06-06 Thread Stephen Hemminger
Since irq mode is determined dynamically on a per-device basis, and virtio needs to know if using intx or msi-x, make it a sysfs attribute. --- a/lib/librte_eal/linuxapp/igb_uio/igb_uio.c +++ b/lib/librte_eal/linuxapp/igb_uio/igb_uio.c @@ -43,6 +43,10 @@ IGBUIO_MSIX_INTR_MODE }; +static

[dpdk-dev] [PATCH v2 10/10] igbuio: use mode string for module param

2014-06-06 Thread Stephen Hemminger
Since we now have a list of interrupt modes for sysfs, use that to match module param values. This also allows msi to be selected as a preferred mode. Signed-off-by: Stephen Hemminger --- a/lib/librte_eal/linuxapp/igb_uio/igb_uio.c +++ b/lib/librte_eal/linuxapp/igb_uio/igb_uio.c @@ -605,21