[dpdk-dev] [PATCH] rte_eth_ctrl: rename rte_eth_fdir_flow.ip6_flow

2014-12-09 Thread Mark Kavanagh
is linked with an application that uses the afforementioned header, the macro is expanded within the DPDK struct, causing a compilation error. Regards, Mark Mark Kavanagh (1): rte_eth_ctrl: rename rte_eth_fdir_flow.ip6_flow app/test-pmd/cmdline.c | 4 ++-- lib/librte_ether/rte_eth_ctrl.h

[dpdk-dev] [PATCH] rte_eth_ctrl: rename rte_eth_fdir_flow.ip6_flow

2014-12-09 Thread Mark Kavanagh
. Rename the relevant attribute in DPDK to resolve this. Signed-off-by: Mark Kavanagh --- app/test-pmd/cmdline.c | 4 ++-- lib/librte_ether/rte_eth_ctrl.h | 2 +- lib/librte_pmd_i40e/i40e_fdir.c | 4 ++-- 3 files changed, 5 insertions(+), 5 deletions(-) diff --git a/app/test-pmd

[dpdk-dev] [PATCH] doc: fix vhost setup in tep-termination app guide

2016-07-19 Thread Mark Kavanagh
- Fix vhost setup flags - Add minor edits to improve readability and consistency Signed-off-by: Mark Kavanagh --- doc/guides/sample_app_ug/tep_termination.rst | 8 1 file changed, 4 insertions(+), 4 deletions(-) mode change 100644 => 100755 doc/guides/sample_app_ug/tep_termination.

[dpdk-dev] [PATCH V2] doc: fix vhost setup in tep-termination app guide

2016-07-21 Thread Mark Kavanagh
- Fix vhost setup flags - Add minor edits to improve readability and consistency --- v2: - revert file mode changes made erroneously in v1 Signed-off-by: Mark Kavanagh --- doc/guides/sample_app_ug/tep_termination.rst | 8 1 file changed, 4 insertions(+), 4 deletions(-) mode change

[dpdk-dev] [PATCH V2] doc: fix vhost setup in tep-termination app guide

2016-07-21 Thread Mark Kavanagh
- Fix vhost setup flags - Add minor edits to improve readability and consistency --- v2: - revert file mode changes made erroneously in v1 Signed-off-by: Mark Kavanagh --- doc/guides/sample_app_ug/tep_termination.rst | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git

[dpdk-dev] [PATCH 1/1] doc: fix errors in pdump doc

2016-10-06 Thread Mark Kavanagh
- Fix copy/paste error in description of how to capture both rx & tx traffic in a single pcap file - Replace duplicate word with what original author presumably intended, such that description now makes sense Signed-off-by: Mark Kavanagh --- doc/guides/sample_app_ug/pdump.rst | 4 ++-

[dpdk-dev] [PATCH 1/7] ofproto: Consider datapath_type when looking for internal ports.

2016-08-05 Thread Mark Kavanagh
From: Daniele Di Proietto Interfaces with type "internal" end up having a netdev with type "tap" in the dpif-netdev datapath, so a strcmp will fail to match internal interfaces. We can translate the types with ofproto_port_open_type() before calling strcmp to fix this.

[dpdk-dev] [PATCH 2/7] vswitchd: Introduce 'mtu_request' column in Interface.

2016-08-05 Thread Mark Kavanagh
From: Daniele Di Proietto The 'mtu_request' column can be used to set the MTU of a specific interface. This column is useful because it will allow changing the MTU of DPDK devices (implemented in a future commit), which are not accessible outside the ovs-vswitchd

[dpdk-dev] [PATCH 3/7] netdev: Pass 'netdev_class' to ->run() and ->wait().

2016-08-05 Thread Mark Kavanagh
From: Daniele Di Proietto This will allow run() and wait() methods to be shared between different classes and still perform class-specific work. Signed-off-by: Daniele Di Proietto --- lib/netdev-bsd.c | 6 +++--- lib/netdev-dummy.c| 4 ++--

[dpdk-dev] [PATCH 4/7] netdev-dummy: Add dummy-internal class.

2016-08-05 Thread Mark Kavanagh
From: Daniele Di Proietto "internal" netdevs are treated specially in OVS (e.g. for MTU), but the dummy datapath remaps both "system" and "internal" devices to the same "dummy" netdev class, so there's no way to discern those in tests. This commit adds a new

[dpdk-dev] [PATCH 5/7] tests: Add a new MTU test.

2016-08-05 Thread Mark Kavanagh
From: Daniele Di Proietto Also, netdev-dummy needs to call netdev_change_seq_changed() in set_mtu(). Signed-off-by: Daniele Di Proietto --- lib/netdev-dummy.c| 5 - tests/ofproto-dpif.at | 30 ++ 2 files changed, 34 insertions(+), 1

[dpdk-dev] [PATCH 6/7] netdev: Make netdev_set_mtu() netdev parameter non-const.

2016-08-05 Thread Mark Kavanagh
From: Daniele Di Proietto Every provider silently drops the const attribute when converting the parameter to the appropriate subclass. Might as well drop the const attribute from the parameter, since this is a "set" function. Signed-off-by: Daniele Di Proietto ---

[dpdk-dev] [PATCH 7/7] netdev-dpdk: add support for Jumbo Frames

2016-08-05 Thread Mark Kavanagh
-off-by: Mark Kavanagh [diproiettod at vmware.com rebased] Signed-off-by: Daniele Di Proietto --- Previous: http://openvswitch.org/pipermail/dev/2016-July/076845.html v2->v1: - rebase to HEAD of master - fall back to previous 'good' MTU if reconfigure fails - introduce new fi

[dpdk-dev] [PATCH 1/1] doc: clarify usage of testpmd mac fwd mode

2016-09-09 Thread Mark Kavanagh
Explain default testpmd behavior in mac fwd mode to remove amiguity/confusion regarding user's ability to specify Ethernet addresses. Signed-off-by: Mark Kavanagh --- doc/guides/testpmd_app_ug/testpmd_funcs.rst | 3 +++ 1 file changed, 3 insertions(+) diff --git a/doc/guides/testpmd_app_ug