Re: Documentation glitch w/AsyncFunction?

2018-04-14 Thread Ted Yu
Sounds good to me. On Sat, Apr 14, 2018 at 9:55 AM, Ken Krugler wrote: > Hi Ted, > > Thanks - yes regarding renaming the variable, and changing the type. > > The other issue is that most clients return a Future, not a > CompletableFuture. > > So should I do the bit

Re: Documentation glitch w/AsyncFunction?

2018-04-14 Thread Ken Krugler
Hi Ted, Thanks - yes regarding renaming the variable, and changing the type. The other issue is that most clients return a Future, not a CompletableFuture. So should I do the bit of extra code to show using a CompletableFuture with a Future? — Ken > On Apr 14, 2018, at 9:13 AM, Ted Yu

Re: Documentation glitch w/AsyncFunction?

2018-04-14 Thread Ted Yu
bq. resultFuture.thenAccept( (String result) -> { I think the type of variable for the above call should be CompletableFuture. Meaning, the variable currently named resultFuture should be renamed so that the intention is clearer. bq.

Documentation glitch w/AsyncFunction?

2018-04-14 Thread Ken Krugler
Hi devs, https://ci.apache.org/projects/flink/flink-docs-release-1.4/dev/stream/operators/asyncio.html Has this example of asyncInvoke: > @Override > public void asyncInvoke(final String str,