KuiLIU created GERONIMO-6603:
--------------------------------

             Summary: Inconsistent method name
                 Key: GERONIMO-6603
                 URL: https://issues.apache.org/jira/browse/GERONIMO-6603
             Project: Geronimo
          Issue Type: Improvement
      Security Level: public (Regular issues)
            Reporter: KuiLIU


The following method is named "listBundles".
"listBundles" seems that the method will return a list of bundles.
Actually, this method adds the bundles into the log info.
Thus, "logBundles" should be more intuitive than "listBundles".

{code:java}
protected void listBundles(BundleContext ctx) {
        StringBuilder b = new StringBuilder("Bundles:");
        for (Bundle bundle: ctx.getBundles()) {
            b.append("\n   Id:").append(bundle.getBundleId()).append("  
status:").append(bundle.getState()).append("  ").append(bundle.getLocation());
        }
        getLog().info(b.toString());
    }
{code}




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to