stack created HBASE-8629:
----------------------------

             Summary: More log edits: we log too much
                 Key: HBASE-8629
                 URL: https://issues.apache.org/jira/browse/HBASE-8629
             Project: HBase
          Issue Type: Umbrella
            Reporter: stack


+ Our thread names are nice and descriptive and are useful particularly when 
running standlone mode but it gets silly printing out full thread names when 
distributed on each log (we could turn off printing thread name but can be 
helpful).
+ Do we have to print the fully qualified path for all files every time?  Lines 
get really long and hard to read.  Ditto for region names.
+ Can we print out just the class name rather than full package qualified class 
name.

For example:

{code}
2013-05-25 12:21:01,912 DEBUG 
[RS_OPEN_REGION-sss-2.ent.cloudera.com,60020,1369507494038-2] 
org.apache.hadoop.hbase.regionserver.handler.OpenRegionHandler: region 
transitioned to opened in zookeeper: {NAME => 
'IntegrationTestDataIngestWithChaosMonkey,c28f5c19,1369509660096.4e91d414f14a75cf367609ce9c4377c7.',
 STARTKEY => 'c28f5c19', ENDKEY => 'ccccccbc', ENCODED => 
4e91d414f14a75cf367609ce9c4377c7,}, server: 
sss-2.ent.cloudera.com,60020,1369507494038
{code}

Should the above just be:

{code}
2013-05-25 12:21:01,912 DEBUG 
[RS_OPEN_REGION-sss-2.ent.cloudera.com,60020,1369507494038-2] 
OpenRegionHandler: region 4e91d414f14a75cf367609ce9c4377c7 transitioned to 
opened
{code}


+ Some logging is bound to freak operators.  We print out the full stack trace 
when we are logging failed assignment because of connection refused.
+ Should  make sure we tell a decent story when INFO level only enabled.  At 
moment it is scattershot.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to