[jira] [Created] (HIVE-23933) Add getRowCountInt support for anti join in calcite.

2020-07-26 Thread mahesh kumar behera (Jira)
mahesh kumar behera created HIVE-23933:
--

 Summary: Add getRowCountInt support for  anti join in calcite. 
 Key: HIVE-23933
 URL: https://issues.apache.org/jira/browse/HIVE-23933
 Project: Hive
  Issue Type: Bug
Reporter: mahesh kumar behera
Assignee: mahesh kumar behera


The current anti join conversion does not support direct conversion of 
not-exists to anti join. The not exists sub query is converted first to left 
out join and then its converted to anti join. This may cause some of the 
optimization rule to be skipped.

 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Created] (HIVE-23935) Fetching primaryKey through beeline fails with NPE

2020-07-26 Thread Ayush Saxena (Jira)
Ayush Saxena created HIVE-23935:
---

 Summary: Fetching primaryKey through beeline fails with NPE
 Key: HIVE-23935
 URL: https://issues.apache.org/jira/browse/HIVE-23935
 Project: Hive
  Issue Type: Bug
Reporter: Ayush Saxena
Assignee: Ayush Saxena


Fetching PrimaryKey of a table through Beeline !primarykey fails with NPE
{noformat}
0: jdbc:hive2://localhost:1> !primarykeys Persons
Error: MetaException(message:java.lang.NullPointerException) (state=,code=0)
org.apache.hive.service.cli.HiveSQLException: 
MetaException(message:java.lang.NullPointerException)
at org.apache.hive.jdbc.Utils.verifySuccess(Utils.java:360)
at org.apache.hive.jdbc.Utils.verifySuccess(Utils.java:351)
at 
org.apache.hive.jdbc.HiveDatabaseMetaData.getPrimaryKeys(HiveDatabaseMetaData.java:573)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.hive.beeline.Reflector.invoke(Reflector.java:89)
at org.apache.hive.beeline.Commands.metadata(Commands.java:125)
at org.apache.hive.beeline.Commands.primarykeys(Commands.java:231)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at 
org.apache.hive.beeline.ReflectiveCommandHandler.execute(ReflectiveCommandHandler.java:57)
at 
org.apache.hive.beeline.BeeLine.execCommandWithPrefix(BeeLine.java:1465)
at org.apache.hive.beeline.BeeLine.dispatch(BeeLine.java:1504)
at org.apache.hive.beeline.BeeLine.execute(BeeLine.java:1364)
at org.apache.hive.beeline.BeeLine.begin(BeeLine.java:1134)
at org.apache.hive.beeline.BeeLine.begin(BeeLine.java:1082)
at 
org.apache.hive.beeline.BeeLine.mainWithInputRedirection(BeeLine.java:546)
at org.apache.hive.beeline.BeeLine.main(BeeLine.java:528)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.hadoop.util.RunJar.run(RunJar.java:323)
at org.apache.hadoop.util.RunJar.main(RunJar.java:236){noformat}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Created] (HIVE-23934) Refactor TezCompiler#markSemiJoinForDPP to avoid redundant operations in nested while

2020-07-26 Thread Stamatis Zampetakis (Jira)
Stamatis Zampetakis created HIVE-23934:
--

 Summary: Refactor TezCompiler#markSemiJoinForDPP to avoid 
redundant operations in nested while
 Key: HIVE-23934
 URL: https://issues.apache.org/jira/browse/HIVE-23934
 Project: Hive
  Issue Type: Improvement
Reporter: Stamatis Zampetakis
Assignee: Stamatis Zampetakis


Most of the code inside the nested while loop can be extracted and computed 
only once in the external loop. Moreover there are catch clauses for NPE which 
seem rather predictable and could possibly be avoided by proper checks.  

The goal of this issue is to refactor TezCompiler#markSemiJoinForDPP method to 
avoid redundant operations and improve code readability. As a side effect of 
this refactoring the method will be slightly more efficient although unlikely 
to have observable difference in practice.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)