Hive index exceptions

2011-06-14 Thread suyu xie
I created the hive index based on hive-0.7, the stataments are as follows: create index ind_userid_txt on table users(userid)as 'org.apache.hadoop.hive.ql.index.compact.CompactIndexHandler' WITH DEFERRED REBUILD STORED AS RCFile; ALTER INDEX ind_userid_txt ON users REBUILD; set

[jira] [Commented] (HIVE-2209) Provide a way by which ObjectInspectorUtils.compare can be extended by the caller for comparing maps which are part of the object

2011-06-14 Thread Krishna Kumar (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2209?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049297#comment-13049297 ] Krishna Kumar commented on HIVE-2209: - He Yongqiang, Can you take a look at this one?

[jira] [Updated] (HIVE-2218) speedup addInputPaths

2011-06-14 Thread He Yongqiang (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2218?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] He Yongqiang updated HIVE-2218: --- Attachment: HIVE-2218.1.patch speedup addInputPaths - Key:

Build failed in Jenkins: Hive-branch-0.7.1-h0.21 #24

2011-06-14 Thread Apache Jenkins Server
See https://builds.apache.org/job/Hive-branch-0.7.1-h0.21/24/ -- [...truncated 7530 lines...] init: dynamic-serde: ivy-init-dirs: ivy-download: [get] Getting: http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.1.0/ivy-2.1.0.jar [get] To:

[jira] [Updated] (HIVE-2218) speedup addInputPaths

2011-06-14 Thread He Yongqiang (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2218?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] He Yongqiang updated HIVE-2218: --- Status: Patch Available (was: Open) speedup addInputPaths -

Re: Hive index exceptions

2011-06-14 Thread John Sichi
It's because you have ...index.io.HiveIndexInputFormat instead of ...index.HiveIndexInputFormat. JVS On Jun 14, 2011, at 5:41 AM, suyu xie wrote: I created the hive index based on hive-0.7, the stataments are as follows: create index ind_userid_txt on table users(userid)as

Re: Review Request: HIVE-2036: Update bitmap indexes for automatic usage

2011-06-14 Thread John Sichi
On 2011-06-13 22:57:46, John Sichi wrote: ql/src/java/org/apache/hadoop/hive/ql/index/IndexPredicateAnalyzer.java, line 114 https://reviews.apache.org/r/857/diff/4/?file=20984#file20984line114 I don't think this should be necessary. We just want to propagate the partition

[jira] [Commented] (HIVE-2036) Update bitmap indexes for automatic usage

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2036?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049324#comment-13049324 ] jirapos...@reviews.apache.org commented on HIVE-2036: - bq. On

[jira] [Created] (HIVE-2219) Make alter table drop partition more efficient

2011-06-14 Thread Sohan Jain (JIRA)
Make alter table drop partition more efficient Key: HIVE-2219 URL: https://issues.apache.org/jira/browse/HIVE-2219 Project: Hive Issue Type: Improvement Components: Query Processor

[jira] [Assigned] (HIVE-2219) Make alter table drop partition more efficient

2011-06-14 Thread Sohan Jain (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2219?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Sohan Jain reassigned HIVE-2219: Assignee: Sohan Jain Make alter table drop partition more efficient

[jira] [Commented] (HIVE-1555) JDBC Storage Handler

2011-06-14 Thread John Sichi (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-1555?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049329#comment-13049329 ] John Sichi commented on HIVE-1555: -- 1+2) The Hadoop jar naming convention changed in

Re: Review Request: HIVE-872: Allow BIGINT constants

2011-06-14 Thread Syed Albiz
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/889/ --- (Updated 2011-06-14 19:04:53.630834) Review request for hive and John Sichi.

[jira] [Commented] (HIVE-872) Allow BIGINT constants

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-872?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049343#comment-13049343 ] jirapos...@reviews.apache.org commented on HIVE-872:

Re: Review Request: HIVE-872: Allow BIGINT constants

2011-06-14 Thread John Sichi
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/889/#review834 --- Wouldn't it be better to change COALESCE to just check that the two

[jira] [Commented] (HIVE-872) Allow BIGINT constants

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-872?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049348#comment-13049348 ] jirapos...@reviews.apache.org commented on HIVE-872:

Re: Review Request: HIVE-872: Allow BIGINT constants

2011-06-14 Thread John Sichi
On 2011-06-14 19:14:04, John Sichi wrote: Wouldn't it be better to change COALESCE to just check that the two objects have the same type family (both numeric)? That's what happens in standard SQL, and then the widest type is used for the result. This is what UNION ALL should be

[jira] [Commented] (HIVE-872) Allow BIGINT constants

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-872?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049354#comment-13049354 ] jirapos...@reviews.apache.org commented on HIVE-872: bq. On

[jira] [Commented] (HIVE-872) Allow BIGINT constants

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-872?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049362#comment-13049362 ] jirapos...@reviews.apache.org commented on HIVE-872: bq. On

Re: Review Request: HIVE-2215

2011-06-14 Thread Ashutosh Chauhan
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/883/ --- (Updated 2011-06-14 20:51:53.179968) Review request for hive and John Sichi.

[jira] [Commented] (HIVE-2215) Add api for marking / querying set of partitions for events

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2215?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049405#comment-13049405 ] jirapos...@reviews.apache.org commented on HIVE-2215: -

[jira] [Commented] (HIVE-2036) Update bitmap indexes for automatic usage

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2036?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049406#comment-13049406 ] jirapos...@reviews.apache.org commented on HIVE-2036: -

Re: Review Request: HIVE-2215

2011-06-14 Thread Ashutosh Chauhan
On 2011-06-14 01:02:20, Carl Steinbach wrote: trunk/metastore/if/hive_metastore.thrift, line 46 https://reviews.apache.org/r/883/diff/1/?file=20969#file20969line46 I think this should be changed to PartitionEventType in order to make it clear that this applies to partitions only.

[jira] [Commented] (HIVE-2215) Add api for marking / querying set of partitions for events

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2215?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049410#comment-13049410 ] jirapos...@reviews.apache.org commented on HIVE-2215: - bq. On

[jira] [Updated] (HIVE-2219) Make alter table drop partition more efficient

2011-06-14 Thread Sohan Jain (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2219?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Sohan Jain updated HIVE-2219: - Attachment: HIVE-2219.1.patch Improves the time it takes to check whether a partition to delete exists in

Review Request: speedup addInputPaths

2011-06-14 Thread Yongqiang He
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/898/ --- Review request for hive. Summary --- speedup addInputPaths This addresses

[jira] [Commented] (HIVE-2218) speedup addInputPaths

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2218?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049426#comment-13049426 ] jirapos...@reviews.apache.org commented on HIVE-2218: -

[jira] [Commented] (HIVE-2218) speedup addInputPaths

2011-06-14 Thread He Yongqiang (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2218?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049423#comment-13049423 ] He Yongqiang commented on HIVE-2218: https://reviews.apache.org/r/898/ speedup

Re: Review Request: HIVE-2036: Update bitmap indexes for automatic usage

2011-06-14 Thread Syed Albiz
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/857/ --- (Updated 2011-06-14 21:26:21.276789) Review request for hive and John Sichi.

[jira] [Commented] (HIVE-2036) Update bitmap indexes for automatic usage

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2036?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049436#comment-13049436 ] jirapos...@reviews.apache.org commented on HIVE-2036: -

Build failed in Jenkins: Hive-trunk-h0.21 #777

2011-06-14 Thread Apache Jenkins Server
See https://builds.apache.org/job/Hive-trunk-h0.21/777/ -- [...truncated 32417 lines...] [echo] Writing POM to https://builds.apache.org/job/Hive-trunk-h0.21/ws/hive/build/jdbc/pom.xml No ivy:settings found for the default reference 'ivy.instance'.

[jira] [Created] (HIVE-2220) Better error messages for MetaStore configuration problems

2011-06-14 Thread Carl Steinbach (JIRA)
Better error messages for MetaStore configuration problems -- Key: HIVE-2220 URL: https://issues.apache.org/jira/browse/HIVE-2220 Project: Hive Issue Type: Improvement

[jira] [Resolved] (HIVE-2176) Schema creation scripts are incomplete since they leave out tables that are specific to DataNucleus

2011-06-14 Thread Carl Steinbach (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Carl Steinbach resolved HIVE-2176. -- Resolution: Fixed Fix Version/s: 0.8.0 Hadoop Flags: [Reviewed] Committed to trunk

Re: Review Request: HIVE-872: Allow BIGINT constants

2011-06-14 Thread Syed Albiz
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/889/ --- (Updated 2011-06-15 00:27:01.842091) Review request for hive and John Sichi.

[jira] [Commented] (HIVE-872) Allow BIGINT constants

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-872?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049545#comment-13049545 ] jirapos...@reviews.apache.org commented on HIVE-872:

Review Request: HIVE-2158: add the HivePreparedStatement implementation based on current HIVE supported data-type

2011-06-14 Thread Carl Steinbach
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/900/ --- Review request for hive. Summary --- Review for HIVe-2158. This addresses

[jira] [Created] (HIVE-2221) Provide metastore upgarde script for HIVE-2215

2011-06-14 Thread Ashutosh Chauhan (JIRA)
Provide metastore upgarde script for HIVE-2215 -- Key: HIVE-2221 URL: https://issues.apache.org/jira/browse/HIVE-2221 Project: Hive Issue Type: Improvement Components: Metastore

[jira] [Commented] (HIVE-2158) add the HivePreparedStatement implementation based on current HIVE supported data-type

2011-06-14 Thread jirapos...@reviews.apache.org (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049552#comment-13049552 ] jirapos...@reviews.apache.org commented on HIVE-2158: -

[jira] [Commented] (HIVE-872) Allow BIGINT constants

2011-06-14 Thread John Sichi (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-872?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049553#comment-13049553 ] John Sichi commented on HIVE-872: - The title and description for this issue need to be

[jira] [Commented] (HIVE-2128) Automatic Indexing with multiple tables

2011-06-14 Thread John Sichi (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2128?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049555#comment-13049555 ] John Sichi commented on HIVE-2128: -- HiveInputFormat already keeps track of the mapping

[jira] [Commented] (HIVE-2158) add the HivePreparedStatement implementation based on current HIVE supported data-type

2011-06-14 Thread Carl Steinbach (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049560#comment-13049560 ] Carl Steinbach commented on HIVE-2158: -- +1. add the HivePreparedStatement

[jira] [Updated] (HIVE-2158) add the HivePreparedStatement implementation based on current HIVE supported data-type

2011-06-14 Thread Carl Steinbach (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2158?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Carl Steinbach updated HIVE-2158: - Resolution: Fixed Hadoop Flags: [Reviewed] Status: Resolved (was: Patch

[jira] [Created] (HIVE-2222) runnable queue in Driver and DriverContext is not thread safe

2011-06-14 Thread He Yongqiang (JIRA)
runnable queue in Driver and DriverContext is not thread safe - Key: HIVE- URL: https://issues.apache.org/jira/browse/HIVE- Project: Hive Issue Type: Bug

[jira] [Updated] (HIVE-2140) Return correct Major / Minor version numbers for Hive Driver

2011-06-14 Thread Carl Steinbach (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2140?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Carl Steinbach updated HIVE-2140: - Resolution: Fixed Hadoop Flags: [Reviewed] Status: Resolved (was: Patch

[jira] [Commented] (HIVE-2158) add the HivePreparedStatement implementation based on current HIVE supported data-type

2011-06-14 Thread Yuanjun Li (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-2158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13049574#comment-13049574 ] Yuanjun Li commented on HIVE-2158: -- Well, the Jasperreport can work well directly with

[jira] [Updated] (HIVE-2222) runnable queue in Driver and DriverContext is not thread safe

2011-06-14 Thread Namit Jain (JIRA)
[ https://issues.apache.org/jira/browse/HIVE-?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Namit Jain updated HIVE-: - Attachment: hive..1.patch runnable queue in Driver and DriverContext is not thread safe