[ 
http://jira.codehaus.org/browse/JBEHAVE-354?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Mauro Talevi updated JBEHAVE-354:
---------------------------------

      Description: 
... in that case the Java method that it pertains to could provide the matching 
expression:

{code}

@Given
public void aUserWithALargeBankBalance { .. }

{code}

would be equiv to

{code}
@Given("a user with a large bank balance")
public void aUserWithALargeBankBalance { .. }
{code}

or maybe we could endorse Ruby naming conventions for extra capitalization 
clarity:

|  @Given
|  public void a_user_with_a_large_bank_balance { .. }

Obviously this is no good for cases where there are parameters. Though that 
could be solved too later, with yet more work. 

Guilherme Silveira's idea :)



  was:
... in that case the Java method that it pertains to could provide the matching 
expression:

|  @Given
|  public void aUserWithALargeBankBalance { .. }

would be equiv to

|  @Given("a user with a large bank balance")
|  public void aUserWithALargeBankBalance { .. }

or maybe we could endorse Ruby naming conventions for extra capitalization 
clarity:

|  @Given
|  public void a_user_with_a_large_bank_balance { .. }

Obviously this is no good for cases where there are parameters. Though that 
could be solved too later, with yet more work. 

Guilherme Silveira's idea :)



    Fix Version/s: 3.1

> @Given, @When and @Then could make the string optional ....
> -----------------------------------------------------------
>
>                 Key: JBEHAVE-354
>                 URL: http://jira.codehaus.org/browse/JBEHAVE-354
>             Project: JBehave
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Paul Hammant
>             Fix For: 3.1
>
>
> ... in that case the Java method that it pertains to could provide the 
> matching expression:
> {code}
> @Given
> public void aUserWithALargeBankBalance { .. }
> {code}
> would be equiv to
> {code}
> @Given("a user with a large bank balance")
> public void aUserWithALargeBankBalance { .. }
> {code}
> or maybe we could endorse Ruby naming conventions for extra capitalization 
> clarity:
> |  @Given
> |  public void a_user_with_a_large_bank_balance { .. }
> Obviously this is no good for cases where there are parameters. Though that 
> could be solved too later, with yet more work. 
> Guilherme Silveira's idea :)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: 
http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply via email to