Re: [VOTE] Apache Karaf 4.2.0.M1 release

2017-10-29 Thread Krzysztof Sobkowiak
Hi

+1 (non-bindng)

I have installed some components with following steps

karaf@root()> feature:repo-add camel 2.19.3
Adding feature url mvn:org.apache.camel.karaf/apache-camel/2.19.3/xml/features
karaf@root()> feature:repo-add activemq 5.15.2
Adding feature url mvn:org.apache.activemq/activemq-karaf/5.15.2/xml/features
karaf@root()> feature:install aries-blueprint
karaf@root()> feature:install  shell-compat
karaf@root()> feature:install  activemq-broker activemq-camel 
activemq-blueprint camel-blueprint camel-jms camel-cxf

Next my routes worked, so my +1. The same with Camel 2.20.0

When I'm trying to install jmsnext, the operation never ends. The same 
situation when I install jms first (before the above steps) and next I'm trying 
to install the other components. It looks to be a dependency resolution problem

Trying to install jmsafter the above steps with Camel 2.20.0 the operation ends 
with following error

karaf@root()> feature:install jms
Error executing command: Uses constraint violation. Unable to resolve resource 
org.apache.activemq.activemq-osgi [org.apache.activemq.activemq-osgi/5.15.2] 
because it is exposed to package 'javax.jms' from resources 
org.apache.geronimo.specs.geronimo-jms_2.0_spec 
[org.apache.geronimo.specs.geronimo-jms_2.0_spec/1.0.0.alpha-2] and 
javax.jms-api [javax.jms-api/2.0.0] via two dependency chains.

Chain 1:
  org.apache.activemq.activemq-osgi [org.apache.activemq.activemq-osgi/5.15.2]
    import: 
(&(osgi.wiring.package=javax.jms)(version>=1.1.0)(!(version>=3.0.0)))
 |
    export: osgi.wiring.package: javax.jms
  org.apache.geronimo.specs.geronimo-jms_2.0_spec 
[org.apache.geronimo.specs.geronimo-jms_2.0_spec/1.0.0.alpha-2]

Chain 2:
  org.apache.activemq.activemq-osgi [org.apache.activemq.activemq-osgi/5.15.2]
    import: 
(&(osgi.wiring.package=org.springframework.jms.connection)(version>=4.0.0)(!(version>=5.0.0)))
 |
    export: osgi.wiring.package=org.springframework.jms.connection; 
uses:=javax.jms
  org.apache.servicemix.bundles.spring-jms 
[org.apache.servicemix.bundles.spring-jms/4.3.12.RELEASE_1]
    import: (osgi.wiring.package=javax.jms)
 |
    export: osgi.wiring.package: javax.jms
  javax.jms-api [javax.jms-api/2.0.0]



Kindly regards
Krzysztof 



On 10/28/17 8:31 AM, Jean-Baptiste Onofré wrote:
> Hi all
>
> I submit Karaf 4.2.0.M1 release to your vote. It's not a GA release but a 
> technical preview. The purpose is to perform a test campaign before the first 
> GA Release.
> Especially the Java9 support is not yet complete as we need new dependencies 
> releases.
>
> Release Notes:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12338362
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1101/
>
> Git tag:
> karaf-4.2.0.M1
>
> Please vote for this release:
>
> [ ] +1 (approve the release)
> [ ] -1 (don't approve the release, provide reason)
>
> This vote is open for 72h.
>
> Thanks
> Regards
> JB
> ⁣​

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf (Container) 4.1.2 release

2017-08-07 Thread Krzysztof Sobkowiak
+1 (non-binding)

Tested with Camel 2.19.0 and ActiveMQ 5.15.0 and some ServiceMix samples.

Kindly regards
Krzysztof

On 8/4/17 8:51 PM, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Karaf (Container) 4.1.2 release to your vote.
>
> Release Notes:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12340261
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1097/
>
> Git Tag:
> karaf-4.1.2
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 48 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [HEADS UP] Releases schedule

2017-04-06 Thread Krzysztof Sobkowiak
Thanks for the update

Regards
Krzysztof

On 06.04.2017 20:43, Jean-Baptiste Onofré wrote:
> Hey,
>
> I will plan a 3.0.9 release next week.
>
> Regards
> JB
>
> On 04/06/2017 08:13 PM, Krzysztof Sobkowiak wrote:
>> Hi
>>
>> Any plans to release 3.0.9? I think this is EOL and I don't wait for 
>> anything important for ServiceMix6 in this release. I only want to be sure 
>> whether I can close (no-fix) one minor issue in ServiceMix 6, which needs 
>> the 3.0.9 to be fixed.
>>
>> Kindly regards
>> Krzysztof
>>
>> On 27.03.2017 13:39, Jean-Baptiste Onofré wrote:
>>> Hi Stephen,
>>>
>>> I'm merging the last changes today. I will submit 4.1.1 release (and 4.0.9) 
>>> to vote tonight.
>>>
>>> Regards
>>> JB
>>>
>>> On 03/27/2017 10:45 AM, Stephen Kitt wrote:
>>>> Hi Jean-Baptiste,
>>>>
>>>> Is there anything we can do to help?
>>>>
>>>> Regards,
>>>>
>>>> Stephen
>>>>
>>>>
>>>> On Thu, 23 Mar 2017 13:32:32 +0100
>>>> Jean-Baptiste Onofré <j...@nanthrax.net> wrote:
>>>>
>>>>> Hi guys,
>>>>>
>>>>> just to let you know that the merge of my local branches is a bit
>>>>> longer than expected. The releases will happen pretty soon, probably
>>>>> during the week end.
>>>>>
>>>>> Sorry about this delay.
>>>>>
>>>>> Regards
>>>>> JB
>>>>>
>>>>> On 03/14/2017 11:08 PM, Jean-Baptiste Onofré wrote:
>>>>>> Hi guys,
>>>>>>
>>>>>> I fixed almost all issues that we wanted for 4.1.1 and 4.0.9 on
>>>>>> local branches.
>>>>>>
>>>>>> I will merge today and tomorrow.
>>>>>>
>>>>>> If no objection, I plan to release both 4.1.1 and 4.0.9 during the
>>>>>> week end.
>>>>>>
>>>>>> Regards
>>>>>> JB
>>>>>>
>>>>>> On 03/05/2017 02:37 PM, Jean-Baptiste Onofré wrote:
>>>>>>> Hi guys,
>>>>>>>
>>>>>>> due to a couple of severe issue we found (in the
>>>>>>> karaf-maven-plugin, ...),  I take two extra days for the releases
>>>>>>> preparation.
>>>>>>>
>>>>>>> I keep you posted with more details asap.
>>>>>>>
>>>>>>> Regards
>>>>>>> JB
>>>>>>>
>>>>>>> On 02/20/2017 02:30 PM, Jean-Baptiste Onofré wrote:
>>>>>>>> Hi guys,
>>>>>>>>
>>>>>>>> I'm finally back from vacation ;)
>>>>>>>>
>>>>>>>> And so, I will bother you again with the releases schedule.
>>>>>>>>
>>>>>>>> Here's the proposed plan:
>>>>>>>>
>>>>>>>> - Karaf Decanter 1.4.0 is planned for end of next week
>>>>>>>> - Karaf Cellar 4.1.0 & 4.0.4 are planned for end of next week or
>>>>>>>> the following week (depending if I can include the fixes and new
>>>>>>>> features I plan)
>>>>>>>> - Karaf (Container) 4.0.9 for the end of this week and 4.1.1 in 2
>>>>>>>> or 3 weeks (I'm checking the Jira right now)
>>>>>>>>
>>>>>>>> Thanks !
>>>>>>>> Regards
>>>>>>>> JB
>>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf (Container) 4.1.0 release, RC#2

2017-02-01 Thread Krzysztof Sobkowiak
And the problem with ActiveMQ conole: should it be fixed in ActiveMQ or is it a 
missing bundle or feature which should be additionally installed in K11x to fix 
this problem? Should I open and issue in ActiveMQ or Karaf?

Kindly regards
Krzysztof

On 01.02.2017 22:27, Jean-Baptiste Onofré wrote:
> Hi
>
> Thanks for your tests. Yes for the shell console and rendering issues around 
> completion: it's known, not release blocker but annoying. Clearly it has to 
> be fix for 4.1.1.
>
> Regards
> JB⁣​
>
> On Feb 1, 2017, 22:12, at 22:12, Krzysztof Sobkowiak 
> <krzys.sobkow...@gmail.com> wrote:
>> +1 (non-binding)
>>
>> I have tested some ActiveMQ and Camel features. The problem with
>> commands after restart has been fixed in the new release candidate.
>> Jdbc, jms and some other features look good too.
>>
>> I have found only 2 problems (non blocker)
>>
>> * After installing ActiveMQ console I got following info on the
>> console:
>>
>>Problem accessing /activemqweb/. Reason: Not Found
>>
>>And following log entry:
>>
>> 2017-02-01 21:56:03,788 | ERROR | pool-3-thread-1  | WebObserver   
>> | 179 - org.ops4j.pax.web.pax-web-extender-war - 6.0.2 | Error scanning
>> web bundle org.apache.activemq.activemq-web-console [70]:
>> javax.servlet.annotation.HandlesTypes not found by
>> org.apache.activemq.activemq-web-console [70]
>> java.lang.ClassNotFoundException: javax.servlet.annotation.HandlesTypes
>> not found by org.apache.activemq.activemq-web-console [70]
>> at
>> org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1574)
>> ~[?:?]
>>
>>
>> * The shell is still not stable - autocompletion sometimes works not
>> correct (additional spaces), sometimes the layout becomes  chaotic
>>
>> Good job!!!
>>
>> Kindly regards
>>
>> Krzysztof
>>
>>
>>
>>
>> On 01.02.2017 20:32, Jean-Baptiste Onofré wrote:
>>> Hi all,
>>>
>>> I submit Karaf (Container) 4.1.0 release (second attempt) to your
>> vote.
>>> Release Notes:
>>>
>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12332799
>>> Staging Repository:
>>>
>> https://repository.apache.org/content/repositories/orgapachekaraf-1089/
>>> Git Tag:
>>> karaf-4.1.0
>>>
>>> Please vote to approve this release:
>>>
>>> [ ] +1 Approve the release
>>> [ ] -1 Don't approve the release (please provide specific comments)
>>>
>>> This vote will be open for at least 48 hours.
>>>
>>> Thanks,
>>> Regards
>>> JB
>> -- 
>> Krzysztof Sobkowiak (@ksobkowiak)
>>
>> JEE & OSS Architect, Integration Architect
>> Apache Software Foundation Member (http://apache.org/)
>> Apache ServiceMix Committer & PMC Member
>> (http://servicemix.apache.org/)
>> Senior Solution Architect @ Capgemini SSC
>> (http://www.capgeminisoftware.pl/)

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf (Container) 4.1.0 release, RC#2

2017-02-01 Thread Krzysztof Sobkowiak
+1 (non-binding)

I have tested some ActiveMQ and Camel features. The problem with commands after 
restart has been fixed in the new release candidate. Jdbc, jms and some other 
features look good too.

I have found only 2 problems (non blocker)

  * After installing ActiveMQ console I got following info on the console:

Problem accessing /activemqweb/. Reason: Not Found

And following log entry:

2017-02-01 21:56:03,788 | ERROR | pool-3-thread-1  | WebObserver
  | 179 - org.ops4j.pax.web.pax-web-extender-war - 6.0.2 | Error 
scanning web bundle org.apache.activemq.activemq-web-console [70]: 
javax.servlet.annotation.HandlesTypes not found by 
org.apache.activemq.activemq-web-console [70]
java.lang.ClassNotFoundException: javax.servlet.annotation.HandlesTypes not 
found by org.apache.activemq.activemq-web-console [70]
at 
org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1574)
 ~[?:?]


  * The shell is still not stable - autocompletion sometimes works not correct 
(additional spaces), sometimes the layout becomes  chaotic

Good job!!!

Kindly regards

Krzysztof




On 01.02.2017 20:32, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Karaf (Container) 4.1.0 release (second attempt) to your vote.
>
> Release Notes:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12332799
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1089/
>
> Git Tag:
> karaf-4.1.0
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 48 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: Problems with 3rd party commands in 4.1.0

2017-02-01 Thread Krzysztof Sobkowiak
I have tested this with the new rc and looks like you have fixed it. Thanks!!

On 01.02.2017 10:57, Christian Schneider wrote:
> I found a bit more now.
>
> The shell.console fragment itself also is in state installed while it should 
> be resolved.
> If I manually refresh shell.core then the fragment shell.console goes to 
> state resolved and the came command bundle can be started.
>
> Christian
>
> On 01.02.2017 10:46, Christian Schneider wrote:
>> I can reproduce the issue.
>> I think it might be a bug in the resolver.
>>
>> What I found:
>> Camel commands import this package: 
>> (&(osgi.wiring.package=org.apache.karaf.shell.console)(version>=3.0.0)(!(version>=5.0.0)))
>>
>> The exported packages show this:
>> org.apache.karaf.shell.console  │ 2.3.0  
>>  │ 42 │ org.apache.karaf.shell.console
>> org.apache.karaf.shell.console  │ 4.1.0  
>>  │ 42 │ org.apache.karaf.shell.console
>>
>> So the package is exported in two versions. The version 2.3.0 would not 
>> match the range camel imports, the 4.1.0 version would match it.
>> I suspect that the resolver behaves differently depending on which version 
>> it checks first. If it checks the 4.1.0 first it works, if it checks the 
>> 2.1.0 version first it fails.
>> I guess it should check both versions and take the working one but 
>> apparently it does not.
>>
>> Unfortunately I do not know the implementation well enough to check or fix 
>> this but maybe it helps Guillaume to find the issue :-)
>>
>> Christian
>>
>> On 31.01.2017 21:42, Krzysztof Sobkowiak wrote:
>>> Hi
>>>
>>> While testing 4.1.0 I have observed following issue.
>>>
>>> karaf@root()> feature:repo-add camel 2.18.2 21:35:06
>>> Adding feature url 
>>> mvn:org.apache.camel.karaf/apache-camel/2.18.2/xml/features
>>> karaf@root()> feature:install camel 21:35:19
>>> karaf@root()> camel 21:35:26
>>> camel   camel:context-list camel:eip-explain   
>>> camel:rest-api-doc camel:route-profile camel:route-start
>>> camel   camel:context-resume camel:eip-explain  
>>>  camel:rest-registry-list camel:route-profile camel:route-stop
>>> camel:component-listcamel:context-resume camel:endpoint-explain 
>>>  camel:rest-registry-list camel:route-reset-stats camel:route-stop
>>> camel:component-listcamel:context-start camel:endpoint-explain  
>>> camel:rest-show camel:route-reset-stats camel:route-suspend
>>> camel:context-inflight  camel:context-start camel:endpoint-list 
>>> camel:rest-show camel:route-resume  camel:route-suspend
>>> camel:context-inflight  camel:context-stop camel:endpoint-list 
>>> camel:route-info camel:route-resume
>>> camel:context-info  camel:context-stop camel:endpoint-stats
>>> camel:route-info camel:route-show
>>> camel:context-info  camel:context-suspend camel:endpoint-stats  
>>>   camel:route-list camel:route-show
>>> camel:context-list  camel:context-suspend camel:rest-api-doc
>>>   camel:route-list camel:route-start
>>>
>>> The commands are available and work. But after Karaf restart they are no 
>>> more available and the log contains following error:
>>>
>>> 2017-01-31 21:37:25,415 | ERROR | FelixStartLevel  | Felix  
>>>   |  -  -  | Bundle org.apache.camel.karaf.camel-karaf-commands 
>>> [57] Error starting mvn:org.apache.camel.karaf/camel-karaf-commands/2.18.2 
>>> (org.osgi.framework.BundleException: Unable to resolve 
>>> org.apache.camel.karaf.camel-karaf-commands [57](R 57.0): missing 
>>> requirement [org.apache.camel.karaf.camel-karaf-commands [57](R 57.0)] 
>>> osgi.wiring.package; 
>>> (&(osgi.wiring.package=org.apache.karaf.shell.console)(version>=3.0.0)(!(version>=5.0.0)))
>>>  [caused by: Unable to resolve org.apache.karaf.shell.console [42](R 42.0): 
>>> missing requirement [org.apache.karaf.shell.console [42](R 42.0)] 
>>> osgi.wiring.host; 
>>> (&(osgi.wiring.host=org.apache.karaf.shell.core)(bundle-version>=0.0.0))] 
>>> Unresolved requirements: [[org.apache.camel.karaf.camel-karaf-commands 
>>> [57](R 57.0)] osgi.wiring.package; 
>>> (&(osgi.wiring.package=org.apache.karaf.shell.console)(version>=3.0.0)(!(version>=5.0.0)))])
>

Problems with 3rd party commands in 4.1.0 (was: Towards Karaf (Container) 4.1.0)

2017-01-31 Thread Krzysztof Sobkowiak
; 
(&(osgi.wiring.host=org.apache.karaf.shell.core)(bundle-version>=0.0.0))] 
Unresolved requirements: [[org.apache.camel.karaf.camel-karaf-commands [57](R 
57.0)] osgi.wiring.package; 
(&(osgi.wiring.package=org.apache.karaf.shell.console)(version>=3.0.0)(!(version>=5.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) 
[?:?]
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) [?:?]
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) 
[?:?]
at 
org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
 [?:?]
at java.lang.Thread.run(Thread.java:745) [?:?]


The same happens with other 3rd party commands, e.g:

karaf@root()> feature:repo-add activemq 5.15.0-SNAPSHOT 

   21:39:14
Adding feature url 
mvn:org.apache.activemq/activemq-karaf/5.15.0-SNAPSHOT/xml/features
karaf@root()> feature:install activemq-broker-noweb 

   21:39:26
karaf@root()> activemq  

   21:39:37
activemq activemq:bstat   activemq:consumeractivemq:list
activemq:produceractivemq:query
activemq:browse  activemq:bstat   activemq:dstat   activemq:list
activemq:purge   activemq:query
activemq:browse  activemq:consumeractivemq:dstat   
activemq:produceractivemq:purge

Is this the same problem you have mentioned in this thread?

Kindly regards
Krzysztof



On 29.01.2017 13:38, Jean-Baptiste Onofré wrote:
>
> 2. Shell command issue
> Several projects providing shell commands (like Camel, ActiveMQ, ...) 
> directly use jline dependency. It's pretty bad (they should use the Karaf 
> "wrapper), and, as Karaf 4.1.x now uses JLine 3.x, those commands don't work 
> in Karaf 4.1.x.
> Here, we have two solutions:
> 2.1. We create the jline "2.x" compliant packages in Karaf (in a bundle as 
> part of the shell-compat feature for instance). It's only a workaround but 
> should fix the issue.
> 2.2. jline 3.x can provide a "compat" bundle with the jline 2.x packages 
> name, wrapping the jline 3.x ones. It's probably the most elegant solution, 
> but it's require a new jline 3.x release. 

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: Towards Karaf (Container) 4.1.0

2017-01-30 Thread Krzysztof Sobkowiak
I understand what Christian means and it's a good idea - a set of simple 
examples showing how easilly the beginner can use Karaf. It's a good material 
for something like "quick start guide" part of the examples.
We will also need more advanced section for more complicated examples and it 
would be a good place for the OSGi samples.

I think having samples for managed service and managed service factory with ds 
and blueprint would be a good idea too.

Kindly regards
Krzysztof

On 30.01.2017 21:23, Jean-Baptiste Onofré wrote:
> Thanks for your feedback Krzysztof.
>
> I share your thoughts. Christian comment was more to put the beginners on the 
> right track as soon as they start.
>
> I'm in favor of keeping OSGi samples (including config) as well.
>
> Let's see what the others will think.
>
> Regards
> JB
>
> On 01/30/2017 09:18 PM, Krzysztof Sobkowiak wrote:
>> I like the new examples. They will be a good starter for people who want to 
>> start using Karaf.
>> Personally I would keep the plain OSGi samples (maybe with a comment this is 
>> a more advanced stuff or moving them to a section with advanced examples).
>> I was often looking for a good sample how to do something good in plain 
>> OSGI. It would be good to have them in Karaf examples
>>
>> Kindly regards
>> Krzysztof
>>
>> On 30.01.2017 19:14, Jean-Baptiste Onofré wrote:
>>> I started to do the changes proposed by Christian, and Christian also 
>>> kindly offered his help to update the examples.
>>>
>>> As I don't want to hold the 4.1.0 longer, I'm postponing the examples in 
>>> the distribution for 4.1.1 release. As examples can be the key part to 
>>> start with Karaf, it makes sense to take time to polish a bit and provide a 
>>> complete overview.
>>>
>>> So, I moved KARAF-2511 (related to the examples in the distribution) to 
>>> Karaf 4.1.1 release and I'm starting 4.1.0 release.
>>>
>>> Sorry again for the noise (just wanted to keep you posted about the last 
>>> progress).
>>>
>>> Stay tuned tonight for the release vote e-mail.
>>>
>>> Thanks !
>>> Regards
>>> JB
>>>
>>> On 01/30/2017 03:12 PM, Christian Schneider wrote:
>>>> Like discussed on IRC.
>>>>
>>>> The examples should be named sample or examples instead of starter.
>>>> Starter would be confused with the spring boot meaning of starter.
>>>> The blueprint and jpa examples are good.
>>>>
>>>> I would leave out the plain OSGi examples. For anything more complex the
>>>> OSGi API is too difficult to use and leads beginners on the wrong track.
>>>> Instead of the OSGi examples I propose to prepare DS examples and add
>>>> them to the next karaf release.
>>>>
>>>> Christian
>>>>
>>>> On 30.01.2017 14:41, Jean-Baptiste Onofré wrote:
>>>>> Agree for the examples in the distribution as well ?
>>>>>
>>>>> Regards
>>>>> JB
>>>>>
>>>>> On 01/30/2017 02:37 PM, Christian Schneider wrote:
>>>>>> I also think a 4.1.0 should be ok with the current status.
>>>>>>
>>>>>> We just need to document that some features like activemq might need the
>>>>>> spring or enterprise legacy repos.
>>>>>>
>>>>>> Christian
>>>>>>
>>>>>> On 30.01.2017 13:39, Jean-Baptiste Onofré wrote:
>>>>>>> Hi,
>>>>>>>
>>>>>>> I confirm the "jline" commands are now working fine.
>>>>>>>
>>>>>>> So, I will release 4.1.0.
>>>>>>>
>>>>>>> As part of the 4.1.0, I would like to include examples (I have some
>>>>>>> more in preparation that I gonna merge) in the standard distribution:
>>>>>>>
>>>>>>> https://github.com/jbonofre/karaf/tree/DEV_GUIDE/examples
>>>>>>>
>>>>>>> We will improve and extend the examples (and dev guide) for 4.1.1.
>>>>>>>
>>>>>>> WDYT ?
>>>>>>>
>>>>>>> Regards
>>>>>>> JB
>>>>>>>
>>>>>>> On 01/30/2017 11:05 AM, Jean-Baptiste Onofré wrote:
>>>>>>>> Hi all,
>>>>>>>>
>>>>>>>> Guillaume fixed the shell backward compatibility this morning.
>&

Re: Towards Karaf (Container) 4.1.0

2017-01-30 Thread Krzysztof Sobkowiak
gt;>>> directly use jline dependency. It's pretty bad (they should use the
>>>>>>> Karaf "wrapper), and, as Karaf 4.1.x now uses JLine 3.x, those
>>>>>>> commands
>>>>>>> don't work in Karaf 4.1.x.
>>>>>>> Here, we have two solutions:
>>>>>>> 2.1. We create the jline "2.x" compliant packages in Karaf (in a
>>>>>>> bundle
>>>>>>> as part of the shell-compat feature for instance). It's only a
>>>>>>> workaround but should fix the issue.
>>>>>>> 2.2. jline 3.x can provide a "compat" bundle with the jline 2.x
>>>>>>> packages
>>>>>>> name, wrapping the jline 3.x ones. It's probably the most elegant
>>>>>>> solution, but it's require a new jline 3.x release.
>>>>>>>
>>>>>>> 3. Version & Schedule
>>>>>>> Basically, I planned to release 4.1.0-M1 version today, as shell
>>>>>>> command
>>>>>>> "break" is pretty bad. I'm postponing the decision to tomorrow
>>>>>>> evening.
>>>>>>> I plan to discuss with Guillaume tomorrow about the jline 3 and shell
>>>>>>> commands issue. If we can find a good solution, and release jline
>>>>>>> 3.1.3
>>>>>>> tomorrow, then, I will release Karaf 4.1.0 tomorrow evening.
>>>>>>> If it's more complex and requires more time, then, I will release
>>>>>>> 4.1.0-M1 tomorrow evening, the 4.1.0 (GA) will be released 3 weeks
>>>>>>> later, giving time for us to fix the jline/command issue.
>>>>>>>
>>>>>>> Thanks !
>>>>>>> Regards
>>>>>>> JB
>>>>>>>
>>>>>>> On 01/29/2017 11:31 AM, Jean-Baptiste Onofré wrote:
>>>>>>>> Hi all,
>>>>>>>>
>>>>>>>> the problem is clearly an incompatible version of jline
>>>>>>>> (resulting of
>>>>>>>> the update we did in Karaf 4.1.x). It breaks other projects which
>>>>>>>> are
>>>>>>>> using directly jline (for completer for instance).
>>>>>>>>
>>>>>>>> So, the other projects should be refactored (camel, activemq,
>>>>>>>> ...) to
>>>>>>>> not relay on jline but Karaf (for the completer for instance).
>>>>>>>>
>>>>>>>> Anyway, it means that Karaf 4.1.0 is not yet ready to support any
>>>>>>>> other
>>>>>>>> projects.
>>>>>>>>
>>>>>>>> So, I'm going to 4.1.0-M1 first and we will invite maximum of
>>>>>>>> people to
>>>>>>>> test on this milestone in order to clearly identify the breaking
>>>>>>>> changes
>>>>>>>> and provide max backward compatibility when possible.
>>>>>>>>
>>>>>>>> I already changed the version in Jira and I will cut 4.1.0-M1 later
>>>>>>>> today.
>>>>>>>>
>>>>>>>> Regards
>>>>>>>> JB
>>>>>>>>
>>>>>>>> On 01/28/2017 03:32 PM, Jean-Baptiste Onofré wrote:
>>>>>>>>> Hi guys,
>>>>>>>>>
>>>>>>>>> as you might know, I'm preparing the Karaf 4.1.0 release.
>>>>>>>>>
>>>>>>>>> We are mostly ok, but during my tests, I found that Camel (at least
>>>>>>>>> 2.18.1) commands are not available in the shell.
>>>>>>>>>
>>>>>>>>> I suspect because they use the "old" style.
>>>>>>>>>
>>>>>>>>> I also see lot of small annoying behaviors in the shell console (on
>>>>>>>>> completion especially).
>>>>>>>>>
>>>>>>>>> So, even we are mostly ready, I'm not sure it's fully ready for
>>>>>>>>> production.
>>>>>>>>>
>>>>>>>>> Instead of directly releasing Karaf 4.1.0, I propose to release
>>>>>>>>> 4.1.0-M1
>>>>>>>>> as a tech preview. I would allow people to review and test
>>>>>>>>> 4.1.0-M1 but
>>>>>>>>> give a good message that's a tech preview.
>>>>>>>>>
>>>>>>>>> WDYT ?
>>>>>>>>>
>>>>>>>>> Regards
>>>>>>>>> JB
>>>>>>>>>
>>>>>>>>> On 01/05/2017 03:39 PM, Jean-Baptiste Onofré wrote:
>>>>>>>>>> Hi guys,
>>>>>>>>>>
>>>>>>>>>> I started the updates and fixes for Karaf 4.1.0.
>>>>>>>>>>
>>>>>>>>>> As dependencies, we will need Pax Exam 4.10.0 and Pax Web 6.0.1.
>>>>>>>>>> Achim
>>>>>>>>>> and I will tackle this as it's pre-requisite for 4.1.0.
>>>>>>>>>>
>>>>>>>>>> I plan to create karaf-4.1.x branch next week for a release the
>>>>>>>>>> following week.
>>>>>>>>>>
>>>>>>>>>> Thoughts ?
>>>>>>>>>>
>>>>>>>>>> Thanks,
>>>>>>>>>> Regards
>>>>>>>>>> JB
>>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>
>>>>
>>>
>>
>>
>

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: R: Re: Towards Karaf (Container) 4.1.0

2017-01-28 Thread Krzysztof Sobkowiak
+1

Preview release will give the first feedback and let to find/fix eventual new 
problems.

Regards
Krzysztof

On 28.01.2017 18:00, Jean-Baptiste Onofré wrote:
> Yes, I'm in favor of 4.1.0-M1 as first release for the 4.1.0 serie.
>
> Regards
> JB
>
> On 01/28/2017 03:35 PM, Andrea Cosentino wrote:
>> +1 from my side
>>
>>   Il sab, 28 gen, 2017 alle 15:32, Jean-Baptiste Onofré<j...@nanthrax.net> 
>> ha scritto:   Hi guys,
>>
>> as you might know, I'm preparing the Karaf 4.1.0 release.
>>
>> We are mostly ok, but during my tests, I found that Camel (at least
>> 2.18.1) commands are not available in the shell.
>>
>> I suspect because they use the "old" style.
>>
>> I also see lot of small annoying behaviors in the shell console (on
>> completion especially).
>>
>> So, even we are mostly ready, I'm not sure it's fully ready for production.
>>
>> Instead of directly releasing Karaf 4.1.0, I propose to release 4.1.0-M1
>> as a tech preview. I would allow people to review and test 4.1.0-M1 but
>> give a good message that's a tech preview.
>>
>> WDYT ?
>>
>> Regards
>> JB
>>
>> On 01/05/2017 03:39 PM, Jean-Baptiste Onofré wrote:
>>> Hi guys,
>>>
>>> I started the updates and fixes for Karaf 4.1.0.
>>>
>>> As dependencies, we will need Pax Exam 4.10.0 and Pax Web 6.0.1. Achim
>>> and I will tackle this as it's pre-requisite for 4.1.0.
>>>
>>> I plan to create karaf-4.1.x branch next week for a release the
>>> following week.
>>>
>>> Thoughts ?
>>>
>>> Thanks,
>>> Regards
>>> JB
>>
>

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: ActiveMQ and Camel 2.17.x on Karaf

2017-01-23 Thread Krzysztof Sobkowiak
Embedding xbean-spring bundle into activemq-osgi solves the problem with Camel 
2.17.x and 2.18.x. I have created an Issue in ActiveQM (AMQ-6576) and a pull 
request with the fix. Hope it will solve the problem (and make no new problems 
:-) ). I have tested the modified ActiveQM with ServiceMix (manually and 
itests) as well as a smoke test to be sure this change didn't make any new 
errors.

Kindly regards
Krzysztof

On 24.01.2017 00:48, Krzysztof Sobkowiak wrote:
> Hi
>
> I have performed some analysis for 2.17.5 (for 2.18.x problem looks more 
> complicated)
>
> karaf@root()> feature:repo-add camel 2.17.5
> Adding feature url mvn:org.apache.camel.karaf/apache-camel/2.17.5/xml/features
> karaf@root()> feature:repo-add activemq 5.14.3
> Adding feature url mvn:org.apache.activemq/activemq-karaf/5.14.3/xml/features
>
> And now:
>
> karaf@root()> feature:install -v activemq-camel
> Adding features: activemq-camel/[5.14.3,5.14.3]
> Changes to perform:
>   Region: root
> Bundles to install:
> .
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/3.2.17.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.2.8.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/3.2.17.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.2.8.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/3.2.17.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.2.8.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/3.2.17.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.2.8.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/3.2.17.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.2.8.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/3.2.17.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.2.8.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-jms/3.2.17.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-jms/4.2.8.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-tx/3.2.17.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-tx/4.2.8.RELEASE_1
>
> 2 versions of Spring are installed.
>
> Now:
>
> karaf@root()> list -t 0
> START LEVEL 100 , List Threshold: 0
> ID | State| Lvl | Version  | Name
> 
> 
> 69 | Active   |  30 | 3.2.17.RELEASE_1 | Apache ServiceMix :: Bundles :: 
> spring-aop
> 70 | Active   |  30 | 4.2.8.RELEASE_1  | Apache ServiceMix :: Bundles :: 
> spring-aop
> 71 | Active   |  30 | 3.2.17.RELEASE_1 | Apache ServiceMix :: Bundles :: 
> spring-beans
> 72 | Active   |  30 | 4.2.8.RELEASE_1  | Apache ServiceMix :: Bundles :: 
> spring-beans
> 73 | Active   |  30 | 3.2.17.RELEASE_1 | Apache ServiceMix :: Bundles :: 
> spring-context
> 74 | Active   |  30 | 4.2.8.RELEASE_1  | Apache ServiceMix :: Bundles :: 
> spring-context
> 75 | Active   |  30 | 3.2.17.RELEASE_1 | Apache ServiceMix :: Bundles :: 
> spring-context-support
> 76 | Active   |  30 | 4.2.8.RELEASE_1  | Apache ServiceMix :: Bundles :: 
> spring-context-support
> 77 | Active   |  30 | 3.2.17.RELEASE_1 | Apache ServiceMix :: Bundles :: 
> spring-core
> 78 | Active   |  30 | 4.2.8.RELEASE_1  | Apache ServiceMix :: Bundles :: 
> spring-core
> 79 | Active   |  30 | 3.2.17.RELEASE_1 | Apache ServiceMix :: Bundles :: 
> spring-expression
> 80 | Active   |  30 | 4.2.8.RELEASE_1  | Apache ServiceMix :: Bundles :: 
> spring-expression
> 81 | Active   |  30 | 3.2.17.RELEASE_1 | Apache ServiceMix :: Bundles :: 
> spring-jms
> 82 | Active   |  30 | 4.2.8.RELEASE_1  | Apache ServiceMix :: Bundles :: 
> spring-jms
> 83 | Active   |  30 | 3.2.17.RELEASE_1 | Apache ServiceMix :: Bundles :: 
> spring-tx
> 84 | Active   |  30 | 4.2.8.RELEASE_1  | Apache ServiceMix :: Bundles :: 
> spring-tx
>
> And when you examine the dependency tree of activemq-camel you can see 
> following (excuse me long listings):
>
> karaf@root()> bundle:tree-show 52
> Bundle org.apache.activemq.activemq-camel [52

Re: ActiveMQ and Camel 2.17.x on Karaf

2017-01-23 Thread Krzysztof Sobkowiak
nd you can see all bundles use the Spring 
4.2.8.RELEASE_1, but there is no org.apache.xbean.spring in this dependency 
tree. Probably because of the error while restarting Karaf. When we inspect 
this bundle we can see it doesn't allow to wire the Spring 4.

org.springframework.beans;version="[2.5,4)",
org.springframework.beans.factory;version="[2.5,4)",
org.springframework.beans.factory.config;version="[2.5,4)",
org.springframework.beans.factory.parsing;version="[2.5,4)",
org.springframework.beans.factory.support;version="[2.5,4)",
org.springframework.beans.factory.xml;version="[2.5,4)",
org.springframework.context;version="[2.5,4)",
org.springframework.context.support;version="[2.5,4)",
org.springframework.core.io;version="[2.5,4)",
org.springframework.core.io.support;version="[2.5,4)",
org.springframework.util;version="[2.5,4)",
org.springframework.util.xml;version="[2.5,4)",

So we have one bundle which cannot use the same Spring version like all other 
bundles. Maybe this is the problem.

Kindly regards
Krzysztof



On 19.01.2017 08:15, Sobkowiak Krzysztof wrote:
> Btw, this trick with camel-cxf doesn't help with Camel 2.18.x. I think, there 
> was a change in Camel 2.17.3 which helped with this problem (but not 
> completely yet), but the change is not available in 2.18.x (I tried current 
> snapshot and it didn't help too).
>
> It looks like this change has helped in 2.17.3 
> https://github.com/apache/camel/commit/284cc6780de1e32468ef2ae50ad357a444e79da1
>  (CAMEL-10153), which introduces [3.2,5) as version range for spring in 
> camel-cxf. In 2.18.x there is still used the version range [4.1,5)
>
> Regards
> Krzysztof
>
> On 19.01.2017 01:17, Krzysztof Sobkowiak wrote:
>> My mistake. This problem still happens in the sample steps below - the 
>> exception still occurs after Karaf restart and broker doesn't start.
>> But adding camel-cxf seems to fix this problem
>>
>> feature:install camel camel-blueprint camel-jms camel-cxf activemq-camel 
>> activemq-broker-noweb activemq-blueprint
>>
>> Kindly regards
>> Krzysztof
>>
>>
>> On 14.01.2017 22:55, Krzysztof Sobkowiak wrote:
>>> Hi
>>>
>>> I could successfully install Camel 2.17.3 and ActiveMQ 5.14.3 on Karaf 
>>> 4.0.8 (also 4.0.7):
>>>
>>>
>>> __ __   
>>>/ //_/ __ _/ __/ 
>>>   / ,<  / __ `/ ___/ __ `/ /_   
>>>  / /| |/ /_/ / /  / /_/ / __/   
>>> /_/ |_|\__,_/_/   \__,_/_/
>>>
>>>   Apache Karaf (4.0.8)
>>>
>>> Hit '' for a list of available commands
>>> and '[cmd] --help' for help on a specific command.
>>> Hit '' or type 'system:shutdown' or 'logout' to shutdown Karaf.
>>>
>>> karaf@root()> feature:repo-add camel 2.17.3
>>> Adding feature url 
>>> mvn:org.apache.camel.karaf/apache-camel/2.17.3/xml/features
>>> karaf@root()> feature:repo-add activemq 5.14.3
>>> Adding feature url 
>>> mvn:org.apache.activemq/activemq-karaf/5.14.3/xml/features
>>> karaf@root()> feature:install camel camel-blueprint camel-jms 
>>> activemq-camel activemq-broker-noweb activemq-blueprint
>>> karaf@root()> activemq:list
>>> brokerName = amq-broker
>>>
>>>
>>> Kindly tegards
>>> Krzysztof
>>>
>>> On 30.11.2016 14:11, IODB wrote:
>>>> Can somebody refer me to the relevant Jira issue, so I can track its
>>>> progress?
>>>>
>>>> Thanks
>>>>
>>>>
> Krzysztof Sobkowiak
>
> JEE & OSS Architect, Integration Architect
> Apache Software Foundation Member (http://apache.org/)
> Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
> Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)




Re: ActiveMQ and Camel 2.17.x on Karaf

2017-01-18 Thread Krzysztof Sobkowiak
My mistake. This problem still happens in the sample steps below - the 
exception still occurs after Karaf restart and broker doesn't start.
But adding camel-cxf seems to fix this problem

feature:install camel camel-blueprint camel-jms camel-cxf activemq-camel 
activemq-broker-noweb activemq-blueprint

Kindly regards
Krzysztof


On 14.01.2017 22:55, Krzysztof Sobkowiak wrote:
> Hi
>
> I could successfully install Camel 2.17.3 and ActiveMQ 5.14.3 on Karaf 4.0.8 
> (also 4.0.7):
>
>
> __ __   
>/ //_/ __ _/ __/ 
>   / ,<  / __ `/ ___/ __ `/ /_   
>  / /| |/ /_/ / /  / /_/ / __/   
> /_/ |_|\__,_/_/   \__,_/_/
>
>   Apache Karaf (4.0.8)
>
> Hit '' for a list of available commands
> and '[cmd] --help' for help on a specific command.
> Hit '' or type 'system:shutdown' or 'logout' to shutdown Karaf.
>
> karaf@root()> feature:repo-add camel 2.17.3
> Adding feature url mvn:org.apache.camel.karaf/apache-camel/2.17.3/xml/features
> karaf@root()> feature:repo-add activemq 5.14.3
> Adding feature url mvn:org.apache.activemq/activemq-karaf/5.14.3/xml/features
> karaf@root()> feature:install camel camel-blueprint camel-jms activemq-camel 
> activemq-broker-noweb activemq-blueprint
> karaf@root()> activemq:list
> brokerName = amq-broker
>
>
> Kindly tegards
> Krzysztof
>
> On 30.11.2016 14:11, IODB wrote:
>> Can somebody refer me to the relevant Jira issue, so I can track its
>> progress?
>>
>> Thanks
>>
>>
>>
>> --
>> View this message in context: 
>> http://karaf.922171.n3.nabble.com/ActiveMQ-and-Camel-2-17-x-on-Karaf-tp4046427p4048863.html
>> Sent from the Karaf - Dev mailing list archive at Nabble.com.
>
> -- 
> Krzysztof Sobkowiak (@ksobkowiak)
>
> JEE & OSS Architect, Integration Architect
> Apache Software Foundation Member (http://apache.org/)
> Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
> Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: ActiveMQ and Camel 2.17.x on Karaf

2017-01-14 Thread Krzysztof Sobkowiak
Hi

I could successfully install Camel 2.17.3 and ActiveMQ 5.14.3 on Karaf 4.0.8 
(also 4.0.7):


__ __   
   / //_/ __ _/ __/ 
  / ,<  / __ `/ ___/ __ `/ /_   
 / /| |/ /_/ / /  / /_/ / __/   
/_/ |_|\__,_/_/   \__,_/_/

  Apache Karaf (4.0.8)

Hit '' for a list of available commands
and '[cmd] --help' for help on a specific command.
Hit '' or type 'system:shutdown' or 'logout' to shutdown Karaf.

karaf@root()> feature:repo-add camel 2.17.3
Adding feature url mvn:org.apache.camel.karaf/apache-camel/2.17.3/xml/features
karaf@root()> feature:repo-add activemq 5.14.3
Adding feature url mvn:org.apache.activemq/activemq-karaf/5.14.3/xml/features
karaf@root()> feature:install camel camel-blueprint camel-jms activemq-camel 
activemq-broker-noweb activemq-blueprint
karaf@root()> activemq:list
brokerName = amq-broker


Kindly tegards
Krzysztof

On 30.11.2016 14:11, IODB wrote:
> Can somebody refer me to the relevant Jira issue, so I can track its
> progress?
>
> Thanks
>
>
>
> --
> View this message in context: 
> http://karaf.922171.n3.nabble.com/ActiveMQ-and-Camel-2-17-x-on-Karaf-tp4046427p4048863.html
> Sent from the Karaf - Dev mailing list archive at Nabble.com.

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: ActiveMQ and Camel 2.17.x on Karaf

2016-11-27 Thread Krzysztof Sobkowiak
Additional observation:

Installing the activemq components leads to installation of 3 versions of 
Spring bundles

la
---
 96 | Active   |  30 | 3.2.17.RELEASE_1   | Apache ServiceMix 
:: Bundles :: spring-aop
 97 | Active   |  30 | 4.1.7.RELEASE_2| Apache ServiceMix 
:: Bundles :: spring-aop
 98 | Active   |  30 | 4.2.5.RELEASE_1| Apache ServiceMix 
:: Bundles :: spring-aop
 99 | Active   |  30 | 3.2.17.RELEASE_1   | Apache ServiceMix 
:: Bundles :: spring-beans
100 | Active   |  30 | 4.1.7.RELEASE_2| Apache ServiceMix 
:: Bundles :: spring-beans
101 | Active   |  30 | 4.2.5.RELEASE_1| Apache ServiceMix 
:: Bundles :: spring-beans
102 | Active   |  30 | 3.2.17.RELEASE_1   | Apache ServiceMix 
:: Bundles :: spring-context
103 | Active   |  30 | 4.1.7.RELEASE_2| Apache ServiceMix 
:: Bundles :: spring-context
104 | Active   |  30 | 4.2.5.RELEASE_1| Apache ServiceMix 
:: Bundles :: spring-context
105 | Active   |  30 | 3.2.17.RELEASE_1   | Apache ServiceMix 
:: Bundles :: spring-context-support
106 | Active   |  30 | 4.1.7.RELEASE_2| Apache ServiceMix 
:: Bundles :: spring-context-support
107 | Active   |  30 | 4.2.5.RELEASE_1| Apache ServiceMix 
:: Bundles :: spring-context-support
108 | Active   |  30 | 3.2.17.RELEASE_1   | Apache ServiceMix 
:: Bundles :: spring-core
109 | Active   |  30 | 4.1.7.RELEASE_2| Apache ServiceMix 
:: Bundles :: spring-core
110 | Active   |  30 | 4.2.5.RELEASE_1| Apache ServiceMix 
:: Bundles :: spring-core
111 | Active   |  30 | 3.2.17.RELEASE_1   | Apache ServiceMix 
:: Bundles :: spring-expression
112 | Active   |  30 | 4.1.7.RELEASE_2| Apache ServiceMix 
:: Bundles :: spring-expression
113 | Active   |  30 | 4.2.5.RELEASE_1| Apache ServiceMix 
:: Bundles :: spring-expression
114 | Active   |  30 | 4.1.7.RELEASE_2| Apache ServiceMix 
:: Bundles :: spring-jms
115 | Active   |  30 | 4.2.5.RELEASE_1| Apache ServiceMix 
:: Bundles :: spring-jms
116 | Active   |  30 | 4.1.7.RELEASE_2| Apache ServiceMix 
:: Bundles :: spring-tx
117 | Active   |  30 | 4.2.5.RELEASE_1| Apache ServiceMix 
:: Bundles :: spring-tx

Regards
Krzysztof


On 27.11.2016 15:58, Krzysztof Sobkowiak wrote:
> I have just added following entry to activemq-osgi pom file in current 
> ActiveMQ master
>
> org.apache.xbean.spring.context.v2;resolution:=optional;version="[3.13,5)",
>
> The problem still exists, but everything looks ok with the wiring:
>
> karaf@root()> exports | grep org.apache.xbean.spring.context.v2
> org.apache.xbean.spring.context.v2 | 4.2.0
>   | 123 | org.apache.xbean.spring
> org.apache.xbean.spring.context.v2c| 4.2.0
>   | 123 | org.apache.xbean.spring
>
> karaf@root()> imports | grep org.apache.xbean.spring.context.v2
> org.apache.xbean.spring.context.v2 | 
> [3.13.0,5.0.0) | resolved   | 66  | org.apache.activemq.activemq-osgi
>
> karaf@root()> bundle:classes 123 | grep XBeanNamespaceHandler
> org/apache/xbean/spring/context/v2/XBeanNamespaceHandler.class
> org/apache/xbean/spring/context/v2/XBeanNamespaceHandlerResolver.class
> org/apache/xbean/spring/context/v2c/XBeanNamespaceHandler$1.class
> org/apache/xbean/spring/context/v2c/XBeanNamespaceHandler.class
>
>
> karaf@root()> headers 66
>
> activemq-osgi (66)
> --
>
> .
>
> Import-Package =
> com.fasterxml.jackson.annotation;resolution:=optional;version="[2.6,3)",
> com.fasterxml.jackson.databind;resolution:=optional;version="[2.6,3)",
> 
> com.fasterxml.jackson.databind.annotation;resolution:=optional;version="[2.6,3)",
> 
> org.apache.tools.ant;resolution:=optional,
> org.apache.xbean.spring.context;resolution:=optional;version="[3.13,5)",
> 
> org.apache.xbean.spring.context.impl;resolution:=optional;version="[3.13,5)",
> 
> org.apache.xbean.spring.context.v2;resolution:=optional;version="[3.13,5)",
> org.apache.zookeeper;resolution:=optional;version="[3.4,4)",
> org.apache.zookeeper.data;resolution:=optional;version="[3.4,4)",
>
>
>
> karaf@root()> headers 123
>
> Apache XBean :: Spring (123)
> 
> .
> Export-Package =
> ...
> org.apache.xbean.spring.context.v2;
> uses:="org.ap

Re: ActiveMQ and Camel 2.17.x on Karaf

2016-11-27 Thread Krzysztof Sobkowiak
I have just added following entry to activemq-osgi pom file in current ActiveMQ 
master

org.apache.xbean.spring.context.v2;resolution:=optional;version="[3.13,5)",

The problem still exists, but everything looks ok with the wiring:

karaf@root()> exports | grep org.apache.xbean.spring.context.v2
org.apache.xbean.spring.context.v2 | 4.2.0  
| 123 | org.apache.xbean.spring
org.apache.xbean.spring.context.v2c| 4.2.0  
| 123 | org.apache.xbean.spring

karaf@root()> imports | grep org.apache.xbean.spring.context.v2
org.apache.xbean.spring.context.v2 | [3.13.0,5.0.0) 
| resolved   | 66  | org.apache.activemq.activemq-osgi

karaf@root()> bundle:classes 123 | grep XBeanNamespaceHandler
org/apache/xbean/spring/context/v2/XBeanNamespaceHandler.class
org/apache/xbean/spring/context/v2/XBeanNamespaceHandlerResolver.class
org/apache/xbean/spring/context/v2c/XBeanNamespaceHandler$1.class
org/apache/xbean/spring/context/v2c/XBeanNamespaceHandler.class


karaf@root()> headers 66

activemq-osgi (66)
--

.

Import-Package =
com.fasterxml.jackson.annotation;resolution:=optional;version="[2.6,3)",
com.fasterxml.jackson.databind;resolution:=optional;version="[2.6,3)",

com.fasterxml.jackson.databind.annotation;resolution:=optional;version="[2.6,3)",

org.apache.tools.ant;resolution:=optional,
org.apache.xbean.spring.context;resolution:=optional;version="[3.13,5)",

org.apache.xbean.spring.context.impl;resolution:=optional;version="[3.13,5)",
org.apache.xbean.spring.context.v2;resolution:=optional;version="[3.13,5)",
org.apache.zookeeper;resolution:=optional;version="[3.4,4)",
org.apache.zookeeper.data;resolution:=optional;version="[3.4,4)",



karaf@root()> headers 123

Apache XBean :: Spring (123)

.
Export-Package =
...
org.apache.xbean.spring.context.v2;
uses:="org.apache.xbean.spring.context,
org.springframework.beans,
org.springframework.beans.factory,
org.springframework.beans.factory.config,
org.springframework.beans.factory.support,
org.springframework.beans.factory.xml,
org.springframework.context,
org.springframework.core.io,
org.w3c.dom";
version=4.2,


So, the package seems to be correctly exported and wired to activemq-osgi. I 
cannot see any other exceptions in log. I tried to refresh/restart/re-resolve 
the bundles and the same effect. Altough the package is correctly wired and 
contains the necessery class, the class cannot be found in the activemq-osgi 
classpath.

One additional observation, maybe it helps - bundle:requirements doesn't show 
xbean as requirement for activemq-osgi.

karaf@root()> bundle:requirements 66 | grep org.apache.xbean
karaf@root()>




Kindly regards
Krzysztof
 









 

On 27.11.2016 14:09, Jean-Baptiste Onofré wrote:
> Hi Krzysztof
>
> yup, it sounds like a missing import.
>
> I gonna take a look later today.
>
> Regards
> JB
>
> On 11/27/2016 01:54 PM, Krzysztof Sobkowiak wrote:
>> Hi
>>
>> I have tested it yesterday again on Karaf 4.0.7 with Camel 2.17.3 and 
>> ActiveMQ 5.14.1 and I can install activemq-broker an activemq-camel. But 
>> after restart I get following error
>>
>> Caused by: java.lang.ClassNotFoundException: 
>> org.apache.xbean.spring.context.v2.XBeanNamespaceHandler not found by 
>> org.apache.activemq.activemq-osgi [62]
>> at 
>> org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1574)[org.apache.felix.framework-5.4.0.jar:]
>> at 
>> org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:79)[org.apache.felix.framework-5.4.0.jar:]
>> at 
>> org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:2018)[org.apache.felix.framework-5.4.0.jar:]
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:357)[:1.8.0_111]
>> at 
>> org.springframework.util.ClassUtils.forName(ClassUtils.java:250)[95:org.apache.servicemix.bundles.spring-core:4.2.5.RELEASE_1]
>> at 
>> org.springframework.beans.factory.xml.DefaultNamespaceHandlerResolver.resolve(DefaultNamespaceHandlerResolver.java:125)[89:org.apache.servicemix.bundles.spring-beans:4.2.5.RELEASE_1]
>>
>> I think, addidng import for org.apache.xbean.spring.context.v2 in 
>> activemq-osgi should help (at least as a workaround)
>>
>> Kindly regards
>> Krzysztof
>>
>>
>>
>> On 27.11.2016 12:24, Jean-Baptiste Onofr

Re: ActiveMQ and Camel 2.17.x on Karaf

2016-11-27 Thread Krzysztof Sobkowiak
Hi

I have tested it yesterday again on Karaf 4.0.7 with Camel 2.17.3 and ActiveMQ 
5.14.1 and I can install activemq-broker an activemq-camel. But after restart I 
get following error

Caused by: java.lang.ClassNotFoundException: 
org.apache.xbean.spring.context.v2.XBeanNamespaceHandler not found by 
org.apache.activemq.activemq-osgi [62]
at 
org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1574)[org.apache.felix.framework-5.4.0.jar:]
at 
org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:79)[org.apache.felix.framework-5.4.0.jar:]
at 
org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:2018)[org.apache.felix.framework-5.4.0.jar:]
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)[:1.8.0_111]
at 
org.springframework.util.ClassUtils.forName(ClassUtils.java:250)[95:org.apache.servicemix.bundles.spring-core:4.2.5.RELEASE_1]
at 
org.springframework.beans.factory.xml.DefaultNamespaceHandlerResolver.resolve(DefaultNamespaceHandlerResolver.java:125)[89:org.apache.servicemix.bundles.spring-beans:4.2.5.RELEASE_1]

I think, addidng import for org.apache.xbean.spring.context.v2 in activemq-osgi 
should help (at least as a workaround)

Kindly regards
Krzysztof



On 27.11.2016 12:24, Jean-Baptiste Onofré wrote:
> Hi Christian,
>
> Please, ping me tomorrow we can sync/work together on that.
>
> Regards
> JB
>
> On 11/27/2016 09:05 AM, Christian Schneider wrote:
>> My fixes were only touching activemq blueprint. I did not check the
>> ActiveMQ spring support.
>> This might be very relevant for TESB though. I will look into it tomorrow.
>>
>> Christian
>>
>>
>> 2016-11-27 6:18 GMT+01:00 Jean-Baptiste Onofré <j...@nanthrax.net>:
>>
>>> Hi,
>>>
>>> Christian did some fixes recently. Did you check with a ActiveMQ SNAPSHOT ?
>>>
>>> Regards
>>> JB
>>>
>>>
>>> On 11/26/2016 09:44 PM, IODB wrote:
>>>
>>>> Issue still exists with ActiveMQ 5.14.1 - Camel 2.18.0 - Karaf 4.0.7
>>>>
>>>>
>>>>
>>>> -- 
>>>> View this message in context: http://karaf.922171.n3.nabble.
>>>> com/ActiveMQ-and-Camel-2-17-x-on-Karaf-tp4046427p4048826.html
>>>> Sent from the Karaf - Dev mailing list archive at Nabble.com.
>>>>
>>>>
>>> -- 
>>> Jean-Baptiste Onofré
>>> jbono...@apache.org
>>> http://blog.nanthrax.net
>>> Talend - http://www.talend.com
>>>
>>
>>
>>
>

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Application Consultant @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [HEADS UP] Next releases

2016-11-12 Thread Krzysztof Sobkowiak
Hi

Any plans for Karaf 3.0.9?

Kindly regards
Krzysztof

On 10.10.2016 07:43, Jean-Baptiste Onofré wrote:
> Hi all,
>
> Just a rough schedule for the next release:
>
> - in the coming two weeks (probably end of this week or next one):
> -- Cellar 4.0.3 (including support of bundles and features update, hazelcast 
> upgrade and other bug fixes)
> -- Decanter 1.3.0 (elasticsearch upgrade, fix on kafka appender, new features)
> - in two weeks:
> -- Container 4.0.8: the ARM/Solaris issue should be fixed now (that was an 
> important regression in 4.0.6 & 4.0.7). Other fixes and upgrades are coming 
> too.
>
> Blog:
> - Karaf & Cellar with Mesos and Marathon: last week, I prepared a blog post 
> showing how to use Karaf and Cellar on Mesos and Marathon. I will push on my 
> github the dockerfile and marathon json. I will propose the docker image as 
> official (based on alpine/jre).
> I planned to do a talk based on that during ApacheCon but my talk proposal 
> has been declined.
> I plan to publish this post during the week end.
>
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Application Consultant @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Managed Service & Managed Service factory

2016-10-16 Thread Krzysztof Sobkowiak
Hi

Are there any samples how to implement correctly the Managed Service and 
Managed Service Factory / Component Factory using the OSGi Declarative Services 
Annotations? Something like in 
https://github.com/apache/karaf/tree/master/scr/examples/managed-service and 
https://github.com/apache/karaf/tree/master/scr/examples/component-factory but 
using the org.osgi.service.component.annotations annotations.

Btw. are there any samples how to do this correctly with Blueprint?

Kindly regards
Krzysztof




-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf (Container) 4.0.7 release

2016-09-19 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 19.09.2016 08:53, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Karaf (Container) 4.0.7 release to your vote.
>
> Release Notes:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12338147
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1075/
>
> Git Tag:
> karaf-4.0.7
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf (Container) 3.0.8 release

2016-08-08 Thread Krzysztof Sobkowiak
+1 (non-biding)

ServiceMix 6 ok with the new version

Regards
Krzysztof

On 08.08.2016 09:59, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Karaf Container 3.0.8 release to your vote.
>
> Release Notes:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12335948
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1069/
>
> Git Tag:
> karaf-3.0.8
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks,

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: Java 6 support broken in Karaf 3.0.x

2016-07-06 Thread Krzysztof Sobkowiak
This problem happens since 3.0.6.

On 06.07.2016 23:20, Krzysztof Sobkowiak wrote:
> Hi
>
> According to http://karaf.apache.org/download.html Karaf 3.0.x supports Java 
> 6. I tried to start it with 1.6.0_45 and got following error while starting 
> the container
>
> java.lang.UnsupportedClassVersionError: 
> org/apache/felix/fileinstall/internal/FileInstall : Unsupported major.minor 
> version 51.0
> at java.lang.ClassLoader.defineClass1(Native Method)
> at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
> at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
> at 
> org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2279)
> at 
> org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1501)
> at 
> org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)
> at 
> org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> at 
> org.apache.felix.framework.BundleWiringImpl.getClassByDelegation(BundleWiringImpl.java:1374)
> at org.apache.felix.framework.Felix.createBundleActivator(Felix.java:4329)
> at org.apache.felix.framework.Felix.activateBundle(Felix.java:2141)
> at org.apache.felix.framework.Felix.startBundle(Felix.java:2064)
> at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1291)
> at 
> org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
> at java.lang.Thread.run(Thread.java:662)
> [FelixStartLevel] ERROR 
> org.apache.aries.blueprint.container.BlueprintContainerImpl - Unable to start 
> blueprint container for bundle org.apache.aries.blueprint.cm/1.0.8
> java.lang.NoClassDefFoundError: java/lang/AutoCloseable
> at java.lang.ClassLoader.defineClass1(Native Method)
> at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
> at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
> at 
> org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2279)
> at 
> org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1501)
> at 
> org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)
> at 
> org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> at 
> org.apache.aries.blueprint.namespace.NamespaceHandlerRegistryImpl$NamespaceHandlerSetImpl.createSchema(NamespaceHandlerRegistryImpl.java:603)
> at 
> org.apache.aries.blueprint.namespace.NamespaceHandlerRegistryImpl$NamespaceHandlerSetImpl.doGetSchema(NamespaceHandlerRegistryImpl.java:458)
> at 
> org.apache.aries.blueprint.namespace.NamespaceHandlerRegistryImpl$NamespaceHandlerSetImpl.getSchema(NamespaceHandlerRegistryImpl.java:443)
> at 
> org.apache.aries.blueprint.container.BlueprintContainerImpl.doRun(BlueprintContainerImpl.java:343)
> at 
> org.apache.aries.blueprint.container.BlueprintContainerImpl.run(BlueprintContainerImpl.java:276)
> at 
> org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:300)
> at 
> org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:269)
> at 
> org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:265)
> at 
> org.apache.aries.blueprint.container.BlueprintExtender.modifiedBundle(BlueprintExtender.java:255)
> at 
> org.apache.aries.blueprint.container.BlueprintExtender.addingBundle(BlueprintExtender.java:218)
> at 
> org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerAdding(BundleHookBundleTracker.java:487)
> at 
> org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerAdding(BundleHookBundleTracker.java:433)
> at 
> org.apache.aries.util.tracker.hook.BundleHookBundleTracker$AbstractTracked.trackAdding(BundleHookBundleTracker.java:749)
> at 
> org.apache.aries.util.tracker.hook.BundleHookBundleTracker$AbstractTracked.trackInitial(BundleHookBundleTracker.java:674)
> at 
> org.apache.aries.util.tracker.hook.BundleHookBundleTracker.open(BundleHookBundleTracker.java:159)
> at 
> org.apache.aries.util.tracker.RecursiveBundleTracker.open(RecursiveBundleTracker.java:106)
> at 
> org.apache.aries.blueprint.container.BlueprintExtender$2.serviceFound(BlueprintExtender.java:119)
> at 
> org.apache.aries.util.tracker.SingleServiceTracker.updat

Java 6 support broken in Karaf 3.0.x

2016-07-06 Thread Krzysztof Sobkowiak
)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2064)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1291)
at 
org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.ClassNotFoundException: java.lang.AutoCloseable
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at 
org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1460)
at 
org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)
at 
org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
... 35 more

AutoCloseable has been introduced in Java 7.

I'm getting similar problems while starting ServiceMix

 19% [=>  
]ERROR: Bundle org.apache.felix.fileinstall [7] Error starting 
mvn:org.apache.felix/org.apache.felix.fileinstall/3.5.2 
(org.osgi.framework.BundleException: Activator start error in bundle 
org.apache.felix.fileinstall [7].)
java.lang.UnsupportedClassVersionError: 
org/apache/felix/fileinstall/internal/FileInstall : Unsupported major.minor 
version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
at java.lang.ClassLoader.defineClass(ClassLoader.java:615)


38% [===>
][FelixStartLevel] ERROR 
org.apache.aries.blueprint.container.BlueprintContainerImpl - Unable to start 
blueprint container for bundle org.apache.karaf.deployer.spring/3.0.6
java.lang.UnsupportedClassVersionError: 
org/apache/felix/fileinstall/ArtifactUrlTransformer : Unsupported major.minor 
version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
at 
org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2279)
at 
org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1501)
at 
org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)
at 
org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at 
org.apache.felix.framework.BundleWiringImpl.getClassByDelegation(BundleWiringImpl.java:1374)


Caused by: java.lang.ClassNotFoundException: 
java.util.concurrent.ConcurrentLinkedDeque
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at 
org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1460)


ConcurrentLinkedDeque introduced in Java 7.

I think Karaf 3.0.x no more supports Java 6 and we should remove this 
iformation from the schedule matrix and update the supported target/source in 
pom.

Kindly regards
Krzysztof

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf 3.0.7 release (take 3)

2016-06-17 Thread Krzysztof Sobkowiak
Look here 
http://irclogs.dankulp.com/logs/irclogger_log/apache-karaf?date=2016-06-16,Thu

On 17.06.2016 22:16, Krzysztof Sobkowiak wrote:
> I've chatted with JB and he told he will include it in 3.0.8.
>
> On 17.06.2016 22:02, Jamie G. wrote:
>> > Is take 3 under vote or was it delayed for Karaf 4539?
>> >

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf 3.0.7 release (take 3)

2016-06-17 Thread Krzysztof Sobkowiak
I've chatted with JB and he told he will include it in 3.0.8.

On 17.06.2016 22:02, Jamie G. wrote:
> Is take 3 under vote or was it delayed for Karaf 4539?
>
> On Fri, Jun 17, 2016 at 5:28 PM, Krzysztof Sobkowiak
> <krzys.sobkow...@gmail.com> wrote:
>> +1 (non-binding) - tests like in take 2
>>
>> Regards
>> Krzysztof
>>
>> On 15.06.2016 06:29, Jean-Baptiste Onofré wrote:
>>> Hi all,
>>>
>>> I submit Apache Karaf (Container) 3.0.7 to your vote.
>>>
>>> Release Notes:
>>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12334639
>>>
>>> Staging Repository:
>>> https://repository.apache.org/content/repositories/orgapachekaraf-1066/
>>>
>>> Please vote to approve this release:
>>>
>>> [ ] +1 Approve the release
>>> [ ] -1 Don't approve the release (please provide specific comments)
>>>
>>> This vote will be open for at least 72 hours.
>>>
>>> Thanks,
>>> Regards
>>> JB
>> --
>> Krzysztof Sobkowiak (@ksobkowiak)
>>
>> JEE & OSS Architect, Integration Architect
>> Apache Software Foundation Member (http://apache.org/)
>> Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
>> Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf 3.0.7 release (take 3)

2016-06-17 Thread Krzysztof Sobkowiak
+1 (non-binding) - tests like in take 2

Regards
Krzysztof

On 15.06.2016 06:29, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Apache Karaf (Container) 3.0.7 to your vote.
>
> Release Notes:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12334639
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1066/
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: ActiveMQ and Camel 2.17.x on Karaf

2016-06-12 Thread Krzysztof Sobkowiak
Hi

Any news about this problem?

Regards
Krzysztof

On 28.04.2016 21:21, Krzysztof Sobkowiak wrote:
> It looks like it's again the problem with installing of multiple Spring 
> versions while ActiveMQ bundles are already present in Karaf. Spring 
> 3.2.14.RELEASE_1 was already installed with the broker and now all other 
> Spring versions are installed with activemq-camel feature.
>
> karaf@root()> feature:install -v activemq-camel
> Adding features: activemq-camel/[5.13.3,5.13.3]
> Changes to perform:
>   Region: root
> Bundles to update:
>   org.apache.servicemix.bundles.jaxb-impl/2.2.11.1 with 
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jaxb-impl/2.2.6_1
> Bundles to install:
>   mvn:org.apache.activemq/activemq-camel/5.13.3
>   mvn:org.apache.camel/camel-blueprint/2.17.0
>   mvn:org.apache.camel/camel-catalog/2.17.0
>   mvn:org.apache.camel/camel-commands-core/2.17.0
>   mvn:org.apache.camel/camel-core/2.17.0
>   mvn:org.apache.camel/camel-jms/2.17.0
>   mvn:org.apache.camel.karaf/camel-karaf-commands/2.17.0
>   mvn:commons-codec/commons-codec/1.9
>   mvn:commons-pool/commons-pool/1.6
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.1.7.RELEASE_2
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.2.5.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.1.7.RELEASE_2
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.2.5.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.1.7.RELEASE_2
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.2.5.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.1.7.RELEASE_2
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.2.5.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.1.7.RELEASE_2
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.2.5.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.1.7.RELEASE_2
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.2.5.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-jms/4.1.7.RELEASE_2
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-jms/4.2.5.RELEASE_1
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-tx/4.1.7.RELEASE_2
>   
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-tx/4.2.5.RELEASE_1
>   mvn:org.springframework/spring-aop/3.1.4.RELEASE
>   mvn:org.springframework/spring-asm/3.1.4.RELEASE
>   mvn:org.springframework/spring-beans/3.1.4.RELEASE
>   mvn:org.springframework/spring-context/3.1.4.RELEASE
>   mvn:org.springframework/spring-context-support/3.1.4.RELEASE
>   mvn:org.springframework/spring-core/3.1.4.RELEASE
>   mvn:org.springframework/spring-expression/3.1.4.RELEASE
>   mvn:org.codehaus.woodstox/stax2-api/3.1.4
>   mvn:org.codehaus.woodstox/woodstox-core-asl/4.4.1
>   ...
>
> I have described something similar here 
> http://karaf.922171.n3.nabble.com/Feature-spring-4-2-3-RELEASE-1-also-installs-bundles-from-Spring-version-3-1-4-when-activemq-is-instd-td4046213.html.
>
> Regards
> Krzysztof
>
>
>
> On 28.04.2016 00:27, Krzysztof Sobkowiak wrote:
>> Hi
>>
>> I have tried to install activemq-broker-noweb and activemq-camel features 
>> (5.13.2, 5.13.3 and current master) with Camel 2.17.0 on Karaf 4.0.5 but 
>> with no success:
>>
>> karaf@root()> feature:repo-add camel 2.17.0
>> Adding feature url 
>> mvn:org.apache.camel.karaf/apache-camel/2.17.0/xml/features
>> karaf@root()> feature:repo-add activemq 5.13.2
>> Adding feature url mvn:org.apache.activemq/activemq-karaf/5.13.2/xml/features
>> karaf@root()> feature:install activemq-broker-noweb
>> karaf@root()> activemq:list
>> brokerName = amq-broker
>>
>> karaf@root()> feature:install activemq-camel
>> karaf@root()> activemq:list
>> karaf@root()>
>>
>> The activemq-osgi bundle is refreshed and and cannot be resolved anymore
>>
>> There is following entry in log
>>
>> Caused by: java.lang.ClassNotFoundException: 
>> org.apache.xbean.spring.context.v2.XBeanNamespaceHandler not foun

Re: [VOTE] Apache Karaf 3.0.7 release (take 2)

2016-06-08 Thread Krzysztof Sobkowiak
+1 (non-binding)

ServiceMix itests and smoke tests ok. Jdbc, jndi, jms ok. Some tests with Camel 
and ActiveMQ on vanilla Karaf ok.

Regards
Krzysztof

On 08.06.2016 15:51, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Apache Karaf (Container) 3.0.7 to your vote. 
>
> Release Notes:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12334639
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1065/
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


java.lang.IllegalArgumentException: Invalid syntax for version: 3.0.7-SNAPSHOT

2016-05-19 Thread Krzysztof Sobkowiak
Hi

While building (successfully) karaf-3.0.x I have observed following stacktraces 
in the maven output

[INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ 
org.apache.karaf.demos.command ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory 
/home/kso/work/projects/asf/karaf/karaf-3.0.x/demos/command/src/test/resources
[INFO] Copying 3 resources
[INFO] Copying 3 resources
[INFO] Copying 3 resources
[INFO]
[INFO] --- maven-compiler-plugin:3.2:testCompile (default-testCompile) @ 
org.apache.karaf.demos.command ---
[INFO] No sources to compile
[INFO]
[INFO] --- maven-surefire-plugin:2.17:test (default-test) @ 
org.apache.karaf.demos.command ---
[INFO] Tests are skipped.
[INFO]
[INFO] --- maven-site-plugin:3.4:attach-descriptor (attach-descriptor) @ 
org.apache.karaf.demos.command ---
[INFO]
[INFO] <<< maven-bundle-plugin:2.5.4:bundle (default-bundle) < package @ 
org.apache.karaf.demos.command <<<
[INFO]
[INFO] --- maven-bundle-plugin:2.5.4:bundle (default-bundle) @ 
org.apache.karaf.demos.command ---
java.lang.IllegalArgumentException: Invalid syntax for version: 3.0.7-SNAPSHOT
at aQute.bnd.version.Version.(Version.java:46)
at aQute.bnd.osgi.Analyzer.augmentExports(Analyzer.java:1711)
at aQute.bnd.osgi.Analyzer.analyze(Analyzer.java:229)
at aQute.bnd.osgi.Builder.analyze(Builder.java:352)
at aQute.bnd.osgi.Analyzer.calcManifest(Analyzer.java:618)
at aQute.bnd.osgi.Builder.build(Builder.java:81)
at 
org.apache.felix.bundleplugin.BundlePlugin.buildOSGiBundle(BundlePlugin.java:632)
at org.apache.felix.bundleplugin.BundlePlugin.execute(BundlePlugin.java:351)
at org.apache.felix.bundleplugin.BundlePlugin.execute(BundlePlugin.java:268)
at org.apache.felix.bundleplugin.BundlePlugin.execute(BundlePlugin.java:259)
at 
org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
at 
org.apache.maven.lifecycle.internal.MojoExecutor.executeForkedExecutions(MojoExecutor.java:352)
at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:197)
at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
at 
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
at 
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
at 
org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
at 
org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at 
org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
at 
org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
at 
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)


It looks like this  happens when maven builds the test sources. Is it ok?


Regards
Krzysztof


-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


ActiveMQ and Camel 2.17.x on Karaf 3.x

2016-05-19 Thread Krzysztof Sobkowiak
support)(version>=4.2.4.RELEASE)(!(version>=4.3.0)))
 |
export: osgi.wiring.package=org.springframework.core.io.support; 
uses:=org.springframework.core.io
export: osgi.wiring.package=org.springframework.core.io
  org.apache.servicemix.bundles.spring-core [133.0]
karaf@root()>

It seems to be something similar (higher Spring version is installed). It looks 
again like something connected with Spring JMS

Regards
Krzysztof



-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: better "users" list

2016-05-12 Thread Krzysztof Sobkowiak
For me it looks better too. I'll propose the same for ServiceMix

Regards
Krzysztof

On 12.05.2016 19:03, Christian Schneider wrote:
> Looks great. Lets refer to this frontend in our web site.
> I also like the Apache OAuth support ... did not know it existed. That
> could prove useful for other things too.
> Christian
>
> 2016-05-12 18:46 GMT+02:00 Jean-Baptiste Onofré <j...@nanthrax.net>:
>
>>
>> Hi Achim
>> Good point. +1 for me.
>> RegardsJB
>>
>>
>> Sent from my Samsung device
>>
>>  Original message 
>> From: Achim Nierbeck <bcanh...@googlemail.com>
>> Date: 12/05/2016  17:22  (GMT+00:00)
>> To: dev@karaf.apache.org
>> Subject: better "users" list
>>
>> Hi,
>>
>> right now we're using the nabbles frontend for the users and dev list.
>> But to be honest, the pony mail interface[1] looks really great now, so
>> what do you think about actually using that list interface instead and link
>> to it from our web-space.
>>
>> regards, Achim
>>
>> [1] - https://lists.apache.org/list.html?u...@karaf.apache.org
>>
>> --
>>
>> Apache Member
>> Apache Karaf <http://karaf.apache.org/> Committer & PMC
>> OPS4J Pax Web <http://wiki.ops4j.org/display/paxweb/Pax+Web/> Committer &
>> Project Lead
>> blog <http://notizblog.nierbeck.de/>
>> Co-Author of Apache Karaf Cookbook <http://bit.ly/1ps9rkS>
>>
>> Software Architect / Project Manager / Scrum Master
>>
>
>

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: ActiveMQ and Camel 2.17.x on Karaf

2016-04-28 Thread Krzysztof Sobkowiak
It looks like it's again the problem with installing of multiple Spring 
versions while ActiveMQ bundles are already present in Karaf. Spring 
3.2.14.RELEASE_1 was already installed with the broker and now all other Spring 
versions are installed with activemq-camel feature.

karaf@root()> feature:install -v activemq-camel
Adding features: activemq-camel/[5.13.3,5.13.3]
Changes to perform:
  Region: root
Bundles to update:
  org.apache.servicemix.bundles.jaxb-impl/2.2.11.1 with 
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jaxb-impl/2.2.6_1
Bundles to install:
  mvn:org.apache.activemq/activemq-camel/5.13.3
  mvn:org.apache.camel/camel-blueprint/2.17.0
  mvn:org.apache.camel/camel-catalog/2.17.0
  mvn:org.apache.camel/camel-commands-core/2.17.0
  mvn:org.apache.camel/camel-core/2.17.0
  mvn:org.apache.camel/camel-jms/2.17.0
  mvn:org.apache.camel.karaf/camel-karaf-commands/2.17.0
  mvn:commons-codec/commons-codec/1.9
  mvn:commons-pool/commons-pool/1.6
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.1.7.RELEASE_2
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.2.5.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.1.7.RELEASE_2
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.2.5.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.1.7.RELEASE_2
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.2.5.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.1.7.RELEASE_2
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.2.5.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.1.7.RELEASE_2
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.2.5.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.1.7.RELEASE_2
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.2.5.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-jms/4.1.7.RELEASE_2
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-jms/4.2.5.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-tx/4.1.7.RELEASE_2
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-tx/4.2.5.RELEASE_1
  mvn:org.springframework/spring-aop/3.1.4.RELEASE
  mvn:org.springframework/spring-asm/3.1.4.RELEASE
  mvn:org.springframework/spring-beans/3.1.4.RELEASE
  mvn:org.springframework/spring-context/3.1.4.RELEASE
  mvn:org.springframework/spring-context-support/3.1.4.RELEASE
  mvn:org.springframework/spring-core/3.1.4.RELEASE
  mvn:org.springframework/spring-expression/3.1.4.RELEASE
  mvn:org.codehaus.woodstox/stax2-api/3.1.4
  mvn:org.codehaus.woodstox/woodstox-core-asl/4.4.1
  ...

I have described something similar here 
http://karaf.922171.n3.nabble.com/Feature-spring-4-2-3-RELEASE-1-also-installs-bundles-from-Spring-version-3-1-4-when-activemq-is-instd-td4046213.html.

Regards
Krzysztof



On 28.04.2016 00:27, Krzysztof Sobkowiak wrote:
> Hi
>
> I have tried to install activemq-broker-noweb and activemq-camel features 
> (5.13.2, 5.13.3 and current master) with Camel 2.17.0 on Karaf 4.0.5 but with 
> no success:
>
> karaf@root()> feature:repo-add camel 2.17.0
> Adding feature url mvn:org.apache.camel.karaf/apache-camel/2.17.0/xml/features
> karaf@root()> feature:repo-add activemq 5.13.2
> Adding feature url mvn:org.apache.activemq/activemq-karaf/5.13.2/xml/features
> karaf@root()> feature:install activemq-broker-noweb
> karaf@root()> activemq:list
> brokerName = amq-broker
>
> karaf@root()> feature:install activemq-camel
> karaf@root()> activemq:list
> karaf@root()>
>
> The activemq-osgi bundle is refreshed and and cannot be resolved anymore
>
> There is following entry in log
>
> Caused by: java.lang.ClassNotFoundException: 
> org.apache.xbean.spring.context.v2.XBeanNamespaceHandler not found by 
> org.apache.activemq.activemq-osgi [61]
> at 
> org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1574)[org.apache.felix.framework-5.4.0.jar:]
> at 
> org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:79)[org.apache.felix.framework-5.4.0.jar:]
> at 
> org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:2018)[org.apache.felix.framework-5.4.0.jar:]
> at java.lang.ClassLoader.loadClass(ClassLoader.java:358)[:1.7.

ActiveMQ and Camel 2.17.x on Karaf

2016-04-27 Thread Krzysztof Sobkowiak
Hi

I have tried to install activemq-broker-noweb and activemq-camel features 
(5.13.2, 5.13.3 and current master) with Camel 2.17.0 on Karaf 4.0.5 but with 
no success:

karaf@root()> feature:repo-add camel 2.17.0
Adding feature url mvn:org.apache.camel.karaf/apache-camel/2.17.0/xml/features
karaf@root()> feature:repo-add activemq 5.13.2
Adding feature url mvn:org.apache.activemq/activemq-karaf/5.13.2/xml/features
karaf@root()> feature:install activemq-broker-noweb
karaf@root()> activemq:list
brokerName = amq-broker

karaf@root()> feature:install activemq-camel
karaf@root()> activemq:list
karaf@root()>

The activemq-osgi bundle is refreshed and and cannot be resolved anymore

There is following entry in log

Caused by: java.lang.ClassNotFoundException: 
org.apache.xbean.spring.context.v2.XBeanNamespaceHandler not found by 
org.apache.activemq.activemq-osgi [61]
at 
org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1574)[org.apache.felix.framework-5.4.0.jar:]
at 
org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:79)[org.apache.felix.framework-5.4.0.jar:]
at 
org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:2018)[org.apache.felix.framework-5.4.0.jar:]
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)[:1.7.0_80]
at 
org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1925)[org.apache.felix.framework-5.4.0.jar:]
at 
org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:978)[org.apache.felix.framework-5.4.0.jar:]
at 
org.springframework.osgi.util.BundleDelegatingClassLoader.findClass(BundleDelegatingClassLoader.java:99)[124:org.springframework.osgi.core:1.2.1]
... 36 more

There is a bundle providing this package

karaf@root()> exports | grep org.apache.xbean.spring.context.v2
org.apache.xbean.spring.context.v2   | 3.18.0   
  | 91  | org.apache.xbean.spring
org.apache.xbean.spring.context.v2c  | 3.18.0   
  | 91  | org.apache.xbean.spring

It looks like activemq-osgi doesn't import this package. But setting 
dynamic-imports on it causes further error

Caused by: java.lang.ClassNotFoundException: 
org.springframework.osgi.context.support.OsgiBundleXmlApplicationContext not 
found by org.apache.activemq.activemq-osgi [61]
at 
org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1574)[org.apache.felix.framework-5.4.0.jar:]
at 
org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:79)[org.apache.felix.framework-5.4.0.jar:]
at 
org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:2018)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)[:1.7.0_80]
... 46 more

There is a bundle providing this package available

karaf@root()> exports | grep org.springframework.osgi.context.support
org.springframework.osgi.context.support | 1.2.1
  | 124 | org.springframework.osgi.core

One another interesting thing - headers command on activemq-osgi shows 
following import

org.springframework.osgi.context.support;resolution:=optional;version="[3,5)"

but in ActiveMQ code there is following entry

org.springframework.osgi*;version="[1,4]";resolution:=optional

I think, the range [3,5) is the reason why the package 
org.springframework.osgi.context.supportcannot be resolved, because it's 
provided in version 1.2.1

Do you have any ideas why this problem happens? I think, it's something 
connected with the changes in Spring dependencies in Camel 2.17.0

Regards
Krzysztof


-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf 4.0.5 release (take 3)

2016-04-18 Thread Krzysztof Sobkowiak
+1 (non-binding) from ServiceMix

The only issue are the unstable itests for which we have a workaround.

Good job :)

Regards
Krzysztof

On 18.04.2016 09:56, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Karaf Container 4.0.5 release to your vote.
>
> Release Note:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12334629
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1061/
>
> Git tag:
> karaf-4.0.5
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf 4.0.5 release (take 3)

2016-04-18 Thread Krzysztof Sobkowiak
Hi

After upgrade to current snapshot or staged release the Drools6 and Activiti 
itests became unstable (or better stable -- they were stable failing). So it 
means, something was changed within the current release.
I could fix them by adding transaction feature into featuresBoot (see my commit 
in my temporary branch 
https://github.com/sobkowiak/servicemix/commit/74e8dd3c3c39e8573927ba24aa6cc714f0acc963).
It prevents bundles refresh.

Regards
Krzysztof




On 18.04.2016 18:38, Jean-Baptiste Onofré wrote:
> About it, Krzysztof said he fixed the itests by adding the transaction 
> feature in Pax Exam.
>
> Regards
> JB
>
> On 04/18/2016 06:30 PM, Christian Schneider wrote:
>> +1 (non binding)
>>
>> I am currently working on the servicemix itests. I have some trouble
>> with the tests (probably because of refreshs) but I think this is not
>> directly
>> related to the karaf release.
>>
>> Christian
>>
>> On 18.04.2016 09:56, Jean-Baptiste Onofré wrote:
>>> Hi all,
>>>
>>> I submit Karaf Container 4.0.5 release to your vote.
>>>
>>> Release Note:
>>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12334629
>>>
>>>
>>> Staging Repository:
>>> https://repository.apache.org/content/repositories/orgapachekaraf-1061/
>>>
>>> Git tag:
>>> karaf-4.0.5
>>>
>>> Please vote to approve this release:
>>>
>>> [ ] +1 Approve the release
>>> [ ] -1 Don't approve the release (please provide specific comments)
>>>
>>> This vote will be open for at least 72 hours.
>>>
>>> Thanks,
>>> Regards
>>> JB
>>
>>
>

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: Feature spring/4.2.3.RELEASE_1 also installs bundles from Spring version 3.1.4 when activemq is installed

2016-04-10 Thread Krzysztof Sobkowiak
Hi JB

I have still the vetoed 4.0.5 on my drive and I can reproduce this problem. I 
have also tested it with 
https://repository.apache.org/content/repositories/snapshots/org/apache/karaf/apache-karaf/4.0.5-SNAPSHOT/apache-karaf-4.0.5-20160410.092716-92.tar.gz
 and the roblem still occurs. 

Regards
Krzysztof



On 11.04.2016 06:34, Jean-Baptiste Onofré wrote:
> Hi Krzysztof
>
> Did you try with 4.0.5-SNAPSHOT ?
> I think commit 41fc57fdcd0697d5dad3a49a56779c310b6c629b may help.
>
> Regards
> JB
>
> On 04/10/2016 11:39 PM, Krzysztof Sobkowiak wrote:
>> Hi
>>
>> Some time ago Cristiano has reported a problem in ServiceMix 7. When you try 
>> to install Spring 4.2.3.RELEASE_1, the bundles from Spring 3.1.4 are 
>> installed as well (details here 
>> http://servicemix.396122.n5.nabble.com/Why-the-feature-spring-4-2-3-RELEASE-1-also-installs-bundles-from-Spring-version-3-1-4-td5723497.html).
>>
>> This problem doesn't occur on fresh Karaf 4.0.4, but I have researched this 
>> problem a bit and have some findings, but I don't understand why the 
>> resolver installs the bundles from 3.1.4.
>>
>> I could reproduce this problem on karaf 4.0.4
>>
>> karaf@root()> feature:repo-add activemq 5.13.2
>> Adding feature url mvn:org.apache.activemq/activemq-karaf/5.13.2/xml/features
>> karaf@root()> feature:install  activemq-client
>>
>> After installing activemq-client Spring 3.2.14.RELEASE is installed and 
>> correctly wired
>>
>> karaf@root()> list -t 0  | grep spring
>> 64 | Active   |  30 | 3.2.14.RELEASE_1 | Apache ServiceMix :: Bundles :: 
>> spring-aop
>> 65 | Active   |  30 | 3.2.14.RELEASE_1 | Apache ServiceMix :: Bundles :: 
>> spring-beans
>> 66 | Active   |  30 | 3.2.14.RELEASE_1 | Apache ServiceMix :: Bundles :: 
>> spring-context
>> 67 | Active   |  30 | 3.2.14.RELEASE_1 | Apache ServiceMix :: Bundles :: 
>> spring-context-support
>> 68 | Active   |  30 | 3.2.14.RELEASE_1 | Apache ServiceMix :: Bundles :: 
>> spring-core
>> 69 | Active   |  30 | 3.2.14.RELEASE_1 | Apache ServiceMix :: Bundles :: 
>> spring-expression
>>
>> karaf@root()> bundle:requirements 70
>> org.apache.xbean.spring [70] requires:
>> --
>> osgi.wiring.package; 
>> (&(osgi.wiring.package=org.springframework.beans)(version>=2.5.0)(!(version>=4.0.0)))
>>  resolved by:
>> osgi.wiring.package; org.springframework.beans 3.2.14.RELEASE from 
>> org.apache.servicemix.bundles.spring-beans [65]
>> osgi.wiring.package; 
>> (&(osgi.wiring.package=org.springframework.beans.factory)(version>=2.5.0)(!(version>=4.0.0)))
>>  resolved by:
>> osgi.wiring.package; org.springframework.beans.factory 3.2.14.RELEASE 
>> from org.apache.servicemix.bundles.spring-beans [65]
>> .
>>
>> karaf@root()> bundle:requirements 52
>> org.apache.activemq.activemq-osgi [52] requires:
>> 
>> ...
>> osgi.wiring.package; 
>> (&(osgi.wiring.package=org.springframework.beans)(version>=3.0.0)(!(version>=5.0.0)))
>>  resolved by:
>> osgi.wiring.package; org.springframework.beans 3.2.14.RELEASE from 
>> org.apache.servicemix.bundles.spring-beans [65]
>> osgi.wiring.package; 
>> (&(osgi.wiring.package=org.springframework.beans.factory)(version>=3.0.0)(!(version>=5.0.0)))
>>  resolved by:
>> osgi.wiring.package; org.springframework.beans.factory 3.2.14.RELEASE 
>> from org.apache.servicemix.bundles.spring-beans [65]
>> osgi.wiring.package; 
>> (&(osgi.wiring.package=org.springframework.beans.factory.config)(version>=3.0.0)(!(version>=5.0.0)))
>>  resolved by:
>> 
>>
>> Let's install now Spring 4.2.3.RELEASE_1
>>
>> karaf@root()> feature:install -v spring/4.2.3.RELEASE_1
>> Adding features: spring/[4.2.3.RELEASE_1,4.2.3.RELEASE_1]
>> Changes to perform:
>>Region: root
>>  Bundles to install:
>>
>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.2.3.RELEASE_1
>>
>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.2.3.RELEASE_1
>>
>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.2.3.RELEASE_1
>>
>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.2.3.RELEASE_1
>>
>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.2.3.RELEASE_1
>>
>> mvn:o

Feature spring/4.2.3.RELEASE_1 also installs bundles from Spring version 3.1.4 when activemq is installed

2016-04-10 Thread Krzysztof Sobkowiak
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.2.3.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.2.3.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.2.3.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.2.3.RELEASE_1
Installing bundles:
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.2.3.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.2.3.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.2.3.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.2.3.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.2.3.RELEASE_1
  
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.2.3.RELEASE_1
Starting bundles:
  org.apache.servicemix.bundles.spring-core/4.2.3.RELEASE_1
  org.apache.servicemix.bundles.spring-expression/4.2.3.RELEASE_1
  org.apache.servicemix.bundles.spring-beans/4.2.3.RELEASE_1
  org.apache.servicemix.bundles.spring-aop/4.2.3.RELEASE_1
  org.apache.servicemix.bundles.spring-context/4.2.3.RELEASE_1
  org.apache.servicemix.bundles.spring-context-support/4.2.3.RELEASE_1
Done.


So I think the problem is connected with changes in ActiveMQ 5.13.x. Indeed, 
activemq-osgi 5.13.x imports Spring with range [3,5) whereas the in 5.12.x the 
range is  [3,4]. Xbeans inports in both cases Spring in range [2.5, 4). So, 
Spring 3.2.14.RELEASE_1  (which already has been installed at the beginning) 
would be ideal candidate to be wired into the both bundles.

 1. I can understand, that ativemq-osgi re-wires the newer Spring version 
(after installation of 4.2.4.RELEASE_1) because it's ok for the version range.  
4.2.4.RELEASE_1 is good for activemq-osgi but not ok for xbeans. My question - 
why should activemq-osgi use 4.2.4.RELEASE_1 and not 3.2.14.RELEASE when 
3.2.14.RELEASE is ideal for both bundles (activemq-osgi and xbeans) and 
4.2.4.RELEASE_1 only for activeq-osgi?
 2. Assuming it's ok what happens with point 1, why the resolver resolves, 
installs and wires 3.1.4.RELEASE into xbeans when  3.2.14.RELEASE was already 
installed and is ok (even better than 3.1.4.RELEASE) for version range defined 
in xbeans?

I could miss something, bu I think, something works here odd. Could you check 
it please?

Kindly regards
Krzysztof


-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf 4.0.5 release (take 2)

2016-04-05 Thread Krzysztof Sobkowiak
emaLoader.loadSchema(Unknown Source)[:]
at org.apache.xerces.impl.xs.XMLSchemaLoader.loadGrammar(Unknown Source)[:]
at org.apache.xerces.impl.xs.XMLSchemaLoader.loadGrammar(Unknown Source)[:]
at org.apache.xerces.jaxp.validation.XMLSchemaFactory.newSchema(Unknown 
Source)[:]


The same happens with Camel 2.17.0.
This error didn't occur in K404. I think, it can be caused by upgrade to Aries 
Blueprint 1.6.0.


Please, correct me if I'm missing something I should do after this upgrade. But 
when it's a new issue introduced by upgrade to Aries Blueprint 1.6.0 the people 
using Camel with Karaf will not be happy with the new version. ServiceMix will 
be broken too.

I'd like to vote with -1, non-binding, but I'm giving -0. Please decide, 
whether this is issue which should stop the release.

Kindly regards
Krzysztof





On 04.04.2016 22:38, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Karaf Container 4.0.5 release to your vote.
>
> Release Note:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12334629
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1060/
>
> Git tag:
> karaf-4.0.5
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: Roadmap and releases schedule

2016-02-04 Thread Krzysztof Sobkowiak
Hi

It would be nice if the release 4.0.5 could contain the change in the 
karaf-maven-plugin which sets the executable bit for unix scripts (e.g. 
bin/karaf) in the generated zip assembly (similar to tgz assembly). We need it 
for the ServiceMix assembly. If it's not too late on Monday, I'll open an issue 
and try to provide the pull request for this. I'm in conference till end of the 
week.

Regards
Krzysztof 

On 03.02.2016 07:36, Jean-Baptiste Onofré wrote:
> By the way 4.0.5 will be in preparation next week as well.
>
> Regards
> JB
>
> On 02/03/2016 07:32 AM, Jean-Baptiste Onofré wrote:
>> Hi all,
>>
>> I would like to provide a quick update about the releases schedule (it's
>> not up to date on the current website, but it is on the new one).
>>
>> 1. New website: as I said yesterday, it's mostly done, I'm adding the
>> last content. I should be able to promote the new website tonight or
>> tomorrow.
>> 2. Decanter 1.0.2: I would like to release Decanter 1.0.2 during the
>> week end or beginning of next week. It will include refactorings
>> (marshaller service), bug fixes (timestamp, JDBC appender, etc), new
>> features (new appenders for kafka, mongodb, etc).
>> 3. Cellar 4.0.1 planned middle of next week, including mostly bug fixes
>> and couple of new features (cluster:status, etc).
>> 4. Karaf 3.0.6: I fixed issues on the 3.x branch. Hopefully, I should be
>> able to propose 3.0.6 to vote for the end of this week.
>> 5. Master is now 4.1.0-SNAPSHOT. I think we could include karaf-boot
>> there and start "major" dependency updates. It's also where I'm doing
>> the complete dev guide refactoring, replacing the existing demos with
>> bunch of samples.
>>
>> Thoughts ?
>> Regards
>> JB
>

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [ANN] New Karaf website online

2016-02-04 Thread Krzysztof Sobkowiak
Great!!! :) You should also update the new feather :)

On 04.02.2016 16:31, Jean-Baptiste Onofré wrote:
> Hi all,
>
> as you may have seen that the new Karaf website is now online.
>
> Don't hesitate to create Jira (with website component) if you see some broken 
> links and rendering issue.
>
> Thanks !
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf 2.3.12 release

2016-01-20 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 19.01.2016 18:16, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Karaf 2.3.12 release to your vote.
>
> This is the last release on the karaf-2.3.x branch to include all last fixes. 
> The karaf-2.3.x branch now moves to "Non Active" mode: it means that it's not 
> in the main focus of the Karaf team (only individual effort).
>
> Release Notes:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12329877
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1055
>
> Git Tag:
> karaf-2.3.12
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Promote the new website look'n feel

2016-01-13 Thread Krzysztof Sobkowiak
+1 (non-binding)

Btw. I can't find the release schedule page. Will be this page available later?

Regards
Krzysztof

On 13.01.2016 18:58, Jean-Baptiste Onofré wrote:
> Hi all,
>
> As already discussed on the mailing list, I would like to promote the new 
> website.
>
> As reminder, the new website proposal is there:
>
> http://maven.nanthrax.net/goodies/karaf/site/
>
> Please vote to approve the new website:
>
> [ ] +1 Approve the new website promotion
> [ ] -1 Don't approve the new website (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


Re: [VOTE] Apache Karaf 4.0.4 release

2016-01-11 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 10.01.2016 18:10, Jean-Baptiste Onofré wrote:
> Hi all,
>
> I submit Karaf 4.0.4 release to your vote.
>
> Release Notes:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140=12334047
>
> Staging Repository:
> https://repository.apache.org/content/repositories/orgapachekaraf-1054/
>
> Git Tag:
> karaf-4.0.4
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


My conference slides

2015-12-01 Thread Krzysztof Sobkowiak
Hi

I'd like to share with you my slides about the ASF and ServiceMix (+Karaf, 
Camel, CXF and ActiveMQ) from the last conference in Wroclaw 
http://www.slideshare.net/ksobkowiak/integrate-yourself-with-the-apache-software-foundation-33rd-degree-4charity
 (You can also see the full version with all slides enabled
http://www.slideshare.net/ksobkowiak/integrate-yourself-with-the-apache-software-foundation-full-version).
 Feel free to re-use it. If you need a odp version I can share it with you as 
well (it's better tu use fragments  from odp than pdf).

There is also a small demo fot this (based on rider-auto-osgi, custom Karaf 
distributions and docker - I have re-used ideas from Achim's ApacheCON demo, 
thanks for this) - https://github.com/sobkowiak/33degree4charity2015. I need to 
add some description for this, especially the demo steps.

Regards
Krzysztof


-- 
Krzysztof Sobkowiak

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)


[DISCUSSION] Introduction to OSGi powered by Apache Karaf

2015-09-13 Thread Krzysztof Sobkowiak
Hi

Assume you have 1 hour for a talk and you would like to show the Java 
developers what OSGi is and how Karaf can simplify the life while developing 
the OSGi application. Which topics would you include in this talk?

Kindly regards
Krzysztof


-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation <http://apache.org/> Member
Apache ServiceMix <http://servicemix.apache.org/> Committer & PMC Member
Senior Solution Architect @ Capgemini SSC <http://www.capgeminisoftware.pl/>


Re: [DISCUSSION] Karaf Boot

2015-09-11 Thread Krzysztof Sobkowiak
gt;>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> regards, Achim
>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> 2015-09-10 20:41 GMT+02:00 Jean-Baptiste Onofré <j...@nanthrax.net>:
>>>>>>>>>>>
>>>>>>>>>>> Thanks Milen,
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> it's an open place to discussion. We just share standpoints and
>>>>>>>>>>>> opinions:
>>>>>>>>>>>> that's the key part !!!
>>>>>>>>>>>>
>>>>>>>>>>>> My goal is to give more traction on Karaf by providing easier
>>>>>>>>>>>>
>>>>>>>>>>>> We all provide valid points, but I think we are not the most
>>>>>>>>>>>> setted
>>>>>>>>>>>> to
>>>>>>>>>>>> argue as we are deeply involved in OSGi and Karaf. The karaf-boot
>>>>>>>>>>>> proto
>>>>>>>>>>>> came when discussing with new Karaf users, coming from "outside"
>>>>>>>>>>>> of
>>>>>>>>>>>> OSGi,
>>>&g

Re: Board report for September 2015

2015-09-07 Thread Krzysztof Sobkowiak
+1

Regards
Krzysztof

On 07.09.2015 21:26, Jean-Baptiste Onofré wrote:
> Hi guys,
>
> I prepared the board report for September 2015:
>
> https://cwiki.apache.org/confluence/display/KARAF/Board+Reports
>
> Please, review and update if I forgot something.
>
> I would like to submit the report to the board tomorrow evening.
>
> Thanks,
> Regards
> JB

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation <http://apache.org/> Member
Apache ServiceMix <http://servicemix.apache.org/> Committer & PMC Member
Senior Solution Architect @ Capgemini SSC <http://www.capgeminisoftware.pl/>


Re: Karaf 3.0.4 and ActiveMQ

2015-08-23 Thread Krzysztof Sobkowiak
Hi

I have just tested it on Linux and I cannot see this problem. We use K304 in 
ServiceMix 6 as well, and it works good too. Could you give more info? Which 
features have you installed? I hae tested it only with activemq-broker (the 
both versions).

Regards
Krzysztof

On 23.08.2015 16:34, Scott Carr wrote:
 Has anyone else tried Karaf 3.0.4 with ActiveMQ.  I have tried 5.11.1 and 
 5.10.1, and when activemq starts it comes up the first time.

 When you restart karaf, ActiveMQ states there is a conflict with Felix and 
 jms-jpa bundles.

 Anyone else seeing this?

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE  OSS Architect, Integration Architect
Apache Software Foundation http://apache.org/ Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC Member
Senior Solution Architect @ Capgemini SSC http://www.capgeminisoftware.pl/


Re: [VOTE] Release Apache Karaf 4.0.1

2015-08-18 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 16.08.2015 14:40, Jamie G. wrote:
 Hi,

 This release candidate is an update patch for Apache Karaf 4.0.x.

 We resolved 43 issues in this release:
 https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140version=12332798

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1039/

 Release git tags:
 4.0.1

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.

-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE  OSS Architect, Integration Architect
Apache Software Foundation http://apache.org/ Member
V.P. Apache ServiceMix | Apache ServiceMix http://servicemix.apache.org/ 
Committer  PMC Member
Senior Solution Architect @ Capgemini SSC http://www.capgeminisoftware.pl/


Re: [VOTE] Release Apache Karaf 2.4.3

2015-07-12 Thread Krzysztof Sobkowiak
Again in spam :(

On 12.07.2015 21:43, Achim Nierbeck wrote:
 Interesting,

 I did those account verifications already in june, and re-did those today
 again.
 wonder if that helps ..

 regards, Achim


 2015-07-12 21:31 GMT+02:00 Krzysztof Sobkowiak krzys.sobkow...@gmail.com:

 Hi

 All Achims mails from last days went to my soam too.

 Regards
 Krzysztof
 On Jul 12, 2015 8:41 PM, Achim Nierbeck bcanh...@googlemail.com wrote:

 :D

 thanks



 2015-07-12 14:52 GMT+02:00 developm...@mobigov.com:

  I saw this email and you vote.  Know that you are important to some
 random stranger over the internet.




 On 2015-07-12 08:49, Achim Nierbeck wrote:

 I feel mobbed by the system now ;-)

 Regards, Achim

 P.S. in hope this email can be seen by all.

 sent from mobile device
 Am 12.07.2015 2:34 nachm. schrieb James Carman 
 ja...@carmanconsulting.com
 :

 I didn't see Achim's vote either. I still don't. On Sun, Jul 12, 2015
 at
 7:34 AM Jamie G. jamie.goody...@gmail.com wrote:

 Yes, 3 binding votes is the minimum - that being said, somehow your
 vote
 got caught in my gmail spam filter?! Didn't see it until I was
 processing
 through that folder this morning. Cheers, Jamie On Sat, Jul 11, 2015 at
 7:50 PM, Achim Nierbeck bcanh...@googlemail.com wrote:

 afaik 3 should be enough, shouldn't it? regards, Achim 2015-07-11 23:51
 GMT+02:00 Jamie G. jamie.goody...@gmail.com:

 Hi All, Just want to gently remind the list that we need more binding
 votes. I'm going to extend the vote by another 24 hours given its the

  weekend.

  Cheers, Jamie On Sat, Jul 11, 2015 at 4:27 PM, Johan Edstrom 
 johan.edst...@acj-consulting.com wrote:

 +1 non binding, tested with build kit and distribution module.

 On Jul 11, 2015, at 12:28 PM, Jamie G. jamie.goody...@gmail.com

  wrote:

 +1 Cheers, Jamie On Thu, Jul 9, 2015 at 6:47 AM, Krzysztof Sobkowiak 
 krzys.sobkow...@gmail.com wrote:

 +1 (non-binding) I have built ServiceMix 5.4.x and tested it. Looks ok
 Regards Krzysztof On 09.07.2015 01:21, Jamie G. wrote:

 Hi, We resolved 23 issues in this release:



 https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140version=12332072
Staging repository:


 https://repository.apache.org/content/repositories/orgapachekaraf-1036/
Git tag: karaf-2.4.3 Please vote to approve this release: [ ] +1
 Approve the release [ ] -1 Veto the release (please provide specific
 comments) This vote will be open for at least 72 hours.

 -- Krzysztof Sobkowiak JEE  OSS Architect Apache Software Foundation
 Member Apache ServiceMix http://servicemix.apache.org/ Committer 
 PMC
 Senior Solution Architect @ Capgemini SSC 

  http://www.pl.capgemini-sdm.com/en/

 -- Apache Member Apache Karaf http://karaf.apache.org/ Committer 
 PMC
 OPS4J Pax Web http://wiki.ops4j.org/display/paxweb/Pax+Web/

  Committer

 

 Project Lead blog http://notizblog.nierbeck.de/ Co-Author of Apache
 Karaf Cookbook http://bit.ly/1ps9rkS Software Architect / Project
 Manager / Scrum Master



 --

 Apache Member
 Apache Karaf http://karaf.apache.org/ Committer  PMC
 OPS4J Pax Web http://wiki.ops4j.org/display/paxweb/Pax+Web/ Committer
 
 Project Lead
 blog http://notizblog.nierbeck.de/
 Co-Author of Apache Karaf Cookbook http://bit.ly/1ps9rkS

 Software Architect / Project Manager / Scrum Master




-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Apache Software Foundation Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC
Senior Solution Architect @ Capgemini SSC http://www.pl.capgemini-sdm.com/en/


Re: [VOTE] Release Apache Karaf 2.4.3

2015-07-12 Thread Krzysztof Sobkowiak
Hi

All Achims mails from last days went to my soam too.

Regards
Krzysztof
On Jul 12, 2015 8:41 PM, Achim Nierbeck bcanh...@googlemail.com wrote:

 :D

 thanks



 2015-07-12 14:52 GMT+02:00 developm...@mobigov.com:

   I saw this email and you vote.  Know that you are important to some
  random stranger over the internet.
 
 
 
 
  On 2015-07-12 08:49, Achim Nierbeck wrote:
 
  I feel mobbed by the system now ;-)
 
  Regards, Achim
 
  P.S. in hope this email can be seen by all.
 
  sent from mobile device
  Am 12.07.2015 2:34 nachm. schrieb James Carman 
 ja...@carmanconsulting.com
 
  :
 
  I didn't see Achim's vote either. I still don't. On Sun, Jul 12, 2015 at
  7:34 AM Jamie G. jamie.goody...@gmail.com wrote:
 
  Yes, 3 binding votes is the minimum - that being said, somehow your vote
  got caught in my gmail spam filter?! Didn't see it until I was processing
  through that folder this morning. Cheers, Jamie On Sat, Jul 11, 2015 at
  7:50 PM, Achim Nierbeck bcanh...@googlemail.com wrote:
 
  afaik 3 should be enough, shouldn't it? regards, Achim 2015-07-11 23:51
  GMT+02:00 Jamie G. jamie.goody...@gmail.com:
 
  Hi All, Just want to gently remind the list that we need more binding
  votes. I'm going to extend the vote by another 24 hours given its the
 
   weekend.
 
   Cheers, Jamie On Sat, Jul 11, 2015 at 4:27 PM, Johan Edstrom 
  johan.edst...@acj-consulting.com wrote:
 
  +1 non binding, tested with build kit and distribution module.
 
  On Jul 11, 2015, at 12:28 PM, Jamie G. jamie.goody...@gmail.com
 
   wrote:
 
  +1 Cheers, Jamie On Thu, Jul 9, 2015 at 6:47 AM, Krzysztof Sobkowiak 
  krzys.sobkow...@gmail.com wrote:
 
  +1 (non-binding) I have built ServiceMix 5.4.x and tested it. Looks ok
  Regards Krzysztof On 09.07.2015 01:21, Jamie G. wrote:
 
  Hi, We resolved 23 issues in this release:
 
 
 
 https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140version=12332072
 
 Staging repository:
 
 
 https://repository.apache.org/content/repositories/orgapachekaraf-1036/
 
 Git tag: karaf-2.4.3 Please vote to approve this release: [ ] +1
  Approve the release [ ] -1 Veto the release (please provide specific
  comments) This vote will be open for at least 72 hours.
 
  -- Krzysztof Sobkowiak JEE  OSS Architect Apache Software Foundation
  Member Apache ServiceMix http://servicemix.apache.org/ Committer  PMC
  Senior Solution Architect @ Capgemini SSC 
 
   http://www.pl.capgemini-sdm.com/en/
 
  -- Apache Member Apache Karaf http://karaf.apache.org/ Committer  PMC
  OPS4J Pax Web http://wiki.ops4j.org/display/paxweb/Pax+Web/
 
   Committer
 
  
 
  Project Lead blog http://notizblog.nierbeck.de/ Co-Author of Apache
  Karaf Cookbook http://bit.ly/1ps9rkS Software Architect / Project
  Manager / Scrum Master
 
 


 --

 Apache Member
 Apache Karaf http://karaf.apache.org/ Committer  PMC
 OPS4J Pax Web http://wiki.ops4j.org/display/paxweb/Pax+Web/ Committer 
 Project Lead
 blog http://notizblog.nierbeck.de/
 Co-Author of Apache Karaf Cookbook http://bit.ly/1ps9rkS

 Software Architect / Project Manager / Scrum Master



Re: [VOTE] Release Apache Karaf 2.4.3

2015-07-09 Thread Krzysztof Sobkowiak
+1 (non-binding)

I have built ServiceMix 5.4.x and tested it. Looks ok

Regards
Krzysztof

On 09.07.2015 01:21, Jamie G. wrote:
 Hi,

 We resolved 23 issues in this release:
 https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140version=12332072

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1036/

 Git tag:
 karaf-2.4.3

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for at least 72 hours.

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Apache Software Foundation Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC
Senior Solution Architect @ Capgemini SSC http://www.pl.capgemini-sdm.com/en/


Re: [VOTE] Release Apache Karaf 3.0.4

2015-07-01 Thread Krzysztof Sobkowiak
+1 (non-binding)

I have built ServiceMix 6.0.0 with Karaf and tested -- looks very good. Good 
job!!!

I have found only 2 things/problems which work differently compared to 
ServiceMix based on Karaf 3.0.3

  * one described here https://issues.apache.org/jira/browse/SM-2595
  * I had to remove eventadmin feature from featuresBoot (or move it to the 
first stage of featuresBoot). Otherwise
ServiceMix freezes.

Perhaps have you some ideas about the both findings. But these are only minor 
problems so I'm waiting for this release
to start the SerivceMix 6 final release :)

Regards
Krzysztof



On 29.06.2015 22:59, Jamie G. wrote:
 Hi,

 We resolved 103 issues in this release:
 https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140version=12329179


 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1034/

 Git tag:
 karaf-3.0.4

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Apache Software Foundation Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC
Senior Solution Architect @ Capgemini SSC http://www.pl.capgemini-sdm.com/en/


Re: [VOTE] Release Apache Karaf 3.0.4

2015-07-01 Thread Krzysztof Sobkowiak
Yet another finding:

I tried to build the demos included in the Karaf distribution and the build 
ends with following error:

INFO] Apache Karaf :: Demos . SUCCESS [1.033s]
[INFO] Apache Karaf :: Demos :: Web .. FAILURE [1.521s]
[INFO] Apache Karaf :: Demos :: Branding :: Shell  SKIPPED
[INFO] Apache Karaf :: Demos :: Command :: Extend Console  SKIPPED
[INFO] Apache Karaf :: Demos :: Demo Dump provider ... SKIPPED
[INFO] Apache Karaf :: Demos :: Deployer . SKIPPED
[INFO] Apache Karaf :: Demos :: Deployer :: Kar .. SKIPPED
[INFO] Apache Karaf :: Demos :: Deployer :: Bundle ... SKIPPED
[INFO] 
[INFO] BUILD FAILURE
[INFO] 
[INFO] Total time: 3.370s
[INFO] Finished at: Thu Jul 02 00:42:04 CEST 2015
[INFO] Final Memory: 32M/662M
[INFO] 
[ERROR] Failed to execute goal 
org.apache.maven.plugins:maven-antrun-plugin:1.7:run (copy-karaf) on project 
web: An Ant
BuildException has occured:
/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/target/karaf/WEB-INF/apache-karaf-3.0.4
 does not exist.
[ERROR] around Ant part ...move
todir=/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/target/karaf/WEB-INF/karaf...
 @ 4:105 in
/home/kso/work/projects/asf/tmp/apache-karaf-3.0.4/demos/web/target/antrun/build-main.xml
[ERROR] - [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e 
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please 
read the following articles:
[ERROR] [Help 1] 
http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn goals -rf :web

I think something wrong happened with resource filtering file building the 
assembly and the property
project.build.directory has been replaced with 
/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/target

kso@lenovo:~/work/projects/asf/tmp/apache-karaf-3.0.4$  fgrep -r kar30x .
./demos/branding/pom.xml:   
directory/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/src/main/resources/directory
./demos/META-INF/maven/org.apache.karaf/demos/pom.xml:   
appendedResourcesDirectory/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/../etc/appended-resources/appendedResourcesDirectory
./demos/META-INF/maven/org.apache.karaf/demos/pom.xml:   
directory/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/../../demos/directory
./demos/META-INF/maven/org.apache.karaf/demos/pom.xml:   
directory/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/../../demos/directory
./demos/web/target/antrun/build-main.xml:  move
todir=/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/target/karaf/WEB-INF/karaf
./demos/web/target/antrun/build-main.xml:fileset
dir=/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/target/karaf/WEB-INF/apache-karaf-3.0.4/
./demos/web/pom.xml:   
appendedResourcesDirectory/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/../../etc/appended-resources/appendedResourcesDirectory
./demos/web/pom.xml:   
webAppSourceDirectory/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/target/apache-karaf-3.0.4/webAppSourceDirectory
./demos/web/pom.xml:   
outputDirectory/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/target/karaf/WEB-INF/outputDirectory
./demos/web/pom.xml:move
todir=/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/target/karaf/WEB-INF/karaf
./demos/web/pom.xml:fileset
dir=/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/target/karaf/WEB-INF/apache-karaf-3.0.4
 /
./demos/deployer/kar/pom.xml:   
featuresFile/x1/asf/karaf/kar30x/target/checkout/assemblies/apache-karaf/src/main/resources/features.xml/featuresFile

I don't think it is blocking problem too, but it should be corrected in the 
next release

Regards
Krzysztof




On 01.07.2015 23:57, Krzysztof Sobkowiak wrote:
 +1 (non-binding)

 I have built ServiceMix 6.0.0 with Karaf and tested -- looks very good. Good 
 job!!!

 I have found only 2 things/problems which work differently compared to 
 ServiceMix based on Karaf 3.0.3

   * one described here https://issues.apache.org/jira/browse/SM-2595
   * I had to remove eventadmin feature from featuresBoot (or move it to the 
 first stage of featuresBoot). Otherwise
 ServiceMix freezes.

 Perhaps have you some ideas about the both findings. But these are only minor

Re: [VOTE] Release Apache Karaf 4.0.0.M3

2015-06-06 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 05.06.2015 23:57, Jamie G. wrote:
 Hi,

 We have 597 issues resolved on our way towards Apache Karaf 4.0.0 GA
 release. This is a technology preview, as such there will be features
 and other functionality not yet implemented. Please refrain from using
 this particular RC in production.

 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-4.0.0.M3-release.page?view=markup

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1032/

 Release git tags:
 4.0.0.M3

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Apache Software Foundation Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC chair
Senior Solution Architect @ Capgemini SSC http://www.pl.capgemini-sdm.com/en/


Re: [PROPOSAL] Releases for this week

2015-05-31 Thread Krzysztof Sobkowiak
Hi

Any plans for 2.4.2?

regards
Krzysztof

On 31.05.2015 18:11, Jean-Baptiste Onofré wrote:
 Hey James,

 see my previous e-mail:


 The plan is to submit Karaf 3.0.4 and 4.0.0.M3 to vote end of this week.


-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Apache Software Foundation Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC chair
Senior Solution Architect @ Capgemini SSC http://www.pl.capgemini-sdm.com/en/


Re: [VOTE] Release Apache Karaf 2.4.2

2015-04-22 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 22.04.2015 17:18, Jamie G. wrote:
 Hi,

 We resolved 71 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.4.2-release.page?view=markup

 Dependency changes can be reviewed here:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-2.4.x.page?view=markup

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1027/

 Git tag:
 karaf-2.4.2

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for at least 72 hours.

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Apache Software Foundation Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC chair
Senior Solution Architect @ Capgemini SSC http://www.pl.capgemini-sdm.com/en/


Re: [PROPOSAL] Move IRC channel to freenode ?

2015-04-20 Thread Krzysztof Sobkowiak
Hi

We should log the new channels so somewhere. Any ideas?

Regards
Krzysztof

On 06.04.2015 18:42, Jean-Baptiste Onofré wrote:
 Hi all,

 as you may know, codehaus will be down soon:

 http://www.codehaus.org/

 Even if it's not clear about the future of the IRC server, I think it makes 
 sense to try to anticipate.
 I propose to move our IRC channels to freenode (irc.freenode.net) with the 
 following name:

 #apache-activemq
 #apache-archiva
 #apache-camel
 #apache-cxf
 #apache-kalumet
 #apache-karaf
 #apache-servicemix

 WDYT ?

 Regards
 JB

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Apache Software Foundation Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC chair
Senior Solution Architect @ Capgemini SSC http://www.pl.capgemini-sdm.com/en/


Re: [VOTE] Release Apache Karaf 2.3.11

2015-04-08 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 08.04.2015 05:50, Jamie G. wrote:
 Hi,

 This is a vote thread for Apache Karaf 2.3.11 - a patch update for
 Apache Karaf 2.3.x line.

 We resolved 7 issues in this release:
 https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140version=12329380

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1026/

 Git tag:
 karaf-2.3.11

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Apache Software Foundation Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC chair
Senior Solution Architect @ Capgemini SSC http://www.pl.capgemini-sdm.com/en/


Re: [PROPOSAL] Move IRC channel to freenode ?

2015-04-06 Thread Krzysztof Sobkowiak
+1

Regards
Krzysztof

On 06.04.2015 18:42, Jean-Baptiste Onofré wrote:
 Hi all,

 as you may know, codehaus will be down soon:

 http://www.codehaus.org/

 Even if it's not clear about the future of the IRC server, I think it makes 
 sense to try to anticipate.
 I propose to move our IRC channels to freenode (irc.freenode.net) with the 
 following name:

 #apache-activemq
 #apache-archiva
 #apache-camel
 #apache-cxf
 #apache-kalumet
 #apache-karaf
 #apache-servicemix

 WDYT ?

 Regards
 JB

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Apache Software Foundation Member
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC chair
Senior Solution Architect @ Capgemini SSC http://www.pl.capgemini-sdm.com/en/


Re: [DISCUSSION] Karaf docker.io

2015-02-11 Thread Krzysztof Sobkowiak
+1

I like this idea. Docker is now more and more popular and becomes a
standard in cloud/visualization. It will help to develop/test such
solutions like clustering with Cellar or different broker topologies
using Karaf+ActiveMQ/ServiceMix or more complex integration scenarios.

Regards
Krzysztof

On 11.02.2015 20:43, Jean-Baptiste Onofré wrote:
 Hi all,

 In order to provide an alternative to the instances, I started to work
 on a small PoC providing simple and convenient docker.io support in
 Karaf.

 The purpose is to easily manage images, containers, and be able to
 provision/create container with Karaf instances.

 For instance, this is a current available use case:

 1/ You can create a docker.io container in two ways:
 1.1/ karaf@root() docker:bootstrap mydock
 creates a fresh docker.io container using karaf:3.0.3 image. I
 prepared different ready to use docker.io images for Karaf. I'm
 working on an embedded docker hub, with the appropriate commands to
 administrate it.
 1.2/ karaf@root() docker:provision mydock
 creates a docker.io container (using a karaf image) and copy the
 current running instance in the dock.
 1.3/ It's also possible to start from a dockerfile.
 2/ Once the dock (I named it dock meaning docker.io container where a
 karaf instance is living) is ready, you can control it using
 docker:start, docker:stop, docker:delete commands.
 3/ it's possible to connect to a running dock using docker:connect
 command

 I'm working on docker:image*, docker:hub, and improve the existing
 docker* features.

 However, before moving forward on this, I would like to know if it
 makes sense and if people are interested by it.

 By the way, the code is on my github:
 http://github.com/jbonofre/karaf-docker.

 I will push my last changes tomorrow morning.

 Any comment is welcome.

 Thanks,
 Regards
 JB

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Senior Solution Architect @ Capgemini SSC
http://www.pl.capgemini-sdm.com/en
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC


Re: [VOTE] Release Apache Karaf 4.0.0.M2 technology preview.

2015-02-10 Thread Krzysztof Sobkowiak
+1 (non-binding)

I was also trying to install ActiveMQ on it but I had some problems
(like missing javax.servlet in version  3.0.0) but I think ActiveMQ
must support the new dependencies from Karaf 4 first. Should I open
issue somewhere for this?

Regards
Krzysztof


On 10.02.2015 12:02, Jamie G. wrote:
 Hi,

 We have 196 issues resolved on our way towards Apache Karaf 4.0.0 GA
 release. This is a technology preview, as such there will be features
 and other functionality not yet implemented. Please refrain from using
 this particular RC in production.
 https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140version=12329322

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1023/

 Release git tags:
 4.0.0.M2

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Senior Solution Architect @ Capgemini SSC
http://www.pl.capgemini-sdm.com/en
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC


Re: [VOTE] Release Apache Karaf 2.3.10

2015-02-06 Thread Krzysztof Sobkowiak
+1 (non-binding)

I have found one small problem but I think it should not block the release

karaf@root jms:create --help
DESCRIPTION
jms:create

Create a JMS connection factory.

SYNTAX
jms:create [options] name

ARGUMENTS
name
The JMS connection factory name

OPTIONS
*-u, --url*
The JMS URL. NB: for WebsphereMQ type, the URL is
hostname/port/queuemanager/channel
*-u, --username*
Username to connect to the JMS broker
(defaults to karaf)
--help
Display this help message
-t, --type
The JMS connection factory type (ActiveMQ or WebsphereMQ)
-p, --password
Password to connect to the JMS broker
(defaults to karaf)

Both, --url and --username have the same short version -u




Regards
Krzysztof


On 04.02.2015 01:45, Jamie G. wrote:
 Hi,

 We resolved 10 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.3.10-release.page?view=markup

 Dependency changes can be reviewed here:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-2.3.x.page?revision=1613719view=markup

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1022/

 Git tag:
 karaf-2.3.10

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.

-- 
Krzysztof Sobkowiak

JEE  OSS Architect
Senior Solution Architect @ Capgemini SSC
http://www.pl.capgemini-sdm.com/en
Apache ServiceMix http://servicemix.apache.org/ Committer  PMC


Re: Using Sphinx for ServiceMix documentation?

2015-01-25 Thread Krzysztof Sobkowiak
Hi

I think too it's a good idea to maintain the documentation using asciidoc.

Regards
Krzysztof


On 25.01.2015 09:52, Christian Schneider wrote:
 I would also prefer asciidoc compared to our scalate based approach.
 The result looks really good.
 Are there other suggestions?
 Can you also provide the source files and build scripts you used?

 Christian

 Am 25.01.2015 um 01:46 schrieb Achim Nierbeck:
 Hi,

 I made a quick run on replacing the headings, codes and certain other
 stuff
 in the scalate files to asciidoc for Karaf.
 The result without doing any tweaks on js or css can be seen here:
 http://karaf.nierbeck.de/  (the all in one page)
 http://karaf.nierbeck.de/installation.html (single page example, btw.
 all
 others can also be navigated to, like jms.html)

 @Karaf community, sorry for crossposting, but figured there might be
 some
 interest in this too :-)
 I could push my added files to karaf master right now, those files
 reside
 in a different folder so it won't hurt.

 regards, Achim




-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: Spring Deployer

2015-01-16 Thread Krzysztof Sobkowiak
Hi Cristiano

I have opened an issue for this yesterday:
https://issues.apache.org/jira/browse/KARAF-3448

Regards
Krzysztof


On 16.01.2015 17:21, Cristiano Costantini wrote:
 Hi all,

 I've found a strange behaviour while trying to make spring deployer work on
 Karaf 2.4.1:

 I start Karaf with spring-dm and camel-spring features enabled at startup:
 featuresBoot = karaf-framework, [...] ,spring-dm,camel-spring,webconsole


 as a result, also spring feature is installed:
 karaf@root features:list | grep spring | grep -v uninstalled
 [installed  ] [1.2.1   ] spring-dm
 spring-2.4.1Spring DM support
 [installed  ] [3.2.11.RELEASE_1] spring
  spring-2.4.1Spring 3.2.x support
 [installed  ] [3.2.11.RELEASE_1] spring-tx
 spring-2.4.1Spring 3.2.x Transaction (TX) support
 [installed  ] [2.13.2  ] camel-spring
  camel-2.13.2


 but the deployer feature has not installed the spring deployer bundle (the
 istallation of which installation is conditional to the presence of the
 spring's feature which is available)

 feature name=deployer description=Karaf Deployer
 version=${project.version}
 bundle start=true
 start-level=26mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.features/${project.version}/bundle
[...]
 conditional
 conditionspring/condition
 bundle start=true
 start-level=24mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.spring/${project.version}/bundle
 /conditional
 [...]
 /feature


 I thought it to be a bootstrap problem dependent on the order of how
 features are loaded, but even if I uninstall and reinstall deployer
 feature, the bundle org.apache.karaf.deployer.spring is not installed:

 karaf@root features:uninstall deployer
 karaf@root features:install deployer
 karaf@root list -t 0
 START LEVEL 100 , List Threshold: 0
ID   State Blueprint  SpringLevel  Name
 ...
 [ 113] [Active ] [Created ] [   ] [   26] Apache Karaf ::
 Deployer :: Features (2.4.1)
 [ 114] [Active ] [Created ] [   ] [   24] Apache Karaf ::
 Deployer :: Blueprint (2.4.1)
 karaf@root


 if install the bundle org.apache.karaf.deployer.spring manually, then
 everything seems to be working and the spring file I have copied on deploy
 folder starts:


 karaf@root install -s
 mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.spring/2.4.1
 Bundle ID: 115
 karaf@root list -t 0
 START LEVEL 100 , List Threshold: 0
ID   State Blueprint  SpringLevel  Name
 ...
 [ 113] [Active ] [Created ] [   ] [   26] Apache Karaf ::
 Deployer :: Features (2.4.1)
 [ 114] [Active ] [Created ] [   ] [   24] Apache Karaf ::
 Deployer :: Blueprint (2.4.1)
 [ 115] [Active ] [Created ] [   ] [   80] Apache Karaf ::
 Deployer :: Spring (2.4.1)
 [ 116] [Active ] [] [Started] [   80] beans.xml (0.0.0)
 karaf@root


 I've also discovered that the deployer feature installs the spring deployer
 bundle only if I install latest version of spring feature, 4.1.2.RELEASE_1,
 which I want to avoid as I don't use yet spring 4.

 Is this behaviour expected or should the spring deployer be installed also
 with previous versions of spring?


 Regards,
 Cristiano


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [VOTE] Release Apache Karaf 2.4.1

2015-01-01 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 31.12.2014 03:10, Jamie G. wrote:
 Hi,

 We resolved 76 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.4.1-release.page?view=markup

 Dependency changes can be reviewed here:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-2.4.x.page?view=markup

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1018/

 Git tag:
 karaf-2.4.1

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for at least 72 hours given the new year's holiday.


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [VOTE] Release Apache Karaf 2.3.9

2014-11-06 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 06.11.2014 02:19, Jamie G. wrote:
 Hi,

 We resolved 7 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.3.9-release.page?view=markup

 Dependency changes can be reviewed here:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-2.3.x.page?revision=1613719view=markup

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1014/

 Git tag:
 karaf-2.3.9

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [VOTE] Release Apache Karaf 3.0.2

2014-10-11 Thread Krzysztof Sobkowiak
+1 (non-binding)  Tested jdbc, jms, jndi and  some recipes from Karaf
Cookbook (Camel, ActiveMQ, JPA)

Regards
Krzysztof



On 10.10.2014 21:34, Jamie G. wrote:
 Hi,

 We resolved 215 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-3.0.2-release.page?view=markup

 Dependency changes can be reviewed here:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-3.0.x.page?view=markup
  (The website published table will be updated after vote)

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1012/

 Git tag:
 karaf-3.0.2

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [UPDATE] 3.0.2 jira freeze 4.0.0.M1

2014-10-06 Thread Krzysztof Sobkowiak
+1 (non-binding)

Regards
Krzysztof

On 05.10.2014 22:32, Jamie G. wrote:
 +1

 On Sun, Oct 5, 2014 at 5:08 PM, Achim Nierbeck bcanh...@googlemail.com 
 wrote:
 Hi JB,

 +1 for releasing fast and for a 4.0.0.M1 preview release.


 regards, Achim

 2014-10-05 20:51 GMT+02:00 Jean-Baptiste Onofré j...@nanthrax.net:

 Hi all,

 We already postponed the Karaf 3.0.2 release two times. It's too much ;)

 I have updated the releases schedule on the website: Karaf 3.0.2 will be
 in vote Wednesday: only really blocker bugs will postpone the release
 again, all other bugs or enhancements will be postponed to 3.0.3.

 We have only three pending issues on which I'm working on. I will have all
 fixed for Tuesday morning. As soon as it's done, I will deal with Jamie to
 cut the release.

 On the other hand, just after 3.0.2 has been submitted to vote, I will
 release a 4.0.0.M1 preview release. It won't be a production ready, but a
 technical preview.

 To summarise, both 3.0.2 and 4.0.0.M1 votes will start on Wednesday max.

 Regards
 JB
 --
 Jean-Baptiste Onofré
 jbono...@apache.org
 http://blog.nanthrax.net
 Talend - http://www.talend.com



 --

 Apache Member
 Apache Karaf http://karaf.apache.org/ Committer  PMC
 OPS4J Pax Web http://wiki.ops4j.org/display/paxweb/Pax+Web/ Committer 
 Project Lead
 blog http://notizblog.nierbeck.de/

 Software Architect / Project Manager / Scrum Master


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [ANN] Apache Karaf 2.4.0 Released!

2014-09-21 Thread Krzysztof Sobkowiak
Hi

I can't see the dependencies table for 2.4.x. Do you plan to prepare a
page for the dependency matrix?

Best regards
Krzysztof


On 20.09.2014 18:35, Jamie G. wrote:
 The Karaf team is pleased to announce the release of Karaf version 2.4.0.

 Apache Karaf is a small OSGi distribution which provides a ready to
 use container for server side applications.

 This release represents a new branch of Apache Karaf development. It
 includes the latest Aries and Pax libraries, Apache Pom 14, add
 support for role-based JMX authorization, includes heap dumps when we
 create debugging data from create dump command, blueprint-web feature,
 support for JAAS groups, and includes Pax CDI feature. There are
 several hundred items currently in this RC's release notes, so you'll
 want to spend some time discovering all the hidden gems.

 http://karaf.apache.org/

 This release is available from
 http://karaf.apache.org/index/community/download.html#Karaf2.4.0 and

 Maven:

  dependency
  groupIdorg.apache.karaf/groupId
  artifactIdapache-karaf/artifactId
  version2.4.0/version
  /dependency

 Download Note:
 Our mirrors are still syncing the new kits, if your primary mirror
 does not have the kit please try another from the server mirror list.

 Release Notes:

 There are 441 resolved issues included in this release, as such we've
 documented them on the 2.4.0 release notes page:
 http://karaf.apache.org/index/community/download/karaf-2.4.0-release.html

 Enjoy!


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [VOTE] Release Apache Karaf 2.4.0

2014-09-17 Thread Krzysztof Sobkowiak
+1 (non-binding). Good job

Regards
Krzysztof

On 17.09.2014 17:43, Jamie G. wrote:
 Hi,

 We resolved 441 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.4.0-release.page?view=markup

 A Dependencies table will be created to track changes on the 2.4.x series.

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1011/

 Git tag:
 karaf-2.4.0

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [UPDATE] Maven 3.2.x support

2014-09-13 Thread Krzysztof Sobkowiak
Hi

I have tested it with 3.2.3, 3.1.1 and 3.0.5 - it works.

Regards
Krzysztof

On 13.09.2014 08:41, Jean-Baptiste Onofré wrote:
 Hi all,

 FYI, this morning I fixed Maven 3.2.x support on karaf-3.0.x and
 master branches.

 I had a successful build with Maven 3.0.4 (as before) and Maven 3.2.2.

 If you have sometime to make a try with Maven 3.2.x on your side (to
 get a double confirmation), it would be great.

 Thanks !

 Regards
 JB


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: Unexpected folder '${karaf.data}'

2014-09-09 Thread Krzysztof Sobkowiak
I have just tested karaf-3.0.x. The both issues (KARAF-3211 and
KARAF-3212) seem to be solved. Good job :) I'm building master now.

Best regards
Krzysztof


On 09.09.2014 22:21, Achim Nierbeck wrote:
 Hi,

 I fixed KARAF-3212, it's been a regression I introduced, sorry for that.
 Current master and karaf-3.0.x branches are fixed and ready to be checked :)

 regards, Achim




 2014-09-09 19:09 GMT+02:00 Jean-Baptiste Onofré j...@nanthrax.net:

 Hey,

 honestly, after some quick tests, I suspect KARAF-2453 to be source of
 couple of regressions ;)

 I'm fixing the latest Jira for Karaf 2.4.0, I will go back on 3.0.x just
 after.

 Regards
 JB

 On 09/09/2014 07:06 PM, Achim Nierbeck wrote:

 Hi,

 might be a regression of KARAF-2453
 https://issues.apache.org/jira/browse/KARAF-2453

 I'm gonna take a look  :)

 regards, Achim



 2014-09-09 15:23 GMT+02:00 Jean-Baptiste Onofré j...@nanthrax.net:

  Yup I saw the Jira, I will tackle that asap.
 Regards
 JB

 On 09/09/2014 03:12 PM, Sobkowiak, Krzysztof wrote:

  https://issues.apache.org/jira/browse/KARAF-3212 - I have raised an
 issue yesterday

 Best regards
 Krzysztof





 On 09.09.2014 15:01, Jean-Baptiste Onofré wrote:

  Hi Rodrigo,
 I'm checking that but I don't think I saw that.

 Regards
 JB

 On 09/09/2014 02:56 PM, Rodrigo Serra wrote:

  Hi,
 Latest karaf 3.0.2-SNAPSHOT create a folder with name ‘${karaf.data}’
 (without the quotes) in KARAF_HOME. Inside the folder exists another
 folder called pax-web-jsp. Some thing create the folder without
 convert the parameters values.

 Regards,
 Rodrigo



  --
 Jean-Baptiste Onofré
 jbono...@apache.org
 http://blog.nanthrax.net
 Talend - http://www.talend.com




 --
 Jean-Baptiste Onofré
 jbono...@apache.org
 http://blog.nanthrax.net
 Talend - http://www.talend.com





-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: Unexpected folder '${karaf.data}'

2014-09-09 Thread Krzysztof Sobkowiak
master fixed too

On 09.09.2014 22:33, Krzysztof Sobkowiak wrote:
 I have just tested karaf-3.0.x. The both issues (KARAF-3211 and
 KARAF-3212) seem to be solved. Good job :) I'm building master now.

 Best regards
 Krzysztof


 On 09.09.2014 22:21, Achim Nierbeck wrote:
 Hi,

 I fixed KARAF-3212, it's been a regression I introduced, sorry for that.
 Current master and karaf-3.0.x branches are fixed and ready to be checked :)

 regards, Achim




 2014-09-09 19:09 GMT+02:00 Jean-Baptiste Onofré j...@nanthrax.net:

 Hey,

 honestly, after some quick tests, I suspect KARAF-2453 to be source of
 couple of regressions ;)

 I'm fixing the latest Jira for Karaf 2.4.0, I will go back on 3.0.x just
 after.

 Regards
 JB

 On 09/09/2014 07:06 PM, Achim Nierbeck wrote:

 Hi,

 might be a regression of KARAF-2453
 https://issues.apache.org/jira/browse/KARAF-2453

 I'm gonna take a look  :)

 regards, Achim



 2014-09-09 15:23 GMT+02:00 Jean-Baptiste Onofré j...@nanthrax.net:

  Yup I saw the Jira, I will tackle that asap.
 Regards
 JB

 On 09/09/2014 03:12 PM, Sobkowiak, Krzysztof wrote:

  https://issues.apache.org/jira/browse/KARAF-3212 - I have raised an
 issue yesterday

 Best regards
 Krzysztof





 On 09.09.2014 15:01, Jean-Baptiste Onofré wrote:

  Hi Rodrigo,
 I'm checking that but I don't think I saw that.

 Regards
 JB

 On 09/09/2014 02:56 PM, Rodrigo Serra wrote:

  Hi,
 Latest karaf 3.0.2-SNAPSHOT create a folder with name ‘${karaf.data}’
 (without the quotes) in KARAF_HOME. Inside the folder exists another
 folder called pax-web-jsp. Some thing create the folder without
 convert the parameters values.

 Regards,
 Rodrigo



  --
 Jean-Baptiste Onofré
 jbono...@apache.org
 http://blog.nanthrax.net
 Talend - http://www.talend.com



 --
 Jean-Baptiste Onofré
 jbono...@apache.org
 http://blog.nanthrax.net
 Talend - http://www.talend.com



-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: MissingResourceException in aries transaction

2014-09-08 Thread Krzysztof Sobkowiak
:148)[6:org.apache.felix.configadmin:1.8.0]
   at 
 org.apache.felix.cm.impl.helper.ManagedServiceTracker.provideConfiguration(ManagedServiceTracker.java:81)[6:org.apache.felix.configadmin:1.8.0]
   at 
 org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.provide(ConfigurationManager.java:1448)[6:org.apache.felix.configadmin:1.8.0]
   at 
 org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1404)[6:org.apache.felix.configadmin:1.8.0]
   at 
 org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:103)[6:org.apache.felix.configadmin:1.8.0]
   at java.lang.Thread.run(Thread.java:745)[:1.7.0_67]
 Caused by: java.util.MissingResourceException: Can't find bundle for base 
 name org.apache.aries.transaction.txManager, locale en_US
   at 
 java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499)[:1.7.0_67]
   at 
 java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322)[:1.7.0_67]
   at 
 java.util.ResourceBundle.getBundle(ResourceBundle.java:1028)[:1.7.0_67]
   at 
 org.apache.aries.util.nls.MessageUtil.createMessageUtil(MessageUtil.java:152)[9:org.apache.aries.util:1.1.0]
   at 
 org.apache.aries.util.nls.MessageUtil.createMessageUtil(MessageUtil.java:107)[9:org.apache.aries.util:1.1.0]
   at 
 org.apache.aries.transaction.internal.NLS.clinit(NLS.java:25)[67:org.apache.aries.transaction.manager:1.1.0]
   ... 8 more

 Regards,
 Rodrigo

 El 08/09/2014, a las 09:32, Jean-Baptiste Onofré j...@nanthrax.net escribió:

 Is it when you install the transaction feature or directly when you start 
 ConfigAdmin/karaf ?

 Regards
 JB

 On 09/08/2014 01:23 PM, Rodrigo Serra wrote:
 Hi,

 When starting latest karaf 3.0.2-SNAPSHOT i get this error:

 2014-09-08 08:06:26,646 | ERROR | es.transaction]) | configadmin
   | 6 - org.apache.felix.configadmin - 1.8.0 | 
 [org.osgi.service.cm.ManagedService, id=652, 
 bundle=67/mvn:org.apache.aries.transaction/org.apache.aries.transaction.manager/1.1.0]:
  Unexpected problem updating configuration 
 org.apache.aries.transactionjava.lang.ExceptionInInitializerError
 at 
 org.apache.aries.transaction.internal.TransactionManagerService.init(TransactionManagerService.java:114)
 at 
 org.apache.aries.transaction.internal.Activator.updated(Activator.java:63)  
   at 
 org.apache.felix.cm.impl.helper.ManagedServiceTracker.updateService(ManagedServiceTracker.java:148)[6:org.apache.felix.configadmin:1.8.0]
 at 
 org.apache.felix.cm.impl.helper.ManagedServiceTracker.provideConfiguration(ManagedServiceTracker.java:81)[6:org.apache.felix.configadmin:1.8.0]
 at 
 org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.provide(ConfigurationManager.java:1448)[6:org.apache.felix.configadmin:1.8.0]
 at 
 org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1404)[6:org.apache.felix.configadmin:1.8.0]
 at 
 org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:103)[6:org.apache.felix.configadmin:1.8.0]
 at java.lang.Thread.run(Thread.java:745)[:1.7.0_67]
 Caused by: java.util.MissingResourceException: Can't find bundle for base 
 name org.apache.aries.transaction.txManager, locale es_ES
 at 
 java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499)[:1.7.0_67]
 at 
 java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322)[:1.7.0_67]
 at 
 java.util.ResourceBundle.getBundle(ResourceBundle.java:1028)[:1.7.0_67]
 at 
 org.apache.aries.util.nls.MessageUtil.createMessageUtil(MessageUtil.java:152)[9:org.apache.aries.util:1.1.0]
 at 
 org.apache.aries.util.nls.MessageUtil.createMessageUtil(MessageUtil.java:107)[9:org.apache.aries.util:1.1.0]
 at 
 org.apache.aries.transaction.internal.NLS.clinit(NLS.java:25)[67:org.apache.aries.transaction.manager:1.1.0]
 ... 8 more

 and no transaction manager service is available. Is some thing regarding my 
 OS installation locale?

 Regards,
 Rodrigo





-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: MissingResourceException in aries transaction

2014-09-08 Thread Krzysztof Sobkowiak
I can reproduce it on Karaf master too. Karaf 2.4 no problem.

On 08.09.2014 21:05, Jean-Baptiste Onofré wrote:
 I don't have it on my machine. Let me check ;)

 Regards
 JB

 On 09/08/2014 08:10 PM, Krzysztof Sobkowiak wrote:
 I could reproduce this problem on my machine too

 On 08.09.2014 15:17, Rodrigo Serra wrote:
 Both of cases. When install feature i get this error (this is for
 clean data dir: rm -fr data):

 2014-09-08 10:11:35,275 | INFO  | FelixStartLevel  |
 RegionsPersistenceImpl   | 63 -
 org.apache.karaf.region.persist - 3.0.2.SNAPSHOT | Loading region
 digraph persistence
 2014-09-08 10:11:35,310 | INFO  | FelixStartLevel  |
 RegionsPersistenceImpl   | 63 -
 org.apache.karaf.region.persist - 3.0.2.SNAPSHOT | initializing
 region digraph from etc/regions-config.xml
 2014-09-08 10:11:35,467 | INFO  | FelixStartLevel  |
 BlueprintContainerImpl   | 15 -
 org.apache.aries.blueprint.core - 1.4.1 | Bundle
 org.apache.karaf.bundle.command is waiting for dependencies
 [(objectClass=org.apache.karaf.bundle.core.BundleWatcher),
 (objectClass=org.apache.karaf.bundle.core.BundleService)]
 2014-09-08 10:11:35,479 | INFO  | rint Extender: 3 |
 BlueprintContainerImpl   | 15 -
 org.apache.aries.blueprint.core - 1.4.1 | Bundle
 org.apache.karaf.bundle.command is waiting for dependencies
 [(objectClass=org.apache.karaf.bundle.core.BundleService)]
 2014-09-08 10:11:48,657 | INFO  | Local user karaf |
 FeaturesServiceImpl  | 20 -
 org.apache.karaf.features.core - 3.0.2.SNAPSHOT | Installing feature
 transaction 1.1.0
 2014-09-08 10:11:48,688 | INFO  | Local user karaf |
 BlueprintContainerImpl   | 15 -
 org.apache.aries.blueprint.core - 1.4.1 | Bundle
 org.apache.aries.transaction.blueprint is waiting for dependencies
 [(objectClass=javax.transaction.TransactionManager)]
 2014-09-08 10:11:48,722 | ERROR | es.transaction]) |
 configadmin  | 6 - org.apache.felix.configadmin
 - 1.8.0 | [org.osgi.service.cm.ManagedService, id=652,
 bundle=67/mvn:org.apache.aries.transaction/org.apache.aries.transaction.manager/1.1.0]:
 Unexpected problem updating configuration org.apache.aries.transaction
 java.lang.ExceptionInInitializerError
 at
 org.apache.aries.transaction.internal.TransactionManagerService.init(TransactionManagerService.java:114)
 at
 org.apache.aries.transaction.internal.Activator.updated(Activator.java:63)
 at
 org.apache.felix.cm.impl.helper.ManagedServiceTracker.updateService(ManagedServiceTracker.java:148)[6:org.apache.felix.configadmin:1.8.0]
 at
 org.apache.felix.cm.impl.helper.ManagedServiceTracker.provideConfiguration(ManagedServiceTracker.java:81)[6:org.apache.felix.configadmin:1.8.0]
 at
 org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.provide(ConfigurationManager.java:1448)[6:org.apache.felix.configadmin:1.8.0]
 at
 org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1404)[6:org.apache.felix.configadmin:1.8.0]
 at
 org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:103)[6:org.apache.felix.configadmin:1.8.0]
 at java.lang.Thread.run(Thread.java:745)[:1.7.0_67]
 Caused by: java.util.MissingResourceException: Can't find bundle for
 base name org.apache.aries.transaction.txManager, locale en_US
 at
 java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499)[:1.7.0_67]
 at
 java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322)[:1.7.0_67]
 at
 java.util.ResourceBundle.getBundle(ResourceBundle.java:1028)[:1.7.0_67]
 at
 org.apache.aries.util.nls.MessageUtil.createMessageUtil(MessageUtil.java:152)[9:org.apache.aries.util:1.1.0]
 at
 org.apache.aries.util.nls.MessageUtil.createMessageUtil(MessageUtil.java:107)[9:org.apache.aries.util:1.1.0]
 at
 org.apache.aries.transaction.internal.NLS.clinit(NLS.java:25)[67:org.apache.aries.transaction.manager:1.1.0]
 ... 8 more

 and this is the error after restarting karaf:

 2014-09-08 10:13:58,540 | INFO  | FelixStartLevel  |
 RegionsPersistenceImpl   | 63 -
 org.apache.karaf.region.persist - 3.0.2.SNAPSHOT | Loading region
 digraph persistence
 2014-09-08 10:13:58,653 | INFO  | FelixStartLevel  |
 BlueprintContainerImpl   | 15 -
 org.apache.aries.blueprint.core - 1.4.1 | Bundle
 org.apache.aries.transaction.blueprint is waiting for dependencies
 [(objectClass=javax.transaction.TransactionManager)]
 2014-09-08 10:13:58,697 | ERROR | es.transaction]) |
 configadmin  | 6 - org.apache.felix.configadmin
 - 1.8.0 | [org.osgi.service.cm.ManagedService, id=477,
 bundle=67/mvn:org.apache.aries.transaction/org.apache.aries.transaction.manager/1.1.0]:
 Unexpected problem updating configuration org.apache.aries.transaction
 java.lang.ExceptionInInitializerError
 at
 org.apache.aries.transaction.internal.TransactionManagerService.init(TransactionManagerService.java:114

Re: MissingResourceException in aries transaction

2014-09-08 Thread Krzysztof Sobkowiak
I have just tested ServiceMix and the problem doesn't occur there. But
here is one difference:

  * when you install transaction feature in Karaf, there is no file
org.apache.aries.transaction.cfg in etc directory.
  * ServiceMix has a predefined org.apache.aries.transaction.cfg with
following content:

aries.transaction.timeout=600
aries.transaction.howl.logFileDir=${karaf.data}/txlog/
aries.transaction.recoverable=true

  * after copying the file from ServiceMix into Karaf and deleting the
data directory, the problem seems to be fixed
  * I have copied the content of the Karaf transaction feature config
into the org.apache.aries.transaction.cfg file

aries.transaction.recoverable = true
aries.transaction.timeout = 600
aries.transaction.howl.logFileDir = ${karaf.data}/txlog
aries.transaction.howl.maxLogFiles = 2
aries.transaction.howl.maxBlocksPerFile = 512
aries.transaction.howl.bufferSizeKBytes = 4


It works too.


It means, the problem is missing etc/org.apache.aries.transaction.cfg
file. But I think this is a correct behavior (missing file), because the
configuration is stored now in the cache, when defined in feature files
using  config tag

Best regards
Krzysztof


On 08.09.2014 22:03, Krzysztof Sobkowiak wrote:
 I can reproduce it on Karaf master too. Karaf 2.4 no problem.

 On 08.09.2014 21:05, Jean-Baptiste Onofré wrote:
 I don't have it on my machine. Let me check ;)

 Regards
 JB

 On 09/08/2014 08:10 PM, Krzysztof Sobkowiak wrote:
 I could reproduce this problem on my machine too

 On 08.09.2014 15:17, Rodrigo Serra wrote:
 Both of cases. When install feature i get this error (this is for
 clean data dir: rm -fr data):

 2014-09-08 10:11:35,275 | INFO  | FelixStartLevel  |
 RegionsPersistenceImpl   | 63 -
 org.apache.karaf.region.persist - 3.0.2.SNAPSHOT | Loading region
 digraph persistence
 2014-09-08 10:11:35,310 | INFO  | FelixStartLevel  |
 RegionsPersistenceImpl   | 63 -
 org.apache.karaf.region.persist - 3.0.2.SNAPSHOT | initializing
 region digraph from etc/regions-config.xml
 2014-09-08 10:11:35,467 | INFO  | FelixStartLevel  |
 BlueprintContainerImpl   | 15 -
 org.apache.aries.blueprint.core - 1.4.1 | Bundle
 org.apache.karaf.bundle.command is waiting for dependencies
 [(objectClass=org.apache.karaf.bundle.core.BundleWatcher),
 (objectClass=org.apache.karaf.bundle.core.BundleService)]
 2014-09-08 10:11:35,479 | INFO  | rint Extender: 3 |
 BlueprintContainerImpl   | 15 -
 org.apache.aries.blueprint.core - 1.4.1 | Bundle
 org.apache.karaf.bundle.command is waiting for dependencies
 [(objectClass=org.apache.karaf.bundle.core.BundleService)]
 2014-09-08 10:11:48,657 | INFO  | Local user karaf |
 FeaturesServiceImpl  | 20 -
 org.apache.karaf.features.core - 3.0.2.SNAPSHOT | Installing
 feature transaction 1.1.0
 2014-09-08 10:11:48,688 | INFO  | Local user karaf |
 BlueprintContainerImpl   | 15 -
 org.apache.aries.blueprint.core - 1.4.1 | Bundle
 org.apache.aries.transaction.blueprint is waiting for dependencies
 [(objectClass=javax.transaction.TransactionManager)]
 2014-09-08 10:11:48,722 | ERROR | es.transaction]) |
 configadmin  | 6 - org.apache.felix.configadmin
 - 1.8.0 | [org.osgi.service.cm.ManagedService, id=652,
 bundle=67/mvn:org.apache.aries.transaction/org.apache.aries.transaction.manager/1.1.0]:
 Unexpected problem updating configuration org.apache.aries.transaction
 java.lang.ExceptionInInitializerError
 at
 org.apache.aries.transaction.internal.TransactionManagerService.init(TransactionManagerService.java:114)
 at
 org.apache.aries.transaction.internal.Activator.updated(Activator.java:63)
 at
 org.apache.felix.cm.impl.helper.ManagedServiceTracker.updateService(ManagedServiceTracker.java:148)[6:org.apache.felix.configadmin:1.8.0]
 at
 org.apache.felix.cm.impl.helper.ManagedServiceTracker.provideConfiguration(ManagedServiceTracker.java:81)[6:org.apache.felix.configadmin:1.8.0]
 at
 org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.provide(ConfigurationManager.java:1448)[6:org.apache.felix.configadmin:1.8.0]
 at
 org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1404)[6:org.apache.felix.configadmin:1.8.0]
 at
 org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:103)[6:org.apache.felix.configadmin:1.8.0]
 at java.lang.Thread.run(Thread.java:745)[:1.7.0_67]
 Caused by: java.util.MissingResourceException: Can't find bundle
 for base name org.apache.aries.transaction.txManager, locale en_US
 at
 java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499)[:1.7.0_67]
 at
 java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322)[:1.7.0_67]
 at
 java.util.ResourceBundle.getBundle(ResourceBundle.java:1028)[:1.7.0_67]

 at
 org.apache.aries.util.nls.MessageUtil.createMessageUtil(MessageUtil.java:152)[9

Re: Latest Karaf 3.0.2-SNAPSHOT build failure

2014-09-07 Thread Krzysztof Sobkowiak
The Jenkins Build runs probably on a Linux machine. I use Linux (64bit)
too. Could it be a problem on Linux?

Best regards
Krzysztof

On 07.09.2014 09:36, Jean-Baptiste Onofré wrote:
 For now, I can't reproduce on my machine, I'm still investigating.

 I keep you posted.

 Regards
 JB

 On 09/07/2014 01:26 AM, Krzysztof Sobkowiak wrote:
 This problem has been probably introduced by KARAF-3191 (Upgrade to Pax
 Web 3.1.2). After this commit the problem occurs on Jenkins too
 (https://builds.apache.org/view/All/job/karaf-3.0.x/291/)


 On 07.09.2014 00:36, Krzysztof Sobkowiak wrote:
 This problem doesn't occur on master and 2.x which use pax-logging
 2.1.0 too

 On 07.09.2014 00:25, Krzysztof Sobkowiak wrote:
 I could build the Karaf Assemblies after removing the m2 repository.
 But similar problem still occurs while building Assembly Archetype --
 warning about missing LightweightHttpWagon and following error

 [INFO] [ERROR] Failed to execute goal on project assembly: Could not
 resolve dependencies for project
 archetype.it:assembly:karaf-assembly:0.1-SNAPSHOT: Failed to collect
 dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT
 (runtime)]: Failed to read artifact descriptor for
 org.apache.aries.blueprint:org.apache.aries.blueprint.core:jar:1.2.0:
 Could not transfer artifact
 org.apache.aries.blueprint:org.apache.aries.blueprint.core:pom:1.2.0
 from/to central (http://repo.maven.apache.org/maven2): No connector
 available to access repository central
 (http://repo.maven.apache.org/maven2) of type default using the
 available factories WagonRepositoryConnectorFactory - [Help 1]
 [INFO] org.apache.maven.lifecycle.LifecycleExecutionException: Failed
 to execute goal on project assembly: Could not resolve dependencies
 for project archetype.it:assembly:karaf-assembly:0.1-SNAPSHOT: Failed
 to collect dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT
 (runtime)]
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:210)

 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies(LifecycleDependencyResolver.java:117)

 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved(MojoExecutor.java:258)

 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:201)

 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)

 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)

 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)

 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)

 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)

 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)

 [INFO] at
 org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
 [INFO] at
 org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
 [INFO] at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
 [INFO] at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
 [INFO] at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
 [INFO] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
 Method)
 [INFO] at
 sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

 [INFO] at
 sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

 [INFO] at java.lang.reflect.Method.invoke(Method.java:606)
 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)

 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)

 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)

 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)

 [INFO] Caused by:
 org.apache.maven.project.DependencyResolutionException: Could not
 resolve dependencies for project
 archetype.it:assembly:karaf-assembly:0.1-SNAPSHOT: Failed to collect
 dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT
 (runtime)]
 [INFO] at
 org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:158)

 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:185)

 [INFO] ... 22 more
 [INFO] Caused

Re: Latest Karaf 3.0.2-SNAPSHOT build failure

2014-09-06 Thread Krzysztof Sobkowiak
(DefaultArtifactResolver.java:468)
... 27 more
Caused by: org.sonatype.aether.transfer.NoRepositoryConnectorException:
No connector available to access repository servicemix
(http://svn.apache.org/repos/asf/servicemix/m2-repo) of type default
using the available factories WagonRepositoryConnectorFactory
at
org.sonatype.aether.impl.internal.DefaultRemoteRepositoryManager.getRepositoryConnector(DefaultRemoteRepositoryManager.java:400)
at
org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:453)
... 27 more

And the build fails with following error

[ERROR] Failed to execute goal
org.apache.karaf.tooling:karaf-maven-plugin:3.0.2-SNAPSHOT:install-kars
(process-resources) on project apache-karaf-minimal: Could not unpack
all dependencies:
[ERROR] Could not install feature:
org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT
[ERROR] Couldn't resolve artifact
org.ops4j.pax.web:pax-web-features:xml:features:3.1.2


Best regards
Krzysztof



On 05.09.2014 07:00, Jean-Baptiste Onofré wrote:
 Hi,

 did you change your Maven version (for instance, update to 3.2) ?

 Regards
 JB

 On 09/04/2014 10:37 PM, Kevin Carr wrote:
 I am seeing a build error when building karaf-3.0.2-SNAPSHOT with
 -Pfastinstall

 The karaf-maven-plugin fails during building of all the tests.  Like:
 test-basic-generation

 It is missing this class:

 org/sonatype/aether/RepositorySystem

 Any ideas?  I have built the 3.0.2-SNAPSHOT before.  This is the
 first time
 I have seen an error like this.




-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: Latest Karaf 3.0.2-SNAPSHOT build failure

2014-09-06 Thread Krzysztof Sobkowiak
 for
org.apache.aries.blueprint:org.apache.aries.blueprint.core:jar:1.2.0
[INFO] at
org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:296)
[INFO] at
org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.readArtifactDescriptor(DefaultArtifactDescriptorReader.java:186)
[INFO] at
org.sonatype.aether.impl.internal.DefaultDependencyCollector.process(DefaultDependencyCollector.java:412)
[INFO] at
org.sonatype.aether.impl.internal.DefaultDependencyCollector.process(DefaultDependencyCollector.java:544)
[INFO] at
org.sonatype.aether.impl.internal.DefaultDependencyCollector.process(DefaultDependencyCollector.java:544)
[INFO] at
org.sonatype.aether.impl.internal.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:240)
[INFO] ... 25 more
[INFO] Caused by:
org.sonatype.aether.resolution.ArtifactResolutionException: Could not
transfer artifact
org.apache.aries.blueprint:org.apache.aries.blueprint.core:pom:1.2.0
from/to central (http://repo.maven.apache.org/maven2): No connector
available to access repository central
(http://repo.maven.apache.org/maven2) of type default using the
available factories WagonRepositoryConnectorFactory
[INFO] at
org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:538)
[INFO] at
org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:216)
[INFO] at
org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:193)
[INFO] at
org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:281)
[INFO] ... 30 more
[INFO] Caused by:
org.sonatype.aether.transfer.ArtifactTransferException: Could not
transfer artifact
org.apache.aries.blueprint:org.apache.aries.blueprint.core:pom:1.2.0
from/to central (http://repo.maven.apache.org/maven2): No connector
available to access repository central
(http://repo.maven.apache.org/maven2) of type default using the
available factories WagonRepositoryConnectorFactory
[INFO] at
org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:468)
[INFO] ... 33 more
[INFO] Caused by:
org.sonatype.aether.transfer.NoRepositoryConnectorException: No
connector available to access repository central
(http://repo.maven.apache.org/maven2) of type default using the
available factories WagonRepositoryConnectorFactory
[INFO] at
org.sonatype.aether.impl.internal.DefaultRemoteRepositoryManager.getRepositoryConnector(DefaultRemoteRepositoryManager.java:400)
[INFO] at
org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:453)
[INFO] ... 33 more
[INFO] [ERROR]
[INFO] [ERROR] Re-run Maven using the -X switch to enable full debug
logging.
[INFO] [ERROR]
[INFO] [ERROR] For more information about the errors and possible
solutions, please read the following articles:
[INFO] [ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
[INFO] Post-archetype-generation invoker exit code: 1

Building ServiceMix master (based on Karaf 3.x) ends with error too --
missing LightweightHttpWagon and following error


[ERROR] Failed to execute goal
org.apache.karaf.tooling:karaf-maven-plugin:3.0.2-SNAPSHOT:features-add-to-repository
(add-features-to-repo) on project apache-servicemix: Error populating
repository: Can't resolve artifact
org.apache.activemq:activemq-karaf:xml:features:5.10.0: Could not
transfer artifact org.apache.activemq:activemq-karaf:xml:features:5.10.0
from/to servicemix (http://svn.apache.org/repos/asf/servicemix/m2-repo):
No connector available to access repository servicemix
(http://svn.apache.org/repos/asf/servicemix/m2-repo) of type default
using the available factories WagonRepositoryConnectorFactory
[ERROR] org.apache.activemq:activemq-karaf:xml:5.10.0

Has this problem been introduced with upgrade of pax-url?

Best regards
Krzysztof



On 06.09.2014 23:17, Krzysztof Sobkowiak wrote:
 Hi

 This error occurs when I'm trying to build with Maven 3.2.3 or 3.1.1.
 But I'm trying to build Karaf 3.x using Maven 3.0.5. In both cases I'm
 getting following warning:

 [INFO] --- karaf-maven-plugin:3.0.2-SNAPSHOT:install-kars
 (process-resources) @ apache-karaf-minimal ---
 [INFO] Installing feature
 file:/home/kso/work/projects/asf/karaf-3.0.x/assemblies/apache-karaf-minimal/target/assembly/system/org/apache/karaf/features/framework/3.0.2-SNAPSHOT/framework-3.0.2-SNAPSHOT-features.xml
 to system and startup.properties
 [INFO] Adding feature repository to system:
 mvn:org.apache.karaf.features/standard/3.0.2-SNAPSHOT/xml/features
 Sep 06, 2014 10:57:36 PM org.sonatype.guice.bean.reflect.Logs$JULSink warn
 WARNING: Error injecting:
 org.apache.maven.wagon.providers.http.LightweightHttpWagon
 java.lang.TypeNotPresentException: Type

Re: Latest Karaf 3.0.2-SNAPSHOT build failure

2014-09-06 Thread Krzysztof Sobkowiak
This problem doesn't occur on master and 2.x which use pax-logging 2.1.0 too

On 07.09.2014 00:25, Krzysztof Sobkowiak wrote:
 I could build the Karaf Assemblies after removing the m2 repository.
 But similar problem still occurs while building Assembly Archetype --
 warning about missing LightweightHttpWagon and following error

 [INFO] [ERROR] Failed to execute goal on project assembly: Could not
 resolve dependencies for project
 archetype.it:assembly:karaf-assembly:0.1-SNAPSHOT: Failed to collect
 dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT
 (runtime)]: Failed to read artifact descriptor for
 org.apache.aries.blueprint:org.apache.aries.blueprint.core:jar:1.2.0:
 Could not transfer artifact
 org.apache.aries.blueprint:org.apache.aries.blueprint.core:pom:1.2.0
 from/to central (http://repo.maven.apache.org/maven2): No connector
 available to access repository central
 (http://repo.maven.apache.org/maven2) of type default using the
 available factories WagonRepositoryConnectorFactory - [Help 1]
 [INFO] org.apache.maven.lifecycle.LifecycleExecutionException: Failed
 to execute goal on project assembly: Could not resolve dependencies
 for project archetype.it:assembly:karaf-assembly:0.1-SNAPSHOT: Failed
 to collect dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT (runtime)]
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:210)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies(LifecycleDependencyResolver.java:117)
 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved(MojoExecutor.java:258)
 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:201)
 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
 [INFO] at
 org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
 [INFO] at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
 [INFO] at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
 [INFO] at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
 [INFO] at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
 [INFO] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 [INFO] at
 sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
 [INFO] at
 sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 [INFO] at java.lang.reflect.Method.invoke(Method.java:606)
 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
 [INFO] Caused by:
 org.apache.maven.project.DependencyResolutionException: Could not
 resolve dependencies for project
 archetype.it:assembly:karaf-assembly:0.1-SNAPSHOT: Failed to collect
 dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT (runtime)]
 [INFO] at
 org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:158)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:185)
 [INFO] ... 22 more
 [INFO] Caused by:
 org.sonatype.aether.collection.DependencyCollectionException: Failed
 to collect dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT (runtime)]
 [INFO] at
 org.sonatype.aether.impl.internal.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:258)
 [INFO] at
 org.sonatype.aether.impl.internal.DefaultRepositorySystem.collectDependencies(DefaultRepositorySystem.java:308)
 [INFO] at
 org.apache.maven.project.DefaultProjectDependenciesResolver.resolve

Re: [ANN] Apache Karaf 2.3.7 Released!

2014-09-06 Thread Krzysztof Sobkowiak
Hi

ServiceMix seems to be very stable, looks very good and many issues have
been solved after upgrade to Karaf 2.3.7. Good job!!

Best regards
Krzysztof


On 06.09.2014 19:04, Jamie G. wrote:
 The Karaf team is pleased to announce the release of Karaf version 2.3.7.

 Apache Karaf is a small OSGi distribution which provides a ready to
 use container for server side applications.

 This is an update patch for Apache Karaf 2.3.6, containing many bug
 fixes, dependency updates, and improvements. New features include
 SyncopeLoginModule, and improved documentation for exposing JAAS
 BackendEngineFactory services for the login module and configfile
 override behavoir. This patch contains a high priority bug fix for
 Windows users experiencing console input issues.

 http://karaf.apache.org/

 This release is available from
 http://karaf.apache.org/index/community/download.html#Karaf2.3.7 and

 Maven:

  dependency
  groupIdorg.apache.karaf/groupId
  artifactIdapache-karaf/artifactId
  version2.3.7/version
  /dependency

 Download Note:
 Our mirrors are still syncing the new kits, if your primary mirror
 does not have the kit please try another from the server mirror list.

 Release Notes:

 There are 15 resolved issues included in this release, as such we've
 documented them on the 2.3.7 release notes page:
 http://karaf.apache.org/index/community/download/karaf-2.3.7-release.html

 Enjoy!


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: Latest Karaf 3.0.2-SNAPSHOT build failure

2014-09-06 Thread Krzysztof Sobkowiak
This problem has been probably introduced by KARAF-3191 (Upgrade to Pax
Web 3.1.2). After this commit the problem occurs on Jenkins too
(https://builds.apache.org/view/All/job/karaf-3.0.x/291/)


On 07.09.2014 00:36, Krzysztof Sobkowiak wrote:
 This problem doesn't occur on master and 2.x which use pax-logging
 2.1.0 too

 On 07.09.2014 00:25, Krzysztof Sobkowiak wrote:
 I could build the Karaf Assemblies after removing the m2 repository.
 But similar problem still occurs while building Assembly Archetype --
 warning about missing LightweightHttpWagon and following error

 [INFO] [ERROR] Failed to execute goal on project assembly: Could not
 resolve dependencies for project
 archetype.it:assembly:karaf-assembly:0.1-SNAPSHOT: Failed to collect
 dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT
 (runtime)]: Failed to read artifact descriptor for
 org.apache.aries.blueprint:org.apache.aries.blueprint.core:jar:1.2.0:
 Could not transfer artifact
 org.apache.aries.blueprint:org.apache.aries.blueprint.core:pom:1.2.0
 from/to central (http://repo.maven.apache.org/maven2): No connector
 available to access repository central
 (http://repo.maven.apache.org/maven2) of type default using the
 available factories WagonRepositoryConnectorFactory - [Help 1]
 [INFO] org.apache.maven.lifecycle.LifecycleExecutionException: Failed
 to execute goal on project assembly: Could not resolve dependencies
 for project archetype.it:assembly:karaf-assembly:0.1-SNAPSHOT: Failed
 to collect dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT (runtime)]
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:210)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies(LifecycleDependencyResolver.java:117)
 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved(MojoExecutor.java:258)
 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:201)
 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
 [INFO] at
 org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
 [INFO] at
 org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
 [INFO] at
 org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
 [INFO] at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
 [INFO] at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
 [INFO] at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
 [INFO] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 [INFO] at
 sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
 [INFO] at
 sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 [INFO] at java.lang.reflect.Method.invoke(Method.java:606)
 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
 [INFO] at
 org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
 [INFO] Caused by:
 org.apache.maven.project.DependencyResolutionException: Could not
 resolve dependencies for project
 archetype.it:assembly:karaf-assembly:0.1-SNAPSHOT: Failed to collect
 dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT (runtime)]
 [INFO] at
 org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:158)
 [INFO] at
 org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:185)
 [INFO] ... 22 more
 [INFO] Caused by:
 org.sonatype.aether.collection.DependencyCollectionException: Failed
 to collect dependencies for
 [org.apache.karaf.features:framework:kar:3.0.2-SNAPSHOT (compile),
 org.apache.karaf.features:standard:xml:features:3.0.2-SNAPSHOT (runtime)]
 [INFO] at
 org.sonatype.aether.impl.internal.DefaultDependencyCollector.collectDependencies

Re: [VOTE] Release Apache Karaf 2.3.7

2014-09-03 Thread Krzysztof Sobkowiak
+1 (non-binding)
Looks good for me

Best regards
Krzysztof

On 03.09.2014 02:47, Jamie G. wrote:
 Hi,

 We resolved 15 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.3.7-release.page?view=markup

 Dependency changes can be reviewed here:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-2.3.x.page?revision=1613719view=markup

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1009/

 Git tag:
 karaf-2.3.7

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: Problem with respectStartLvlDuringFeatureStartup

2014-07-30 Thread Krzysztof Sobkowiak
Hi

I have tested ServiceMix 6.0.x which is based on Karaf 3.0.x. With Karaf
3.0.1 we have solved the problem similar to the ServiceMix based on
Karaf 2.3.5. With Karaf 2.3.6-SNAPSHOT this solution doesn't work
anymore too (see https://issues.apache.org/jira/browse/SM-2358)

Best regards
Krzysztof

On 29.07.2014 22:11, Krzysztof Sobkowiak wrote:
 You can see more details in
 https://issues.apache.org/jira/browse/SM-2301 and
 https://issues.apache.org/jira/browse/SM-2330

 On 29.07.2014 22:10, Krzysztof Sobkowiak wrote:
 Hi

 I'm testing ServiceMix after upgrade to the latest 2.3.6-SNAPSHOT. I
 think, there is no difference between 2.3.6 and 2.3.6-SNAPSHOT. It
 looks very good, our most problems have been fixed,  but I have found
 one problem I want to describe here. You can answer whether it is a
 new issue in Karaf or whether we do something wrong.

 After upgrade to ActiveMQ 5.9.1 we have found a problem when we
 wanted to start activiti feature in featuresBoot. At startup we got
 following error


 java.lang.Exception: Could not start bundle
 mvn:org.activiti/activiti-engine/5.15.1 in feature(s)
 activiti-5.15.1: Uses constraint violation. Unable to resolve bundle
 revision org.activiti.engine [187.0] because it is exposed to package
 'org.joda.time.format' from bundle revisions
 org.apache.servicemix.bundles.joda-time [56.0] and joda-time [106.0]
 via two dependency chains.

 Chain 1:
   org.activiti.engine [187.0]
 import:
 ((osgi.wiring.package=org.joda.time.format)(version=2.1.0)(!(version=3.0.0)))
  |
 export: osgi.wiring.package=org.joda.time.format
   org.apache.servicemix.bundles.joda-time [56.0]

 Chain 2:
   org.activiti.engine [187.0]
 import:
 ((osgi.wiring.package=org.drools.runtime)(version=5.5.0)(!(version=6.0.0)))
  |
 export: osgi.wiring.package=org.drools.runtime;
 uses:=com.thoughtworks.xstream.annotations
   org.apache.servicemix.bundles.drools [179.0]
 import: (osgi.wiring.package=com.thoughtworks.xstream.annotations)
  |
 export: osgi.wiring.package=com.thoughtworks.xstream.annotations;
 uses:=org.joda.time.format
   org.apache.servicemix.bundles.xstream [107.0]
 import:
 ((osgi.wiring.package=org.joda.time.format)(version=1.6.0)(!(version=3.0.0)))
  |
 export: osgi.wiring.package=org.joda.time.format
   joda-time [106.0]


 It happend when we ServiceMix was based on Karaf 2.3.5. To solve this
 problem we forced the start of the bundle 
 org.apache.servicemix.bundles.joda-timeat the beginning. We have
 created following feature and added it at featuresBoot.

 feature name=joda-time
 bundle
 start-level='10'mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.joda-time/${jodatime.bundle.version}/bundle
 /feature

 We have also set the parameter respectStartLvlDuringFeatureStartup to
 true. It solved our problem andorg.apache.servicemix.bundles.xstream
 could resolve the package from
 org.apache.servicemix.bundles.joda-time. I don't know if it was
 correct solution but it solved our problem.

 Next we had to downgrade to Karaf 2.3.4 (due to another problem
 introduced in 2.3.5). Because Karaf 2.3.4 does not support the
 respectStartLvlDuringFeatureStartup parameter,  our solution didn't
 work anymore an we had to add this bundle to startup.properties. It
 worked.

 Now we want to upgrade to Karaf 2.3.6. I have removed the joda bundle
 from startup.properties and our problem exists again - the solution
 which worked with Karaf 2.3.5 doesn't work with 2.3.6. Moreover, when
 I set respectStartLvlDuringFeatureStartup to false,  the problem
 seems to be fixed. Downgrade to Karaf 2.3.5 solves the problem too.

 Have you changed something in the features installer and the logic of
 respectStartLvlDuringFeatureStartup? Is our solution correct or
 should we allways use startup.properties to force bundles to be
 installed before other features are installed.  I suppose, the answer
 for my second question will be /yes/, but I'd like to know why our
 solution with additional feature doesn't work anymore with Karaf 2.3.6.


 Best regards
 Krzysztof




 -- 
 Krzysztof Sobkowiak

 JEE  OSS Architect | Senior Solution Architect @ Capgemini |
 Committer @ ASF
 Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
 http://www.pl.capgemini-sdm.com/ | Wroclaw
 e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
 Twitter: @KSobkowiak
 Calendar: http://goo.gl/yvsebC


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [VOTE] Release Apache Karaf 2.3.6

2014-07-30 Thread Krzysztof Sobkowiak
+1 (non-binding)

Best regards
Krzysztof

On 29.07.2014 04:39, Jamie G. wrote:
 Hi,

 We resolved 70 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.3.6-release.page?view=markup

 Dependency changes can be reviewed here:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-2.3.x.page?revision=1613719view=markup

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1008/

 Git tag:
 karaf-2.3.6

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Problem with respectStartLvlDuringFeatureStartup (was: [VOTE] Release Apache Karaf 2.3.6)

2014-07-29 Thread Krzysztof Sobkowiak
Hi

I'm testing ServiceMix after upgrade to the latest 2.3.6-SNAPSHOT. I
think, there is no difference between 2.3.6 and 2.3.6-SNAPSHOT. It looks
very good, our most problems have been fixed,  but I have found one
problem I want to describe here. You can answer whether it is a new
issue in Karaf or whether we do something wrong.

After upgrade to ActiveMQ 5.9.1 we have found a problem when we wanted
to start activiti feature in featuresBoot. At startup we got following error


java.lang.Exception: Could not start bundle
mvn:org.activiti/activiti-engine/5.15.1 in feature(s) activiti-5.15.1:
Uses constraint violation. Unable to resolve bundle revision
org.activiti.engine [187.0] because it is exposed to package
'org.joda.time.format' from bundle revisions
org.apache.servicemix.bundles.joda-time [56.0] and joda-time [106.0] via
two dependency chains.

Chain 1:
  org.activiti.engine [187.0]
import:
((osgi.wiring.package=org.joda.time.format)(version=2.1.0)(!(version=3.0.0)))
 |
export: osgi.wiring.package=org.joda.time.format
  org.apache.servicemix.bundles.joda-time [56.0]

Chain 2:
  org.activiti.engine [187.0]
import:
((osgi.wiring.package=org.drools.runtime)(version=5.5.0)(!(version=6.0.0)))
 |
export: osgi.wiring.package=org.drools.runtime;
uses:=com.thoughtworks.xstream.annotations
  org.apache.servicemix.bundles.drools [179.0]
import: (osgi.wiring.package=com.thoughtworks.xstream.annotations)
 |
export: osgi.wiring.package=com.thoughtworks.xstream.annotations;
uses:=org.joda.time.format
  org.apache.servicemix.bundles.xstream [107.0]
import:
((osgi.wiring.package=org.joda.time.format)(version=1.6.0)(!(version=3.0.0)))
 |
export: osgi.wiring.package=org.joda.time.format
  joda-time [106.0]


It happend when we ServiceMix was based on Karaf 2.3.5. To solve this
problem we forced the start of the bundle 
org.apache.servicemix.bundles.joda-timeat the beginning. We have created
following feature and added it at featuresBoot.

feature name=joda-time
bundle
start-level='10'mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.joda-time/${jodatime.bundle.version}/bundle
/feature

We have also set the parameter respectStartLvlDuringFeatureStartup to
true. It solved our problem andorg.apache.servicemix.bundles.xstream
could resolve the package from org.apache.servicemix.bundles.joda-time.
I don't know if it was correct solution but it solved our problem.

Next we had to downgrade to Karaf 2.3.4 (due to another problem
introduced in 2.3.5). Because Karaf 2.3.4 does not support the
respectStartLvlDuringFeatureStartup parameter,  our solution didn't work
anymore an we had to add this bundle to startup.properties. It worked.

Now we want to upgrade to Karaf 2.3.6. I have removed the joda bundle
from startup.properties and our problem exists again - the solution
which worked with Karaf 2.3.5 doesn't work with 2.3.6. Moreover, when I
set respectStartLvlDuringFeatureStartup to false,  the problem seems to
be fixed. Downgrade to Karaf 2.3.5 solves the problem too.

Have you changed something in the features installer and the logic of
respectStartLvlDuringFeatureStartup? Is our solution correct or should
we allways use startup.properties to force bundles to be installed
before other features are installed.  I suppose, the answer for my
second question will be /yes/, but I'd like to know why our solution
with additional feature doesn't work anymore with Karaf 2.3.6.


Best regards
Krzysztof








On 29.07.2014 04:39, Jamie G. wrote:
 Hi,

 We resolved 70 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.3.6-release.page?view=markup

 Dependency changes can be reviewed here:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-2.3.x.page?revision=1613719view=markup

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1008/

 Git tag:
 karaf-2.3.6

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: Problem with respectStartLvlDuringFeatureStartup

2014-07-29 Thread Krzysztof Sobkowiak
You can see more details in
https://issues.apache.org/jira/browse/SM-2301 and
https://issues.apache.org/jira/browse/SM-2330

On 29.07.2014 22:10, Krzysztof Sobkowiak wrote:
 Hi

 I'm testing ServiceMix after upgrade to the latest 2.3.6-SNAPSHOT. I
 think, there is no difference between 2.3.6 and 2.3.6-SNAPSHOT. It
 looks very good, our most problems have been fixed,  but I have found
 one problem I want to describe here. You can answer whether it is a
 new issue in Karaf or whether we do something wrong.

 After upgrade to ActiveMQ 5.9.1 we have found a problem when we wanted
 to start activiti feature in featuresBoot. At startup we got following
 error


 java.lang.Exception: Could not start bundle
 mvn:org.activiti/activiti-engine/5.15.1 in feature(s) activiti-5.15.1:
 Uses constraint violation. Unable to resolve bundle revision
 org.activiti.engine [187.0] because it is exposed to package
 'org.joda.time.format' from bundle revisions
 org.apache.servicemix.bundles.joda-time [56.0] and joda-time [106.0]
 via two dependency chains.

 Chain 1:
   org.activiti.engine [187.0]
 import:
 ((osgi.wiring.package=org.joda.time.format)(version=2.1.0)(!(version=3.0.0)))
  |
 export: osgi.wiring.package=org.joda.time.format
   org.apache.servicemix.bundles.joda-time [56.0]

 Chain 2:
   org.activiti.engine [187.0]
 import:
 ((osgi.wiring.package=org.drools.runtime)(version=5.5.0)(!(version=6.0.0)))
  |
 export: osgi.wiring.package=org.drools.runtime;
 uses:=com.thoughtworks.xstream.annotations
   org.apache.servicemix.bundles.drools [179.0]
 import: (osgi.wiring.package=com.thoughtworks.xstream.annotations)
  |
 export: osgi.wiring.package=com.thoughtworks.xstream.annotations;
 uses:=org.joda.time.format
   org.apache.servicemix.bundles.xstream [107.0]
 import:
 ((osgi.wiring.package=org.joda.time.format)(version=1.6.0)(!(version=3.0.0)))
  |
 export: osgi.wiring.package=org.joda.time.format
   joda-time [106.0]


 It happend when we ServiceMix was based on Karaf 2.3.5. To solve this
 problem we forced the start of the bundle 
 org.apache.servicemix.bundles.joda-timeat the beginning. We have
 created following feature and added it at featuresBoot.

 feature name=joda-time
 bundle
 start-level='10'mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.joda-time/${jodatime.bundle.version}/bundle
 /feature

 We have also set the parameter respectStartLvlDuringFeatureStartup to
 true. It solved our problem andorg.apache.servicemix.bundles.xstream
 could resolve the package from
 org.apache.servicemix.bundles.joda-time. I don't know if it was
 correct solution but it solved our problem.

 Next we had to downgrade to Karaf 2.3.4 (due to another problem
 introduced in 2.3.5). Because Karaf 2.3.4 does not support the
 respectStartLvlDuringFeatureStartup parameter,  our solution didn't
 work anymore an we had to add this bundle to startup.properties. It
 worked.

 Now we want to upgrade to Karaf 2.3.6. I have removed the joda bundle
 from startup.properties and our problem exists again - the solution
 which worked with Karaf 2.3.5 doesn't work with 2.3.6. Moreover, when
 I set respectStartLvlDuringFeatureStartup to false,  the problem seems
 to be fixed. Downgrade to Karaf 2.3.5 solves the problem too.

 Have you changed something in the features installer and the logic of
 respectStartLvlDuringFeatureStartup? Is our solution correct or should
 we allways use startup.properties to force bundles to be installed
 before other features are installed.  I suppose, the answer for my
 second question will be /yes/, but I'd like to know why our solution
 with additional feature doesn't work anymore with Karaf 2.3.6.


 Best regards
 Krzysztof








 On 29.07.2014 04:39, Jamie G. wrote:
 Hi,

 We resolved 70 issues in this release:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.3.6-release.page?view=markup

 Dependency changes can be reviewed here:
 http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-2.3.x.page?revision=1613719view=markup

 Staging repository:
 https://repository.apache.org/content/repositories/orgapachekaraf-1008/

 Git tag:
 karaf-2.3.6

 Please vote to approve this release:

 [ ] +1 Approve the release
 [ ] -1 Veto the release (please provide specific comments)

 This vote will be open for 72 hours.


 -- 
 Krzysztof Sobkowiak

 JEE  OSS Architect | Senior Solution Architect @ Capgemini |
 Committer @ ASF
 Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
 http://www.pl.capgemini-sdm.com/ | Wroclaw
 e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
 Twitter: @KSobkowiak
 Calendar: http://goo.gl/yvsebC


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com

Re: AspectJ WeavingHook

2014-07-14 Thread Krzysztof Sobkowiak
Hi

Any idea?

Best regards
Krzysztof

On 11.06.2014 22:20, Krzysztof Sobkowiak wrote:
 Hi

 I'd like to do one small step towards the AspectJ WeavingHook
 implementation. If it should be part of karaf-extra, what a package
 naming should be used? Do you have any idea which license should be
 used for this code?

 Best regards
 Krzysztof

 On 11.01.2014 14:08, Jean-Baptiste Onofré wrote:
 Good point. Theoretical, I would say aries-extra if you are based on
 Aries weaving. However, as Aries is a library, in order to use/test
 it you have to use it in a container like Karaf. So as a ready to use
 solution (with features), it could be in karaf-extra. Actually, it's
 likely like the other Aries project: the library/API codebase is in
 Aries, the execution (features and usage) is in Karaf.

 Regards
 JB

 On 01/11/2014 01:02 PM, Krzysztof Sobkowiak wrote:
 By the way, which project would be the best final place for the
 solution
 with AspectJ?   Karaf (in this case karaf-extra) or Aries
 (aries-extra)?

 Best regards
 Krzysztof

 On 10.01.2014 08:06, Jean-Baptiste Onofré wrote:

 I use an example again  - AspectJ is licensed under EPL 1.0 license.
 Assume I'd like to implement a WeavingHook using the AspectJ classes
 (reference AspectJ as maven dependency and use the classes in my
 code).
 Does it mean, my code can not be included in Apache licensed project,
 but I can implement the hook in a project under other license and
 eventually reference it in Karaf feature?

 Correct, you can't include in Apache project. You can create your
 project outside of Apache project and reference it. Same as before:
 you can do your WeavingHook in karaf-extra.



 -- 
 Krzysztof Sobkowiak

 JEE  OSS Architect | Technical Architect @ Capgemini
 Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
 http://www.pl.capgemini-sdm.com/ | Wroclaw
 e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
 Twitter: @KSobkowiak
 Calendar: goo.gl/yvsebC


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [DISCUSS] Release Karaf 2.4.0

2014-07-12 Thread Krzysztof Sobkowiak
Hi

I could successfully test the demos from chapter7 (after some changes
necessary to downgrade the code to Karaf 2.4) using OpenJPA 2.2.2 and
2.3.0, with and without bytecode weaving (with and without
openjpa-maven-plugin).

Best regards
Krzysztof

On 11.07.2014 18:53, Jean-Baptiste Onofré wrote:
 Hi Krzysztof,

 We have the samples from Karaf Cookbook (it's on github).
 I plan to merge my dev guide updates containing samples.

 Regards
 JB

 On 07/11/2014 04:28 PM, Krzysztof Sobkowiak wrote:
 Hi

 Are there any existing samples/demos which could be used to test this
 feature?

 Regards
 Krzysztof
 On Jul 11, 2014 3:49 AM, Matt Sicker boa...@gmail.com wrote:

 JPA with and without bytecode weaving perhaps?


 On 10 July 2014 15:51, Krzysztof Sobkowiak krzys.sobkow...@gmail.com
 wrote:

 Hi

 I have just tested jdbc, jms, jndi commands and performed some tests
 with ActiveMQ and Camel. This part looks ok. I'll try to perform some
 more tests tomorrow. Are there any special parts which should be
 tested
 more intensive?

 Best regards
 Krzysztof

 On 09.07.2014 21:16, Jean-Baptiste Onofré wrote:
 By the way, it's the same Aries * new releases that we will have on
 master, karaf-3.0.x (for the next 3.0.2) and karaf-2.x (for the next
 2.4.0).
 Just to be clear.

 Regards
 JB

 On 07/09/2014 07:44 PM, Christian Schneider wrote:
 We should also include the upcoming aries jpa release. It contains
 some
 important fixes.
 The bug in the current aries jpa makes it almost impossible to use.
 (See
 https://issues.apache.org/jira/browse/ARIES-1160)
 JB offered to prepare this release.

 Christian

 Am 09.07.2014 17:24, schrieb Guillaume Nodet:
 Now that Aries releases are done, I'd like to discuss a 2.4.0
 release
 asap.
 I think it's in a good shape, but i'll do a bit more testing and I
 would
 welcome any additional volunteers.

 Anyway, does anyone as any urgent stuff to put in before we
 release ?
 I'd like to start the release friday or monday if nothing
 requires a
 delay.

 Thoughts ?

 Guillaume




 -- 
 Matt Sicker boa...@gmail.com





-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Re: [DISCUSS] Release Karaf 2.4.0

2014-07-11 Thread Krzysztof Sobkowiak
Hi

Are there any existing samples/demos which could be used to test this
feature?

Regards
Krzysztof
On Jul 11, 2014 3:49 AM, Matt Sicker boa...@gmail.com wrote:

 JPA with and without bytecode weaving perhaps?


 On 10 July 2014 15:51, Krzysztof Sobkowiak krzys.sobkow...@gmail.com
 wrote:

  Hi
 
  I have just tested jdbc, jms, jndi commands and performed some tests
  with ActiveMQ and Camel. This part looks ok. I'll try to perform some
  more tests tomorrow. Are there any special parts which should be tested
  more intensive?
 
  Best regards
  Krzysztof
 
  On 09.07.2014 21:16, Jean-Baptiste Onofré wrote:
   By the way, it's the same Aries * new releases that we will have on
   master, karaf-3.0.x (for the next 3.0.2) and karaf-2.x (for the next
   2.4.0).
   Just to be clear.
  
   Regards
   JB
  
   On 07/09/2014 07:44 PM, Christian Schneider wrote:
   We should also include the upcoming aries jpa release. It contains
 some
   important fixes.
   The bug in the current aries jpa makes it almost impossible to use.
 (See
   https://issues.apache.org/jira/browse/ARIES-1160)
   JB offered to prepare this release.
  
   Christian
  
   Am 09.07.2014 17:24, schrieb Guillaume Nodet:
   Now that Aries releases are done, I'd like to discuss a 2.4.0 release
   asap.
   I think it's in a good shape, but i'll do a bit more testing and I
   would
   welcome any additional volunteers.
  
   Anyway, does anyone as any urgent stuff to put in before we release ?
   I'd like to start the release friday or monday if nothing requires a
   delay.
  
   Thoughts ?
  
   Guillaume
  
  
  
  
 
 
  --
  Krzysztof Sobkowiak
 
  JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
  @ ASF
  Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
  http://www.pl.capgemini-sdm.com/ | Wroclaw
  e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
  Twitter: @KSobkowiak
  Calendar: http://goo.gl/yvsebC
 



 --
 Matt Sicker boa...@gmail.com



Re: [DISCUSS] Release Karaf 2.4.0

2014-07-10 Thread Krzysztof Sobkowiak
Hi

I have just tested jdbc, jms, jndi commands and performed some tests
with ActiveMQ and Camel. This part looks ok. I'll try to perform some
more tests tomorrow. Are there any special parts which should be tested
more intensive?

Best regards
Krzysztof

On 09.07.2014 21:16, Jean-Baptiste Onofré wrote:
 By the way, it's the same Aries * new releases that we will have on
 master, karaf-3.0.x (for the next 3.0.2) and karaf-2.x (for the next
 2.4.0).
 Just to be clear.

 Regards
 JB

 On 07/09/2014 07:44 PM, Christian Schneider wrote:
 We should also include the upcoming aries jpa release. It contains some
 important fixes.
 The bug in the current aries jpa makes it almost impossible to use. (See
 https://issues.apache.org/jira/browse/ARIES-1160)
 JB offered to prepare this release.

 Christian

 Am 09.07.2014 17:24, schrieb Guillaume Nodet:
 Now that Aries releases are done, I'd like to discuss a 2.4.0 release
 asap.
 I think it's in a good shape, but i'll do a bit more testing and I
 would
 welcome any additional volunteers.

 Anyway, does anyone as any urgent stuff to put in before we release ?
 I'd like to start the release friday or monday if nothing requires a
 delay.

 Thoughts ?

 Guillaume






-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Senior Solution Architect @ Capgemini | Committer
@ ASF
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: http://goo.gl/yvsebC


Activemq web console fails in karaf+equinox

2014-06-07 Thread Krzysztof Sobkowiak
Hi

Could you look at https://issues.apache.org/jira/browse/AMQ-4794? Is it
really an ActiveMQ problem or is it a problem of Karaf  Equinox only
triggered by installation of ActiveMQ web console? 

Best regards
Krzysztof

-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Technical Architect @ Capgemini
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak
Calendar: goo.gl/yvsebC


Re: [PROPOSAL] Include samples and new dev guide for Karaf 3.0.1

2014-04-24 Thread Krzysztof Sobkowiak
Hi Jean-Baptiste

What are the plans for the dev guide?

Best regards
Krzysztof

On 18.02.2014 18:16, Jean-Baptiste Onofré wrote:
 Hi all,

 You probably saw that we did a good job in the quickstart, update
 notes, and user guide for Karaf 3.0.0:
 http://karaf.apache.org/manual/latest/quick-start.html
 http://karaf.apache.org/manual/latest/update-notes.html
 http://karaf.apache.org/manual/latest/users-guide/index.html

 I started to work on a complete refactoring of the dev guide on a
 local git branch.
 I already started to discussed with Christian to provide dev examples
 directly in the Karaf distribution. It's a refactoring and huge
 extension to the existing demo folder.

 The purpose is illustrate the content in the dev guide with real
 examples, covering all Karaf features (especially the enterprise ones,
 like JPA, CDI, etc).

 I will push the samples module structure.
 Christian already said he's in to help, but any help is welcome ;)

 I should be able to push the structure and samples frame tonight.

 Thanks in advance for your help.

 Regards
 JB


-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Technical Architect @ Capgemini
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak


Re: Build freezes when the invoker plugin is invoked

2014-04-21 Thread Krzysztof Sobkowiak
Hi Jean-Baptiste

I have tested it again and it works now. From any reason the aggregate
has not finished when I tried to build Karaf some days ago.
My platform

kso@Inspiron-7720:~/work/SEU/dev/maven/apache-maven-3.0.5/bin$ ./mvn -V
Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da;
2013-02-19 14:51:28+0100)
Maven home: /home/kso/work/SEU/dev/maven/apache-maven-3.0.5
Java version: 1.7.0_45, vendor: Oracle Corporation
Java home: /home/kso/work/SEU/jvm/jdk1.7.0_45/jre
Default locale: en_US, platform encoding: UTF-8
OS name: linux, version: 3.11.0-19-generic, arch: amd64, family:
unix

Best regards
Krzysztof


On 21.04.2014 09:25, Jean-Baptiste Onofré wrote:
 Hi Krzysztof

 I just tested on master and karaf-3.0.x and the karaf-maven-plugin
 itests work fine for me:

 [INFO] --- maven-invoker-plugin:1.6:run (integration-test) @
 karaf-maven-plugin ---
 [INFO] Building: test-aggregate-features/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-aggregate-features/verify.bsh
 [INFO] ..SUCCESS (36.7 s)
 [INFO] Building: test-kar-classifier/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-kar-classifier/verify.bsh
 [INFO] ..SUCCESS (3.7 s)
 [INFO] Building: test-kar-packaging/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-kar-packaging/verify.bsh
 [INFO] ..SUCCESS (3.6 s)
 [INFO] Building: test-basic-generation/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-basic-generation/verify.bsh
 [INFO] ..SUCCESS (4.8 s)
 [INFO] Building: test-type-classifier/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-type-classifier/verify.bsh
 [INFO] ..SUCCESS (5.2 s)
 [INFO] Building: test-kar-with-pom-packaging/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-kar-with-pom-packaging/verify.bsh
 [INFO] ..SUCCESS (3.6 s)
 [INFO] Building: test-check-dependencies/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-check-dependencies/verify.bsh
 [INFO] ..SUCCESS (6.9 s)
 [INFO] Building: test-kar-multiple-kars/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-kar-multiple-kars/verify.bsh
 [INFO] ..SUCCESS (3.5 s)
 [INFO] Building: test-check-dependencies-failure/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-check-dependencies-failure/verify.bsh
 [INFO] ..SUCCESS (7.2 s)
 [INFO] Building: test-recursive/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-recursive/verify.bsh
 [INFO] ..SUCCESS (6.4 s)
 [INFO] Building: test-input-file/pom.xml
 [INFO] run script
 /home/jbonofre/workspace/karaf/karaf/tooling/karaf-maven-plugin/target/it/test-input-file/verify.bsh
 [INFO] ..SUCCESS (5.6 s)
 [INFO] -
 [INFO] Build Summary:
 [INFO]   Passed: 11, Failed: 0, Errors: 0, Skipped: 0
 [INFO] -


 I just noticed that the aggregate itest takes time (about 30s).

 What's your build platform (system, JDK, etc) ?

 Regards
 JB

 On 04/15/2014 11:36 PM, Krzysztof Sobkowiak wrote:
 Hi

 I'm trying to build (mvn clean install) the master or 3.0.x branch and
 the build freezes when invoking the invoker plugin

 [INFO]
 [INFO] --- maven-invoker-plugin:1.6:run (integration-test) @
 karaf-maven-plugin ---
 [INFO] Building: test-check-dependencies/pom.xml

 Building the code usingmvn install -DskipTests helps, but disables the
 tests. After this run evenmvn install works. But mvn clean install
 freezes again. Do you have any good solution for this problem?

 Best regards
 Krzysztof








-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Technical Architect @ Capgemini
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak


Build freezes when the invoker plugin is invoked

2014-04-15 Thread Krzysztof Sobkowiak
Hi

I'm trying to build (mvn clean install) the master or 3.0.x branch and
the build freezes when invoking the invoker plugin

[INFO]
[INFO] --- maven-invoker-plugin:1.6:run (integration-test) @
karaf-maven-plugin ---
[INFO] Building: test-check-dependencies/pom.xml

Building the code usingmvn install -DskipTests helps, but disables the
tests. After this run evenmvn install works. But mvn clean install
freezes again. Do you have any good solution for this problem?

Best regards
Krzysztof





-- 
Krzysztof Sobkowiak

JEE  OSS Architect | Technical Architect @ Capgemini
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com |
Twitter: @KSobkowiak


Re: [VOTE] Release Apache Karaf 2.3.5

2014-04-11 Thread Krzysztof Sobkowiak

+1

I have performed a quick build of ServiceMix 5.0.x with Karaf 2.3.5 from 
the staging repository. It looks ok


 * build successful
 * testcases successful
 * quick test of the assembly seccessful

I think, the staged Karaf release is ok.

Regards
Krzysztof

On 10.04.2014 18:45, Jamie G. wrote:

Hi,

We resolved 34 issues in this release:
http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/community/download/karaf-2.3.5-release.page?view=log

Dependency changes can be reviewed here:
http://svn.apache.org/viewvc/karaf/site/trunk/src/main/webapp/index/documentation/karaf-dependencies/karaf-deps-2.3.x.page?view=log

Staging repository:
https://repository.apache.org/content/repositories/orgapachekaraf-1004/

Git tag:
karaf-2.3.5

Please vote to approve this release:

[ ] +1 Approve the release
[ ] -1 Veto the release (please provide specific comments)

This vote will be open for 72 hours.



--
Krzysztof Sobkowiak

JEE  OSS Architect | Technical Architect @ Capgemini
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center 
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com | 
Twitter: @KSobkowiak


Re: [PROPOSAL] Roadmap

2014-03-06 Thread Krzysztof Sobkowiak

Hi Jean-Baptiste

When do you plan to push the changes for samples and developer guide?

Regards
Krzysztof

On 25.02.2014 10:57, Jean-Baptiste Onofré wrote:

Hi all,

In the latest weeks, we discussed about different topics and changes 
for Karaf. We had very interesting different proposals, discussions, 
etc. However, some discussions were on IRC, so it's not easy for 
everybody to follow.


I would like to summarise the different topics and build a roadmap.

I gonna update the roadmap wiki page:
https://cwiki.apache.org/confluence/display/KARAF/Roadmap

But before updating the wiki page, I would like to share with you all 
the different topics and provide a global picture overview.


1/ Short term (3.0.x/3.1.x)
-
- Fixed and enhancements on the maven-karaf-plugin. It's on my TODO 
for today. It includes several fixes, add more tests, and support of 
Maven 3.1/3.2
- Usage of commons-daemon. As we are stuck to a old Tanuki JSW wrapper 
(license issue), I prepared the usage of Apache commons-daemon on a 
branch. I will push this branch to let you take a look.
- Samples and developer guide. I prepared a branch where I replaced 
the demos modules with samples modules. The purpose is to illustrate 
the developer guide (that I refactored/enhanced too) with CDI, JPA, 
etc samples.
- Net/minimal distributions. In addition of the standard 
distribution, we will provide two other distributions: the net is very 
very minimal and will download all artifacts from remote repository 
(Internet) at startup, on the other hand, minimal distribution 
contains a minimal system repository and allow to easily construct 
custom distribution.
- Reduce number of bundles: with Karaf 3.0.0, we introduced multiple 
bundles: in Karaf itself, or due to dependency projects (like Pax URL 
for instance). If I think it's good, maybe we want a bit far and, if 
possible, I would reduce the number of bundles started.
- Own versioning for Spring and Enteprise Karaf Features: now, to 
upgrade to new version of Spring, Hibernate, OpenJPA, etc, we have to 
release a new version of Karaf. Of course, the Karaf features should 
be provided by the projects themselves, but waiting this, I would like 
to manage Spring and Enterprise Karaf features as standalone. The 
codebase stays where it's, but instead of depending to Karaf parent 
POM, it will depend directly to Apache POM and excluded from the Karaf 
reactor.


2/ Middle term (3.1.x/future)
--
- Blueprint dependency and more usage of pure OSGi/DS. Now, lot of 
Karaf modules depend to blueprint (for IoC or namespace handler). In 
order to minimise the footprint, and avoid some issues (like proxy), 
it would be great to set Blueprint as optional and more use pure OSGi 
or DS internally in Karaf. We should also provide a better 
advertising about DS support.
- Generic shell commands. Now, projects (like CXF, Camel, etc) depends 
to Karaf shell modules (and console by transitivity). The purpose is:
1/ simplify the usage/coding of commands (providing annotation 
especially)

2/ avoid the dependency to blueprint (especially the namespace handler)
3/ reduce the dependency
4/ provide a better support of Felix Gogo shell in Karaf

Again, the purpose of this e-mail is not to details each section, but 
to provide a global picture. The details will go into the 
corresponding Jira.


Thoughts ?

Regards
JB



--
Krzysztof Sobkowiak

JEE  OSS Architect | Technical Architect @ Capgemini
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center 
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com | 
Twitter: @KSobkowiak


Problem with hibernate-envers 3.x

2014-02-18 Thread Krzysztof Sobkowiak

Hi friends

I think, the hibernate-envers feature for Hibernate 3 should not exist 
(or must be remastered). There is no 
org.hibernate:hibernate-envers:jar:3.3.2.GA anywhere (in central repo 
nor in JBoss repo).


karaf@root() feature:install hibernate-envers/3.3.2.GA
Error executing command: Error resolving artifact 
org.hibernate:hibernate-envers:jar:3.3.2.GA: Could not find artifact 
org.hibernate:hibernate-envers:jar:3.3.2.GA in defaultlocal 
(file:/home/kso/.m2/repository/)


The first version of hibernate-envers is 3.5.0, but the original jars 
from the line 3.x have no OSGi metadata. The line 4.x has been osgified. 
So, we should create a bundle for envers 3.3.2.GA (if doesn't exist in 
EBR yet) or remove the hibernate-envers feature for this version. I'm 
going to open an JIRA issue for this problem


Regards
Krzysztof

--
Krzysztof Sobkowiak

JEE  OSS Architect | Technical Architect @ Capgemini
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center 
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com | 
Twitter: @KSobkowiak


Re: Problem with hibernate-envers 3.x

2014-02-18 Thread Krzysztof Sobkowiak

Yes, it is my preferred solution too, I will open proper issue.


On 18.02.2014 15:05, Jean-Baptiste Onofré wrote:

Hi Krzysztof,

it's a mistake in the POM property used for the version and merge.

I would remove hibernate-envers as it doesn't make sense for Hibernate 
3.x.


Regards
JB

On 02/18/2014 03:01 PM, Krzysztof Sobkowiak wrote:

Hi friends

I think, the hibernate-envers feature for Hibernate 3 should not exist
(or must be remastered). There is no
org.hibernate:hibernate-envers:jar:3.3.2.GA anywhere (in central repo
nor in JBoss repo).

karaf@root() feature:install hibernate-envers/3.3.2.GA
Error executing command: Error resolving artifact
org.hibernate:hibernate-envers:jar:3.3.2.GA: Could not find artifact
org.hibernate:hibernate-envers:jar:3.3.2.GA in defaultlocal
(file:/home/kso/.m2/repository/)

The first version of hibernate-envers is 3.5.0, but the original jars
from the line 3.x have no OSGi metadata. The line 4.x has been osgified.
So, we should create a bundle for envers 3.3.2.GA (if doesn't exist in
EBR yet) or remove the hibernate-envers feature for this version. I'm
going to open an JIRA issue for this problem

Regards
Krzysztof






--
Krzysztof Sobkowiak

JEE  OSS Architect | Technical Architect @ Capgemini
Capgemini http://www.pl.capgemini.com/ | Software Solutions Center 
http://www.pl.capgemini-sdm.com/ | Wroclaw
e-mail: krzys.sobkow...@gmail.com mailto:krzys.sobkow...@gmail.com | 
Twitter: @KSobkowiak


  1   2   >