Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Justin Leet
I just merged Raghu's PR into master, so we should be good to go. On Fri, Aug 11, 2017 at 12:53 PM, Justin Leet wrote: > I disagree with the hardcoded versions being bad, the obvious concern I > have being the repeatability of the build. > > I'd also like to note that we

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Justin Leet
I disagree with the hardcoded versions being bad, the obvious concern I have being the repeatability of the build. I'd also like to note that we release source as the Apache release artifacts, anything else we put out is convenience. Say we have a situation where we rely on library Foo version

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread RaghuMitra Kandikonda
I agree that we can have a separate discussion about moving to yarn. Hardcoding all the versions in package.json is a bad idea considering that JS world releases happen very frequently and it's easy to miss on a good feature. All the ASF projected that I know of have moved to yarn and not hard

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Nick Allen
Yes, I agree Justin. I think we need to have another (maybe separate?) discussion on changing the dependency tool set and discuss pros and cons. On Fri, Aug 11, 2017 at 10:45 AM Justin Leet wrote: > I'm honestly not very familiar with this stuff, but this seems more like

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Justin Leet
I'm honestly not very familiar with this stuff, but this seems more like a "how we use it issue", rather than an issue with the tech itself. Do we have a more compelling reason, or set of reasons, beyond just fixing to specific version of our dependencies? On Fri, Aug 11, 2017 at 10:37 AM, Nick

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Nick Allen
And I suggest that as a short-term (or medium-term) fix, separate from moving wholesale to another dependency mechanism. On Fri, Aug 11, 2017 at 10:36 AM Nick Allen wrote: > Would it make sense to just 'fix' at a specific version all NPM > dependencies, instead of allowing

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Casey Stella
I agree; we should have a long-term JIRA for moving to yarn (so confusing *sigh*) and a tactical JIRA + PR to fix the build. We should prioritize review of that tactical JIRA. Casey On Fri, Aug 11, 2017 at 10:19 AM, Otto Fowler wrote: > Can you create a jira for

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Otto Fowler
Can you create a jira for moving to yarn please. On August 11, 2017 at 10:17:40, Otto Fowler (ottobackwa...@gmail.com) wrote: Are there any other NPM modules where we are exposed to this risk? On August 11, 2017 at 10:11:22, RaghuMitra Kandikonda ( raghumitra@gmail.com) wrote: Ok,

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Otto Fowler
Are there any other NPM modules where we are exposed to this risk? On August 11, 2017 at 10:11:22, RaghuMitra Kandikonda ( raghumitra@gmail.com) wrote: Ok, Bootstrap made a release 10hrs ago and they removed few files that we were using hence the issue. We need to update package.json in

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Otto Fowler
Where are the bootstrap files? the @import ~bootstrap/….. looks like it is failing? On August 11, 2017 at 09:51:03, RaghuMitra Kandikonda ( raghumitra@gmail.com) wrote: I am running a clean install now, I will keep you posted. -Raghu Mitra On Fri, Aug 11, 2017 at 7:02 PM, Casey Stella

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread RaghuMitra Kandikonda
I am running a clean install now, I will keep you posted. -Raghu Mitra On Fri, Aug 11, 2017 at 7:02 PM, Casey Stella wrote: > Yes, I'm getting it locally too, here's more context: > > [INFO] ERROR in multi script-loader!./~/jquery/dist/jquery.js >

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Casey Stella
Yes, I'm getting it locally too, here's more context: [INFO] ERROR in multi script-loader!./~/jquery/dist/jquery.js script-loader!./~/tether/dist/js/tether.js script-loader!./~/ace-builds/src-noconflict/ace.js [INFO] Module not found: Error: Can't resolve

Re: Metron Alerts bombing in Travis?

2017-08-11 Thread Otto Fowler
Deleting my caches did NOT resolve the issue. On August 11, 2017 at 09:24:22, zeo...@gmail.com (zeo...@gmail.com) wrote: Master is failing with that right now. https://travis-ci.org/apache/metron#L2637 Jon On Fri, Aug 11, 2017 at 9:21 AM Otto Fowler wrote: > Has

Metron Alerts bombing in Travis?

2017-08-11 Thread Otto Fowler
Has anyone seen this error in travis? I am going to delete my caches and try again : [ERROR] npm ERR! Linux 4.4.0-83-generic [ERROR] npm ERR! argv "/home/travis/build/ottobackwards/metron/metron-interface/metron-alerts/node/node"