Re: [OSM-dev] Missing records from osmium-tool tags-filter

2019-11-21 Thread Jochen Topf
Hi! The Osmium version 1.11.1 released yesterday has the fix. Jochen On Tue, Nov 12, 2019 at 06:31:14PM +0100, Jochen Topf wrote: > Date: Tue, 12 Nov 2019 18:31:14 +0100 > From: Jochen Topf > To: Craig Kochis via dev > Subject: Re: [OSM-dev] Missing records from osmium-tool

Re: [OSM-dev] Missing records from osmium-tool tags-filter

2019-11-12 Thread Jochen Topf
ate: Tue, 12 Nov 2019 16:22:24 +0100 > From: Jochen Topf > To: Craig Kochis via dev > Subject: Re: [OSM-dev] Missing records from osmium-tool tags-filter > > Hi! > > When I try to run https://www.openstreetmap.org/way/24801630 through the > commands you provided, it

Re: [OSM-dev] Missing records from osmium-tool tags-filter

2019-11-12 Thread Michael Reichert
Hi Craig, Am 12.11.19 um 15:45 schrieb Craig Kochis via dev: > Then exporting to JSON > > osmium export poi.osm.pbf --output-format=geojsonseq --omit-rs > --add-unique-id=type_id -v -o poi.json > > And some records are being omitted that I would expect to be in the output. > For instance,

Re: [OSM-dev] Missing records from osmium-tool tags-filter

2019-11-12 Thread Jochen Topf
; To: dev@openstreetmap.org > Subject: [OSM-dev] Missing records from osmium-tool tags-filter > > First off, just want to say this tool has been amazing, it's blazing fast > for parsing through huge amounts of data. > > There's probably something I'm not understanding about ho

[OSM-dev] Missing records from osmium-tool tags-filter

2019-11-12 Thread Craig Kochis via dev
First off, just want to say this tool has been amazing, it's blazing fast for parsing through huge amounts of data. There's probably something I'm not understanding about how the tags-filter command is working, but there are some records missing from the output that I'd expect to be there based