[racket-dev] arity error with latest from git

2012-07-17 Thread David Van Horn
Hi, I'm getting an arity mismatch error whenever I run a saved file in DrRacket. Welcome to DrRacket, version 5.3.0.15--2012-07-17(3b5eb1da/d) [3m]. Language: racket [custom]; memory limit: 1024 MB. . . ../../racket/collects/drracket/private/module-language.rkt:373:8:

Re: [racket-dev] arity error with latest from git

2012-07-17 Thread Sam Tobin-Hochstadt
On Tue, Jul 17, 2012 at 5:14 PM, David Van Horn dvanh...@ccs.neu.edu wrote: I'm getting an arity mismatch error whenever I run a saved file in DrRacket. I get this identical error in DrRacket with the latest git HEAD. -- sam th sa...@ccs.neu.edu _ Racket Developers

Re: [racket-dev] arity error with latest from git

2012-07-17 Thread Matthew Flatt
I've pushed a correction related to a change today in the module name resolver (missed a direct call in DrRacket). At Tue, 17 Jul 2012 17:27:19 -0400, Sam Tobin-Hochstadt wrote: On Tue, Jul 17, 2012 at 5:14 PM, David Van Horn dvanh...@ccs.neu.edu wrote: I'm getting an arity mismatch error

Re: [racket-dev] arity error with latest from git

2012-07-17 Thread David Van Horn
On 7/17/12 5:33 PM, Matthew Flatt wrote: I've pushed a correction related to a change today in the module name resolver (missed a direct call in DrRacket). Thanks for the quick fix! I notice a small typo in the docs: A module name resolver takes one and four arguments: Should be two and