[Bug 63078] autodeploy in Tomcat 9.0.14 is not working anymore

2019-01-16 Thread bugzilla
https://bz.apache.org/bugzilla/show_bug.cgi?id=63078 --- Comment #11 from Peter --- If I copy a new war in the appBase directory,nothing happens. No message in the log file. The war does not get unpacked and started until I restart the tomcat. If I upload a new war-file with the Tomcat Manager

[GUMP@vmgump-vm3]: Project tomcat-tc7.0.x-test-apr (in module tomcat-7.0.x) failed

2019-01-16 Thread Bill Barker
To whom it may engage... This is an automated request, but not an unsolicited one. For more information please visit http://gump.apache.org/nagged.html, and/or contact the folk at gene...@gump.apache.org. Project tomcat-tc7.0.x-test-apr has an issue affecting its community

svn commit: r1851494 - in /tomcat/trunk: java/org/apache/catalina/connector/Connector.java java/org/apache/catalina/connector/LocalStrings.properties java/org/apache/catalina/core/AprLifecycleListener

2019-01-16 Thread csutherl
Author: csutherl Date: Thu Jan 17 02:25:03 2019 New Revision: 1851494 URL: http://svn.apache.org/viewvc?rev=1851494=rev Log: Log a message when using a Connector that requires Apr without enabling the AprLifecycleListener first Modified:

[GUMP@vmgump-vm3]: Project tomcat-trunk (in module tomcat-trunk) failed

2019-01-16 Thread Bill Barker
To whom it may engage... This is an automated request, but not an unsolicited one. For more information please visit http://gump.apache.org/nagged.html, and/or contact the folk at gene...@gump.apache.org. Project tomcat-trunk has an issue affecting its community integration. This issue

[Bug 63080] New: Support rfc7239 Forwarded header

2019-01-16 Thread bugzilla
https://bz.apache.org/bugzilla/show_bug.cgi?id=63080 Bug ID: 63080 Summary: Support rfc7239 Forwarded header Product: Tomcat 8 Version: 8.5.x-trunk Hardware: PC OS: Mac OS X 10.1 Status: NEW Severity:

svn commit: r1851463 - in /tomcat/tc8.5.x/trunk: ./ java/org/apache/coyote/http2/

2019-01-16 Thread markt
Author: markt Date: Wed Jan 16 15:59:46 2019 New Revision: 1851463 URL: http://svn.apache.org/viewvc?rev=1851463=rev Log: Refactor - simplification Modified: tomcat/tc8.5.x/trunk/ (props changed) tomcat/tc8.5.x/trunk/java/org/apache/coyote/http2/AbstractStream.java

svn commit: r1851461 - in /tomcat/trunk/java/org/apache/coyote/http2: AbstractStream.java Http2AsyncUpgradeHandler.java Http2UpgradeHandler.java Stream.java StreamStateMachine.java

2019-01-16 Thread markt
Author: markt Date: Wed Jan 16 15:55:46 2019 New Revision: 1851461 URL: http://svn.apache.org/viewvc?rev=1851461=rev Log: Refactor - simplification Modified: tomcat/trunk/java/org/apache/coyote/http2/AbstractStream.java

[Bug 63078] autodeploy in Tomcat 9.0.14 is not working anymore

2019-01-16 Thread bugzilla
https://bz.apache.org/bugzilla/show_bug.cgi?id=63078 --- Comment #10 from Remy Maucherat --- Except the use of startStopThreads="0" which uses parallel deployment, this looks like a default configuration. There is nothing which radically changes in the deployer with parallel deployment here.

Re: [Bug 51294] Since 7.0.12 do not work option unpackWARs=true for WARs outside appBase

2019-01-16 Thread Mark Thomas
On 16/01/2019 12:56, bugzi...@apache.org wrote: > https://bz.apache.org/bugzilla/show_bug.cgi?id=51294 > > --- Comment #30 from Caroline Webb --- > I read comments carefully that also referable about option unpackWARs=true for > WARs outside appBase since 7.0.12 do not work. Keep sharing and

[Bug 51294] Since 7.0.12 do not work option unpackWARs=true for WARs outside appBase

2019-01-16 Thread bugzilla
https://bz.apache.org/bugzilla/show_bug.cgi?id=51294 --- Comment #30 from Caroline Webb --- I read comments carefully that also referable about option unpackWARs=true for WARs outside appBase since 7.0.12 do not work. Keep sharing and providing solutions to users. Caroline,

[Bug 63078] autodeploy in Tomcat 9.0.14 is not working anymore

2019-01-16 Thread bugzilla
https://bz.apache.org/bugzilla/show_bug.cgi?id=63078 --- Comment #9 from Peter --- Hi, her is my server.xml file. Like mentioned before, I do use exactly the same with Tomcat 9.0.13 and 9.0.14. If I remove the attribute startStopThreads="0" from the host element, autodeployment is working on

[Bug 63078] autodeploy in Tomcat 9.0.14 is not working anymore

2019-01-16 Thread bugzilla
https://bz.apache.org/bugzilla/show_bug.cgi?id=63078 --- Comment #8 from Mark Thomas --- Just a thought. I can't reproduce it either. Neither did a code inspection suggest any potential configuration that would cause it. Peter - can you provide the server.xml file for the 9.0.14 install that

[Bug 63078] autodeploy in Tomcat 9.0.14 is not working anymore

2019-01-16 Thread bugzilla
https://bz.apache.org/bugzilla/show_bug.cgi?id=63078 --- Comment #7 from Remy Maucherat --- (In reply to Mark Thomas from comment #5) > Related to the server executor refactoring? That sounds like it, but I cannot reproduce the issue using the steps and configuration given. -- You are

[Bug 63078] autodeploy in Tomcat 9.0.14 is not working anymore

2019-01-16 Thread bugzilla
https://bz.apache.org/bugzilla/show_bug.cgi?id=63078 --- Comment #5 from Mark Thomas --- Related to the server executor refactoring? --- Comment #6 from Mark Thomas --- Related to the server executor refactoring? -- You are receiving this mail because: You are the assignee for the bug.

[Bug 63078] autodeploy in Tomcat 9.0.14 is not working anymore

2019-01-16 Thread bugzilla
https://bz.apache.org/bugzilla/show_bug.cgi?id=63078 --- Comment #5 from Mark Thomas --- Related to the server executor refactoring? -- You are receiving this mail because: You are the assignee for the bug. - To unsubscribe,