Re: Watch out for build issues on non-Unicode systems

2019-08-22 Thread Mike Hommey
On Thu, Aug 22, 2019 at 02:42:48PM +0200, Nihanth Subramanya wrote:
> Note that the config.status changes in bug 844509 seem to break `$./mach
> clobber` - I had to manually rm -rf my objdir.

Filed as bug 1575959, fixed on mozilla-central.

Sorry for the annoyance.

Mike

> On Thu, Aug 22, 2019 at 2:35 AM Mike Hommey  wrote:
> 
> > Hi,
> >
> > In bug 1575135 and bug 844509, we've changed how configure handles
> > strings from files and subprocesses, to normalize everything to Unicode.
> >
> > On systems where the system locale is based on UTF-8 (e.g. most Linux
> > or macOS), this shouldn't make a difference.
> >
> > On systems where the system locale is not based on UTF-8, this might
> > cause problems, so please watch out, especially on non-Latin Windows.
> >
> > I don't believe things would have regressed (things should be handled
> > more or less similarly to before). I can think of a few things that
> > could fail, but for that matter, those I have in mind would have failed
> > before too.
> >
> > However, it is possible that a few corner cases that are not covered by
> > automation lead to configure complaining about some key or values not
> > being unicode strings. If that happens, please file bugs with your
> > mozconfig and as much detail as possible.
> >
> > Cheers,
> >
> > Mike
> > ___
> > dev-platform mailing list
> > dev-platform@lists.mozilla.org
> > https://lists.mozilla.org/listinfo/dev-platform
> >
___
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform


Re: Watch out for build issues on non-Unicode systems

2019-08-22 Thread Jonathan Kew

On 22/08/2019 13:42, Nihanth Subramanya wrote:

Note that the config.status changes in bug 844509 seem to break `$./mach
clobber` - I had to manually rm -rf my objdir.



Ah, that'll be what just happened to me, too. (Not just ./mach clobber, 
I was getting the same failure with ./mach build as well.)


Unfortunately I was a bit slow to realize that manually rm'ing the 
objdir might help, so in the meantime I'd wasted time re-running ./mach 
bootstrap, checking if my python was current, etc. :\


JK


On Thu, Aug 22, 2019 at 2:35 AM Mike Hommey  wrote:


Hi,

In bug 1575135 and bug 844509, we've changed how configure handles
strings from files and subprocesses, to normalize everything to Unicode.

On systems where the system locale is based on UTF-8 (e.g. most Linux
or macOS), this shouldn't make a difference.

On systems where the system locale is not based on UTF-8, this might
cause problems, so please watch out, especially on non-Latin Windows.

I don't believe things would have regressed (things should be handled
more or less similarly to before). I can think of a few things that
could fail, but for that matter, those I have in mind would have failed
before too.

However, it is possible that a few corner cases that are not covered by
automation lead to configure complaining about some key or values not
being unicode strings. If that happens, please file bugs with your
mozconfig and as much detail as possible.

Cheers,

Mike
___
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform


___
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform
.



___
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform


Re: Watch out for build issues on non-Unicode systems

2019-08-22 Thread Nihanth Subramanya
To clarify: it only breaks the clobber of an existing old objdir.
Clobbering works fine henceforth.

On Thu, Aug 22, 2019 at 2:42 PM Nihanth Subramanya  wrote:

> Note that the config.status changes in bug 844509 seem to break `$./mach
> clobber` - I had to manually rm -rf my objdir.
>
> On Thu, Aug 22, 2019 at 2:35 AM Mike Hommey  wrote:
>
>> Hi,
>>
>> In bug 1575135 and bug 844509, we've changed how configure handles
>> strings from files and subprocesses, to normalize everything to Unicode.
>>
>> On systems where the system locale is based on UTF-8 (e.g. most Linux
>> or macOS), this shouldn't make a difference.
>>
>> On systems where the system locale is not based on UTF-8, this might
>> cause problems, so please watch out, especially on non-Latin Windows.
>>
>> I don't believe things would have regressed (things should be handled
>> more or less similarly to before). I can think of a few things that
>> could fail, but for that matter, those I have in mind would have failed
>> before too.
>>
>> However, it is possible that a few corner cases that are not covered by
>> automation lead to configure complaining about some key or values not
>> being unicode strings. If that happens, please file bugs with your
>> mozconfig and as much detail as possible.
>>
>> Cheers,
>>
>> Mike
>> ___
>> dev-platform mailing list
>> dev-platform@lists.mozilla.org
>> https://lists.mozilla.org/listinfo/dev-platform
>>
>
___
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform


Re: Watch out for build issues on non-Unicode systems

2019-08-22 Thread Nihanth Subramanya
Note that the config.status changes in bug 844509 seem to break `$./mach
clobber` - I had to manually rm -rf my objdir.

On Thu, Aug 22, 2019 at 2:35 AM Mike Hommey  wrote:

> Hi,
>
> In bug 1575135 and bug 844509, we've changed how configure handles
> strings from files and subprocesses, to normalize everything to Unicode.
>
> On systems where the system locale is based on UTF-8 (e.g. most Linux
> or macOS), this shouldn't make a difference.
>
> On systems where the system locale is not based on UTF-8, this might
> cause problems, so please watch out, especially on non-Latin Windows.
>
> I don't believe things would have regressed (things should be handled
> more or less similarly to before). I can think of a few things that
> could fail, but for that matter, those I have in mind would have failed
> before too.
>
> However, it is possible that a few corner cases that are not covered by
> automation lead to configure complaining about some key or values not
> being unicode strings. If that happens, please file bugs with your
> mozconfig and as much detail as possible.
>
> Cheers,
>
> Mike
> ___
> dev-platform mailing list
> dev-platform@lists.mozilla.org
> https://lists.mozilla.org/listinfo/dev-platform
>
___
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform