Re: ClientWindow compatibility - Rename post param to javax.faces.ClientWindow?

2014-01-21 Thread Gerhard Petracek
it's fine that you have a workaround there, however, we need to think about
the out-of-the-box compatibility with other component-libraries as well.

regards,
gerhard



2014/1/20 Thomas Andraschko andraschko.tho...@gmail.com

 I added a workaround in PrimeFaces -
 https://code.google.com/p/primefaces/issues/detail?id=6525


 2014/1/17 Thomas Andraschko andraschko.tho...@gmail.com

  Hi,
 
  currently our hidden input is called dsPostWindowId.
  This breaks the compatibility with PF partialSubmit feature -
  https://issues.apache.org/jira/browse/DELTASPIKE-446
 
  In PrimeFaces partialSubmit mode, we just collect all inputs which will
 be
  processed.
  If the form will NOT be processed, we manually collect
  javax.faces.ViewState and javax.faces.ClientWindow and add them as post
  params.
 
  If we would rename it to javax.faces.ClientWindow, DS would be compatible
  with partialSubmit and we would avoid duplicate hidden inputs if DS runs
 on
  JSF 2.2.
 
  Regards,
  Thomas
 
 
 
 
 



Re: ClientWindow compatibility - Rename post param to javax.faces.ClientWindow?

2014-01-21 Thread Thomas Andraschko
Does any other component lib has a similiar feature like PF partialSubmit?
I don't know :)



2014/1/21 Gerhard Petracek gerhard.petra...@gmail.com

 it's fine that you have a workaround there, however, we need to think about
 the out-of-the-box compatibility with other component-libraries as well.

 regards,
 gerhard



 2014/1/20 Thomas Andraschko andraschko.tho...@gmail.com

  I added a workaround in PrimeFaces -
  https://code.google.com/p/primefaces/issues/detail?id=6525
 
 
  2014/1/17 Thomas Andraschko andraschko.tho...@gmail.com
 
   Hi,
  
   currently our hidden input is called dsPostWindowId.
   This breaks the compatibility with PF partialSubmit feature -
   https://issues.apache.org/jira/browse/DELTASPIKE-446
  
   In PrimeFaces partialSubmit mode, we just collect all inputs which will
  be
   processed.
   If the form will NOT be processed, we manually collect
   javax.faces.ViewState and javax.faces.ClientWindow and add them as post
   params.
  
   If we would rename it to javax.faces.ClientWindow, DS would be
 compatible
   with partialSubmit and we would avoid duplicate hidden inputs if DS
 runs
  on
   JSF 2.2.
  
   Regards,
   Thomas
  
  
  
  
  
 



Re: ClientWindow compatibility - Rename post param to javax.faces.ClientWindow?

2014-01-21 Thread Gerhard Petracek
imo it's more a general question, because we can never know all of them
(esp. not the proprietary component-libraries).

regards,
gerhard



2014/1/21 Thomas Andraschko andraschko.tho...@gmail.com

 Does any other component lib has a similiar feature like PF partialSubmit?
 I don't know :)



 2014/1/21 Gerhard Petracek gerhard.petra...@gmail.com

  it's fine that you have a workaround there, however, we need to think
 about
  the out-of-the-box compatibility with other component-libraries as well.
 
  regards,
  gerhard
 
 
 
  2014/1/20 Thomas Andraschko andraschko.tho...@gmail.com
 
   I added a workaround in PrimeFaces -
   https://code.google.com/p/primefaces/issues/detail?id=6525
  
  
   2014/1/17 Thomas Andraschko andraschko.tho...@gmail.com
  
Hi,
   
currently our hidden input is called dsPostWindowId.
This breaks the compatibility with PF partialSubmit feature -
https://issues.apache.org/jira/browse/DELTASPIKE-446
   
In PrimeFaces partialSubmit mode, we just collect all inputs which
 will
   be
processed.
If the form will NOT be processed, we manually collect
javax.faces.ViewState and javax.faces.ClientWindow and add them as
 post
params.
   
If we would rename it to javax.faces.ClientWindow, DS would be
  compatible
with partialSubmit and we would avoid duplicate hidden inputs if DS
  runs
   on
JSF 2.2.
   
Regards,
Thomas
   
   
   
   
   
  
 



Re: ClientWindow compatibility - Rename post param to javax.faces.ClientWindow?

2014-01-21 Thread Mark Struberg
+1

And personally I think the PF partial submit simply contradicts the spec. Does 
it work with multiple forms in a page already? 

To be honest, MyFaces does some similar optimisation afaik. But because it is a 
JSF container, it can do it in a way to _not_ break the spec. We should rather 
try to get this into the JSF spec.

LieGrue,
strub





On Tuesday, 21 January 2014, 10:02, Gerhard Petracek 
gerhard.petra...@gmail.com wrote:
 
imo it's more a general question, because we can never know all of them
(esp. not the proprietary component-libraries).

regards,
gerhard




2014/1/21 Thomas Andraschko andraschko.tho...@gmail.com

 Does any other component lib has a similiar feature like PF partialSubmit?
 I don't know :)



 2014/1/21 Gerhard Petracek gerhard.petra...@gmail.com

  it's fine that you have a workaround there, however, we need to think
 about
  the out-of-the-box compatibility with other component-libraries as well.
 
  regards,
  gerhard
 
 
 
  2014/1/20 Thomas Andraschko andraschko.tho...@gmail.com
 
   I added a workaround in PrimeFaces -
   https://code.google.com/p/primefaces/issues/detail?id=6525
  
  
   2014/1/17 Thomas Andraschko andraschko.tho...@gmail.com
  
Hi,
   
currently our hidden input is called dsPostWindowId.
This breaks the compatibility with PF partialSubmit feature -
https://issues.apache.org/jira/browse/DELTASPIKE-446
   
In PrimeFaces partialSubmit mode, we just collect all inputs which
 will
   be
processed.
If the form will NOT be processed, we manually collect
javax.faces.ViewState and javax.faces.ClientWindow and add them as
 post
params.
   
If we would rename it to javax.faces.ClientWindow, DS would be
  compatible
with partialSubmit and we would avoid duplicate hidden inputs if DS
  runs
   on
JSF 2.2.
   
Regards,
Thomas
   
   
   
   
   
  
 





Re: ClientWindow compatibility - Rename post param to javax.faces.ClientWindow?

2014-01-20 Thread Thomas Andraschko
I added a workaround in PrimeFaces -
https://code.google.com/p/primefaces/issues/detail?id=6525


2014/1/17 Thomas Andraschko andraschko.tho...@gmail.com

 Hi,

 currently our hidden input is called dsPostWindowId.
 This breaks the compatibility with PF partialSubmit feature -
 https://issues.apache.org/jira/browse/DELTASPIKE-446

 In PrimeFaces partialSubmit mode, we just collect all inputs which will be
 processed.
 If the form will NOT be processed, we manually collect
 javax.faces.ViewState and javax.faces.ClientWindow and add them as post
 params.

 If we would rename it to javax.faces.ClientWindow, DS would be compatible
 with partialSubmit and we would avoid duplicate hidden inputs if DS runs on
 JSF 2.2.

 Regards,
 Thomas







ClientWindow compatibility - Rename post param to javax.faces.ClientWindow?

2014-01-17 Thread Thomas Andraschko
Hi,

currently our hidden input is called dsPostWindowId.
This breaks the compatibility with PF partialSubmit feature -
https://issues.apache.org/jira/browse/DELTASPIKE-446

In PrimeFaces partialSubmit mode, we just collect all inputs which will be
processed.
If the form will NOT be processed, we manually collect
javax.faces.ViewState and javax.faces.ClientWindow and add them as post
params.

If we would rename it to javax.faces.ClientWindow, DS would be compatible
with partialSubmit and we would avoid duplicate hidden inputs if DS runs on
JSF 2.2.

Regards,
Thomas