[jira] [Updated] (ISIS-156) Renaming getName() and other methods in metamodel

2019-01-06 Thread Dan Haywood (JIRA)


 [ 
https://issues.apache.org/jira/browse/ISIS-156?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Dan Haywood updated ISIS-156:
-
Fix Version/s: (was: 3.0.0)
   2.0.0

> Renaming getName() and other methods in metamodel
> -
>
> Key: ISIS-156
> URL: https://issues.apache.org/jira/browse/ISIS-156
> Project: Isis
>  Issue Type: Improvement
>  Components: Core
>Affects Versions: 0.1.2-incubating
>Reporter: Dan Haywood
>Priority: Trivial
> Fix For: 2.0.0
>
>
> from email exchange on mailing list:
> >
> > Just completing change for spec names.  To confirm that name == singular
> > name, what we have at the moment is:
> >
> >getFullName - fully qualified class name
> >getShortName - class name only
> >getName - singular name with spacing
> >getPluralName - the pluralised version with spacing
> >
> > It seems we have redundancy all along.
> >
> Yup, that's what we have.  Did mean to rename 'getName' to
> 'getSingularName', but I guess I forgot.  I'll go ahead and do that.
> > They are two types of name though which isn't obvious from the method
> > names. The first two are actually identifiers and won't change, whereas the
> > other two are dynamic and will change, especially on a localised client.
> > We might want to reflect this with getFullIdentifier and
> > getShortIdentifier.
> >;
> That's a good idea.  I'll make that change too.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Updated] (ISIS-156) Renaming getName() and other methods in metamodel

2013-01-03 Thread Dan Haywood (JIRA)

 [ 
https://issues.apache.org/jira/browse/ISIS-156?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Dan Haywood updated ISIS-156:
-

Fix Version/s: (was: isis-1.0.1)
   isis-2.0.0

 Renaming getName() and other methods in metamodel
 -

 Key: ISIS-156
 URL: https://issues.apache.org/jira/browse/ISIS-156
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: 0.1.2-incubating
Reporter: Dan Haywood
Assignee: Dan Haywood
Priority: Trivial
 Fix For: isis-2.0.0


 from email exchange on mailing list:
 
  Just completing change for spec names.  To confirm that name == singular
  name, what we have at the moment is:
 
 getFullName - fully qualified class name
 getShortName - class name only
 getName - singular name with spacing
 getPluralName - the pluralised version with spacing
 
  It seems we have redundancy all along.
 
 Yup, that's what we have.  Did mean to rename 'getName' to
 'getSingularName', but I guess I forgot.  I'll go ahead and do that.
  They are two types of name though which isn't obvious from the method
  names. The first two are actually identifiers and won't change, whereas the
  other two are dynamic and will change, especially on a localised client.
  We might want to reflect this with getFullIdentifier and
  getShortIdentifier.
 ;
 That's a good idea.  I'll make that change too.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira