[jira] [Commented] (ISIS-503) Refactor the way that members are ordered to allow contributee actions to be ordered within regular actions

2013-09-20 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/ISIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13773135#comment-13773135
 ] 

ASF subversion and git services commented on ISIS-503:
--

Commit 3fd5244e02cdeb125c5f1587cbfe2ab2d0d7 in branch refs/heads/master 
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=3fd5244 ]

ISIS-503: BookmarkService provides a contributed action and a contributed 
property


 Refactor the way that members are ordered to allow contributee actions to be 
 ordered within regular actions 
 

 Key: ISIS-503
 URL: https://issues.apache.org/jira/browse/ISIS-503
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: core-1.2.0
Reporter: Dan Haywood
Assignee: Dan Haywood
 Fix For: core-1.3.0


 Currently ordering is done on FacetedMethods, and contributee actions are 
 grafted onto the end.  Also complicating matters is the ObjectActionSet, 
 which groups contributee actions according to the service that contributed 
 them.
 First change is to remove ObjectActionSet, and have everything flattened.  
 Second change is to rework MemberLayoutArranger such that it acts upon 
 ObjectMembers rather than FacetedMethods.
 At same time, suggest retire the old actionOrder() supporting method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (ISIS-503) Refactor the way that members are ordered to allow contributee actions to be ordered within regular actions

2013-09-16 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/ISIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13768870#comment-13768870
 ] 

ASF subversion and git services commented on ISIS-503:
--

Commit d82f3d3c7655f9a825a070f0f9cd3aa5e189b2c3 in branch refs/heads/master 
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=d82f3d3 ]

ISIS-478,ISIS-503: various fixes.

ISIS_478, for conditional choices, for EntitySelect:
* clear link now should work
* if no choices/autocomplete then doesn't NPE (BankMandates#newBankMandate)
* removed ID_ENTITY_TITLE_NULL label, since never visible
* sets up a placeholder text
for conditional choices, for ValueSelect:
* correctly initializes second dropdown based

ISIS-503, for contributee actions/associations, calculate identifier
* was causing stack trace when go back to list, caused by call to 
getIdentifier() incorrectly returning the wrong value for a contributed 
association.


 Refactor the way that members are ordered to allow contributee actions to be 
 ordered within regular actions 
 

 Key: ISIS-503
 URL: https://issues.apache.org/jira/browse/ISIS-503
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: core-1.2.0
Reporter: Dan Haywood
Assignee: Dan Haywood
 Fix For: core-1.3.0


 Currently ordering is done on FacetedMethods, and contributee actions are 
 grafted onto the end.  Also complicating matters is the ObjectActionSet, 
 which groups contributee actions according to the service that contributed 
 them.
 First change is to remove ObjectActionSet, and have everything flattened.  
 Second change is to rework MemberLayoutArranger such that it acts upon 
 ObjectMembers rather than FacetedMethods.
 At same time, suggest retire the old actionOrder() supporting method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (ISIS-503) Refactor the way that members are ordered to allow contributee actions to be ordered within regular actions

2013-09-05 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/ISIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13758986#comment-13758986
 ] 

ASF subversion and git services commented on ISIS-503:
--

Commit c009dec571e84de2ea304807d43558ec08212111 in branch refs/heads/master 
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=c009dec ]

ISIS-503: can now order contributed members

* FacetProcessor extended to be able to request sorting on an individual object 
member
  * introduced new MemberOrderingFacetFactory interface to identify the facet 
factories that do this work
* ObjectSpecDefault/Abstract now call the FacetProcessor whenever the 
contributed actions/associations are computed
* ObjectActionContributee, OneToOneAssociationContributee and 
OneToManyAssociationContributee now have their own copy of FacetHolderImpl 
(initialized with the facets from the underlying contributed action), so that 
can sort them without side-effects
* fixed bug such that contributed actions that are associated to contributed 
associations are also suppressed from the header

Also:
* ObjectAction.isAlwaysHidden redefined, only true if never visible anywhere 
and always

And also:
* renamed ObjectAssociationFilters - ObjectAssociation.Filters
* renamed ObjectActionFilters - ObjectAction.Filters
* renamed ObjectActionParameterFilters - ObjectActionParameter.Filters

And also:
* enhanced ToDoItem to demonstrate this capability
* ToDoItemContributions#next and ToDoItemContributions#previous added


 Refactor the way that members are ordered to allow contributee actions to be 
 ordered within regular actions 
 

 Key: ISIS-503
 URL: https://issues.apache.org/jira/browse/ISIS-503
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: core-1.2.0
Reporter: Dan Haywood
Assignee: Dan Haywood
 Fix For: core-1.3.0


 Currently ordering is done on FacetedMethods, and contributee actions are 
 grafted onto the end.  Also complicating matters is the ObjectActionSet, 
 which groups contributee actions according to the service that contributed 
 them.
 First change is to remove ObjectActionSet, and have everything flattened.  
 Second change is to rework MemberLayoutArranger such that it acts upon 
 ObjectMembers rather than FacetedMethods.
 At same time, suggest retire the old actionOrder() supporting method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (ISIS-503) Refactor the way that members are ordered to allow contributee actions to be ordered within regular actions

2013-09-03 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/ISIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13756413#comment-13756413
 ] 

ASF subversion and git services commented on ISIS-503:
--

Commit c2c30052de0443342123bc2d4da92d9e37e14a82 in branch refs/heads/master 
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=c2c3005 ]

ISIS-503: more minor refactoring...

... splitting out the responsibility of converting FacetedMethods to OTOA, OTMA 
or ObjectActions vs traversing the DeweyOrderSet collection.


 Refactor the way that members are ordered to allow contributee actions to be 
 ordered within regular actions 
 

 Key: ISIS-503
 URL: https://issues.apache.org/jira/browse/ISIS-503
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: core-1.2.0
Reporter: Dan Haywood
Assignee: Dan Haywood
 Fix For: core-1.3.0


 Currently ordering is done on FacetedMethods, and contributee actions are 
 grafted onto the end.  Also complicating matters is the ObjectActionSet, 
 which groups contributee actions according to the service that contributed 
 them.
 First change is to remove ObjectActionSet, and have everything flattened.  
 Second change is to rework MemberLayoutArranger such that it acts upon 
 ObjectMembers rather than FacetedMethods.
 At same time, suggest retire the old actionOrder() supporting method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (ISIS-503) Refactor the way that members are ordered to allow contributee actions to be ordered within regular actions

2013-09-03 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/ISIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13756415#comment-13756415
 ] 

ASF subversion and git services commented on ISIS-503:
--

Commit 04662a6ff5fbb696309fe3201ca19c9845dc83f7 in branch refs/heads/master 
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=04662a6 ]

ISIS-503: removed MemberLayoutArranger completely

... inlined functionality within MemberLayoutArrangerUsingMemberOrderFacet into 
ObjectSpecificationDefault


 Refactor the way that members are ordered to allow contributee actions to be 
 ordered within regular actions 
 

 Key: ISIS-503
 URL: https://issues.apache.org/jira/browse/ISIS-503
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: core-1.2.0
Reporter: Dan Haywood
Assignee: Dan Haywood
 Fix For: core-1.3.0


 Currently ordering is done on FacetedMethods, and contributee actions are 
 grafted onto the end.  Also complicating matters is the ObjectActionSet, 
 which groups contributee actions according to the service that contributed 
 them.
 First change is to remove ObjectActionSet, and have everything flattened.  
 Second change is to rework MemberLayoutArranger such that it acts upon 
 ObjectMembers rather than FacetedMethods.
 At same time, suggest retire the old actionOrder() supporting method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (ISIS-503) Refactor the way that members are ordered to allow contributee actions to be ordered within regular actions

2013-09-03 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/ISIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13756412#comment-13756412
 ] 

ASF subversion and git services commented on ISIS-503:
--

Commit 5fa2c117b8c2e9d7ffc567acddc56a1eaf823066 in branch refs/heads/master 
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=5fa2c11 ]

ISIS-503: DeweyOrderSet now sorting on OTOA etc ...

... rather than on FacetedMethods.


 Refactor the way that members are ordered to allow contributee actions to be 
 ordered within regular actions 
 

 Key: ISIS-503
 URL: https://issues.apache.org/jira/browse/ISIS-503
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: core-1.2.0
Reporter: Dan Haywood
Assignee: Dan Haywood
 Fix For: core-1.3.0


 Currently ordering is done on FacetedMethods, and contributee actions are 
 grafted onto the end.  Also complicating matters is the ObjectActionSet, 
 which groups contributee actions according to the service that contributed 
 them.
 First change is to remove ObjectActionSet, and have everything flattened.  
 Second change is to rework MemberLayoutArranger such that it acts upon 
 ObjectMembers rather than FacetedMethods.
 At same time, suggest retire the old actionOrder() supporting method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (ISIS-503) Refactor the way that members are ordered to allow contributee actions to be ordered within regular actions

2013-09-03 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/ISIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13756411#comment-13756411
 ] 

ASF subversion and git services commented on ISIS-503:
--

Commit db82c67eb6911bc6f915bc0c4df8787ab2780c80 in branch refs/heads/master 
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=db82c67 ]

ISIS-503: more minor refactoring...

* extract/inline methods
* simplifying


 Refactor the way that members are ordered to allow contributee actions to be 
 ordered within regular actions 
 

 Key: ISIS-503
 URL: https://issues.apache.org/jira/browse/ISIS-503
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: core-1.2.0
Reporter: Dan Haywood
Assignee: Dan Haywood
 Fix For: core-1.3.0


 Currently ordering is done on FacetedMethods, and contributee actions are 
 grafted onto the end.  Also complicating matters is the ObjectActionSet, 
 which groups contributee actions according to the service that contributed 
 them.
 First change is to remove ObjectActionSet, and have everything flattened.  
 Second change is to rework MemberLayoutArranger such that it acts upon 
 ObjectMembers rather than FacetedMethods.
 At same time, suggest retire the old actionOrder() supporting method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (ISIS-503) Refactor the way that members are ordered to allow contributee actions to be ordered within regular actions

2013-09-03 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/ISIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13757347#comment-13757347
 ] 

ASF subversion and git services commented on ISIS-503:
--

Commit 02340bfa08d7e65363a039142c8b85cea4256ae7 in branch refs/heads/master 
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=02340bf ]

ISIS-503: refactoring ObjectSpecificationDefault for actions and associations

- simplifying the overloading
- deprecated ObjectActionFilters, converted to ObjectAction.Filters
- deprecated ObjectAssociationFilters, converted to ObjectAssociation.Filters


 Refactor the way that members are ordered to allow contributee actions to be 
 ordered within regular actions 
 

 Key: ISIS-503
 URL: https://issues.apache.org/jira/browse/ISIS-503
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: core-1.2.0
Reporter: Dan Haywood
Assignee: Dan Haywood
 Fix For: core-1.3.0


 Currently ordering is done on FacetedMethods, and contributee actions are 
 grafted onto the end.  Also complicating matters is the ObjectActionSet, 
 which groups contributee actions according to the service that contributed 
 them.
 First change is to remove ObjectActionSet, and have everything flattened.  
 Second change is to rework MemberLayoutArranger such that it acts upon 
 ObjectMembers rather than FacetedMethods.
 At same time, suggest retire the old actionOrder() supporting method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (ISIS-503) Refactor the way that members are ordered to allow contributee actions to be ordered within regular actions

2013-09-03 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/ISIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13757346#comment-13757346
 ] 

ASF subversion and git services commented on ISIS-503:
--

Commit 242739ad6af3670bb443abfa3deac2c5a5ed8d1b in branch refs/heads/master 
from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=242739a ]

ISIS-503: store contributee members along with regular members

- ie refactor how they are calculated

also:
- more refactorings of the overloads of getAssociations and getObjectActions
- rename properties to metadataProperties and convert to a field (in order 
to make available for sorting contributee actions later on when calculated and 
saved)
- rename layoutProperties(...) to metadataProperties(...)


 Refactor the way that members are ordered to allow contributee actions to be 
 ordered within regular actions 
 

 Key: ISIS-503
 URL: https://issues.apache.org/jira/browse/ISIS-503
 Project: Isis
  Issue Type: Improvement
  Components: Core
Affects Versions: core-1.2.0
Reporter: Dan Haywood
Assignee: Dan Haywood
 Fix For: core-1.3.0


 Currently ordering is done on FacetedMethods, and contributee actions are 
 grafted onto the end.  Also complicating matters is the ObjectActionSet, 
 which groups contributee actions according to the service that contributed 
 them.
 First change is to remove ObjectActionSet, and have everything flattened.  
 Second change is to rework MemberLayoutArranger such that it acts upon 
 ObjectMembers rather than FacetedMethods.
 At same time, suggest retire the old actionOrder() supporting method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira