[jira] [Commented] (LUCENE-8799) Add Force Commit Method to RandomIndexWriter

2019-05-15 Thread Atri Sharma (JIRA)


[ 
https://issues.apache.org/jira/browse/LUCENE-8799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16840674#comment-16840674
 ] 

Atri Sharma commented on LUCENE-8799:
-

[~jpountz] Hmm, good point. I think the elaborate steps RandomIndexWriter takes 
to flush concurrently is what causes a bit of confusion.

 

Would it make sense to add docs around the method, calling out what exactly 
happens when you pass in true/false, or would it be an overkill?

> Add Force Commit Method to RandomIndexWriter
> 
>
> Key: LUCENE-8799
> URL: https://issues.apache.org/jira/browse/LUCENE-8799
> Project: Lucene - Core
>  Issue Type: Improvement
>Reporter: Atri Sharma
>Priority: Minor
> Attachments: LUCENE-8799.patch
>
>
> A test convenience would be to add a force commit method in 
> RandomIndexWriter. This will allow writing tests where segment sizes can be 
> accurately controlled.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Commented] (LUCENE-8799) Add Force Commit Method to RandomIndexWriter

2019-05-15 Thread Adrien Grand (JIRA)


[ 
https://issues.apache.org/jira/browse/LUCENE-8799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16840620#comment-16840620
 ] 

Adrien Grand commented on LUCENE-8799:
--

[~atris] I don't have a checkout of the code locally so apologies if I'm 
missing something, but it looks like calling RandomIndexWriter.commit(false) 
today would call w.commit(), just like the new method you are proposing?

> Add Force Commit Method to RandomIndexWriter
> 
>
> Key: LUCENE-8799
> URL: https://issues.apache.org/jira/browse/LUCENE-8799
> Project: Lucene - Core
>  Issue Type: Improvement
>Reporter: Atri Sharma
>Priority: Minor
> Attachments: LUCENE-8799.patch
>
>
> A test convenience would be to add a force commit method in 
> RandomIndexWriter. This will allow writing tests where segment sizes can be 
> accurately controlled.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Commented] (LUCENE-8799) Add Force Commit Method to RandomIndexWriter

2019-05-15 Thread Atri Sharma (JIRA)


[ 
https://issues.apache.org/jira/browse/LUCENE-8799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16840171#comment-16840171
 ] 

Atri Sharma commented on LUCENE-8799:
-

[~dweiss] Yes, that is a good point. However, for the sake of clarity, we do 
maintain methods in RandomIndexWriter that are wrappers on top of the internal 
IndexWriter instance (forceMergeDeletes() for eg). The proposal in this Jira is 
on similar lines.

> Add Force Commit Method to RandomIndexWriter
> 
>
> Key: LUCENE-8799
> URL: https://issues.apache.org/jira/browse/LUCENE-8799
> Project: Lucene - Core
>  Issue Type: Improvement
>Reporter: Atri Sharma
>Priority: Minor
> Attachments: LUCENE-8799.patch
>
>
> A test convenience would be to add a force commit method in 
> RandomIndexWriter. This will allow writing tests where segment sizes can be 
> accurately controlled.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Commented] (LUCENE-8799) Add Force Commit Method to RandomIndexWriter

2019-05-15 Thread Dawid Weiss (JIRA)


[ 
https://issues.apache.org/jira/browse/LUCENE-8799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16840131#comment-16840131
 ] 

Dawid Weiss commented on LUCENE-8799:
-

Wouldn't it be better to just expose the writer from RandomIndexWriter so that 
you can do whatever you wish in your test? I'd rather shift this to the caller 
than explain why this method is oh-so-useful...

> Add Force Commit Method to RandomIndexWriter
> 
>
> Key: LUCENE-8799
> URL: https://issues.apache.org/jira/browse/LUCENE-8799
> Project: Lucene - Core
>  Issue Type: Improvement
>Reporter: Atri Sharma
>Priority: Minor
> Attachments: LUCENE-8799.patch
>
>
> A test convenience would be to add a force commit method in 
> RandomIndexWriter. This will allow writing tests where segment sizes can be 
> accurately controlled.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Commented] (LUCENE-8799) Add Force Commit Method to RandomIndexWriter

2019-05-14 Thread Atri Sharma (JIRA)


[ 
https://issues.apache.org/jira/browse/LUCENE-8799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16839994#comment-16839994
 ] 

Atri Sharma commented on LUCENE-8799:
-

[~jpountz] The primary difference is not flushing in memory segments to disk. 
The idea is to have a method which just fsyncs what is already flushed and 
allows IndexReaders to see the changes. This can be useful for controlling the 
visibility of segments in fine grained tests i.e. a test might want some 
specific data to be visible, but may have some other document in flight that 
should not yet surface in searches.

> Add Force Commit Method to RandomIndexWriter
> 
>
> Key: LUCENE-8799
> URL: https://issues.apache.org/jira/browse/LUCENE-8799
> Project: Lucene - Core
>  Issue Type: Improvement
>Reporter: Atri Sharma
>Priority: Minor
> Attachments: LUCENE-8799.patch
>
>
> A test convenience would be to add a force commit method in 
> RandomIndexWriter. This will allow writing tests where segment sizes can be 
> accurately controlled.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Commented] (LUCENE-8799) Add Force Commit Method to RandomIndexWriter

2019-05-14 Thread Adrien Grand (JIRA)


[ 
https://issues.apache.org/jira/browse/LUCENE-8799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16839913#comment-16839913
 ] 

Adrien Grand commented on LUCENE-8799:
--

What does it do differently than RandomIndexWriter#commit(false)?

> Add Force Commit Method to RandomIndexWriter
> 
>
> Key: LUCENE-8799
> URL: https://issues.apache.org/jira/browse/LUCENE-8799
> Project: Lucene - Core
>  Issue Type: Improvement
>Reporter: Atri Sharma
>Priority: Minor
> Attachments: LUCENE-8799.patch
>
>
> A test convenience would be to add a force commit method in 
> RandomIndexWriter. This will allow writing tests where segment sizes can be 
> accurately controlled.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Commented] (LUCENE-8799) Add Force Commit Method to RandomIndexWriter

2019-05-14 Thread Atri Sharma (JIRA)


[ 
https://issues.apache.org/jira/browse/LUCENE-8799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16839677#comment-16839677
 ] 

Atri Sharma commented on LUCENE-8799:
-

Attached is a patch adding the same

 

[^LUCENE-8799.patch]

> Add Force Commit Method to RandomIndexWriter
> 
>
> Key: LUCENE-8799
> URL: https://issues.apache.org/jira/browse/LUCENE-8799
> Project: Lucene - Core
>  Issue Type: Improvement
>Reporter: Atri Sharma
>Priority: Minor
>
> A test convenience would be to add a force commit method in 
> RandomIndexWriter. This will allow writing tests where segment sizes can be 
> accurately controlled.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org