Re: Reported OLE issue w/ RC2

2017-09-22 Thread Jörg Schmidt

> From: Patricia Shanahan [mailto:p...@acm.org] 
> Sent: Wednesday, September 20, 2017 1:51 PM
> To: dev@openoffice.apache.org
> Subject: Re: Reported OLE issue w/ RC2
> 
> That specific bug has already been tested. It is a symptom of the 
> unfortunate fact that what I don't know about the AOO source code can 
> hurt us, in the form of unexpected regressions.
> 
> The more different testing, the better. Linked files are the general 
> area that should be hit most, but any and all regression 
> testing is useful.

Yes, I understand that, but I'm just trying to help and you say it yourself: 
"The more different testing, the better."

I am aware that the current method of testing is not very systematic, but since 
we are suffering from a lack of programmers, I think it is right to help the 
few programmers in the best way possible. The latter means that I also find 
fast, orienting tests useful when helping programmers with their practical work.


greetings,
Jörg


-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



Re: Reported OLE issue w/ RC2

2017-09-22 Thread Jörg Schmidt
> From: Jim Jagielski [mailto:j...@jagunet.com] 
> Sent: Wednesday, September 20, 2017 12:54 PM
> To: OOo Apache
> Subject: Re: Reported OLE issue w/ RC2
> 
> https://lists.apache.org/thread.html/b7b4b86ca38d03eb5c72a4acc
> 80b399ec7e7cb0a739d72d40b3cb49c@%3Cdev.openoffice.apache.org%3E

OK, I've tested this bug and it doesn't occur to me anymore.

my system:
Windows 7 Professional (32 Bit)
AOO414m2(Build:9785)  -  Rev. 1804788 2017-09-18 17:56
(JRE-Version is 1.7.0_71)


greetings,
Jörg


-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



Re: Reported OLE issue w/ RC2

2017-09-20 Thread Matthias Seidel
I just installed AOO 4.1.4 pre-RC3 on my business notebook with Windows
7 64bit.
The bug is not reproducible for me...

(Tried it also in Windows 10 64bit and Windows 7 32bit)

Matthias


Am 20.09.2017 um 14:56 schrieb Pedro Lino:
> Under Windows 7 x64 the equation does display correctly but there is no way 
> to save the document without crashing.
>
> AOO crashes when inserting the equation in Writer but also when opening a 
> Math/Formula file and simply by typing an equation in Math. See detailed 
> instructions in
>
> https://bz.apache.org/ooo/show_bug.cgi?id=126180
>
> It is not a 4.1.4 specific bug. This is a regression in 4.1.x (at least since 
> 4.1.2).
> It worked correctly in 4.0.1
>
> -
> To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
> For additional commands, e-mail: dev-h...@openoffice.apache.org
>
>




smime.p7s
Description: S/MIME Cryptographic Signature


Re: Reported OLE issue w/ RC2

2017-09-20 Thread Pedro Lino
Under Windows 7 x64 the equation does display correctly but there is no way to 
save the document without crashing.

AOO crashes when inserting the equation in Writer but also when opening a 
Math/Formula file and simply by typing an equation in Math. See detailed 
instructions in

https://bz.apache.org/ooo/show_bug.cgi?id=126180

It is not a 4.1.4 specific bug. This is a regression in 4.1.x (at least since 
4.1.2).
It worked correctly in 4.0.1

-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



Re: Reported OLE issue w/ RC2

2017-09-20 Thread Patricia Shanahan
That specific bug has already been tested. It is a symptom of the 
unfortunate fact that what I don't know about the AOO source code can 
hurt us, in the form of unexpected regressions.


The more different testing, the better. Linked files are the general 
area that should be hit most, but any and all regression testing is useful.


On 9/20/2017 3:53 AM, Jim Jagielski wrote:

https://lists.apache.org/thread.html/b7b4b86ca38d03eb5c72a4acc80b399ec7e7cb0a739d72d40b3cb49c@%3Cdev.openoffice.apache.org%3E


On Sep 20, 2017, at 3:30 AM, Jörg Schmidt <joe...@j-m-schmidt.de> wrote:



From: Matthias Seidel [mailto:matthias.sei...@hamburg.de]
Sent: Tuesday, September 19, 2017 9:28 PM
To: dev@openoffice.apache.org
Subject: Re: Reported OLE issue w/ RC2

Hi Jim,

Could you provide DEBs as well?

Windows builds can now be found here:
https://home.apache.org/~mseidel/AOO-builds/AOO-414-pre-RC3/


Can you specify which OLE error should be tested? Link to the relevant issue?


Jörg


-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org




-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



Re: Reported OLE issue w/ RC2

2017-09-20 Thread Jörg Schmidt
 

> -Original Message-
> From: Jim Jagielski [mailto:j...@jagunet.com] 
> Sent: Wednesday, September 20, 2017 12:54 PM
> To: OOo Apache
> Subject: Re: Reported OLE issue w/ RC2
> 
> https://lists.apache.org/thread.html/b7b4b86ca38d03eb5c72a4acc
> 80b399ec7e7cb0a739d72d40b3cb49c@%3Cdev.openoffice.apache.org%3E

Thank you. I will test 414-pre-RC3 (Windows) until tomorrow and give feedback.


Jörg


-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



Re: Reported OLE issue w/ RC2

2017-09-20 Thread Jim Jagielski
https://lists.apache.org/thread.html/b7b4b86ca38d03eb5c72a4acc80b399ec7e7cb0a739d72d40b3cb49c@%3Cdev.openoffice.apache.org%3E

> On Sep 20, 2017, at 3:30 AM, Jörg Schmidt <joe...@j-m-schmidt.de> wrote:
> 
> 
>> From: Matthias Seidel [mailto:matthias.sei...@hamburg.de] 
>> Sent: Tuesday, September 19, 2017 9:28 PM
>> To: dev@openoffice.apache.org
>> Subject: Re: Reported OLE issue w/ RC2
>> 
>> Hi Jim,
>> 
>> Could you provide DEBs as well?
>> 
>> Windows builds can now be found here:
>> https://home.apache.org/~mseidel/AOO-builds/AOO-414-pre-RC3/
> 
> Can you specify which OLE error should be tested? Link to the relevant issue?
> 
> 
> Jörg
> 
> 
> -
> To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
> For additional commands, e-mail: dev-h...@openoffice.apache.org
> 


-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



Re: Reported OLE issue w/ RC2

2017-09-20 Thread Jörg Schmidt

> From: Matthias Seidel [mailto:matthias.sei...@hamburg.de] 
> Sent: Tuesday, September 19, 2017 9:28 PM
> To: dev@openoffice.apache.org
> Subject: Re: Reported OLE issue w/ RC2
> 
> Hi Jim,
> 
> Could you provide DEBs as well?
> 
> Windows builds can now be found here:
> https://home.apache.org/~mseidel/AOO-builds/AOO-414-pre-RC3/

Can you specify which OLE error should be tested? Link to the relevant issue?


Jörg


-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



Re: Reported OLE issue w/ RC2

2017-09-19 Thread Pedro Lino

Hi Jim, all

On 19/09/2017 11:49, Jim Jagielski wrote:

There have been reports of some OLE issues w/ RC2. If you have
been affected my it, could you try out the below:

 http://home.apache.org/~jim/AOO-builds/pre-RC3/

I'd like to push a RC3 out asap.


Can you point to the issue / bug report so that RC3 can be checked?

Thanks!
Pedro

-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



Re: Reported OLE issue w/ RC2

2017-09-19 Thread Jim Jagielski

> On Sep 19, 2017, at 3:27 PM, Matthias Seidel  
> wrote:
> 
> Hi Jim,
> 
> Could you provide DEBs as well?

All done. As with the macOS dmgs and Linux rpms, located at:

http://home.apache.org/~jim/AOO-builds/pre-RC3/

> 
> Windows builds can now be found here:
> https://home.apache.org/~mseidel/AOO-builds/AOO-414-pre-RC3/
> 
> Regards, Matthias
> 
> 
> Am 19.09.2017 um 12:49 schrieb Jim Jagielski:
>> There have been reports of some OLE issues w/ RC2. If you have
>> been affected my it, could you try out the below:
>> 
>>http://home.apache.org/~jim/AOO-builds/pre-RC3/
>> 
>> I'd like to push a RC3 out asap.
>> 
>> -
>> To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
>> For additional commands, e-mail: dev-h...@openoffice.apache.org
>> 
> 
> 


-
To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
For additional commands, e-mail: dev-h...@openoffice.apache.org



Re: Reported OLE issue w/ RC2

2017-09-19 Thread Matthias Seidel
Hi Jim,

Could you provide DEBs as well?

Windows builds can now be found here:
https://home.apache.org/~mseidel/AOO-builds/AOO-414-pre-RC3/

Regards, Matthias


Am 19.09.2017 um 12:49 schrieb Jim Jagielski:
> There have been reports of some OLE issues w/ RC2. If you have
> been affected my it, could you try out the below:
>
> http://home.apache.org/~jim/AOO-builds/pre-RC3/
>
> I'd like to push a RC3 out asap.
>
> -
> To unsubscribe, e-mail: dev-unsubscr...@openoffice.apache.org
> For additional commands, e-mail: dev-h...@openoffice.apache.org
>




smime.p7s
Description: S/MIME Cryptographic Signature