Re: [OSM-dev] PostgreSQL 11 - osm2pgsql performance problems during --append?

2019-09-13 Thread Sarah Hoffmann
Hi, On Fri, Sep 13, 2019 at 01:07:39PM +0200, Michael Kussmaul wrote: > local network: constant 17.8Mb in and 17.8Mb out. It looks like those are > postgres UDP packets sent/received (according to lsof), googling it seems > those are from the stats collector. Perhaps this is my problem - I will

Re: [OSM-dev] PostgreSQL 11 - osm2pgsql performance problems during --append?

2019-09-13 Thread Sven Geggus
Michael Kussmaul wrote: > - Or PostgreSQL 11 has some regressions? Unlikely. I'm using PostgreSQL 11 + Debian 10 on my new tile.openstreetmap.de machines without problems. Sven -- If we want hardware to work to its full potential, we need to claim to be a recent version of Windows. (Matthew

Re: [OSM-dev] PostgreSQL 11 - osm2pgsql performance problems during --append?

2019-09-13 Thread Michael Kussmaul
> Sounds similar to this issue. How is your RAM usage? Perhaps the new -C0 flag > will help, I dunno. > https://github.com/openstreetmap/osm2pgsql/issues/946 > j I had memory problems first after upgrading to PostgreSQL 11, but I disabled JIT on PostgreSQL 11 and then it worked fine again - not

Re: [OSM-dev] PostgreSQL 11 - osm2pgsql performance problems during --append?

2019-09-12 Thread Frederik Ramm
Hi, if you are using the flatnodes option (which you should for a world-wide import) then the node import step will mainly hit the flatnodes file and only have relatively limited PostgreSQL interaction. It therefore sounds unlikely that the PostgreSQL upgrade could be at fault. Bye Frederik --

Re: [OSM-dev] PostgreSQL 11 - osm2pgsql performance problems during --append?

2019-09-12 Thread j
Sounds similar to this issue. How is your RAM usage? Perhaps the new -C0 flag will help, I dunno. https://github.com/openstreetmap/osm2pgsql/issues/946 j On Thu, 12 Sep 2019 17:59:06 +0200 Michael Kussmaul wrote: > Hi > > I'm running my osm2pgsql setup for a couple of years now by >