[jira] [Commented] (DISPATCH-1667) Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2

2020-05-26 Thread ASF GitHub Bot (Jira)


[ 
https://issues.apache.org/jira/browse/DISPATCH-1667?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17117336#comment-17117336
 ] 

ASF GitHub Bot commented on DISPATCH-1667:
--

asfgit closed pull request #742:
URL: https://github.com/apache/qpid-dispatch/pull/742


   



This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


> Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2
> ---
>
> Key: DISPATCH-1667
> URL: https://issues.apache.org/jira/browse/DISPATCH-1667
> Project: Qpid Dispatch
>  Issue Type: Improvement
>  Components: Container
>Affects Versions: 1.12.0
>Reporter: Ganesh Murthy
>Assignee: Ganesh Murthy
>Priority: Major
> Fix For: 1.13.0
>
>
> LibWebSockets v2.1.0 was released on 2016-10-06 and is quite old. Move to a 
> more recent version 2.4.2 which was released on 2018-03-07.
> 2.4.2 is a stable version and contains features like allowing deleting http 
> listener ports on demand.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org



[jira] [Commented] (DISPATCH-1667) Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2

2020-05-26 Thread ASF GitHub Bot (Jira)


[ 
https://issues.apache.org/jira/browse/DISPATCH-1667?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17117271#comment-17117271
 ] 

ASF GitHub Bot commented on DISPATCH-1667:
--

ganeshmurthy commented on pull request #742:
URL: https://github.com/apache/qpid-dispatch/pull/742#issuecomment-634018029


   LibWebSockets 2.4.2 is known to be a stable version.
   
   Here is a list of default LWS versions in the following OSes -
   
   CentOS 6
   No LibWebSockets
   
   RHEL 6
   LibWebSockets: 2.1.0 (LWS 2.4.2 is available to upgrade)
   
   CentOS 7
   LibWebSockets: 3.0.1
   
   RHEL 7
   LibWebSockets: 2.1.0 (LWS 2.4.2 is available to upgrade)
   
   CentOS 8
   LibWebSockets: 3.0.1
   
   Ubuntu:Xenial
   LibWebSockets: 1.7.0
   
   Ubuntu:Bionic
   LibWebSockets 2.0.3
   
   Ubuntu:latest
   LibWebSockets 3.2.0
   

   
   Since RHEL 6 and RHEL 7 can upgrade to LWS 2.4.2, I proposed increasing the 
least LWS version to 2.4.2.



This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


> Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2
> ---
>
> Key: DISPATCH-1667
> URL: https://issues.apache.org/jira/browse/DISPATCH-1667
> Project: Qpid Dispatch
>  Issue Type: Improvement
>  Components: Container
>Affects Versions: 1.12.0
>Reporter: Ganesh Murthy
>Assignee: Ganesh Murthy
>Priority: Major
> Fix For: 1.13.0
>
>
> LibWebSockets v2.1.0 was released on 2016-10-06 and is quite old. Move to a 
> more recent version 2.4.2 which was released on 2018-03-07.
> 2.4.2 is a stable version and contains features like allowing deleting http 
> listener ports on demand.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org



[jira] [Commented] (DISPATCH-1667) Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2

2020-05-26 Thread ASF subversion and git services (Jira)


[ 
https://issues.apache.org/jira/browse/DISPATCH-1667?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17116923#comment-17116923
 ] 

ASF subversion and git services commented on DISPATCH-1667:
---

Commit 13edd8d9c7923e75bf8bb03c060af5c9130cca20 in qpid-dispatch's branch 
refs/heads/master from Ganesh Murthy
[ https://gitbox.apache.org/repos/asf?p=qpid-dispatch.git;h=13edd8d ]

DISPATCH-1667 - Make 2.4.2 as the minimum required version of LibWebSockets. 
This closes #742.


> Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2
> ---
>
> Key: DISPATCH-1667
> URL: https://issues.apache.org/jira/browse/DISPATCH-1667
> Project: Qpid Dispatch
>  Issue Type: Improvement
>  Components: Container
>Affects Versions: 1.12.0
>Reporter: Ganesh Murthy
>Assignee: Ganesh Murthy
>Priority: Major
>
> LibWebSockets v2.1.0 was released on 2016-10-06 and is quite old. Move to a 
> more recent version 2.4.2 which was released on 2018-03-07.
> 2.4.2 is a stable version and contains features like allowing deleting http 
> listener ports on demand.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org



[jira] [Commented] (DISPATCH-1667) Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2

2020-05-22 Thread ASF GitHub Bot (Jira)


[ 
https://issues.apache.org/jira/browse/DISPATCH-1667?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17114240#comment-17114240
 ] 

ASF GitHub Bot commented on DISPATCH-1667:
--

ganeshmurthy opened a new pull request #742:
URL: https://github.com/apache/qpid-dispatch/pull/742


   …ockets



This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


> Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2
> ---
>
> Key: DISPATCH-1667
> URL: https://issues.apache.org/jira/browse/DISPATCH-1667
> Project: Qpid Dispatch
>  Issue Type: Improvement
>  Components: Container
>Affects Versions: 1.12.0
>Reporter: Ganesh Murthy
>Assignee: Ganesh Murthy
>Priority: Major
>
> LibWebSockets v2.1.0 was released on 2016-10-06 and is quite old. Move to a 
> more recent version 2.4.2 which was released on 2018-03-07.
> 2.4.2 is a stable version and contains features like allowing deleting http 
> listener ports on demand.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org



[jira] [Commented] (DISPATCH-1667) Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2

2020-05-22 Thread Ganesh Murthy (Jira)


[ 
https://issues.apache.org/jira/browse/DISPATCH-1667?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17114225#comment-17114225
 ] 

Ganesh Murthy commented on DISPATCH-1667:
-

Always appreciate the prodding and yes, this Jira is a placeholder which we 
will use to increase the min version of LWS to 2.4.2 and yes DISPATCH-1646 
effectively raised it to 2.3.0. I think we should link the JIRAs. I will do 
that. Thanks.

> Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2
> ---
>
> Key: DISPATCH-1667
> URL: https://issues.apache.org/jira/browse/DISPATCH-1667
> Project: Qpid Dispatch
>  Issue Type: Improvement
>  Components: Container
>Affects Versions: 1.12.0
>Reporter: Ganesh Murthy
>Assignee: Ganesh Murthy
>Priority: Major
>
> LibWebSockets v2.1.0 was released on 2016-10-06 and is quite old. Move to a 
> more recent version 2.4.2 which was released on 2018-03-07.
> 2.4.2 is a stable version and contains features like allowing deleting http 
> listener ports on demand.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org



[jira] [Commented] (DISPATCH-1667) Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2

2020-05-22 Thread Robbie Gemmell (Jira)


[ 
https://issues.apache.org/jira/browse/DISPATCH-1667?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17114193#comment-17114193
 ] 

Robbie Gemmell commented on DISPATCH-1667:
--

{quote}
The fix for DISPATCH-1646 requires at least LibWebSockets 2.3.0.
{quote}
Ok. Mainly I was prodding if maybe the JIRAs should be linked, given it sounds 
like DISPATCH-1646 effectively already raised the minimum to 2.3.0 but without 
actually enforcing it as this presumably will.

> Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2
> ---
>
> Key: DISPATCH-1667
> URL: https://issues.apache.org/jira/browse/DISPATCH-1667
> Project: Qpid Dispatch
>  Issue Type: Improvement
>  Components: Container
>Affects Versions: 1.12.0
>Reporter: Ganesh Murthy
>Assignee: Ganesh Murthy
>Priority: Major
>
> LibWebSockets v2.1.0 was released on 2016-10-06 and is quite old. Move to a 
> more recent version 2.4.2 which was released on 2018-03-07.
> 2.4.2 is a stable version and contains features like allowing deleting http 
> listener ports on demand.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org



[jira] [Commented] (DISPATCH-1667) Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2

2020-05-22 Thread Ganesh Murthy (Jira)


[ 
https://issues.apache.org/jira/browse/DISPATCH-1667?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17114151#comment-17114151
 ] 

Ganesh Murthy commented on DISPATCH-1667:
-

The fix for DISPATCH-1646 requires at least LibWebSockets 2.3.0.

LibWebSockets 2.4.2 is known to be a stable version.

Here is a list of default LWS versions in the following OSes -

CentOS 6
No LibWebSockets

RHEL 6
LibWebSockets: 2.1.0 (LWS 2.4.2 is available to upgrade)

CentOS 7
LibWebSockets: 3.0.1

RHEL 7
LibWebSockets: 2.1.0 (LWS 2.4.2 is available to upgrade)

CentOS 8
LibWebSockets: 3.0.1

Ubuntu:Xenial
LibWebSockets: 1.7.0

Ubuntu:Bionic
LibWebSockets 2.0.3

Ubuntu:latest
LibWebSockets 3.2.0

 

Since RHEL 6 and RHEL 7 can upgrade to LWS 2.4.2, I proposed increasing the 
least LWS version to 2.4.2.

> Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2
> ---
>
> Key: DISPATCH-1667
> URL: https://issues.apache.org/jira/browse/DISPATCH-1667
> Project: Qpid Dispatch
>  Issue Type: Improvement
>  Components: Container
>Affects Versions: 1.12.0
>Reporter: Ganesh Murthy
>Assignee: Ganesh Murthy
>Priority: Major
>
> LibWebSockets v2.1.0 was released on 2016-10-06 and is quite old. Move to a 
> more recent version 2.4.2 which was released on 2018-03-07.
> 2.4.2 is a stable version and contains features like allowing deleting http 
> listener ports on demand.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org



[jira] [Commented] (DISPATCH-1667) Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2

2020-05-22 Thread Robbie Gemmell (Jira)


[ 
https://issues.apache.org/jira/browse/DISPATCH-1667?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17114063#comment-17114063
 ] 

Robbie Gemmell commented on DISPATCH-1667:
--

So this blocks or is required by DISPATCH-1646?

> Increase minimum required LibWebSockets version from 2.1.0 to 2.4.2
> ---
>
> Key: DISPATCH-1667
> URL: https://issues.apache.org/jira/browse/DISPATCH-1667
> Project: Qpid Dispatch
>  Issue Type: Improvement
>  Components: Container
>Affects Versions: 1.12.0
>Reporter: Ganesh Murthy
>Assignee: Ganesh Murthy
>Priority: Major
>
> LibWebSockets v2.1.0 was released on 2016-10-06 and is quite old. Move to a 
> more recent version 2.4.2 which was released on 2018-03-07.
> 2.4.2 is a stable version and contains features like allowing deleting http 
> listener ports on demand.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org