Re: [racket-dev] racket-5.2.900.1-20120725 read ill-formed code error ?

2012-07-28 Thread Neil Van Dyke

Matthew Flatt wrote at 07/26/2012 06:36 PM:

I've pushed a repair. Thanks for the report!


Thanks, Matthew.  Today, I plan to run a large pile of code through the 
20120727 pre-release.


Neil V.

_
 Racket Developers list:
 http://lists.racket-lang.org/dev


Re: [racket-dev] racket-5.2.900.1-20120725 read ill-formed code error ?

2012-07-26 Thread Neil Van Dyke

Definitely looks like a Racket bug (or really broken hardware/OS)...

If I start DrRacket 5.2.900.1-20120725 and load up the below file, the 
first few clicks on the Run button give the ill-formed code error, and 
then, after trying the Run button for 10+ seconds, suddenly Run starts 
working.


#lang racket/base
(require (planet neil/html-template:1:=1))
(html-template (hr (@ (clear all) (id foo

If I quit DrRacket and start it back up, the problem is reproducible.

Problem with background optimizing of some kind?

That's all I can spend on this right now; hopefully other people can 
reproduce based on this info.


Neil V.

Neil Van Dyke wrote at 07/26/2012 05:18 PM:

Anyone know offhand why this error with 5.3 pre-release from yesterday?

UNKNOWN: : read (compiled): ill-formed code [./../src/validate.c:1573]
  context...:
   
/usr/local/racket-5.2.900.1-20120725/lib/racket/collects/racket/private/map.rkt:53:19: 
loop
   
/home/user/.racket/planet/300/5.2.900.1/cache/neil/html-template.plt/1/1/html-template.rkt:103:0: 
%html-template:transform
   
/home/user/.racket/planet/300/5.2.900.1/cache/neil/html-template.plt/1/1/html-template.rkt:523:0 



I built Racket from source.  32-bit x86 on Debian Stable.  I don't 
think there are any old versions of code in compiled directories 
being picked up, but I might have missed some, but I'd expect get an 
error message about the version mismatch.  PLaneT html-template:1:1 
is currently a bit messy with syntax objects and phases, and might be 
doing something questionable that 5.2.1 permitted.  This works fine 
with Racket 5.2.1.


Unfortunately, I don't have time to debug at this moment.  I'm posting 
now because I understand that a release is close, and I don't know how 
likely it is that this is a Racket bug.


Neil V.


_
 Racket Developers list:
 http://lists.racket-lang.org/dev


Re: [racket-dev] racket-5.2.900.1-20120725 read ill-formed code error ?

2012-07-26 Thread Neil Van Dyke

This version :2:0 is a better test case than :1:1 :

#lang racket/base
(require (planet neil/html-template:2:=0))
(html-template (hr (@ (clear all) (id foo


Neil Van Dyke wrote at 07/26/2012 05:33 PM:

Definitely looks like a Racket bug (or really broken hardware/OS)...

If I start DrRacket 5.2.900.1-20120725 and load up the below file, the 
first few clicks on the Run button give the ill-formed code error, 
and then, after trying the Run button for 10+ seconds, suddenly Run 
starts working.


#lang racket/base
(require (planet neil/html-template:1:=1))
(html-template (hr (@ (clear all) (id foo

If I quit DrRacket and start it back up, the problem is reproducible.

Problem with background optimizing of some kind?

That's all I can spend on this right now; hopefully other people can 
reproduce based on this info.


Neil V.

Neil Van Dyke wrote at 07/26/2012 05:18 PM:

Anyone know offhand why this error with 5.3 pre-release from yesterday?

UNKNOWN: : read (compiled): ill-formed code [./../src/validate.c:1573]
  context...:
   
/usr/local/racket-5.2.900.1-20120725/lib/racket/collects/racket/private/map.rkt:53:19: 
loop
   
/home/user/.racket/planet/300/5.2.900.1/cache/neil/html-template.plt/1/1/html-template.rkt:103:0: 
%html-template:transform
   
/home/user/.racket/planet/300/5.2.900.1/cache/neil/html-template.plt/1/1/html-template.rkt:523:0 



I built Racket from source.  32-bit x86 on Debian Stable.  I don't 
think there are any old versions of code in compiled directories 
being picked up, but I might have missed some, but I'd expect get an 
error message about the version mismatch.  PLaneT html-template:1:1 
is currently a bit messy with syntax objects and phases, and might be 
doing something questionable that 5.2.1 permitted.  This works fine 
with Racket 5.2.1.


Unfortunately, I don't have time to debug at this moment.  I'm 
posting now because I understand that a release is close, and I don't 
know how likely it is that this is a Racket bug.


Neil V.


_
 Racket Developers list:
 http://lists.racket-lang.org/dev


_
 Racket Developers list:
 http://lists.racket-lang.org/dev


Re: [racket-dev] racket-5.2.900.1-20120725 read ill-formed code error ?

2012-07-26 Thread Matthew Flatt
I'm able to replicate the error, and I'm investigating.

At Thu, 26 Jul 2012 17:42:09 -0400, Neil Van Dyke wrote:
 This version :2:0 is a better test case than :1:1 :
 
 #lang racket/base
 (require (planet neil/html-template:2:=0))
 (html-template (hr (@ (clear all) (id foo
 
 
 Neil Van Dyke wrote at 07/26/2012 05:33 PM:
  Definitely looks like a Racket bug (or really broken hardware/OS)...
 
  If I start DrRacket 5.2.900.1-20120725 and load up the below file, the 
  first few clicks on the Run button give the ill-formed code error, 
  and then, after trying the Run button for 10+ seconds, suddenly Run 
  starts working.
 
  #lang racket/base
  (require (planet neil/html-template:1:=1))
  (html-template (hr (@ (clear all) (id foo
 
  If I quit DrRacket and start it back up, the problem is reproducible.
 
  Problem with background optimizing of some kind?
 
  That's all I can spend on this right now; hopefully other people can 
  reproduce based on this info.
 
  Neil V.
 
  Neil Van Dyke wrote at 07/26/2012 05:18 PM:
  Anyone know offhand why this error with 5.3 pre-release from yesterday?
 
  UNKNOWN: : read (compiled): ill-formed code [./../src/validate.c:1573]
context...:
 
  
 /usr/local/racket-5.2.900.1-20120725/lib/racket/collects/racket/private/map.rkt:
 53:19: 
  loop
 
  
 /home/user/.racket/planet/300/5.2.900.1/cache/neil/html-template.plt/1/1/html-te
 mplate.rkt:103:0: 
  %html-template:transform
 
  
 /home/user/.racket/planet/300/5.2.900.1/cache/neil/html-template.plt/1/1/html-te
 mplate.rkt:523:0 
 
 
  I built Racket from source.  32-bit x86 on Debian Stable.  I don't 
  think there are any old versions of code in compiled directories 
  being picked up, but I might have missed some, but I'd expect get an 
  error message about the version mismatch.  PLaneT html-template:1:1 
  is currently a bit messy with syntax objects and phases, and might be 
  doing something questionable that 5.2.1 permitted.  This works fine 
  with Racket 5.2.1.
 
  Unfortunately, I don't have time to debug at this moment.  I'm 
  posting now because I understand that a release is close, and I don't 
  know how likely it is that this is a Racket bug.
 
  Neil V.
 
  _
   Racket Developers list:
   http://lists.racket-lang.org/dev
 
 _
   Racket Developers list:
   http://lists.racket-lang.org/dev
_
  Racket Developers list:
  http://lists.racket-lang.org/dev


Re: [racket-dev] racket-5.2.900.1-20120725 read ill-formed code error ?

2012-07-26 Thread Matthew Flatt
I've pushed a repair. Thanks for the report!

At Thu, 26 Jul 2012 17:42:09 -0400, Neil Van Dyke wrote:
 This version :2:0 is a better test case than :1:1 :
 
 #lang racket/base
 (require (planet neil/html-template:2:=0))
 (html-template (hr (@ (clear all) (id foo
 
 
 Neil Van Dyke wrote at 07/26/2012 05:33 PM:
  Definitely looks like a Racket bug (or really broken hardware/OS)...
 
  If I start DrRacket 5.2.900.1-20120725 and load up the below file, the 
  first few clicks on the Run button give the ill-formed code error, 
  and then, after trying the Run button for 10+ seconds, suddenly Run 
  starts working.
 
  #lang racket/base
  (require (planet neil/html-template:1:=1))
  (html-template (hr (@ (clear all) (id foo
 
  If I quit DrRacket and start it back up, the problem is reproducible.
 
  Problem with background optimizing of some kind?
 
  That's all I can spend on this right now; hopefully other people can 
  reproduce based on this info.
 
  Neil V.
 
  Neil Van Dyke wrote at 07/26/2012 05:18 PM:
  Anyone know offhand why this error with 5.3 pre-release from yesterday?
 
  UNKNOWN: : read (compiled): ill-formed code [./../src/validate.c:1573]
context...:
 
  
 /usr/local/racket-5.2.900.1-20120725/lib/racket/collects/racket/private/map.rkt:
 53:19: 
  loop
 
  
 /home/user/.racket/planet/300/5.2.900.1/cache/neil/html-template.plt/1/1/html-te
 mplate.rkt:103:0: 
  %html-template:transform
 
  
 /home/user/.racket/planet/300/5.2.900.1/cache/neil/html-template.plt/1/1/html-te
 mplate.rkt:523:0 
 
 
  I built Racket from source.  32-bit x86 on Debian Stable.  I don't 
  think there are any old versions of code in compiled directories 
  being picked up, but I might have missed some, but I'd expect get an 
  error message about the version mismatch.  PLaneT html-template:1:1 
  is currently a bit messy with syntax objects and phases, and might be 
  doing something questionable that 5.2.1 permitted.  This works fine 
  with Racket 5.2.1.
 
  Unfortunately, I don't have time to debug at this moment.  I'm 
  posting now because I understand that a release is close, and I don't 
  know how likely it is that this is a Racket bug.
 
  Neil V.
 
  _
   Racket Developers list:
   http://lists.racket-lang.org/dev
 
 _
   Racket Developers list:
   http://lists.racket-lang.org/dev
_
  Racket Developers list:
  http://lists.racket-lang.org/dev