Re: hdf5-1.8.8 in rawhide

2011-11-17 Thread Jussi Lehtola
On Wed, 16 Nov 2011 17:08:27 -0700 Orion Poplawski or...@cora.nwra.com wrote: hdf5-1.8.8 is now in rawhide. Any packages that build against hdf5 need to be rebuilt. I've already done R-hdf5 and gdl. Note that there is no soname bump but the hdf5 library checks that the runtime and compile

Need help with bundled lib issue for OpenColorIO

2011-11-17 Thread Richard Shaw
I'm working on packaging OpenColorIO for Fedora and ran into an issue with bundled libraries. The project is currently statically compiling in yaml-cpp, tinyxml, and lcms. Upstream doesn't have a problem with unbundling lcms, but is not sure about the other two, here's his explination: hmmm

Re: Need help with bundled lib issue for OpenColorIO

2011-11-17 Thread Jon Ciesla
I'm working on packaging OpenColorIO for Fedora and ran into an issue with bundled libraries. The project is currently statically compiling in yaml-cpp, tinyxml, and lcms. Upstream doesn't have a problem with unbundling lcms, but is not sure about the other two, here's his explination:

Re: Need help with bundled lib issue for OpenColorIO

2011-11-17 Thread Richard Shaw
On Thu, Nov 17, 2011 at 8:55 AM, Jon Ciesla l...@jcomserv.net wrote: I'm working on packaging OpenColorIO for Fedora and ran into an issue with bundled libraries. The project is currently statically compiling in yaml-cpp, tinyxml, and lcms. Upstream doesn't have a problem with unbundling

Unannounced ABI bump in rawhide: quvi

2011-11-17 Thread Adam Jackson
quvi 0.4.0 is both an ABI and API break. See the rawhide report for details. Nicoleau, please remember to announce changes that may affect others: https://fedoraproject.org/wiki/Package_maintainer_responsibilities#Notify_others_of_changes_that_may_affect_their_packages - ajax signature.asc

Re: hdf5-1.8.8 in rawhide

2011-11-17 Thread Orion Poplawski
On 11/17/2011 02:46 AM, Jussi Lehtola wrote: On Wed, 16 Nov 2011 17:08:27 -0700 Orion Poplawskior...@cora.nwra.com wrote: hdf5-1.8.8 is now in rawhide. Any packages that build against hdf5 need to be rebuilt. I've already done R-hdf5 and gdl. Note that there is no soname bump but the hdf5

Re: cisco vpn because of ipsec over tcp

2011-11-17 Thread Benjamin LaHaise
On Wed, Nov 16, 2011 at 12:49:41PM +, David Woodhouse wrote: We *have* had Cisco's IPSec over TCP working; it's not particularly difficult. However, we never really worked out how to make it work nicely on Linux; the kernel really *really* wants to eat all TCP packets and will give a TCP

[Bug 754725] Using Yumex - some updates throw error - ERROR with transaction check vs depsolve

2011-11-17 Thread bugzilla
Please do not reply directly to this email. All additional comments should be made in the comments box of this bug. https://bugzilla.redhat.com/show_bug.cgi?id=754725 Bill Nottingham nott...@redhat.com changed: What|Removed |Added

Re: Need help with bundled lib issue for OpenColorIO

2011-11-17 Thread Toshio Kuratomi
On Thu, Nov 17, 2011 at 09:11:06AM -0600, Richard Shaw wrote: On Thu, Nov 17, 2011 at 8:55 AM, Jon Ciesla l...@jcomserv.net wrote: I'm working on packaging OpenColorIO for Fedora and ran into an issue with bundled libraries. The project is currently statically compiling in yaml-cpp,

Re: cisco vpn because of ipsec over tcp

2011-11-17 Thread David Woodhouse
On Thu, 2011-11-17 at 11:10 -0500, Benjamin LaHaise wrote: Why not use a tun/tap interface set up with a private ip address which the vpn application causes to be masqueraded by the host? That should work and be portable across all kernel versions. Yeah, that's one of of the options. But

[Bug 754725] Using Yumex - some updates throw error - ERROR with transaction check vs depsolve

2011-11-17 Thread bugzilla
Please do not reply directly to this email. All additional comments should be made in the comments box of this bug. https://bugzilla.redhat.com/show_bug.cgi?id=754725 Iain Arnell iarn...@gmail.com changed: What|Removed |Added

scripts without she-bang in /usr/lib/packagename/

2011-11-17 Thread Paul Wouters
I have a package that contains ruby scripts in /usr/lib/packagename/ These scripts are only called/included via other binaries. If I do not make these executable, then rpmlint complains about non-executable content in /usr/lib/packagename/ and suggests I move it to /usr/share/packagename. If I

Re: scripts without she-bang in /usr/lib/packagename/

2011-11-17 Thread Toshio Kuratomi
On Thu, Nov 17, 2011 at 12:26:13PM -0500, Paul Wouters wrote: I have a package that contains ruby scripts in /usr/lib/packagename/ These scripts are only called/included via other binaries. If I do not make these executable, then rpmlint complains about non-executable content in

Re: scripts without she-bang in /usr/lib/packagename/

2011-11-17 Thread Paul Wouters
On Thu, 17 Nov 2011, Toshio Kuratomi wrote: When you talk about scripts, do you mean that the code calling these scripts does the equivalent of this (note, I generated my examples by reading up on ruby on the web just prior to posting... please allow for this perhaps not being real ruby code

Re: New build of fedpkg (fedora-packager) coming to updates-testing / rawhide

2011-11-17 Thread Jesse Keating
On Nov 15, 2011, at 1:54 AM, Marek Goldmann wrote: I see the same issue with clone on F16: [goldmann@nightmare fedora]$ fedpkg clone appliance-tools Could not execute clone: must be type, not classobj [goldmann@nightmare fedora]$ rpm -q fedpkg fedpkg-1.5-1.fc16.noarch Downgrading to

Re: [Test-Announce] Announcing the release of Fedora 16.

2011-11-17 Thread Jesse Keating
On Nov 14, 2011, at 3:38 PM, Adam Williamson wrote: On Tue, 2011-11-08 at 17:48 +0100, Gerd Hoffmann wrote: Hi, Fedora 16 is not science fiction. It is here right now: http://get.fedoraproject.org Hmm, no jigdo downloads any more? Releng say they dropped jigdo due to overwhelming

Re: scripts without she-bang in /usr/lib/packagename/

2011-11-17 Thread Toshio Kuratomi
On Thu, Nov 17, 2011 at 01:09:47PM -0500, Paul Wouters wrote: On Thu, 17 Nov 2011, Toshio Kuratomi wrote: When you talk about scripts, do you mean that the code calling these scripts does the equivalent of this (note, I generated my examples by reading up on ruby on the web just prior to

Re: Need help with bundled lib issue for OpenColorIO

2011-11-17 Thread Richard Shaw
On Thu, Nov 17, 2011 at 10:31 AM, Toshio Kuratomi a.bad...@gmail.com wrote: [SNIP] Only if he's significantly modifying the bundled libs and upstream won't take the changes.  If you unbundle and build against the system versions, and it works, that's what you need to do.  Always link

cone : potentially orphaned package

2011-11-17 Thread Michael Schwendt
2011-06-23 : FTBFS not responded to 2010-06-30 : -static packaging bug not responded to Plus, release 0.89 from 20-May-2011 is available whereas Fedora contains 0.84 from 2010 ( http://sourceforge.net/projects/courier/files/cone/ ). This looks like somebody with interest in Cone should sign up

Re: rawhide report: 20111117 changes

2011-11-17 Thread Richard W.M. Jones
On Thu, Nov 17, 2011 at 12:36:36PM +, Rawhide Report wrote: 1:libguestfs-1.15.3-3.fc17.i686 requires /usr/lib/libkdb5.so.5 1:libguestfs-1.15.3-3.fc17.x86_64 requires /usr/lib64/libkdb5.so.5 Should be fixed now. Rich. -- Richard Jones, Virtualization Group, Red Hat

Re: scripts without she-bang in /usr/lib/packagename/

2011-11-17 Thread Paul Wouters
On Thu, 17 Nov 2011, Toshio Kuratomi wrote: nod And also note -- the use of /usr/lib (*not* %{_libdir}) vs /usr/share is debatable (I said could above rather than should). The modules that go into the default search path, for python, perl, and ruby, for instance, all end up in /usr/lib if

syslinux package spec file

2011-11-17 Thread Michael Schwendt
Main package syslinux does: Obsoletes: syslinux-devel %{version}-%{release} Provides: syslinux-devel However, a syslinux-devel subpackage definition is present. A -devel package is built. No comment explains above Obs/Prov pair. %changelog only says: * Thu Dec 17 2009 Peter Jones … -

Re: Systemd unit file: Can/Should ExecStart and ExecStop run a script?

2011-11-17 Thread Richard Shaw
Ok, reviving this conversation! I ran into the issue that user mythtv can not create the file /var/run/mythbackend.pid. I see other services that have their pid file owned by their own user... Also, user mythtv can't write to the log file in /var/log/mythtv/ How do I do this with systemd? I

Re: Systemd unit file: Can/Should ExecStart and ExecStop run a script?

2011-11-17 Thread Jeffrey Ollie
On Thu, Nov 17, 2011 at 3:34 PM, Richard Shaw hobbes1...@gmail.com wrote: Ok, reviving this conversation! I ran into the issue that user mythtv can not create the file /var/run/mythbackend.pid. I see other services that have their pid file owned by their own user... systemd doesn't really

Re: Systemd unit file: Can/Should ExecStart and ExecStop run a script?

2011-11-17 Thread Richard Shaw
On Thu, Nov 17, 2011 at 3:41 PM, Jeffrey Ollie j...@ocjtech.us wrote: On Thu, Nov 17, 2011 at 3:34 PM, Richard Shaw hobbes1...@gmail.com wrote: Ok, reviving this conversation! I ran into the issue that user mythtv can not create the file /var/run/mythbackend.pid. I see other services that

Re: Systemd unit file executed as non-root user, WAS: Systemd unit file: Can/Should ExecStart and ExecStop run a script?

2011-11-17 Thread Richard Shaw
On Thu, Nov 17, 2011 at 3:56 PM, Richard Shaw hobbes1...@gmail.com wrote: On Thu, Nov 17, 2011 at 3:41 PM, Jeffrey Ollie j...@ocjtech.us wrote: On Thu, Nov 17, 2011 at 3:34 PM, Richard Shaw hobbes1...@gmail.com wrote: Ok, reviving this conversation! I ran into the issue that user mythtv can

python-fedora update for F-14 brings in additional 57 packages

2011-11-17 Thread Dominik 'Rathann' Mierzejewski
Hi list, could someone explain why an update in a branch that's supposed to be stable and is nearing EOL requires me to download 14MB worth of additional packages (57 extra dependencies) for a 360KB package? Doesn't this go against our update guidelines? For the record, the installed version is

Re: python-fedora update for F-14 brings in additional 57 packages

2011-11-17 Thread Toshio Kuratomi
On Thu, Nov 17, 2011 at 11:28:48PM +0100, Dominik 'Rathann' Mierzejewski wrote: Hi list, could someone explain why an update in a branch that's supposed to be stable and is nearing EOL requires me to download 14MB worth of additional packages (57 extra dependencies) for a 360KB package?

Re: python-fedora update for F-14 brings in additional 57 packages

2011-11-17 Thread Adam Williamson
On Thu, 2011-11-17 at 14:33 -0800, Toshio Kuratomi wrote: On Thu, Nov 17, 2011 at 11:28:48PM +0100, Dominik 'Rathann' Mierzejewski wrote: Hi list, could someone explain why an update in a branch that's supposed to be stable and is nearing EOL requires me to download 14MB worth of

Re: Systemd unit file executed as non-root user, WAS: Systemd unit file: Can/Should ExecStart and ExecStop run a script?

2011-11-17 Thread Tom Hughes
On 17/11/11 22:09, Richard Shaw wrote: On Thu, Nov 17, 2011 at 3:56 PM, Richard Shawhobbes1...@gmail.com wrote: On Thu, Nov 17, 2011 at 3:41 PM, Jeffrey Olliej...@ocjtech.us wrote: On Thu, Nov 17, 2011 at 3:34 PM, Richard Shawhobbes1...@gmail.com wrote: Ok, reviving this conversation! I

push direct to stable?

2011-11-17 Thread Neal Becker
Is it possible to push this update direct to stable to close this bug? https://bugzilla.redhat.com/show_bug.cgi?id=754741 https://admin.fedoraproject.org/updates/kdiff3-0.9.96-5.fc16 -- devel mailing list devel@lists.fedoraproject.org https://admin.fedoraproject.org/mailman/listinfo/devel

Re: push direct to stable?

2011-11-17 Thread Adam Williamson
On Thu, 2011-11-17 at 20:26 -0500, Neal Becker wrote: Is it possible to push this update direct to stable to close this bug? https://bugzilla.redhat.com/show_bug.cgi?id=754741 https://admin.fedoraproject.org/updates/kdiff3-0.9.96-5.fc16 It's not critical path, so you only need a single

Re: Anyone interested in abi-compatibility-checker?

2011-11-17 Thread Angus Salkeld
- Original Message - From: Richard Shaw hobbes1...@gmail.com To: Development discussions related to Fedora devel@lists.fedoraproject.org Sent: Friday, 18 November, 2011 5:41:19 AM Subject: Re: Anyone interested in abi-compatibility-checker? Just an FYI to anyone who's interested.

[Bug 754689] New: CGI::Session emits deprecation warning when running under 'use warnings'

2011-11-17 Thread bugzilla
Please do not reply directly to this email. All additional comments should be made in the comments box of this bug. Summary: CGI::Session emits deprecation warning when running under 'use warnings' https://bugzilla.redhat.com/show_bug.cgi?id=754689 Summary: CGI::Session emits

[Bug 746941] perl-Mojolicious-2.27 is available

2011-11-17 Thread bugzilla
Please do not reply directly to this email. All additional comments should be made in the comments box of this bug. https://bugzilla.redhat.com/show_bug.cgi?id=746941 Upstream Release Monitoring upstream-release-monitor...@fedoraproject.org changed: What|Removed

[Bug 754689] CGI::Session emits deprecation warning when running under 'use warnings'

2011-11-17 Thread bugzilla
Please do not reply directly to this email. All additional comments should be made in the comments box of this bug. https://bugzilla.redhat.com/show_bug.cgi?id=754689 --- Comment #1 from Simon Andrews simon.andr...@bbsrc.ac.uk 2011-11-17 06:37:27 EST --- The fix is to change line 882 from:

File abi-compliance-checker-1.95.10.tar.gz uploaded to lookaside cache by hobbes1069

2011-11-17 Thread Richard Shaw
A file has been added to the lookaside cache for abi-compliance-checker: eb6be17e017a581793cf2fd1d793d470 abi-compliance-checker-1.95.10.tar.gz -- Fedora Extras Perl SIG http://www.fedoraproject.org/wiki/Extras/SIGs/Perl perl-devel mailing list perl-devel@lists.fedoraproject.org

[Bug 754725] Using Yumex - some updates throw error - ERROR with transaction check vs depsolve

2011-11-17 Thread bugzilla
Please do not reply directly to this email. All additional comments should be made in the comments box of this bug. https://bugzilla.redhat.com/show_bug.cgi?id=754725 Chris Jones ch...@mollingtonconsultants.com changed: What|Removed |Added

[abi-compliance-checker] Initial import (#753900).

2011-11-17 Thread Richard Shaw
commit 1e3d82d88f3b468ffe407279f5ac5f55936f6acc Author: Richard M. Shaw hobbes1...@gmail.com Date: Thu Nov 17 11:29:40 2011 -0600 Initial import (#753900). .gitignore |1 + ChangeLog | 221 +++

[abi-compliance-checker/f16] Initial import (#753900).

2011-11-17 Thread Richard Shaw
Summary of changes: 1e3d82d... Initial import (#753900). (*) (*) This commit already existed in another branch; no separate mail sent -- Fedora Extras Perl SIG http://www.fedoraproject.org/wiki/Extras/SIGs/Perl perl-devel mailing list perl-devel@lists.fedoraproject.org

[abi-compliance-checker/f15] Initial import (#753900).

2011-11-17 Thread Richard Shaw
Summary of changes: 1e3d82d... Initial import (#753900). (*) (*) This commit already existed in another branch; no separate mail sent -- Fedora Extras Perl SIG http://www.fedoraproject.org/wiki/Extras/SIGs/Perl perl-devel mailing list perl-devel@lists.fedoraproject.org

[Bug 754446] Upgrade to new upstream version

2011-11-17 Thread bugzilla
Please do not reply directly to this email. All additional comments should be made in the comments box of this bug. https://bugzilla.redhat.com/show_bug.cgi?id=754446 Fedora Update System upda...@fedoraproject.org changed: What|Removed |Added

[389-devel] Please review: use slapi_hexchar2int and slapi_str_to_u8 everywhere

2011-11-17 Thread Rich Megginson
From 1a0660f4fa2da22a6918078442afffba51c8c225 Mon Sep 17 00:00:00 2001 From: Rich Megginson rmegg...@redhat.com Date: Thu, 17 Nov 2011 09:41:06 -0700 Subject: [PATCH] use slapi_hexchar2int and slapi_str_to_u8 everywhere uniqueid code was using local str2Byte - use slapi_str_to_u8 instead there

Re: [389-devel] Please review: use slapi_hexchar2int and slapi_str_to_u8 everywhere

2011-11-17 Thread Nathan Kinder
On 11/17/2011 02:23 PM, Rich Megginson wrote: -- 389-devel mailing list 389-devel@lists.fedoraproject.org https://admin.fedoraproject.org/mailman/listinfo/389-devel ack. -- 389-devel mailing list 389-devel@lists.fedoraproject.org https://admin.fedoraproject.org/mailman/listinfo/389-devel