Re: Needing Some Maintenance Help

2021-01-14 Thread Guido Aulisi
Hi Erich, Il giorno gio, 14/01/2021 alle 10.14 -0800, Erich Eickmeyer ha scritto: > Hi All, > > Over the course of the past few months, I have become employed by a > company to provide their user software experience. This has limited > the > time that I have, and, unfortunately, my involvement

Re: Fedora 34 Change: Unify the GRUB configuration files location across all supported architectures (System-Wide Change proposal)

2021-01-13 Thread Guido Aulisi
Hi, Il giorno mer, 13/01/2021 alle 13.46 -0700, Chris Murphy ha scritto: > On Tue, Jan 12, 2021 at 8:48 PM Michel Alexandre Salim > wrote: ... snip > There are separate issues. > > grubenv is "OK" on ext4 and XFS. The issue is that none of the file > systems developers like anything other

Re: Fedora 34 Change: Route all Audio to PipeWire (System-Wide Change)

2021-01-03 Thread Guido Aulisi
Il giorno ven, 20/11/2020 alle 11.26 -0500, Ben Cotton ha scritto: > https://fedoraproject.org/wiki/Changes/DefaultPipeWire > > == Summary == > This change proposal is to route all audio from PulseAudio and JACK > to > the PipeWire Audio > daemon by default. > > == Owner == > * Name:

Re: Bodhi down?

2021-01-02 Thread Guido Aulisi
Hello, Il giorno sab, 02/01/2021 alle 09.16 -0600, Richard Shaw ha scritto: > I tried to push an update but got the following: > > Builds : Unable to create update. Bodhi failed to get a resource from > PDC at the following URL " >

Re: can't install package pipewire-jack-audio-connection-kit

2021-01-02 Thread Guido Aulisi
Il giorno ven, 01/01/2021 alle 20.01 +0100, Michael Schwendt ha scritto: > On Fri, 1 Jan 2021 06:58:43 -0500, Neal Gompa wrote: > > > > Explicit "Conflicts" here, at least, in pipewire-jack-audio- > > > connection-kit: > > > https://koji.fedoraproject.org/koji/rpminfo?rpmID=24326970 > > > > > >

Re: Stale proven packagers

2020-12-27 Thread Guido Aulisi
gt; where > security requirements are higher, like in two-factor authentication. > Requiring biometrics is effectively the same as prohibiting stronger > authentication methods, which is a stupid thing to do. Guido Aulisi signature.asc Description: This is a digitally signed me

Should we retire ardour5 in rawhide?

2020-12-22 Thread Guido Aulisi
Hi, ardour5 fails to build in rawhide and it has been obsoleted by ardour6. Should we retire it in rawhide? Nils, if you can give me commit access to ardour6 I can help build the new version as they are released. My FAS account: tartina Thanks Ciao Guido signature.asc Description: This is

HEADS UP -- Hydrogen SONAME bump

2020-12-21 Thread Guido Aulisi
Hi, I'm updating Hydrogen drum machine to the latest version in rawhide. It bumps SONAME in libhydrogen-core.so To my knowledge nothing requires this library, it seems an internal use only lib. Ciao Guido FAS: tartina signature.asc Description: This is a digitally signed message part

Re: Problems upgrading to f33 cloud edition

2020-12-18 Thread Guido Aulisi
Il giorno ven, 18/12/2020 alle 22.42 +0100, Marius Schwarz ha scritto: > Am 18.12.20 um 20:37 schrieb Guido Aulisi: > > > > Yes, but I found an issue regarding this list: > > Package hwdata in F32 is newer than the one in F33. > > > > hwdata-0.342-1.fc32 | hwda

Re: Problems upgrading to f33 cloud edition

2020-12-18 Thread Guido Aulisi
Il giorno ven, 18/12/2020 alle 10.33 -0700, stan via devel ha scritto: > On Fri, 18 Dec 2020 10:25:30 +0100 > Guido Aulisi wrote: > > > Hi, sorry for posting here if this is not correct. > > Probably more appropriate for the user list. Yes, but I found an issue regardi

Problems upgrading to f33 cloud edition

2020-12-18 Thread Guido Aulisi
-helper-messages installed in f32. Thanks for you help Guido Aulisi signature.asc Description: This is a digitally signed message part ___ devel mailing list -- devel@lists.fedoraproject.org To unsubscribe send an email to devel-le

Re: The Future of the Java Stack (also regarding ELN and RHEL)

2020-09-10 Thread Guido Aulisi
> Il giorno 10 set 2020, alle ore 16:53, Vitaly Zaitsev via devel > ha scritto: > > On 10.09.2020 16:10, Aleksandar Kurtakov wrote: >> Flatpak is way better suited for our use case and in addition gives us >> access to a way bigger install base. > > Flathub is a third-party repository and

Re: Removing a branch created by mistake

2020-09-09 Thread Guido Aulisi
Il giorno mer, 09/09/2020 alle 15.57 +0200, Jun Aruga ha scritto: > On Wed, Sep 9, 2020 at 3:28 PM Mikolaj Izdebski > wrote: > > On Wed, Sep 9, 2020 at 3:15 PM Jun Aruga wrote: > > > Yesterday I created the "wip/2.7" branch on modules/ruby dist-git > > > repository by mistake. ;-< > > >

Re: The Future of the Java Stack (also regarding ELN and RHEL)

2020-09-09 Thread Guido Aulisi
Hi, > Il giorno 9 set 2020, alle ore 00:19, Fabio Valentini > ha scritto: > > Hi everybody, > > So, after some recent FESCo decisions (no default module streams in > fedora, new Module Policy for fedora and ELN modules), it's time to > ask this question again: > > What's the future of the

Build failure of zynaddsubfx on armv7hl

2020-08-07 Thread Guido Aulisi
Hi, I got a segmentation fault trying to rebuild zynaddsubfx [0]. I pasted the main build.log below. I found some strange compiler options passed by the build system and g++ warns about that: cc1plus: warning: switch '-mcpu=cortex-a9' conflicts with '-march=armv7-a' switch Is this an annobin

Re: s390x weirdness during mass rebuild

2020-07-28 Thread Guido Aulisi
Il giorno lun 27 lug 2020 alle ore 17:11 Jerry James ha scritto: > > I don't know if this is related to what we saw during the previous > mass rebuild, but on s390x only, the TOPCOM build failed with: > > BuildrootError: Requested repo (1785306) is DELETED I'm having the same issue.

Re: Packages that failed to build with Python 3.9

2020-05-30 Thread Guido Aulisi
Il giorno ven, 29/05/2020 alle 21.59 +0200, Miro Hrončok ha scritto: > Hello. Hello, > As you might already know, we have recently merged in the Python 3.9 > side tag, > despite several builds have not succeeded. We always aim for some > compromise > between having the side tag open for too

New package review tickets page last update on 2020-04-06

2020-05-24 Thread Guido Aulisi
Hi, the new package review tickets page [0] was last updated on 2020-04-06. New tickets are not displayed, I made a new review request on April 19 and it never appeared on that page Is there anything not working on auto updating that page? Ciao Guido FAS: tartina [0]:

Re: Problems with packages compiled with gcc 10.0

2020-05-19 Thread Guido Aulisi
Il giorno mar, 19/05/2020 alle 18.43 +0200, Dan Horák ha scritto: > On Tue, 19 May 2020 17:42:29 +0200 > Guido Aulisi wrote: > > > Il giorno mar, 19/05/2020 alle 12.11 +0200, Florian Weimer ha > > scritto: > > > * Guido Aulisi: > > > > > > >

Re: Problems with packages compiled with gcc 10.0

2020-05-19 Thread Guido Aulisi
Il giorno mar, 19/05/2020 alle 12.11 +0200, Florian Weimer ha scritto: > * Guido Aulisi: > > > I'm getting some strange errors from some packages built for f32 > > with > > gcc 10.0 [0]. > > Building with g++ 10.1 ardourd5 seems fine... > > > >

Problems with packages compiled with gcc 10.0

2020-05-19 Thread Guido Aulisi
Hi, I'm getting some strange errors from some packages built for f32 with gcc 10.0 [0]. Building with g++ 10.1 ardourd5 seems fine... It seems GCC 10.0 had some bugs that could be discovered only at runtime. Did you have any similar problems? Ciao Guido FAS: tartina [0]:

Re: CPE Weekly: 2020-05-11

2020-05-11 Thread Guido Aulisi
Il giorno lun, 11/05/2020 alle 09.40 +0100, Aoife Moloney ha scritto: > # CPE Weekly: 2020-05-11 > --- > title: CPE Weekly status email > tags: CPE Weekly, email > --- > ... > > ## GitForge Updates > * We are tracking our progress here (nothing new added yet, fyi) >

Re: CPE Weekly: 2020-04-26

2020-05-05 Thread Guido Aulisi
So you are doing a technical deep-dive now after choosing Gitlab, not before deciding? It's a very strange way to take decisions... I'd expect that the entire git forge discussion would start from the beginning, because of the many mistakes that were made in this process. Sorry for my bad english...

Intent to retire jamin

2020-05-03 Thread Guido Aulisi
Hello, I'm going to retire the jamin package [0], because it's unmaintained upstream and it uses an old audio plugin standard (LADSPA). According to this thread [1], it introduces a lot of distortion too. Ciao Guido FAS: tartina [0]: https://src.fedoraproject.org/rpms/jamin [1]:

Re: kiss-fft's builds failure on rawhide after upgrading of gcc and glibc

2020-04-22 Thread Guido Aulisi
Il giorno mar, 21/04/2020 alle 21.27 +0200, Guido Aulisi ha scritto: > Il giorno mar, 21/04/2020 alle 11.19 -0700, Samuel Sieb ha scritto: > > On 4/21/20 2:30 AM, Guido Aulisi wrote: > > > I'm trying to understand why kiss-fft (an FFT library) is failing > > > in &g

Re: kiss-fft's builds failure on rawhide after upgrading of gcc and glibc

2020-04-21 Thread Guido Aulisi
Il giorno mar, 21/04/2020 alle 11.19 -0700, Samuel Sieb ha scritto: > On 4/21/20 2:30 AM, Guido Aulisi wrote: > > I'm trying to understand why kiss-fft (an FFT library) is failing > > in > > rawhide only on aarch64. > > The failing test does some fft ca

kiss-fft's builds failure on rawhide after upgrading of gcc and glibc

2020-04-21 Thread Guido Aulisi
Hello, I'm trying to understand why kiss-fft (an FFT library) is failing in rawhide only on aarch64. The failing test does some fft calculation and compares them with the same done with numpy. For waht I understood the upgrade of gcc and/or glibc makes this test fail only on aarch64, and I cannot

Re: CPE Git Forge Decision

2020-04-03 Thread Guido Aulisi
t; > Jeremy, rest assure that your work added real value. > > I must concur with Erich in everything that they replied to this. I would like to add that personally I like Pagure UX much more that Gitlab. If any help is needed to improve Pagure, I could add some of my little fre ti

Re: CPE Git Forge Decision

2020-03-31 Thread Guido Aulisi
ee Software as the hosting > platform > for Fedora should be an absolute no go. In other words, self-hosted > GitLab > CE or Pagure, no other options. > > Kevin Kofler I totally agree with Kevin +1. Guido Aulisi signature.asc Description: This is a digitally signed message par

Re: CPE Git Forge Decision

2020-03-30 Thread Guido Aulisi
Il giorno lun 30 mar 2020 alle 11:21 Leigh Griffin ha scritto: > Hi everyone, > > Thank you for your patience while the CPE Team worked through an > incredible number of requirements from multiple stakeholder sources. On > Friday evening we announced on the Community Blog >

Re: Beware: java-1.8.0-openjdk SIGSEGVs / SIGABRTs in rawhide

2020-03-19 Thread Guido Aulisi
Il giorno gio, 19/03/2020 alle 12.07 +0100, Iñaki Ucar ha scritto: > Yet another gcc10-related headache... I'm experiencing issues > building rstudio in rawhide for i686: > https://koji.fedoraproject.org/koji/taskinfo?taskID=42614405. But I > believe this is not the best package to chase the bug.

Re: Intent to request a FESCo exception for python2 for ardour5

2020-03-16 Thread Guido Aulisi
Il giorno dom, 15/03/2020 alle 14.44 +0100, Fabio Valentini ha scritto: > On Sun, Mar 15, 2020 at 2:37 PM Alexander Bokovoy < > aboko...@redhat.com> wrote: > > On su, 15 maalis 2020, Guido Aulisi wrote: > > > Hi, > > > > > > I’m going to ask a FESCo ex

Re: Beware: java-1.8.0-openjdk SIGSEGVs / SIGABRTs in rawhide

2020-03-16 Thread Guido Aulisi
Il giorno dom, 15/03/2020 alle 15.02 +0100, Fabio Valentini ha scritto: > Hi everybody, > > The latest java-1.8.0-openjdk update for rawhide (the first build > with > GCC 10) seems to have introduced some serious problems - including > crashes and segmentation faults during package builds for

Intent to request a FESCo exception for python2 for ardour5

2020-03-15 Thread Guido Aulisi
Hi, I’m going to ask a FESCo exception for python2 for package ardour5. Python2 is only needed to build the package using the WAF build system. Ardour has been undergoing a complete rewriting for 2 years, no stable versions have been released in the last 2 years, so we are stuck with ardour

Help needed debugging core dump while building lilv on ppc64le and arm

2020-03-08 Thread Guido Aulisi
Hi, I'm trying to debug a build failure of package lilv on ppc64le and arm platforms, x86 builds fine. [0] is the status of lilv package on Koschei The build core dumps while executing tests, in particular lilv_test, which uses sord library. Dmesg output: [292790.757364] lilv_test[603241]:

Re: Orphaned packages

2020-03-07 Thread Guido Aulisi
Il giorno sab, 07/03/2020 alle 10.11 -0800, er...@ericheickmeyer.com ha scritto: > On Sat, 2020-03-07 at 19:04 +0100, Guido Aulisi wrote: > > Hi Erich, > > I took lv2-x42-plugins, because I've been maintaining it for the > > latest > > time, I'm currently maintaining s

Re: Orphaned packages

2020-03-07 Thread Guido Aulisi
Il giorno sab, 07/03/2020 alle 09.08 -0800, er...@ericheickmeyer.com ha scritto: > Hi Brendan, > > On Sat, 2020-03-07 at 09:10 +0100, Brendan Jones wrote: > > Hello, > > > > the following packages have been orphaned and require a primary > > maintainer. Feel free to take them over > > > > Add64

Creation of pkgconfig file for libraries that do not ship one

2020-03-02 Thread Guido Aulisi
Hi, can we create a pkgconfig file for libraries that do not ship one? I did not find anything about that in our packaging policy. A bug was filed [0] about a missing pkgconfig file for zita-convolver library and I'm thinking og creating the missing pkgconfig file myself. Thank you Guido FAS:

Intent to retire clalsadrv

2020-02-17 Thread Guido Aulisi
I'm going to retire clalsadrv, it's been deprecated upstream [0] for a long time and it has been replaced by zita-alsa-pcmi. Nothing depends on it in rawhide according to this query: dnf --disablerepo='*' --enablerepo='rawhide' repoquery --whatrequires clalsadrv --alldep Ciao Guido FAS:

Re: Ideas for better development processes when maintaining hundreds of packages

2020-01-28 Thread Guido Aulisi
Il giorno mar 28 gen 2020 alle ore 10:04 Richard W.M. Jones ha scritto: > > I always think that Fedora works fine if you maintain 1-5 packages. > It's possible to maintain 20 with a lot of work. And if you want to > maintain 100+ (things like the ocaml-* set that I help to maintain) > then you

Re: Git Forge Requirements: Please see the Community Blog

2020-01-21 Thread Guido Aulisi
> Il giorno 21 gen 2020, alle ore 18:15, Fabio Valentini > ha scritto: > > On Tue, Jan 21, 2020 at 5:40 PM Leigh Griffin > wrote: >> >> Hey Everyone, >> >> On behalf of the CPE team I want to draw the communities attention to a >> recent blog post which you may

Re: Self Introduction: Philip Matura

2020-01-21 Thread Guido Aulisi
> Il giorno 5 dic 2019, alle ore 17:34, p...@tura-home.de ha scritto: > > Hello, > > my name is Philip Matura and I'm currently a student in mathematics. In > my freetime I'm doing audio/music and electronics stuff. I've been > converted to the Linux world with Fedora about 10 years ago and

Re: Effort to remove libdb

2020-01-17 Thread Guido Aulisi
Ah, it permits linking only with GPLv3!!! ___ devel mailing list -- devel@lists.fedoraproject.org To unsubscribe send an email to devel-le...@lists.fedoraproject.org Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/

Re: Effort to remove libdb

2020-01-17 Thread Guido Aulisi
Sorry if I misunderstood, but I thought BDB was licensed under the GNU AFFERO GENERAL PUBLIC LICENSE v3 [1]. Is that not correct? Ciao Guido [1]: https://www.oracle.com/downloads/licenses/berkeleydb-oslicense.html ___ devel mailing list --

Re: Upgrading libffi

2020-01-06 Thread Guido Aulisi
Il giorno lun, 06/01/2020 alle 18.11 -0500, Anthony Green ha scritto: > I released a new version of libffi a month or so ago, the first one > in 5 > years. There's an ABI change that was unavoidable in order to > accommodate the aarch64 port, and the sonumber was bumped. > > I am also the Fedora

Intent to unretire non-ntk

2020-01-05 Thread Guido Aulisi
Ciao, I'm going to unretire non-ntk in rawhide and f31 releases, because it's a dependency for lv2-sorcer and maybe other audio packages. I will file a review request ASAP, I have already made a scratch build in rawhide [0] FAS account: tartina Ciao Guido [0]:

Re: lv2-sorcer is not installable

2020-01-05 Thread Guido Aulisi
Il giorno dom, 05/01/2020 alle 12.21 +0100, Miro Hrončok ha scritto: > On 03. 01. 20 19:24, Kevin Kofler wrote: > > Zbigniew Jędrzejewski-Szmek wrote: > > > The dep was provided by non-ntk, which got retired about half a > > > year > > > ago [1] after FTBFSing since F29 [2]. > > > > Isn't it

Re: Build complete, but result generic error

2019-12-23 Thread Guido Aulisi
Il giorno lun 23 dic 2019 alle ore 09:24 Guido Aulisi ha scritto: > > Hi, > Koji reports that build [0] is complete, but it is marked with this error: > GenericError: cannot update build 1424540, state: COMPLETE > > It's not selectable in Bodhi. > Do I have to run it aga

Build complete, but result generic error

2019-12-23 Thread Guido Aulisi
Hi, Koji reports that build [0] is complete, but it is marked with this error: GenericError: cannot update build 1424540, state: COMPLETE It's not selectable in Bodhi. Do I have to run it again? Thanks Ciao Guido [0]: https://koji.fedoraproject.org/koji/buildinfo?buildID=1424540

Re: List of Python 2 packages to be removed mid-November

2019-10-31 Thread Guido Aulisi
> tartina >lilv > (BuildRequires: python2-numpy → PY2) Fixed. ___ devel mailing list -- devel@lists.fedoraproject.org To unsubscribe send an email to devel-le...@lists.fedoraproject.org Fedora Code of Conduct:

Re: Modularity and the system-upgrade path

2019-10-16 Thread Guido Aulisi
Il giorno mer 16 ott 2019 alle ore 11:58 Fabio Valentini ha scritto: > > On Wed, Oct 16, 2019 at 11:50 AM Alexander Bokovoy > wrote: > > > > On ti, 15 loka 2019, John M. Harris Jr wrote: > > >On Tuesday, October 15, 2019 9:40:31 PM MST Neal Gompa wrote: > > >> And to be fair, while it is a hard

Re: Intent to unretire qm-dsp

2019-10-02 Thread Guido Aulisi
Il giorno mer, 02/10/2019 alle 14.32 +0200, Guido Aulisi ha scritto: > Hi, > I'm going to unretire qm-dsp in all current Fedora supported > releases, > because it's a dependency for ardour5. > > I will file a review request ASAP, I have already made a scratch > build

Intent to unretire qm-dsp

2019-10-02 Thread Guido Aulisi
Hi, I'm going to unretire qm-dsp in all current Fedora supported releases, because it's a dependency for ardour5. I will file a review request ASAP, I have already made a scratch build in rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=38004441 FAS account: tartina Ciao

Re: Defining the future of the packager workflow in Fedora

2019-09-30 Thread Guido Aulisi
Il giorno ven, 27/09/2019 alle 08.31 +, Petr Pisar ha scritto: > On 2019-09-26, Pierre-Yves Chibon wrote: > > ○ Every changes to dist-git is done via pull-requests > > Pull requests are great for proposing your changes to foreign > packages. > It does not make sense when maintaining the

Re: Audio packages depending on python2

2019-09-20 Thread Guido Aulisi
Il giorno ven 20 set 2019 alle ore 13:03 Leigh Scott ha scritto: > > Shouldn't you be using system waf instead of the ancient bundled version?, > try the waf-python3 package instead. It's not that simple, every wscript file needs to be patched. WAF change its API from version 1.7 (if I remember

Audio packages depending on python2

2019-09-20 Thread Guido Aulisi
Hi, there are many audio related packages that depend on python2, mainly because they use the WAF build system, which will be retired in f32 if not ported to python3. Porting them to python3 is not a trivial job. Some of the most important packages are: ardour5 jack-audio-connection-kit (next

Re: Donate 1 minute of your time to test upgrades from F30 to F31

2019-09-13 Thread Guido Aulisi
Il giorno mer, 11/09/2019 alle 14.54 +0200, Miroslav Suchý ha scritto: > Do you want to make Fedora 31 better? Please spend 1 minute of your > time and try to run [*]: > > sudo dnf --releasever=31 --setopt=module_platform_id=platform:f31 > --enablerepo=updates-testing distro-sync > > If you

Re: Donate 1 minute of your time to test upgrades from F29 to F30

2019-09-13 Thread Guido Aulisi
Il giorno gio, 28/02/2019 alle 10.22 +0100, Miroslav Suchý ha scritto: > Do you want to make Fedora 30 better? Please spend 1 minute of your > time and try to run: > > sudo dnf --releasever=30 --setopt=module_platform_id=platform:f30 > --enablerepo=updates-testing distro-sync > > If you get

Intent to deprecate clalsadrv

2019-09-09 Thread Guido Aulisi
I'm going to deprecate clalsadrv, because it has been deprecated and replaced by zita-alsa-pcmi upstream. Nothing depends on it in rawhide: dnf --disablerepo='*' --enablerepo=rawhide --enablerepo=rawhide-source repoquery --whatdepends clalsadrv --alldeps reports only

Re: Self Introduction: alciregi

2019-09-09 Thread Guido Aulisi
Il giorno lun, 09/09/2019 alle 19.02 +0200, alcir...@gmail.com ha scritto: > Hello. > My name is Alessio. > FAS: alciregi Welcome to Fedora... > I work as an unpretentious sysadmin, mostly as the "IT guy". > I've been a long-time user/administrator of *nix systems, starting > with > Red Hat

Intent to unretire ladspa-swh-plugins

2019-09-09 Thread Guido Aulisi
I'd like to unretire ladspa-swh-plugins in rahwide, f31 and f30, because it is a dependency of some packages I maintain: ams jamin It's a dependency of pulseeffects too. I will file a review request ASAP, I have already made a scratch build in rawhide:

Correct path for package bash completion file

2019-08-28 Thread Guido Aulisi
Ciao, what is the right path for package bash completion file? Most packages put then in %sysconf/bash_completion.d some other (and bash_completion itself) in %datadir/bash-completion/completions/ IMHO I think %sysconf should be for users and %datadir for packages Am I correct? Thanks Ciao

Re: unorphaning ladspa-swh-plugins

2019-08-28 Thread Guido Aulisi
Il giorno mer 28 ago 2019 alle ore 12:16 Miro Hrončok ha scritto: > > On 28. 08. 19 8:47, Guido Aulisi wrote: > > I'd like to take ownership of orphaned ladspa-swh-plugins package, > > because it's needed by some other packages I maintain. > > For some reason I missed th

unorphaning ladspa-swh-plugins

2019-08-28 Thread Guido Aulisi
I'd like to take ownership of orphaned ladspa-swh-plugins package, because it's needed by some other packages I maintain. For some reason I missed the orphaning announcement, I'm sorry for that. What are the next steps to unorphan it? Thanks. FAS account: tartina Ciao Guido

Re: HEADS-UP: soname version bump for zita-convolver

2019-06-25 Thread Guido Aulisi
Il giorno lun, 24/06/2019 alle 19.09 +0200, Igor Gnatenko ha scritto: > Hi Guido, > > On Mon, Jun 24, 2019 at 6:59 PM Guido Aulisi > wrote: > > Hello, > > I'm going to update zita-convolver library to version 4 in the next > > weeks, it will be a rathe

HEADS-UP: soname version bump for zita-convolver

2019-06-24 Thread Guido Aulisi
Hello, I'm going to update zita-convolver library to version 4 in the next weeks, it will be a rather slow job because of holidays :-) According to dnf this update will impact the packages listed below: guitarix-0:0.37.3-3.fc30.x86_64 jconvolver-0:0.9.2-17.fc30.x86_64

Re: Help needed for FTBFS in rawhide because of libraries order

2019-02-04 Thread Guido Aulisi
Il giorno lun 4 feb 2019 alle ore 13:14 Mamoru TASAKA ha scritto: > > Guido Aulisi wrote on 2019/02/03 20:31: > > Hi, > > I'm trying to debug a FTBFS in rawhide: > > > > https://koji.fedoraproject.org/koji/taskinfo?taskID=32412101 > > > > Appar

Re: Help needed for FTBFS in rawhide because of libraries order

2019-02-04 Thread Guido Aulisi
Il giorno dom 3 feb 2019 alle ore 23:17 Kalev Lember ha scritto: > > > On 2/3/19 12:31, Guido Aulisi wrote: > > Hi, > > I'm trying to debug a FTBFS in rawhide: > > > > https://koji.fedoraproject.org/koji/taskinfo?taskID=32412101 > > > > Ap

Help needed for FTBFS in rawhide because of libraries order

2019-02-03 Thread Guido Aulisi
Hi, I'm trying to debug a FTBFS in rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=32412101 Apparently it fails because of library ordering, but it works in f29. g_object_unref is defined in gobject-2.0 and it gets surely added by the 'pkgconf --libs cairo pangocairo pango'

Re: Fedora 30 Self-Contained Change proposal: Make ambiguous python shebangs error

2018-08-31 Thread Guido Aulisi
Il giorno ven 31 ago 2018 alle ore 13:18 Miro Hrončok ha scritto: > > On 31.8.2018 08:22, Guido Aulisi wrote: > > Can we explicitly call python2? > > Instead of calling > > ./waf ... > > which contains the unversioned shebang, we call > > python2 waf ... ?

Re: Fedora 30 Self-Contained Change proposal: Make ambiguous python shebangs error

2018-08-31 Thread Guido Aulisi
in intact by this change. > For details see > https://fedoraproject.org/wiki/Packaging:Guidelines#Shebang_lines and > https://fedoraproject.org/wiki/Packaging:Guidelines#BRP_.28BuildRoot_Policy.29_Scripts > sections of the packaging guidelines. > Can we explicitly call python2? Ins

Library ABI change

2018-08-06 Thread Guido Aulisi
Hi, recently serd library changed its ABI adding 1 function without bumping the soname. I think adding one function should not be a problem for depending packages, what do you think about it? Guido fas account: tartina ___ devel mailing list --

Re: Build failures of packages which use waf as build system

2018-07-17 Thread Guido Aulisi
2018-07-17 0:38 GMT+02:00 Miro Hrončok : > On 16.7.2018 21:54, Guido Aulisi wrote: >> >> I fixed some of these audio packages, prefixing waf calls with >> %{__python2} macro. You have to BR python2-rpm-macros or python2-devel >> to use it. > > > Or you can just

Build failures of packages which use waf as build system

2018-07-16 Thread Guido Aulisi
Hi all, I found many build failure of packages using waf as build system. This is due to recent move of /usr/bin/python into a separate package https://fedoraproject.org/wiki/Changes/Move_usr_bin_python_into_separat e_package Many audio related packages have this problem. I fixed some of these

Re: F29 System Wide Change: i686 Is For x86-64

2018-06-04 Thread Guido Aulisi
__ > devel mailing list -- devel@lists.fedoraproject.org > To unsubscribe send an email to devel-le...@lists.fedoraproject.org > Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html > List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines >

Re: GCC 8.1.1 broken in rawhide due to annobin

2018-05-04 Thread Guido Aulisi
It seems broken in f28 too. Ciao Guido ___ devel mailing list -- devel@lists.fedoraproject.org To unsubscribe send an email to devel-le...@lists.fedoraproject.org

Re: Fedora mass rebuild 2018

2018-02-23 Thread Guido Aulisi
2018-02-22 21:47 GMT+01:00 Josh Boyer : > On Thu, Feb 22, 2018 at 12:49 PM, Marek Polacek wrote: >> As many of you know, every year we (the GCC team) rebuild all the Fedora >> packages with the upcoming GCC, so as to reveal as many bugs as possible

Re: [ACTION NEEDED] Missing BuildRequires: gcc/gcc-c++

2018-02-19 Thread Guido Aulisi
2018-02-19 9:30 GMT+01:00 Igor Gnatenko <ignatenkobr...@fedoraproject.org>: >> amsynth has been fixed in all supported branches. > > It should have both gcc and gcc-c++. Done, BR for both. Ciao Guido Aulisi fas account: tartina ___

Re: [ACTION NEEDED] Missing BuildRequires: gcc/gcc-c++

2018-02-19 Thread Guido Aulisi
2018-02-19 9:30 GMT+01:00 Igor Gnatenko <ignatenkobr...@fedoraproject.org>: > On Mon, 2018-02-19 at 09:12 +0100, Guido Aulisi wrote: >> Hi Igor >> >> > 2018-02-18 18:09 GMT+01:00 Igor Gnatenko <ignatenkobr...@fedoraproject.org> >> > : >> >

Re: [ACTION NEEDED] Missing BuildRequires: gcc/gcc-c++

2018-02-19 Thread Guido Aulisi
.txt amsynth has been fixed in all supported branches. Thanks for your work. Guido Aulisi fas account: tartina ___ devel mailing list -- devel@lists.fedoraproject.org To unsubscribe send an email to devel-le...@lists.fedoraproject.org

Re: Ambiguous python version in waf

2018-02-05 Thread Guido Aulisi
2018-02-05 12:00 GMT+01:00 Petr Viktorin <pvikt...@redhat.com>: > On 02/05/2018 09:32 AM, Guido Aulisi wrote: >> >> Hi, >> according to latest python guides, we should avoid calling generic >> unversioned python command >> >

Ambiguous python version in waf

2018-02-05 Thread Guido Aulisi
python2 or python3, or use PYTHON_DISALLOW_AMBIGUOUS_VERSION=0? I got this problem in recent ardour5 rawhide builds (https://apps.fedoraproject.org/koschei/package/ardour5?collection=f28). Now I'm seeing that builds are back to normal and python2 has been downgraded. Thanks Guido Aulisi FAS

Re: Infrastructure move -- thanks

2017-12-11 Thread Guido Aulisi
Great job, thanks to everyone Guido fas account: tartina ___ devel mailing list -- devel@lists.fedoraproject.org To unsubscribe send an email to devel-le...@lists.fedoraproject.org

Re: Sailing to others seas

2017-09-20 Thread Guido Aulisi
2017-09-19 21:44 GMT+02:00 Alexandre Moine : > Hi all, > > Short version: I am leaving from fedora to archlinux. > > Long version: I really want to thank ALL of the fedora community, which > was more than friends. You have been in fact great teachers for me, when > I started

ardour5 build failures in rawhide

2017-09-15 Thread Guido Aulisi
o you think about it? Nils, please let me know your opinion when you have time. Thanks Guido Aulisi ___ devel mailing list -- devel@lists.fedoraproject.org To unsubscribe send an email to devel-le...@lists.fedoraproject.org

Re: No i686 kernel: Can we require SSE2 for i686?

2017-07-12 Thread Guido Aulisi
I'm still using some old 32 bit physical servers with Fedora, and they still work well! So I would like to have a 32 bit kernel for some other releases, maybe f28 if possible. Guido 2017-07-12 2:18 GMT+02:00 Solomon Peachy : > On Wed, Jul 12, 2017 at 12:00:05AM +0200, Zdenek

Comaintaining of lv2-x42-plugins

2017-06-28 Thread Guido Aulisi
Hi, I'd like to help update lv2-x42-plugins to the latest upstream version, so I asked for acls on pkgdb. As pkgdb is near EOL, I'm also writing here... Guido Aulisi signature.asc Description: This is a digitally signed message part ___ devel mailing

Upgrade of Ardour to latest version

2017-06-20 Thread Guido Aulisi
I'm going to upgrade ardour5 to the latest upstream version 5.10, starting with rawhide, f26, f25 and f24. Guido Aulisi signature.asc Description: This is a digitally signed message part ___ devel mailing list -- devel@lists.fedoraproject.org

Re: Retiring Packages with Broken Dependencies in branched (2017-06-12)

2017-06-13 Thread Guido Aulisi
Il giorno mar, 13/06/2017 alle 19.12 +0200, Till Maas ha scritto: > On Tue, Jun 13, 2017 at 11:14:37AM +0200, Guido Aulisi wrote: > > > This is going to break all audio applications in Fedora, because > > jack- > > audio-connection-kit is affected, but I cannot see

Re: Retiring Packages with Broken Dependencies in branched (2017-06-12)

2017-06-13 Thread Guido Aulisi
Il giorno mar, 13/06/2017 alle 11.11 +0100, Peter Robinson ha scritto: > I'm not sure how all those people can be co-maintainers of efl. I'm > not sure how that's meant to be interpreted but given some of the > other responses I think this script as bit rotted some what. > > Peter I think these

Re: Retiring Packages with Broken Dependencies in branched (2017-06-12)

2017-06-13 Thread Guido Aulisi
Il giorno lun, 12/06/2017 alle 22.38 +, t...@fedoraproject.org ha scritto: > In preparation for the Final Freeze on 2017-06-27 Release > Engineering will retire all packages in Branched with broken > dependencies and > all packages depending on these. If you get this e-mail directly this >

Possible patch to fix Ardour appdata

2017-05-23 Thread Guido Aulisi
. This patch should be applied after your commit 0f1915a7162a0f64d01 AppData release tags need a date to be valid I'm attaching my patch, maybe this could help accept the PR Bye Guido AulisiFrom bc6e617d1df5587d54bce40a7ac1e2f9e72896fe Mon Sep 17 00:00:00 2001 From: Guido Aulisi <guido.

Re: Update Ardour to 5.9.0

2017-05-19 Thread Guido Aulisi
Il giorno ven, 19/05/2017 alle 19.13 +0200, Nils Philippsen ha scritto: > On Fri, 2017-05-19 at 19:06 +0200, Nils Philippsen wrote: > > Hi Guido, > > > > On Fri, 2017-05-19 at 18:58 +0200, Guido Aulisi wrote: > > > Hi, > > > I'm updating Ardour 5

Update Ardour to 5.9.0

2017-05-19 Thread Guido Aulisi
Hi, I'm updating Ardour 5 to the latest 5.9.0 version in rawhide. Nils, I will wait for your review to update f26 and f25, too. Guido Aulisi fas account: tartina signature.asc Description: This is a digitally signed message part ___ devel mailing list

Upgrade of lv2 audio plugin system related packages in F26

2017-04-13 Thread Guido Aulisi
Hi, I have updated some LV2 related packages in F26, as announced some days ago. The packages are: lv2 serd sord sratom lilv suil FWIU any packages that depend on these should rebuild. There are no soname bumps, so old packages should work fine, but you could get enhancements if dependent

Conflicting gstreamer1-plugins packages in rawhide?

2017-04-12 Thread Guido Aulisi
I tried to build a new version of jalv package and I got a conflict between gstreamer1-plugins-bad-free-1.11.2-1.fc26.x86_64 and gstreamer1-plugins-base-1.11.90-1.fc27.x86_64 Local mockbuild for x86_64 had no errors. Partial output of root.log: DEBUG util.py:439:  Error: Transaction check error:

Upgrade of lv2 audio plugin system related packages in F26

2017-03-20 Thread Guido Aulisi
serdisplib-tools sonic-visualiser Thanks Guido Aulisi (fas account name: tartina) signature.asc Description: This is a digitally signed message part ___ devel mailing list -- devel@lists.fedoraproject.org To unsubscribe send an email to devel-le

Re: Gitignore configuration for packages

2017-03-16 Thread Guido Aulisi
Il giorno gio, 16/03/2017 alle 11.10 +, Tom Hughes ha scritto: > On 16/03/17 10:47, Guido Aulisi wrote: > > Il giorno gio, 16/03/2017 alle 10.38 +, Tom Hughes ha scritto: > > > On 16/03/17 10:32, Guido Aulisi wrote: > > > > > > > I was thinki

Re: Gitignore configuration for packages

2017-03-16 Thread Guido Aulisi
Il giorno gio, 16/03/2017 alle 10.38 +, Tom Hughes ha scritto: > On 16/03/17 10:32, Guido Aulisi wrote: > > > I was thinking about adding some default gitignores to package > > repositories, I think we need at least: > > > > /results_* > > /*.src.r

Gitignore configuration for packages

2017-03-16 Thread Guido Aulisi
it be a global fedora config? Guido Aulisi FAS account: tartina signature.asc Description: This is a digitally signed message part ___ devel mailing list -- devel@lists.fedoraproject.org To unsubscribe send an email to devel-le...@lists.fedoraproject.org

  1   2   >