Re: module 'posix' not found when module load mpi/mpich-x86_64

2020-07-01 Thread Tom Callaway
Lmod needed a little patch to detect Lua 5.4 as a valid version, but it's fixed and rebuilt in rawhide now (Lmod-8.3.17-2.fc33). Thanks, Tom On Tue, Jun 30, 2020 at 6:24 PM Miro Hrončok wrote: > On 30. 06. 20 19:34, Christoph Junghans wrote: > > Adding > > BuildRequires: lua-posix > > doesn't

Re: module 'posix' not found when module load mpi/mpich-x86_64

2020-06-30 Thread Miro Hrončok
On 30. 06. 20 19:34, Christoph Junghans wrote: Adding BuildRequires: lua-posix doesn't help. lua-posix was rebuilt for Lua 5.4 hence it is installed into /usr/share/lua/5.4 lmod searches in /usr/share/lua/5.3 Any ideas? Does lmod need a rebuild for lua-5.3? Given the above I assume Lmod

module 'posix' not found when module load mpi/mpich-x86_64

2020-06-30 Thread Christoph Junghans
Hi, when building some of my mpi packages, I got the following error message: + module load mpi/mpich-x86_64 ++ /usr/share/lmod/lmod/libexec/lmod sh load mpi/mpich-x86_64 /usr/bin/lua: /usr/share/lmod/lmod/libexec/lmod:61: module 'posix' not found: no field package.preload['posix'] no file