Test release of multicast NAND updater

2008-11-07 Thread Mitch Bradley
http://dev.laptop.org/~wmb/q2e22a.rom This firmware contains a test version of the multicast NAND update utility. It can clone an XO's NAND image onto any number of other XO's simultaneously. (It can also send NAND images from USB sticks,etc, but I'm not ready for people to begin testing

Re: Test release of multicast NAND updater

2008-11-07 Thread quozl
Test 3, a different place, B4 acting as sender, five C2 as receiver, channel 1, four C2 updated fine in one or two passes. The C2 that I mentioned before is continuing to give trouble. Same symptom occurs, usually between 20 and 200 blocks after starting. Have tried varying position, channel,

Re: Major differences between releases

2008-11-07 Thread Morgan Collett
On Mon, Sep 29, 2008 at 16:20, Morgan Collett [EMAIL PROTECTED] wrote: On Sun, Sep 28, 2008 at 21:43, C. Scott Ananian [EMAIL PROTECTED] wrote: On Sun, Sep 28, 2008 at 2:56 PM, Bert Freudenberg [EMAIL PROTECTED] wrote: I think it would be a good idea for everyone (activity authors in

Re: [sugar] Wrapping Sugar activities for other desktops

2008-11-07 Thread Martin Langhoff
On Fri, Nov 7, 2008 at 5:00 AM, Marco Pesenti Gritti [EMAIL PROTECTED] wrote: Sounds good, it's on the list of the things I'd really like to do but I'm too swamped to put focus on :( Ah, great to hear I'm not so lost in the woods! - journal behaviour - though it might be relatively simple

Re: Test release of multicast NAND updater

2008-11-07 Thread quozl
Worked great. Test 1, C2 as sender, channel 1, B4 as receiver, C2 copy-nand'd from os757.img, broadcast update worked fine, only three lost packets, and that was as I was handling the receiving unit. On the next run through the sequence numbers the missing packets were picked up, the NAND was

new journal

2008-11-07 Thread Tomeu Vizoso
Hi Scott, do you have any news for us about the work on your journal+datastore replacement? Thanks, Tomeu ___ Devel mailing list Devel@lists.laptop.org http://lists.laptop.org/listinfo/devel

Re: [sugar] Wrapping Sugar activities for other desktops

2008-11-07 Thread Marco Pesenti Gritti
On Fri, Nov 7, 2008 at 7:32 AM, Martin Langhoff [EMAIL PROTECTED] wrote: Thinking about how to extend the appeal (and long term viability!) of sugar activities, one thing that appears as a clear opportunity is to create a wrapper that allows to run sugar activities in a conventional

[Server-devel] A moodle rpm postinst issue with Pg

2008-11-07 Thread Martin Langhoff
One thing I discovered -- and will have to fix -- is that the Moodle rpm assumed that postgres is running during postinst. This is clearly not the case when we're installing/upgrading via anaconda, so I'll have to move that to the init script. Nothing major -- we're getting close :-) m --

Re: [Server-devel] Anaconda installs OOM with selinux-policy-targeted rpm from F9 updates

2008-11-07 Thread Daniel J Walsh
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Martin Langhoff wrote: One the last rounds of testing the new release of OLPCXS, I rebuilt it with fresh packages from F9 update and started testing the installer. Funny thing, the install did not complete -- instead, the machine would switch off

Re: [Server-devel] Anaconda installs OOM with selinux-policy-targeted rpm from F9 updates

2008-11-07 Thread Chris Lumens
- Anaconda OOMs without a warning or useful message to the user I don't believe there's any way for anaconda to know this, and there's certainly no way for us to do anything about it. - Chris ___ Server-devel mailing list [EMAIL PROTECTED]

Re: [Server-devel] Anaconda installs OOM with selinux-policy-targeted rpm from F9 updates

2008-11-07 Thread Dave Jones
On Fri, Nov 07, 2008 at 01:13:38AM -0500, Martin Langhoff wrote: One the last rounds of testing the new release of OLPCXS, I rebuilt it with fresh packages from F9 update and started testing the installer. Funny thing, the install did not complete -- instead, the machine would switch off

MPP with two XOs and a pppd via GPRS

2008-11-07 Thread Sameer Verma
I have two XOs (XO#1 and XO#2) with build 767. XO#1 is connected using wvdial (pppd) over GPRS. I am using Vodafone's service in India. By itself, XO#1 gets online. I do have to add the nameserver to /etc/resolv.conf but other than that, it works. When I try to set XO#1 as a MPP using the mpp.py