Re: [OMPI devel] hcoll missing libsharp

2019-10-15 Thread Gilles Gouaillardet via devel
Folks, -L/path/to/lib -lfoo will look for the foo library (libfoo.so or libfoo.a on Linux) in the /path/to/lib directory. In the case of a dynamic library (e.g. libfoo.so), its dependencies will *not* be searched in /path/to/lib (and this is where LD_LIBRARY_PATH helps) that can be

Re: [OMPI devel] hcoll missing libsharp

2019-10-15 Thread Gilles GOUAILLARDET via devel
Jeff, I agree we are not trying to run the binary here, but I am still puzzled here... Basically, gcc -o a.out foo.o -L/.../hcoll/lib -lhcoll and libhcoll.so depends on libsharp.so (that is in /.../sharp/lib) 1) do you expect this to just work even if the linker has no idea where to find

Re: [OMPI devel] hcoll missing libsharp

2019-10-15 Thread Gilles GOUAILLARDET via devel
Chris, I would try to add the directory containing libsharp in your LD_LIBRARY_PATH Cheers, Gilles On October 15, 2019, at 11:08 PM, Chris Ward via devel wrote: Adding an appropriate LDFLAGS= didn't help; the revised tarball is here http://tjcw.freeshell.org/ompi-output-2.tar.bz2 . Do I

Re: [OMPI devel] Is mpirun in slurm producing the correct "srun" cmd behind the scene?

2019-07-05 Thread Gilles Gouaillardet via devel
Lawrence, My apologies for the incorrect link. The patch is at https://github.com/open-mpi/ompi/pull/6672.patch Cheers, Gilles On Sat, Jul 6, 2019 at 12:21 PM Gilles Gouaillardet wrote: > > Lawrence, > > this is a known issue (--cpu_bind optioned was removed from SLURM in > favor of the

Re: [OMPI devel] Is mpirun in slurm producing the correct "srun" cmd behind the scene?

2019-07-05 Thread Gilles Gouaillardet via devel
Lawrence, this is a known issue (--cpu_bind optioned was removed from SLURM in favor of the --cpu-bind option) and the fix will be available in Open MPI 4.0.1 Meanwhile, you can manually download and apply the patch at https://github.com/open-mpi/ompi/pull/6445.patch or use a nightly build of

Re: [OMPI devel] Fw: Is OMPI_ENABLE_HETEROGENEOUS_SUPPORT still supported ?

2019-05-14 Thread Gilles Gouaillardet via devel
Hi Chris, This is supported (but lightly tested) You should grep OPAL_ENABLE_HETEROGENEOUS_SUPPORT instead. All you need is to configure --enable-heterogeneous ... Cheers, Gilles Sent from my iPod > On May 14, 2019, at 19:12, Chris Ward via devel > wrote: > >