[Devel] Re: [PATCH] pidns: Limit kill -1 and cap_set_all

2007-10-29 Thread Kirill Korotaev
I dislike this patch: it's not scalable/efficient to travers all the tasks while we know the pid namespace we care about. Kirill Eric W. Biederman wrote: This patch implements task_in_pid_ns and uses it to limit cap_set_all and sys_kill(-1,) to only those tasks in the current pid namespace.

[Devel] [PATCH] watchdog: spin_lock_init() fixes

2007-10-29 Thread Alexey Dobriyan
Some watchdog drivers initialize global spinlocks in module's init function which is tolerable, but some do it in PCI probe function. So, switch to static initialization to fix theoretical bugs and, more importantly, stop giving people bad examples. Signed-off-by: Alexey Dobriyan [EMAIL

[Devel] Re: [PATCH] Signal semantics for /sbin/init

2007-10-29 Thread Dave Hansen
On Sat, 2007-10-27 at 12:00 -0700, [EMAIL PROTECTED] wrote: +static int sig_init_ignore(struct task_struct *tsk) +{ -static int sig_ignored(struct task_struct *t, int sig) + // Currently this check is a bit racy with exec(), + // we can _simplify_ de_thread and close the race. +

[Devel] [PATCH] Report usage in CFS cgroup

2007-10-29 Thread Paul Menage
Report CPU usage in CFS Cgroup directories Adds a cpu.usage file to the CFS cgroup that reports CPU usage in milliseconds for that cgroup's tasks Signed-off-by: Paul Menage [EMAIL PROTECTED] --- kernel/sched.c | 36 +++- 1 file changed, 31 insertions(+), 5

[Devel] Re: [PATCH] pidns: Limit kill -1 and cap_set_all

2007-10-29 Thread Dave Hansen
On Mon, 2007-10-29 at 11:59 -0600, Eric W. Biederman wrote: ier to read.) Also, can we think of any better name for this? It seems a bit funky that: pid_in_pid_ns(mypid, init_pid_ns); would _ever_ return 0. It can't. So, it isn't truly a test for belonging *in* a

[Devel] Re: [PATCH] pidns: Limit kill -1 and cap_set_all

2007-10-29 Thread Eric W. Biederman
Kirill Korotaev [EMAIL PROTECTED] writes: I dislike this patch: it's not scalable/efficient to travers all the tasks while we know the pid namespace we care about. Well the unix way is to implement it simple and stupid and then to optimize, where needed. We don't currently have a per pid

Re: [Devel] [PATCH] pidns: Place under CONFIG_EXPERIMENTAL (take 2)

2007-10-29 Thread Cedric Le Goater
Eric W. Biederman wrote: Andrew Morton [EMAIL PROTECTED] writes: On Sat, 27 Oct 2007 04:04:08 +0200 Adrian Bunk [EMAIL PROTECTED] wrote: be happy to hear if someone has a better idea. There is a difference between complete the feature and early adopters to start playing with the feature on

Re: [Devel] [PATCH] pidns: Place under CONFIG_EXPERIMENTAL (take 2)

2007-10-29 Thread Eric W. Biederman
Cedric Le Goater [EMAIL PROTECTED] writes: Pavel also has a CONFIG_NAMESPACES patch that he should be resending to andrew when 2.6.24-rc1-mm1 is released. pidns will go under this option, like all the other namespaces, and should protect the distros from shipping any immature namespace.

[Devel] Re: [PATCH] pidns: Place under CONFIG_EXPERIMENTAL (take 2)

2007-10-29 Thread Eric W. Biederman
Kirill Korotaev [EMAIL PROTECTED] writes: Can you please send namespace related patches to containers@ ML first before sending them to Linus/Andrew? If you are so anxious to review my patches can you please review them? I'd love to see an acked-by or an actual bug found. I only did what I

Re: [Devel] [PATCH] pidns: Place under CONFIG_EXPERIMENTAL (take 2)

2007-10-29 Thread Eric W. Biederman
Cedric Le Goater [EMAIL PROTECTED] writes: The outstanding issues I can think of off the top of my head: - signal handling for init on secondary pid namespaces. - Properly setting si_pid on signals that cross namespaces. these are being addressed by suka patches, and also you with the latest

[Devel] Re: [RFC] [-mm PATCH] Memory controller fix swap charging context in unuse_pte()

2007-10-29 Thread Hugh Dickins
On Mon, 29 Oct 2007, Balbir Singh wrote: On Mon, Oct 29, 2007 at 01:57:40AM +0530, Balbir Singh wrote: Hugh Dickins wrote: [snip] Without your mem_cgroup mods in mm/swap_state.c, unuse_pte makes the right assignments (I believe). But I find that swapout (using 600M in a 512M

[Devel] Re: [PATCH 1/2] Container-init must be immune to unwanted signals

2007-10-29 Thread Eric W. Biederman
[EMAIL PROTECTED] writes: Note: this patch applies on top of Eric's patch: http://lkml.org/lkml/2007/10/26/440 --- From: Sukadev Bhattiprolu [EMAIL PROTECTED] Subject: [PATCH 1/2] Container-init must be immune to unwanted signals Container-init process must appear like a normal

[Devel] Re: [PATCH] Masquerade sender information

2007-10-29 Thread Eric W. Biederman
[EMAIL PROTECTED] writes: From: Sukadev Bhattiprolu [EMAIL PROTECTED] Subject: [PATCH] Masquerade sender information With multiple pid namespaces, sender of a signal could be in an ancestor namespace of the receiver and so the sender will not have a valid 'pid_t' in the receiver's

[Devel] Re: [RFC] [-mm PATCH] Memory controller fix swap charging context in unuse_pte()

2007-10-29 Thread Balbir Singh
Hugh Dickins wrote: On Mon, 29 Oct 2007, Balbir Singh wrote: On Mon, Oct 29, 2007 at 01:57:40AM +0530, Balbir Singh wrote: Hugh Dickins wrote: [snip] Without your mem_cgroup mods in mm/swap_state.c, unuse_pte makes the right assignments (I believe). But I find that swapout (using 600M

[Devel] Fw: [PATCH 2/2] Warn when container-init defaults fatal signals

2007-10-29 Thread sukadev
Resend to the Eric's correct address... Suka - Forwarded message from [EMAIL PROTECTED] - | Date: Sat, 27 Oct 2007 12:09:28 -0700 | From: [EMAIL PROTECTED] | To: [EMAIL PROTECTED], Pavel Emelianov [EMAIL PROTECTED],Oleg Nesterov | [EMAIL PROTECTED] | Cc: Containers [EMAIL

[Devel] Re: [PATCH] Signal semantics for /sbin/init

2007-10-29 Thread Eric W. Biederman
[EMAIL PROTECTED] writes: (This is Oleg's patch with my tweaks to compile, Oleg pls sign-off). --- From: Sukadev Bhattiprolu [EMAIL PROTECTED] Subject: [PATCH 1/3] Signal semantics for /sbin/init Currently, /sbin/init is protected from unhandled signals by the current ==

[Devel] Re: [DRAFT] Container mini-summit notes v0.01

2007-10-29 Thread Oren Laadan
[EMAIL PROTECTED] wrote: Oren Laadan [EMAIL PROTECTED] wrote: | | (sorry from the delay, been away :) | | Eric W. Biederman wrote: | Serge E. Hallyn [EMAIL PROTECTED] writes: | | Sorry, I was focusing on the virtual server needs. | | devpts is it's own fs so I was fully expecting to

[Devel] Re: [PATCH][BUGFIX][for -mm] Misc fix for memory cgroup [4/5] skip !PageLRU page in mem_cgroup_isolate_pages

2007-10-29 Thread Balbir Singh
KAMEZAWA Hiroyuki wrote: I'm sorry that this patch needs following fix.. Andrew, could you apply this ? (All version I sent has this bugSigh) Thanks, -Kame == Bugfix for memory cgroup skip !PageLRU page in mem_cgroup_isolate_pages Signed-off-by: KAMEZAWA Hiroyuki [EMAIL PROTECTED]