[Devel] Re: [BUG] cpu controller can't provide fair CPU time for each group

2009-11-11 Thread Yasunori Goto
After receiving your mail, I realized I misunderstood about test case 1). I thought 1) was occur without cpu affinity due to mis-communication with test team. I'm really really sorry for noise. I need much coffee. :-( On Wed, 2009-11-11 at 15:21 +0900, Yasunori Goto wrote: When users use

[Devel] Re: [BUG] cpu controller can't provide fair CPU time for each group

2009-11-11 Thread Peter Zijlstra
On Wed, 2009-11-11 at 15:21 +0900, Yasunori Goto wrote: Someone needs to fix that if they really care. To be honest, I don't have any good idea because I'm not familiar with schduler's code. You could possible try something like the below, its rather gross but might maybe work,.. has other

[Devel] Re: [PATCH 1/1] implement s390 clone_with_pids syscall

2009-11-11 Thread Serge E. Hallyn
Quoting Nathan Lynch (nath...@austin.ibm.com): + parent_tid_ptr = (int *)kca.parent_tid_ptr; + child_tid_ptr = (int *)kca.child_tid_ptr; + + stack_size = (unsigned long)kca.child_stack_size; + child_stack = (unsigned long)kca.child_stack_base; + if (child_stack) +

[Devel] [PATCH 0/4] Introduction: LSM c/r patchset

2009-11-11 Thread serue
Here is a resend of the LSM c/r patchset. The SELinux set could stand a few acks, but since our c/r tree is somewhat behind upstream, I'll wait until we forward-port to resend to the selinux list and seek those ACKS. Can we get the rest of the patches applied now? All tests pass with this set

[Devel] [PATCH 1/4] add lsm name and lsm_info (policy header) to container info

2009-11-11 Thread serue
From: Serge E. Hallyn se...@us.ibm.com The LSM name is 'selinux', 'smack', 'tomoyo', or 'dummy'. We add that to the container configuration section. We also add a LSM policy configuration section. That is placed after the LSM name. It is written by the LSM in security_checkpoint_header(),

[Devel] [PATCH 4/4] cr: add selinux support (v6)

2009-11-11 Thread serue
From: Serge E. Hallyn se...@us.ibm.com Documentation/checkpoint/readme.txt begins: Application checkpoint/restart is the ability to save the state of a running application so that it can later resume its execution from the time at which it was checkpointed. This patch adds the ability to

[Devel] [PATCH user-cr] restart: accept the lsm_name field in header and add -k flag (v2)

2009-11-11 Thread serue
From: Serge E. Hallyn se...@us.ibm.com The checkpoint file header now has an 11-character string containing the name of the active LSM, following the uts info, and a variable length buffer type conaining LSM-specific version information (for instance a sha1sum of policy). Handle these. Also add

[Devel] [PATCH 2/4] cr: add generic LSM c/r support (v7)

2009-11-11 Thread serue
From: Serge E. Hallyn se...@us.ibm.com Documentation/checkpoint/readme.txt begins: Application checkpoint/restart is the ability to save the state of a running application so that it can later resume its execution from the time at which it was checkpointed. This patch adds generic support for

[Devel] Re: [PATCH 1/1] implement s390 clone_with_pids syscall

2009-11-11 Thread Serge E. Hallyn
Quoting Nathan Lynch (nath...@austin.ibm.com): On Wed, 2009-11-11 at 08:46 -0600, Serge E. Hallyn wrote: Quoting Nathan Lynch (nath...@austin.ibm.com): + parent_tid_ptr = (int *)kca.parent_tid_ptr; + child_tid_ptr = (int *)kca.child_tid_ptr; + + stack_size

[Devel] Re: [PATCH 1/4] Unify skb read/write functions and fix for fragmented buffers

2009-11-11 Thread Serge E. Hallyn
Quoting Dan Smith (da...@us.ibm.com): The INET code often creates socket buffers by attaching fragments instead of writing to the linear region. This extends the skb write functions to write out the linear and fragment regions of an skb, and adds a function to be used by others wishing to

[Devel] Re: [PATCH 5/6] Makes procs file writable to move all threads by tgid at once

2009-11-11 Thread Daniel Lezcano
Li Zefan wrote: Hi Ben, The current code (with or without your patch) may lead to an error because the fork hook can fail and the exit hook is called in all the cases making the fork / exit asymmetric. The _current_ code won't lead to this error, because the fork hook can't

[Devel] Re: [PATCH 2/4] [RFC] Add c/r support for connected INET sockets (v4)

2009-11-11 Thread Serge E. Hallyn
Quoting Dan Smith (da...@us.ibm.com): This patch adds basic support for C/R of open INET sockets. I think that all the important bits of the TCP and ICSK socket structures is saved, but I think there is still some additional IPv6 stuff that needs to be handled. With this patch applied, the

[Devel] Re: [PATCH 1/1] implement s390 clone_with_pids syscall

2009-11-11 Thread Serge E. Hallyn
Quoting Nathan Lynch (nath...@austin.ibm.com): Something I missed earlier is that the stack_size you are passing in from user space is not actually the size of the stack. It's adjusted to account for arguments that have been placed at the end of the stack region. So stack_size becomes a

[Devel] Re: [BUG] cpu controller can't provide fair CPU time for each group

2009-11-11 Thread Chris Friesen
On 11/11/2009 01:20 AM, Peter Zijlstra wrote: On Wed, 2009-11-11 at 15:21 +0900, Yasunori Goto wrote: When users use cpuset/cpu affinity, then they would like to controll cpu affinity. Not CPU time. What are people using affinity for? The only use of affinity is to restrict or disable

[Devel] Re: [BUG] cpu controller can't provide fair CPU time for each group

2009-11-11 Thread Peter Zijlstra
On Wed, 2009-11-11 at 14:39 -0600, Chris Friesen wrote: On 11/11/2009 01:20 AM, Peter Zijlstra wrote: On Wed, 2009-11-11 at 15:21 +0900, Yasunori Goto wrote: When users use cpuset/cpu affinity, then they would like to controll cpu affinity. Not CPU time. What are people using

[Devel] Re: [PATCH 3/4] Update the UNIX buffer restore code to match the new format saved in the image file

2009-11-11 Thread Serge E. Hallyn
Quoting Dan Smith (da...@us.ibm.com): /* Make sure there's room in the send buffer */ sndbuf = sk-sk_sndbuf; - if (((sk-sk_sndbuf - atomic_read(sk-sk_wmem_alloc)) len) + if (((sk-sk_sndbuf - atomic_read(sk-sk_wmem_alloc)) h-lin_len) capable(CAP_NET_ADMIN)) -

[Devel] Re: [PATCH 3/4] Update the UNIX buffer restore code to match the new format saved in the image file

2009-11-11 Thread Dan Smith
/* Make sure there's room in the send buffer */ sndbuf = sk-sk_sndbuf; -if (((sk-sk_sndbuf - atomic_read(sk-sk_wmem_alloc)) len) +if (((sk-sk_sndbuf - atomic_read(sk-sk_wmem_alloc)) h-lin_len) capable(CAP_NET_ADMIN)) -sk-sk_sndbuf += len; +sk-sk_sndbuf +=

[Devel] Re: [v12][PATCH 0/9] Implement eclone() syscall

2009-11-11 Thread Sukadev Bhattiprolu
Cc: LKML Sukadev Bhattiprolu [suka...@linux.vnet.ibm.com] wrote: | | Based on discussions on containers mailing list and IRC, we settled on | the name eclone(). Please let me know of a better name or if there are | other comments on the patchset. | | --- | | Subject: [v12][PATCH 0/9] Implement

[Devel] Re: [v12][PATCH 1/9] Factor out code to allocate pidmap page

2009-11-11 Thread Sukadev Bhattiprolu
Cc LKML Sukadev Bhattiprolu [suka...@linux.vnet.ibm.com] wrote: | | Subject: [v12][PATCH 1/9] Factor out code to allocate pidmap page | | To simplify alloc_pidmap(), move code to allocate a pid map page to a | separate function. | | Changelog[v3]: | - Earlier version of patchset called

[Devel] Re: [v12][PATCH 3/9] Define set_pidmap() function

2009-11-11 Thread Sukadev Bhattiprolu
Cc: LKML Sukadev Bhattiprolu [suka...@linux.vnet.ibm.com] wrote: | | Subject: [v12][PATCH 3/9] Define set_pidmap() function | | Define a set_pidmap() interface which is like alloc_pidmap() only that | caller specifies the pid number to be assigned. | | Changelog[v9]: | - Completely

[Devel] Re: [v12][PATCH 7/9] Define do_fork_with_pids()

2009-11-11 Thread Sukadev Bhattiprolu
cc: lkml Sukadev Bhattiprolu [suka...@linux.vnet.ibm.com] wrote: | | Subject: [v12][PATCH 7/9] Define do_fork_with_pids() | | do_fork_with_pids() is same as do_fork(), except that it takes an | additional, 'pid_set', parameter. This parameter, currently unused, | specifies the set of target

[Devel] Re: [v12][PATCH 4/9] Add target_pids parameter to alloc_pid()

2009-11-11 Thread Sukadev Bhattiprolu
Cc: LKML Sukadev Bhattiprolu [suka...@linux.vnet.ibm.com] wrote: | | Subject: [v12][PATCH 4/9] Add target_pids parameter to alloc_pid() | | This parameter is currently NULL, but will be used in a follow-on patch. | | Signed-off-by: Sukadev Bhattiprolu suka...@linux.vnet.ibm.com | Acked-by:

[Devel] Re: [v12][PATCH 5/9] Add target_pids parameter to copy_process()

2009-11-11 Thread Sukadev Bhattiprolu
CC: LKML Sukadev Bhattiprolu [suka...@linux.vnet.ibm.com] wrote: | | Subject: [v12][PATCH 5/9] Add target_pids parameter to copy_process() | | Add a 'target_pids' parameter to copy_process(). The new parameter will be | used in a follow-on patch when eclone() is implemented. | |

[Devel] Re: [v12][PATCH 6/9] Check invalid clone flags

2009-11-11 Thread Sukadev Bhattiprolu
Cc: LKML Sukadev Bhattiprolu [suka...@linux.vnet.ibm.com] wrote: | | Subject: [v12][PATCH 6/9] Check invalid clone flags | | As pointed out by Oren Laadan, we want to ensure that unused bits in the | clone-flags remain unused and available for future. To ensure this, define | a mask of

[Devel] Re: [v12][PATCH 8/9] Define eclone() syscall

2009-11-11 Thread Sukadev Bhattiprolu
cc: lkml Sukadev Bhattiprolu [suka...@linux.vnet.ibm.com] wrote: | | Subject: [v12][PATCH 8/9] Define eclone() syscall | | Container restart requires that a task have the same pid it had when it was | checkpointed. When containers are nested the tasks within the containers | exist in multiple

[Devel] Re: [v12][PATCH 9/9] Document eclone() syscall

2009-11-11 Thread Sukadev Bhattiprolu
CC: LKML Sukadev Bhattiprolu [suka...@linux.vnet.ibm.com] wrote: | | Subject: [v12][PATCH 9/9] Document eclone() syscall | | This gives a brief overview of the eclone() system call. We should | eventually describe more details in existing clone(2) man page or in | a new man page. | |

[Devel] Re: [BUG] cpu controller can't provide fair CPU time for each group

2009-11-11 Thread Yasunori Goto
On Wed, 2009-11-11 at 15:21 +0900, Yasunori Goto wrote: Someone needs to fix that if they really care. To be honest, I don't have any good idea because I'm not familiar with schduler's code. You could possible try something like the below, its rather gross but might maybe work,..

[Devel] Re: [PATCH 3/4] Update the UNIX buffer restore code to match the new format saved in the image file

2009-11-11 Thread Serge E. Hallyn
Quoting Dan Smith (da...@us.ibm.com): /* Make sure there's room in the send buffer */ sndbuf = sk-sk_sndbuf; - if (((sk-sk_sndbuf - atomic_read(sk-sk_wmem_alloc)) len) + if (((sk-sk_sndbuf - atomic_read(sk-sk_wmem_alloc)) h-lin_len) capable(CAP_NET_ADMIN)) - sk-sk_sndbuf