Re: Ticket #3515: covoar failure while running for full testsuites

2020-02-20 Thread Bran S
On Wed, 19 Feb 2020 at 22:51, Vijay Kumar Banerjee wrote: > > > > On Mon, Feb 17, 2020 at 12:08 AM Bran S wrote: >> >> Hi Guys, >> > Hi Bran! >> >> I am trying to understand and solve Ticket #3515. >> https://devel.rtems.org/ticket/3515 >>

Ticket #3515: covoar failure while running for full testsuites

2020-02-16 Thread Bran S
Hi Guys, I am trying to understand and solve Ticket #3515. https://devel.rtems.org/ticket/3515 $ /home/user45/quick-start/rtems/5/share/rtems/tester/bin/covoar - -S /home/user45/quick-start/rtems/5/share/rtems/tester/rtems/testing/coverage/leon3-sis-symbols.ini -O leon3-sis-coverage -E

Re: Ticket #3515

2020-02-06 Thread Bran S
On Tue, 4 Feb 2020 at 13:28, Vijay Kumar Banerjee wrote: > > > On Tue, Feb 4, 2020, 11:33 AM Bran S wrote: > >> On Saturday, 1 February 2020, Vijay Kumar Banerjee < >> vijaykumar9...@gmail.com> wrote: >> > >> > >> > >> > On Sa

#1977 mq_open lacks support of "mode" argument

2020-02-04 Thread Bran S
Trying to solve ticket https://devel.rtems.org/ticket/1977 The mode parameter sets access permissions for the created message queue. Examples: S_IRUSR 00400 user has read permission S_IWUSR 00200 user has write permission S_IXUSR 00100 user has execute permission Complete list is at:

Re: Ticket #3515

2020-02-01 Thread Bran S
On Sat, 1 Feb 2020 at 18:44, Vijay Kumar Banerjee wrote: > > On Sat, Feb 1, 2020 at 12:57 PM Bran S wrote: >> >> On Thu, 30 Jan 2020 at 05:52, Chris Johns wrote: >> > >> > On 29/1/20 7:03 pm, Bran S wrote: >> > > Hi Guys, >> > > >

Re: Ticket #3515

2020-01-31 Thread Bran S
On Thu, 30 Jan 2020 at 05:52, Chris Johns wrote: > > On 29/1/20 7:03 pm, Bran S wrote: > > Hi Guys, > > > > I am trying to solve #3515 > > https://devel.rtems.org/ticket/3515 <https://devel.rtems.org/ticket/3515> > > Nice and thanks. > > > For

Ticket #3515

2020-01-29 Thread Bran S
Hi Guys, I am trying to solve #3515 https://devel.rtems.org/ticket/3515 For this issue covoar is required. So I cloned https://git.rtems.org/rtems-tools/ This is my directory structure: $HOME/quick-start/src/rtems - Main RTEMS repo $HOME/quick-start/src/rsb - Source Builder

Re: #2920 -> #3515

2020-01-28 Thread Bran S
On Tue, 28 Jan 2020 at 23:17, Joel Sherrill wrote: > >> >> Then I ran `hello.exe` using the command `sparc-rtems5-gdb hello.exe` >> inside gdb. >> But when I did `target sim` it displayed (Undefined target command: "sim") >> As a workaround, using `sparc-rtems5-sis` to run hello.exe worked. >> As

#2920 -> #3515

2020-01-28 Thread Bran S
Hi Guys, I am new to rtems. Looking to solve some issues to get familiar with the project. While going through the ticket list I found issue #3515. I would like to solve this. Background Work: Following the quick-start guide I have built rtems5 and rsb. Ran the 600 tests on BSP erc32 of which 5