[Server-devel] xs-config packaging

2008-08-27 Thread Jerry Vonau
Martin: For F9 your going to need to add to the xs-config.spec.in requires: libertas-usb8388-firmware To fit into fedora's packaging guidelines, shouldn't altfiles and scripts live in /usr/share/xs-config and not /? Jerry ___ Server-devel mailing

Re: [Server-devel] Network address for activation - Fwd: [Techteam] Activating laptops from the school server

2008-08-28 Thread Jerry Vonau
John Watlington wrote: Martin, that shouldn't be needed. Somewhere, network_config has gotten screwed up... On Aug 28, 2008, at 4:24 AM, Martin Langhoff wrote: yup, all three ifcfg-brX files have device=br0 edit ifcfg-br1: DEVICE=br1 and ifcfg-br2 DEVICE=br2 OR do you want msh0, msh1, and

Re: [Server-devel] Network address for activation - Fwd: [Techteam] Activating laptops from the school server

2008-08-28 Thread Jerry Vonau
Jerry Vonau wrote: OR do you want msh0, msh1, and msh2 on the same bridge? That would require editing the BRIDGE= line to be the same bridge device in all three ifcfg-mshX files Sorry make that read TYPE= time for sleep in a bit, Jerry

Re: [Server-devel] Using bridges and interrupt load

2008-09-04 Thread Jerry Vonau
Martin Langhoff wrote: In the XS networking infrastructure we sometimes setup a bridge with an IP address and netblock (as you would with an interface) and then if-and-when the HW interface comes up, we assign the interface to the bridge. This is a technique used quite a bit on projects

Re: [Server-devel] Notes on replacing bridging with bonding

2008-09-08 Thread Jerry Vonau
Jerry Vonau wrote: Jerry Vonau wrote: Martin Langhoff wrote: On Mon, Sep 8, 2008 at 7:43 PM, Alexander Dupuy [EMAIL PROTECTED] wrote: I have placed TYPE=Bonding in the ifcfg-bond0 config files, but this is not needed for Fedora 7 or later (it doesn't hurt to have it, though) well, I grepped

Re: [Server-devel] Notes on replacing bridging with bonding

2008-09-08 Thread Jerry Vonau
Jerry Vonau wrote: Jerry Vonau wrote: Jerry Vonau wrote: Martin Langhoff wrote: On Mon, Sep 8, 2008 at 7:43 PM, Alexander Dupuy [EMAIL PROTECTED] wrote: I have placed TYPE=Bonding in the ifcfg-bond0 config files, but this is not needed for Fedora 7 or later (it doesn't hurt to have

Re: [Server-devel] F9 XS - Take it for a spin...

2008-09-09 Thread Jerry Vonau
Martin Langhoff wrote: with some caveats... this is a developer preview, lots of things are b0rken, but still... - download all 759MB of iso here http://xs-dev.laptop.org/xs/other/Fedora-0.5.dev2-i386.iso - Burn it to a DVD (see notes below on using USB sticks) - Install it on a new

Re: [Server-devel] A few F9 upgrade things I need help with...

2008-09-09 Thread Jerry Vonau
Martin Langhoff wrote: As part of the XS upgrade, I've ended up caught with a number of F9 oddities -- none of them a complete blocker, but definitely rought edges... - Cannot include beecrypt in Pungi/Revisor build - this is probably a bug worthy of filing in BZ but needs a bit of

Re: [Server-devel] Revisor / yum oddity: anaconda-runtime

2008-09-18 Thread Jerry Vonau
Martin Langhoff wrote: On Fedora 9, using F9's revisor which has not changed in a while... - last week, I was able to invoke revisor and create a new installer CD without any problem... - this week, buildinstall dies, and if I enable logging it complains missing anaconda-runtime - this

Re: [Server-devel] Getting closer: XS-0.5-dev5 preview

2008-10-14 Thread Jerry Vonau
Martin Langhoff wrote: On Tue, Oct 14, 2008 at 1:59 PM, Martin Langhoff [EMAIL PROTECTED] wrote: Grab it and take it for a spin http://xs-dev.laptop.org/xs/other/OLPCXS-0.5-dev5-i386.iso http://xs-dev.laptop.org/xs/other/OLPCXS-0.5-dev6-i386.iso is now slowly being copied to the server.

Re: [Server-devel] Getting closer: XS-0.5-dev5 preview

2008-10-14 Thread Jerry Vonau
Martin Langhoff wrote: Fantastic testing - thanks! More notes below... On Wed, Oct 15, 2008 at 12:35 PM, Jerry Vonau [EMAIL PROTECTED] wrote: The automated kickstart install pauses at the method screen for input. This could be avoided by adding method=cdrom:/dev/sr0 to the boot prompt

Re: [Server-devel] Getting closer: XS-0.5-dev5 preview

2008-10-15 Thread Jerry Vonau
Martin Langhoff wrote: On Wed, Oct 15, 2008 at 2:04 PM, Jerry Vonau [EMAIL PROTECTED] wrote: However domain_config is leaving its xs_domain_name file in olpc-scripts instead of sysconfig causing make dhcpd.conf and thus dhcpd to fail. That is very weird - and was fixed ages ago - perhaps

Re: [Server-devel] XS 0.4 to 0.5 upgrade (vs. reinstall) path

2008-11-10 Thread Jerry Vonau
Bill Bogstad wrote: Is there a supported 0.4 to 0.5 upgrade path for the XS software which doesn't involve a disk reformat? I tried using one of the 0.5 dev ISOs on a test install of 0.4 and couldn't figure out an install which didn't involve a disk format? I'm hoping that I'm just missing

Re: [Server-devel] XS 0.5 upgrade notes

2008-11-12 Thread Jerry Vonau
Martin Langhoff wrote: On Wed, Nov 12, 2008 at 12:31 AM, Douglas Bagnall [EMAIL PROTECTED] wrote: Some issues noticed with an upgrade from XS 0.4 to a XS 0.5 candidate. At this point I tried to yum upgrade to get changes I'd made since spinning the ISO, but nothing happened, because:

Re: [Server-devel] iso size

2008-11-17 Thread Jerry Vonau
Martin Langhoff wrote: On Sun, Nov 16, 2008 at 12:04 PM, Jerry Vonau [EMAIL PROTECTED] wrote: Well, the upgrade is not painful. The weird thing I found is about yum, $releasever, and fedora-updates.repo, we have two issues.. First with the use of xs-release when I do a rpm -q --whatprovides

Re: [Server-devel] iso size

2008-11-17 Thread Jerry Vonau
Martin Langhoff wrote: On Sun, Nov 16, 2008 at 2:37 PM, Jerry Vonau [EMAIL PROTECTED] wrote: Well other issues popped up, avahi from F7 appeared in a rpm -q avahi along with the one from F9 like above. Quick fix: rpm -e --justdb avahi-0.6.17-1.fc7.i386 This an upstream issue, the rpm exit

Re: [Server-devel] Networking on Version 0.5 .

2008-12-03 Thread Jerry Vonau
Eroni Tuiloma wrote: hello . Hi: ive been having problem with version 0.5 in the sense that 1. eth0 - main interface for WAN works fine as in it picks up the ip-address from the isp/dhcp 2.eth1- the LAN interface does not seem to function at all as a dhcp server . ive looked at the

Re: [Server-devel] XS 0.5 Second Attempt at eth1

2008-12-04 Thread Jerry Vonau
Reuben K. Caron wrote: Thanks for clarification. Still no go: Dec 4 12:12:24 schoolserver1 kernel: eth0: link up, 100Mbps, full-duplex, lpa 0xC1E1 Dec 4 12:12:24 schoolserver1 kernel: eth0: link up, 100Mbps, full-duplex, lpa 0xC1E1 Dec 4 12:12:24 schoolserver1 kernel: Ethernet Channel

Re: [Server-devel] XS 0.5 Second Attempt at eth1

2008-12-04 Thread Jerry Vonau
Anna wrote: Per Jerry's suggestion, I added this to /etc/modprobe.d/xs_bonding and deleted stuff from the prior suggestion, though I can put that back in if it's going to make a difference. options lanbond0 mode=active-backup arp_interval=1000 arp_ip_target= 172.18.96.5 I went ahead and

Re: [Server-devel] Amateurish Workaround to Get Bonding to Work With eth1

2008-12-10 Thread Jerry Vonau
Anna wrote: This is probably far from ideal, but it works for me and I'm putting it out there in case you're messing with XS 0.5 and need to have eth1 working now so you can test other stuff. I'm sure there's a more elegant solution. Put this in /etc/rc.local ifenslave lanbond0 eth1

[Server-devel] XO

2009-01-08 Thread Jerry Vonau
Hi All: Ok, I just received my XOs, being an absolute newbie with the XO, if all I see upon booting is a gray screen and the XO logo, and I don't get asked for a name as shown at: http://www.laptop.org/8.2.0/manual/XO_Starting.html I need to load an os image on this puppy, correct? If I hold

Re: [Server-devel] Notes about XS on XO...

2009-01-08 Thread Jerry Vonau
On Thu, 2009-01-08 at 11:48 -0200, Martin Langhoff wrote: Jerry prompted me to think about what's interesting to hack on around running XS on the XO... these are somewhat rambling notes... - we need to think about what to do to for handling the /library partition - need to think the workflow

Re: [Server-devel] XS 05

2009-01-20 Thread Jerry Vonau
On Fri, 2009-01-16 at 14:15 -0200, Martin Langhoff wrote: On Fri, Jan 16, 2009 at 12:12 PM, Henry Vélez Molina henry.lap...@gmail.com wrote: Thanks Martin for you answer. No problem! We have been trying to install the server via the Kickstart, but that happens when anaconda to start

Re: SoaS on the XO progress

2009-01-22 Thread Jerry Vonau
On Thu, 2009-01-22 at 18:01 -0500, Chris Ball wrote: Hi Marco, Some extra steps: * Clone git://git.fedoraproject.org/spin-kickstarts * If you want F10 apply spin.patch * Apply live.patch in /usr/lib/python2.5/site-packages/imgcreate * sudo yum -y install livecd-tools

Re: Joyide on Fedora 11/rawhide

2009-02-04 Thread Jerry Vonau
On Wed, 2009-02-04 at 20:47 +0100, Peter Robinson wrote: Hi Chris, I wanted to put it to the lists and get some feedback, with the plans on basing the 9.1.0 release on Fedora 11 I think we need to have a testing stream based on rawhide so that we can start testing core OS

Re: Joyide on Fedora 11/rawhide

2009-02-04 Thread Jerry Vonau
On Wed, 2009-02-04 at 15:05 -0500, Chris Ball wrote: Hi Jerry, I've been playing with booting fedora on the XO, mostly with anaconda (F9/F10) to be able to run an install on the XO itself for the XS. I'll try to boot the F11 kernel/installer when one is available, it looks

Re: [Server-devel] xs-activation-server over IPv6

2009-02-05 Thread Jerry Vonau
On Thu, 2009-02-05 at 11:04 -0300, Daniel Drake wrote: I have got xs-activation-server working over IPv6. It is quite simple. Firstly, the server must bind to a hardcoded address on the LAN. This can be done with this command: ip addr add fe80::abcd:ef01/64 dev lanbond0 Secondly,

Re: [Server-devel] updates

2009-02-05 Thread Jerry Vonau
On Thu, 2009-01-29 at 08:48 +1300, Martin Langhoff wrote: On Thu, Jan 29, 2009 at 5:24 AM, Jerry Vonau jvo...@shaw.ca wrote: Next, find a regular PC that is capable of reading SD cards. We're using Oh, good point. I thought that the XO SD reader was handled by the same kernel module

Re: [Server-devel] XS 0.5.1 RC - Last round of testing...

2009-02-13 Thread Jerry Vonau
On Thu, 2009-02-12 at 23:30 -0800, Sameer Verma wrote: On Wed, Feb 11, 2009 at 10:37 PM, Sameer Verma sve...@sfsu.edu wrote: On Wed, Feb 11, 2009 at 8:42 PM, Martin Langhoff martin.langh...@gmail.com wrote: On Thu, Feb 12, 2009 at 2:41 PM, Sameer Verma sve...@sfsu.edu wrote: was with eth0

Re: [Server-devel] XS 0.5.1 RC - Last round of testing...

2009-02-13 Thread Jerry Vonau
On Fri, 2009-02-13 at 10:19 -0800, Sameer Verma wrote: On Fri, Feb 13, 2009 at 2:57 AM, Jerry Vonau jvo...@shaw.ca wrote: On Thu, 2009-02-12 at 23:30 -0800, Sameer Verma wrote: On Wed, Feb 11, 2009 at 10:37 PM, Sameer Verma sve...@sfsu.edu wrote: On Wed, Feb 11, 2009 at 8:42 PM, Martin

[Server-devel] mkusbinstall enhancements

2009-02-17 Thread Jerry Vonau
Martin: Can you apply and test: xo.patch from: http://members.shaw.ca/jvonau/pub/0216 Now sets the filesystem label to be XSRepo, used with the sed's line to set the ks= directive to be that of the usbdrive's label. That should fix the need to edit the bootloader's config file. I need to append

Re: [Server-devel] mkusbinstall enhancements

2009-02-18 Thread Jerry Vonau
On Tue, 2009-02-17 at 18:41 -0600, Jerry wrote: Martin: Can you apply and test: xo.patch from: http://members.shaw.ca/jvonau/pub/0216 I need to append method=hd:LABEL=XSRepo:/iso to the same line, Can you change this line in the patch from: sed -i -e 's/cdrom:/hd:LABEL=XSRepo:/g'

Re: [Server-devel] mkusbinstall enhancements

2009-02-18 Thread Jerry Vonau
On Wed, 2009-02-18 at 11:50 -0600, Jerry Vonau wrote: On Tue, 2009-02-17 at 18:41 -0600, Jerry wrote: Martin: Can you apply and test: xo.patch from: http://members.shaw.ca/jvonau/pub/0216 I need to append method=hd:LABEL=XSRepo:/iso to the same line, Can you change this line

Re: [Server-devel] mkusbinstall enhancements

2009-02-22 Thread Jerry Vonau
On Sat, 2009-02-21 at 17:24 -0600, Jerry Vonau wrote: On Thu, 2009-02-19 at 15:02 +1300, Martin Langhoff wrote: On Thu, Feb 19, 2009 at 6:50 AM, Jerry Vonau jvo...@shaw.ca wrote: I need to append method=hd:LABEL=XSRepo:/iso to the same line, Can you change this line in the patch from

Re: [Server-devel] Please test - XS-0.5.2-dev01

2009-03-02 Thread Jerry Vonau
On Mon, 2009-03-02 at 09:59 -0800, Sameer Verma wrote: On Sun, Mar 1, 2009 at 3:46 PM, Martin Langhoff martin.langh...@gmail.com wrote: On Sat, Feb 28, 2009 at 3:44 PM, Sameer Verma sve...@sfsu.edu wrote: dev02 is at 291 M while dev01 is at 547 M. Is it all there? Do you have checksums?

Re: [Server-devel] adding custom dns entries on XS

2009-03-17 Thread Jerry Vonau
On Tue, 2009-03-17 at 09:40 -0400, Daniel Drake wrote: Hi, We'd like to add a custom DNS entry on the XS to override updates.laptop.org to point it at another address (where we'll serve antitheft/lease data for paraguay). I have got it working as follows: I modified /etc/named-xs.conf

Re: [Server-devel] Debugging booting problems with F9 on SD card...

2009-04-13 Thread Jerry Vonau
I can download the image, or at least the initrd.img, from where? Jerry On Mon, 2009-04-13 at 12:29 +0200, Martin Langhoff wrote: On the mission of getting a XS image running on the XO, I have abused imagecreator (part of livecdtools) to create an ext3 image based on the XS ISO we

Re: [Server-devel] Debugging booting problems with F9 on SD card...

2009-04-19 Thread Jerry Vonau
On Mon, 2009-04-13 at 14:44 +0200, Alexander Boström wrote: Maybe something is missing from the initrd. The process of creating it is a bit of a mystery to me, but making sure /dev/root is set up right before generating the initrd seems to work. Try this: The initrd is missing the modules

[Server-devel] firewalling/nocat

2009-09-29 Thread Jerry Vonau
Hi Martin: I've worked up what I think the basic layout of what the firewall rules need to look like that would be used with nocat's access.fw I've stripped and ported nocat's initialize.fw script for our needs, should set up the required iptable rules. access.fw accepts 4 inputs: [permit\|deny]

[Server-devel] Name server operation

2009-10-02 Thread Jerry Vonau
Martin: I was thinking of a clean way to introduce the forward nameserver info for the nameservice that the XS provides. The nice way that dnsmasq uses the namesevers in /etc/resolv.conf got me thinking that we could run dnsmasq on lo only and point bind to the use lo as the forwarder.

Re: [Server-devel] Name server operation

2009-10-05 Thread Jerry Vonau
On Mon, 2009-10-05 at 11:24 +0200, Martin Langhoff wrote: On Fri, Oct 2, 2009 at 7:51 PM, Jerry Vonau jvo...@shaw.ca wrote: dnsmasq on lo only and point bind to the use lo as the forwarder. This requires dnsmasq to listen on 127.0.0.1 and bind on 172.18.0.1. The resolv.conf.in file wound

Re: [Server-devel] Early F11 XS build

2009-10-27 Thread Jerry Vonau
On Sun, 2009-10-25 at 12:44 +0100, Martin Langhoff wrote: On Sat, Oct 24, 2009 at 9:51 AM, Peter Robinson pbrobin...@gmail.com wrote: -- the vanilla F11 kernels fail to boot on the XO -- expected? I think it should boot but I don't think the boot.fth is created but its been a while

Re: [Server-devel] Early F11 XS build

2009-10-27 Thread Jerry Vonau
On Mon, 2009-10-26 at 10:52 +0100, Martin Langhoff wrote: On Mon, Oct 26, 2009 at 1:17 AM, Jerry Vonau jvo...@shaw.ca wrote: Is this with anaconda or with your XO image? I've booted F11's anaconda that was released on the dvd in my prior testing. XO image - I'll try tomorrow

Re: [Server-devel] Early F11 XS build

2009-10-27 Thread Jerry Vonau
On Mon, 2009-10-26 at 12:42 -0500, Jerry Vonau wrote: On Mon, 2009-10-26 at 10:52 +0100, Martin Langhoff wrote: snip Maybe there was PEBKAC and/or just a better fix (hints?). I just hope the instructions for our end users can be simple :-) I'm re-testing now, but I'm on a F11 host

Re: [Server-devel] Transparent proxy

2009-11-28 Thread Jerry Vonau
On Sat, 2009-11-28 at 10:11 +0100, Martin Langhoff wrote: 2009/11/27 Henry Vélez Molina henry.lap...@gmail.com: We are working with the XS-0.6 version and for the moment all is working well. We want to disable the transparent proxy, for security, and put it as an intermediary proxy in a

Re: [Server-devel] Transparent proxy

2009-11-28 Thread Jerry Vonau
On Sat, 2009-11-28 at 10:11 +0100, Martin Langhoff wrote: 2009/11/27 Henry Vélez Molina henry.lap...@gmail.com: We are working with the XS-0.6 version and for the moment all is working well. We want to disable the transparent proxy, for security, and put it as an intermediary proxy in a

Re: who is being shown in Neighborhood View

2010-06-02 Thread Jerry Vonau
On Tue, 2010-05-25 at 20:52 -0500, Mikus Grinbergs wrote: Been trying out os240py. My current setup is an ethernet LAN, with *no* DHCP server. It was interesting to note (just by changing the /etc/resolv.conf content, plus clicking on an AP icon) that when I do not have a valid

Re: [Server-devel] XS eth1 problems

2010-07-09 Thread Jerry Vonau
On Thu, 2010-07-08 at 22:19 -0700, Sameer Verma wrote: I'm setting up a XS machine (XS 0.6) that has only one Ethernet port. This port gets appropriated at eth0 and acts as the primary LAN interface for XOs to talk to it (via a bridged AP). I also want to get this box to talk to the outside

Re: [Server-devel] XS eth1 problems

2010-07-09 Thread Jerry Vonau
On Fri, 2010-07-09 at 09:47 -0500, Jerry Vonau wrote: On Thu, 2010-07-08 at 22:19 -0700, Sameer Verma wrote: [r...@schoolserver ~]# ifconfig eth0 eth0 Link encap:Ethernet HWaddr 00:01:C0:05:AD:5D inet addr:172.18.96.34 Bcast:172.18.96.255 Mask:255.255.255.0 Where

olpc-configure

2010-08-14 Thread Jerry Vonau
I've been using OSBuilder to spin up some custom images, I'm just wondering if my XO-1.5 is a little strange or if I uncovered a bug. When olpc-configure is run at first boot and reads the $MFG_DATA in /ofw the LO tag that is returned has en_US.UTF8 in it which will never match: if ! locale -a |

Re: olpc-configure

2010-08-14 Thread Jerry Vonau
On Sat, 2010-08-14 at 15:15 -0400, Bernie Innocenti wrote: El Sat, 14-08-2010 a las 02:05 -0500, Jerry Vonau escribió: I've been using OSBuilder to spin up some custom images, I'm just wondering if my XO-1.5 is a little strange or if I uncovered a bug. When olpc-configure is run at first

Re: OLPC 10.1.2 Release Candidate 2

2010-08-15 Thread Jerry Vonau
On Mon, 2010-08-09 at 20:44 -0400, Chris Ball wrote: http://wiki.laptop.org/go/Release_notes/10.1.2 http://build.laptop.org/10.1.2/xo-1.5/os851 http://build.laptop.org/10.1.2/xo-1/os851 Compressed image size: 704.85mb (+0.15mb since build 850) * olpc-utils, #10281: Move pentablet mode

Re: OLPC 10.1.2 Release Candidate 2

2010-08-15 Thread Jerry Vonau
On Sun, 2010-08-15 at 13:09 -0400, Chris Ball wrote: Hi, Is koji.dist-f11-updates-10.1.2 fully updated? No, it's frozen; we don't want an F11 update to destabilize the system before release. - Chris. tar was released on May 4 etoys on June 25 coreutiles was on May 30 openssl on

Re: Firmware update

2010-11-24 Thread Jerry Vonau
On Wed, 2010-11-24 at 22:25 +, Daniel Drake wrote: On 24 November 2010 08:26, Jerry Vonau jvo...@shaw.ca wrote: I've played around with the bootfw rpm, altering the install path to reflect where /boot really is on the filesystem while booted up. This has the advantage of being able

Re: Firmware update - os-builder

2010-11-24 Thread Jerry Vonau
On Wed, 2010-11-24 at 22:49 +, Daniel Drake wrote: On 24 November 2010 22:40, Kevin Gordon kgordon...@gmail.com wrote: Is this recommendation against yum and rpm for all software, or just the oplc repo packages, the kernel and the firmware? I'm certainly happy doing just safe builds

Re: Firmware update - os-builder

2010-11-25 Thread Jerry Vonau
On Thu, 2010-11-25 at 08:17 +, Daniel Drake wrote: On 25 November 2010 04:11, Jerry Vonau jvo...@shaw.ca wrote: Having os-builder required to have net access in ksmain.50.repos.py is less than ideal for remote image creation. Once the cache is downloaded could we not just run createrepo

Re: olpc-utils for new 10.1.3 builds

2011-01-02 Thread Jerry Vonau
On Mon, 2011-01-03 at 11:04 +1100, James Cameron wrote: On Sat, Jan 01, 2011 at 04:44:39AM -0600, Mikus Grinbergs wrote: Among the package changes for build os359: | -olpc-utils-1.0.31-1.fc11.i586 | +olpc-utils-1.0.36-1.fc11.i586 Yet build os360 (and os360a and os360b) was built

Re: hwclock accuracy

2011-01-20 Thread Jerry Vonau
On Thu, 2011-01-20 at 02:15 -0800, Hal Murray wrote: What is the accuracy of the hwclock on XOs? Can we assume that it will keep good time over an XO's five-year lifespan? The ballpark for the hardware is 1 second per day. We have some XO-1.5s that have their hwclocks off by 10-20

Re: [OLPC-AU] hwclock accuracy

2011-01-26 Thread Jerry Vonau
On Thu, 2011-01-20 at 14:40 -0500, Martin Langhoff wrote: On Thu, Jan 20, 2011 at 8:02 AM, Sridhar Dhanapalan srid...@laptop.org.au wrote: We've actually disabled the /sbin/hwclock --systohc in our latest build (probably to be released tomorrow). If you are spinning your own build, ensure

Re: [OLPC-AU] hwclock accuracy

2011-01-26 Thread Jerry Vonau
On Thu, 2011-01-27 at 15:30 +1100, James Cameron wrote: On Wed, Jan 26, 2011 at 06:09:02PM -0600, Jerry Vonau wrote: That actually makes things worse, try installing ntpdate and run it with the stock /etc/adjtime file, now the real time clock is set to localtime as that is the first time

Re: [OLPC-AU] hwclock accuracy

2011-01-27 Thread Jerry Vonau
On Thu, 2011-01-27 at 09:01 -0500, Martin Langhoff wrote: Very interesting. Strange. Unexpected. On Wed, Jan 26, 2011 at 11:30 PM, James Cameron qu...@laptop.org wrote: Until these problems are fixed, please change your build; Could this be added to

Re: [OLPC-AU] hwclock accuracy

2011-01-27 Thread Jerry Vonau
On Thu, 2011-01-27 at 15:30 +1100, James Cameron wrote: On Wed, Jan 26, 2011 at 06:09:02PM -0600, Jerry Vonau wrote: That actually makes things worse, try installing ntpdate and run it with the stock /etc/adjtime file, now the real time clock is set to localtime as that is the first time

olpc.fth

2011-02-03 Thread Jerry Vonau
Hi all: Just a quick question is it possible to run commands that are available at OFW prompt inside the olpc.fth file? I'm looking at trying to run add-tag-from-file from within olpc.fth. Any hints will be welcome, Jerry ___ Devel mailing list

Re: olpc.fth

2011-02-03 Thread Jerry Vonau
On Thu, 2011-02-03 at 16:21 -0500, Martin Langhoff wrote: On Thu, Feb 3, 2011 at 4:16 PM, Jerry Vonau jvo...@shaw.ca wrote: Just a quick question is it possible to run commands that are available at OFW prompt inside the olpc.fth file? I'm looking at trying to run add-tag-from-file from

Re: olpc.fth

2011-02-03 Thread Jerry Vonau
On Thu, 2011-02-03 at 15:37 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 16:21 -0500, Martin Langhoff wrote: On Thu, Feb 3, 2011 at 4:16 PM, Jerry Vonau jvo...@shaw.ca wrote: Just a quick question is it possible to run commands that are available at OFW prompt inside the olpc.fth file

Re: olpc.fth

2011-02-03 Thread Jerry Vonau
On Thu, 2011-02-03 at 15:52 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 15:37 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 16:21 -0500, Martin Langhoff wrote: On Thu, Feb 3, 2011 at 4:16 PM, Jerry Vonau jvo...@shaw.ca wrote: Just a quick question is it possible to run commands

Re: olpc.fth

2011-02-03 Thread Jerry Vonau
On Thu, 2011-02-03 at 17:02 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 15:52 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 15:37 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 16:21 -0500, Martin Langhoff wrote: On Thu, Feb 3, 2011 at 4:16 PM, Jerry Vonau jvo...@shaw.ca wrote

Re: olpc.fth

2011-02-03 Thread Jerry Vonau
On Fri, 2011-02-04 at 10:16 +1100, James Cameron wrote: On Thu, Feb 03, 2011 at 03:16:43PM -0600, Jerry Vonau wrote: Just a quick question is it possible to run commands that are available at OFW prompt inside the olpc.fth file? I'm looking at trying to run add-tag-from-file from within

Re: olpc.fth

2011-02-03 Thread Jerry Vonau
On Thu, 2011-02-03 at 17:20 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 17:02 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 15:52 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 15:37 -0600, Jerry Vonau wrote: On Thu, 2011-02-03 at 16:21 -0500, Martin Langhoff wrote: On Thu

Re: Language support for 11.2.0

2011-02-04 Thread Jerry Vonau
On Fri, 2011-02-04 at 12:16 +, Daniel Drake wrote: Hi, Currently we are including the following languages and locales in 11.2.0 official builds: en_US es ar pt pt_BR fr ht mn mr_IN am_ET km_KH ne_NP ur_PK rw ps fa_AF si zh_CN We can extend that list if there are

magic update usbkey

2011-02-09 Thread Jerry Vonau
Hi All: Ever want to have an action occur when you plug your usbkey in on an XO? With a bit of udev magic that is possible. First you need to have a udev .rules file in place to trap the occurrence, I created /etc/udev/rules.d/99-setup.rules that contained, on one line: ACTION==add,

Re: NANDblaster failing

2011-02-10 Thread Jerry Vonau
On Fri, 2011-02-11 at 16:16 +1100, Sridhar Dhanapalan wrote: I am seeing NANDblaster (nb-secure) fail after some time (from my tests, anywhere between 30 minutes to an hour). The text was scrolling very fast (screenshots attached), but I think it was: SDHCI: Error: ISR = 8000 ESR = 3

Re: [OLPC-AU] Upgrading firmware with nb-secure

2011-02-17 Thread Jerry Vonau
On Fri, 2011-02-18 at 01:35 +1100, Sridhar Dhanapalan wrote: If I use nb-secure to push out a signed build that includes new firmware, would the new firmware be written to the XO the next time it boots with external power connected? Thanks, Sridhar Only if it has a greater reversion

Re: [Server-devel] Hidden SSID and Proxy settings

2011-03-02 Thread Jerry Vonau
On Wed, 2011-03-02 at 20:54 -0500, Dr. Gerald Ardito wrote: Hello again, I am just getting back to this. I have tried the instructions on the wiki at: http://wiki.laptop.org/go/Wifi_Connectivity#SSID_Network_Name But these instructions do not seem to work. After making the changes,

Re: [Server-devel] Hidden SSID and Proxy settings

2011-03-03 Thread Jerry Vonau
On Thu, 2011-03-03 at 14:47 +1100, James Cameron wrote: On Wed, Mar 02, 2011 at 10:38:07PM -0500, Dr. Gerald Ardito wrote: Both methods work within a session. In GNOME, I can connect to the hidden network. And, if I change back to Sugar, the connection is intact. Yes. NetworkManager

Re: [Server-devel] Hidden SSID and Proxy settings

2011-03-06 Thread Jerry Vonau
On Fri, 2011-03-04 at 15:34 +1100, James Cameron wrote: On Thu, Mar 03, 2011 at 09:55:26PM -0600, Jerry Vonau wrote: On Thu, 2011-03-03 at 14:47 +1100, James Cameron wrote: On Wed, Mar 02, 2011 at 10:38:07PM -0500, Dr. Gerald Ardito wrote: Both methods work within a session. In GNOME

Re: [Server-devel] Hidden SSID and Proxy settings

2011-03-07 Thread Jerry Vonau
On Mon, 2011-03-07 at 18:42 +1100, James Cameron wrote: On Sun, Mar 06, 2011 at 11:29:09PM -0600, Jerry Vonau wrote: On Fri, 2011-03-04 at 15:34 +1100, James Cameron wrote: On Thu, Mar 03, 2011 at 09:55:26PM -0600, Jerry Vonau wrote: On Thu, 2011-03-03 at 14:47 +1100, James Cameron wrote

Re: [Server-devel] Hidden SSID and Proxy settings

2011-03-07 Thread Jerry Vonau
On Mon, 2011-03-07 at 11:49 +0100, Sascha Silbe wrote: Excerpts from Jerry Vonau's message of Mon Mar 07 09:51:30 +0100 2011: Yes, think that would be a good idea, with this method connections.cfg can be empty. Perhaps network.py can just use/create the needed file for

Re: [OLPC-AU] Determining developer lock status

2011-03-10 Thread Jerry Vonau
On Thu, 2011-03-10 at 15:22 +1100, James Cameron wrote: On Thu, Mar 10, 2011 at 03:06:10PM +1100, Sridhar Dhanapalan wrote: We find this to be a bit hit-and-miss - sometimes the prompt shows and sometimes it doesn't. I normally turn on the XO while either holding down the Esc key or tapping

Re: [OLPC-AU] XO-1 developer key does not work

2011-03-12 Thread Jerry Vonau
On Sat, 2011-03-12 at 02:36 -0500, C. Scott Ananian wrote: On Sat, Mar 12, 2011 at 2:16 AM, Mikus Grinbergs mi...@bga.com wrote: why am I getting different readings for each method? My guess is that file /home/.devkey.html was copied in from some other system, and shows the serial number

Re: Corrupt xo1.5 signed q3a62 bootfw file

2011-04-07 Thread Jerry Vonau
On Thu, 2011-04-07 at 15:53 -0400, Anish Mangal wrote: Hi, The signed firmware q3a62 link for xo1.5 [1] seems corrupt to me. While trying to upgrade the firmware on a 1.5, I get a message saying 'bad crc'. Can somebody check this? [1] http://dev.laptop.org/pub/firmware/q3a62/bootfw.zip

rpm installation via customization stick

2011-05-04 Thread Jerry Vonau
Hi all: This there any interest in the ability to install rpms with a customization stick? I have a POC patch that does that with just a small patch to dracut's 30olpc-customization routine[1]. On a side note I noticed that the use of unzip suffers the same issue as os-builder does when it comes

Re: rpm installation via customization stick

2011-05-04 Thread Jerry Vonau
On Wed, 2011-05-04 at 20:00 -0400, Chris Ball wrote: Hi Jerry, On Wed, May 04 2011, Jerry Vonau wrote: This there any interest in the ability to install rpms with a customization stick? I have a POC patch that does that with just a small patch to dracut's 30olpc-customization routine

Testing sprase file support for 10.1.3

2011-06-09 Thread Jerry Vonau
Hi All: This is to announce the latest OLPC-AU build for the XO-1.5 for testing featuring sparse file support [1], Browse-122, and Musicpainter-9 is available for testing [2]. With this release if you don't upgrade the firmware prior to testing you will receive a harmless warning at the end of

OLPC-AU

2011-06-30 Thread Jerry Vonau
Hi All: This is to announce that we may have a Release Candidate with the latest OLPC-AU build for the XO-1.5 featuring sparse file support[1], is now available for testing[2]. This build has q3a65 firmware in the payload, so you might get an upgrade if your firmware is not up to that level. The

Re: [OLPC-AU] OLPC-AU revised release candidate

2011-07-01 Thread Jerry Vonau
: www.laptop.org.au On 1 July 2011 08:43, Jerry Vonau jvo...@shaw.ca wrote: Hi All: This is to announce that we may have a Release Candidate with the latest OLPC-AU build for the XO-1.5 featuring sparse file support[1], is now available for testing[2]. This build has q3a65 firmware

Re: Build 871

2011-07-03 Thread Jerry Vonau
On Sun, 2011-07-03 at 14:54 -0500, Mikus Grinbergs wrote: I still cant connect to the candidates on download.laptop.org. Works fine from here. I have tried several times over the past 24 hours and the connection worked ok each time. I've been trying (browser, wget) on Jul 1 and Jul 2

Re: *.laptop.org issues

2011-07-07 Thread Jerry Vonau
On Thu, 2011-07-07 at 09:30 +0200, Bert Freudenberg wrote: On 06.07.2011, at 23:42, Chris Ball wrote: Hi, On Wed, Jul 06 2011, Yioryos Asprobounitis wrote: I'm not sure this is a devel issue, so apologies for any pollution. I too had problems downloading os871 and accessing

OLPC-AU release candidate RC3 (au867)

2011-07-07 Thread Jerry Vonau
Hi all: There is a new image to be tested: http://build.laptop.org.au/xo/10.1.3/xo-1.5/RC3/ The release notes, including links to the changes, is online at: https://dev.laptop.org.au/projects/xo-au/wiki/1013-au3_release_notes Some things that have changed (with their issues numbers in our

Re: OLPC-AU release candidate RC3 (au867)

2011-07-07 Thread Jerry Vonau
On Fri, 2011-07-08 at 08:58 +1000, James Cameron wrote: On Fri, Jul 08, 2011 at 08:54:10AM +1000, Sridhar Dhanapalan wrote: https://dev.laptop.org.au/projects/xo-au-usb/repository/revisions/delta/changes/key/delta.zip wget gives me an 8615 byte file. That can't be right. Need to use what

udev rules for wedo

2011-07-14 Thread Jerry Vonau
Hi all: Playing around with wedo, I've found that scratch is providing udev rules for wedo and there are rules installed by olpc-utils. I'm wondering if the rules provided by scratch should be used in place of or in conjunction with the olpc provided rules in /etc/udev/rules.d. Here are the

OLPC-AU release candidate RC4 (au868)

2011-07-14 Thread Jerry Vonau
Hi all: There is a new image to be tested: http://build.laptop.org.au/xo/10.1.3/xo-1.5/RC4/ The release notes, including links to the changes, is online at: https://dev.laptop.org.au/projects/xo-au/wiki/1013-au3_release_notes Delta updater:

Re: OLPC-AU release candidate RC4 (au868)

2011-07-14 Thread Jerry Vonau
On Thu, 2011-07-14 at 15:41 -0300, Gonzalo Odiard wrote: This grew by 30MB to 70MB due to an update to version 10 of biology.xol. I can put together a slimmed down version if there is interest. Why is bigger? biology 10 must have the same size of biology 9.

Re: Melbourne testing group, RC4 (au868)

2011-07-20 Thread Jerry Vonau
On Thu, 2011-07-21 at 01:49 +1000, Sridhar Dhanapalan wrote: Thanks Tony. On 16 July 2011 18:09, fors...@ozonline.com.au wrote: * gtk-recordmysesktop in GNOME [#564] Unable to stop the recording session, the app disappears, maybe we are missing the obvious It's hard to spot -

Re: [Sugar-devel] battery indicator missing on customized image based on 11.2.0 for XO 1.5

2011-08-02 Thread Jerry Vonau
Hi: I haven't tried to remove gnome, but the one difference is the battery applet rpm(batti) is being asked to be installed on the image in modules/gnome/kspkglist.50.gnome.inc, which is no longer being included. Sounds like batti should be in a kspkglist file in modules/powered if sugar needs

Re: Help with OS Builder

2011-08-26 Thread Jerry Vonau
On Fri, 2011-08-26 at 09:15 +0200, Christophe Guéret wrote: Hi all, I'm using the OS builder to create a customized 11.2.0 for my XOs 1 and I can't figure out how to do two things: * Include a new binary which is not packaged + the related start scripts Are your saying not in rpm format?

Re: Wireless Security WPA2

2011-09-01 Thread Jerry Vonau
On Fri, 2011-09-02 at 01:21 -0400, Kevin Gordon wrote: Folks: I have a site where I sometimes work on my little XO's that has now implemented WPA2 Enterprise wireless security. On the Gnome side I can edit a Wireless Network Connection to correctly enter the parameters and get onto the

Re: 11.3.0 build 4 released, for *XO-1.75*, XO-1.5 and XO-1

2011-09-12 Thread Jerry Vonau
On Sat, 2011-09-10 at 14:08 +0100, Peter Robinson wrote: On Sat, Sep 10, 2011 at 2:20 AM, Martin Langhoff martin.langh...@gmail.com wrote: On Fri, Sep 9, 2011 at 8:14 PM, Kevin Gordon kgordon...@gmail.com wrote: the same: i.e.: os4.zd4. It would be nice to be able to differentiate Use

Re: 11.3.0 build 5 released, for XO-1.75, XO-1.5 and XO-1

2011-09-15 Thread Jerry Vonau
On Thu, 2011-09-15 at 06:08 -0400, Kevin Gordon wrote: On Thu, Sep 15, 2011 at 4:44 AM, Daniel Drake d...@laptop.org wrote: http://build.laptop.org/11.3.0/os5/ Thanks Peter. It would be neat if someone can test the olpc-update from

Re: How to disabled xo security without developers key

2011-09-15 Thread Jerry Vonau
On Thu, 2011-09-15 at 21:50 +0530, ganesh gajre wrote: Hello, I am deploying more than 30 XO-1 in a village where I don't have Internet facility. I have to update the firmware of all the XO. Currently all XO-1 has q2e41 firmware version, which has to be updated to q2e46. The last

  1   2   3   4   5   6   >