Re: [OMPI devel] 答复: 答复: Migrate the OpenMPI to VxWorks

2010-04-19 Thread Ralf Wildenhues
* 张晶 wrote on Fri, Apr 16, 2010 at 04:50:21PM CEST: > I think I should switch the host now in the windows to the linux ,or I will > have little chance to build the autotool, Thank you for your advice ! autotools work just fine under Windows. For example, Cygwin or MinGW ship pre-built autotools

Re: [OMPI devel] Porting OpenMPI to a new system

2010-04-29 Thread Ralf Wildenhues
Hello Ioannis, * Ioannis E. Venetis wrote on Wed, Apr 28, 2010 at 05:34:47PM CEST: > b) The cross-compilation environment should be run on a Linux x86_64 > system. The cross-compiler, libraries, etc are already working, which > means that only OpenMPI needs to be ported right now. We use this >

Re: [OMPI devel] bug with /bin/sh and /bin/ksh

2010-05-03 Thread Ralf Wildenhues
Hello, * Jeff Squyres wrote on Mon, May 03, 2010 at 04:04:59PM CEST: > > On Apr 29, 2010, at 11:24 AM, Jonathan Vincent wrote: > > > > > sh -c '/usr/bin/env FOO=bar (echo hello)' > > > ksh -c '/usr/bin/env FOO=bar (echo hello)' > > > > > > is not valid > > > sh -c '/usr/bin/env FOO=bar echo

Re: [OMPI devel] The" Missing Symbol" issue and OpenMPI on NetBSD

2010-05-11 Thread Ralf Wildenhues
Hello Kevin, * kevin.buck...@ecs.vuw.ac.nz wrote on Tue, May 11, 2010 at 06:42:01AM CEST: > That is a file that gets patched in the NetBSD build as follows > > $diff opal/mca/base/mca_base_component_find.c{.orig,} > 44,46d43 > < #ifndef __WINDOWS__ > < #include "opal/libltdl/ltdl.h" > <

Re: [OMPI devel] v1.5 .so version numbers

2010-06-05 Thread Ralf Wildenhues
Hi Jeff, * Jeff Squyres wrote on Thu, Jun 03, 2010 at 09:34:16PM CEST: > SHORT VERSION: We broke ABI from the 1.4 series to the v1.5 series. I > propose changing all the libtool .so version numbers as shown below to > enforce that break. Can someone sanity check this? Looks sane to me, with

Re: [OMPI devel] [PATCH] openmpi: get it built with newer autoconf

2010-08-18 Thread Ralf Wildenhues
Hello, * Jeff Squyres wrote on Wed, Aug 18, 2010 at 06:35:22PM CEST: > > With a quick grep, I actually see 16 uses of AS_VAR_GET. Do the other > 15 cases not cause problems? Whether or not, since AS_VAR_GET is undocumented (and inefficient, and now also buggy), it's prudent to replace them all

Re: [OMPI devel] Fixes to OpenMPI-1.4.2 for PGI compilers

2010-08-20 Thread Ralf Wildenhues
and fixes to the developers of the code I use. I really have > to leave it up to them to decide whether to pass them on to their > upstream providers. > > Larry Baker > US Geological Survey > 650-329-5608 > ba...@usgs.gov > > On Aug 20, 2010, at 8:24 AM, Jeff Sq

Re: [OMPI devel] "make check" (libtool?) failure on Solaris/SPARC (1.5rc5 and 1.4.3rc1)

2010-08-26 Thread Ralf Wildenhues
Hello Paul, * Paul H. Hargrove wrote on Thu, Aug 26, 2010 at 01:58:11AM CEST: > I have been able to configure and build both 1.5rc5 and 1.4.3rc1 on > Solaris 10 for SPARC, using Sun C 5.10. > I have also build 1.5rc5 w/ gcc-3.3.2 (and expect 1.4.3rc1 to build > w/ gcc as well, once I have time) >

Re: [OMPI devel] make install (libtool) failure on Solaris 10 (1.5rc5 and 1.4.3rc1)

2010-08-26 Thread Ralf Wildenhues
Hi Paul, * Paul H. Hargrove wrote on Thu, Aug 26, 2010 at 05:37:23AM CEST: > This has got to be the stupidest failure I have ever seen! > > $ make install > [...] > make[3]: Entering directory > `/export/home/phargrov/openmpi-1.5rc5/BLD-gcc-vt/ompi' > test -z "/usr/local/pkg/ompi-1.5rc5/lib" ||

Re: [OMPI devel] "make check" (libtool?) failure on Solaris/SPARC (1.5rc5 and 1.4.3rc1)

2010-08-26 Thread Ralf Wildenhues
* Paul H. Hargrove wrote on Thu, Aug 26, 2010 at 10:14:22PM CEST: > I just had a thought on this one: In my environment on this > platform I have LD_LIBRARY_PATH_32 and LD_LIBRARY_PATH_64 set. It > seems possible to me that this is causing the loader to ignore the > LD_LIBRARY_PATH setting that

Re: [OMPI devel] "make check" (libtool) failure on Linux/ppc w/ XLC (1.5rc5 and 1.4.3rc1)

2010-08-27 Thread Ralf Wildenhues
* Paul H. Hargrove wrote on Fri, Aug 27, 2010 at 03:54:54AM CEST: > >I am now looking at using IBM's XLC compilers for ILP32 builds on > >the same Linux/PPC64 platform for which I've reported some > >XLC/LP64 bugs. > > > >What I find now is that "make check" is failing with the loader > >unable to

Re: [OMPI devel] AS_VAR_COPY failure (Re: === CREATE FAILURE (v1.4) ===)

2010-09-09 Thread Ralf Wildenhues
> > It seems that the execution of "autoconf" has failed. See above for > > the specific error message that caused it to abort. > > - > > &

Re: [OMPI devel] Setting AUTOMAKE_JOBS

2010-09-22 Thread Ralf Wildenhues
Hi Jeff, adding bug-automake in Cc: (non-subscribers can't post to the Open MPI list, so please remove that Cc: in case) * Jeff Squyres wrote on Wed, Sep 22, 2010 at 03:50:19PM CEST: > $AUTOMAKE_JOBS Total wall time > valueof autogen.pl > 8

[OMPI devel] update configury for Autoconf 2.68

2010-09-23 Thread Ralf Wildenhues
Hello OpenMPI developers, just-released Autoconf 2.68 contains more stringent checks and warnings about stuff passed to AC_{COMPILE,LINK,RUN}_IFELSE and AC_TRY_* macros. Specifically, it will warn if C or C++ programs are not generated with AC_LANG_SOURCE or AC_LANG_PROGRAM, in order to avoid

Re: [OMPI devel] update configury for Autoconf 2.68

2010-09-23 Thread Ralf Wildenhues
Hi Jeff, * Jeff Squyres wrote on Thu, Sep 23, 2010 at 03:31:32PM CEST: > One very minor question: I notice you added silent-rules to > AM_INIT_AUTOMAKE (and bumped the required version, too), but still > left in the call to AM_SILENT_RULES: > > -AM_INIT_AUTOMAKE([foreign dist-bzip2

Re: [OMPI devel] update configury for Autoconf 2.68

2010-09-23 Thread Ralf Wildenhues
* Jeff Squyres wrote on Thu, Sep 23, 2010 at 08:11:41PM CEST: > On Sep 23, 2010, at 2:03 PM, Ralf Wildenhues wrote: > > >> Is the call to AM_SILENT_RULES now moot because it's listed in > >> AM_INIT_AUTOMAKE? > > > > Oh, just drop that hunk, that wa

Re: [OMPI devel] Setting AUTOMAKE_JOBS

2010-09-24 Thread Ralf Wildenhues
Hello Ralph, wow, that's not good to hear. I knew the perl ithreads implementation wasn't all that efficient, but causing a deadlock sounds like you have more trouble than just perl; at least I hope so. For reference, can you send 'perl -V' output (if you like, to the bug-automake at gnu.org

Re: [OMPI devel] Setting AUTOMAKE_JOBS

2010-09-24 Thread Ralf Wildenhues
* Ralph Castain wrote on Fri, Sep 24, 2010 at 06:41:38AM CEST: > My point is just that it is unwise to assume that the OMPI build can utilize > all available processors. I'm sure it's fine for the MTT runs, especially on > Jeff's machines as they are dedicated to that purpose - just not a good >

Re: [OMPI devel] update configury for Autoconf 2.68

2010-09-24 Thread Ralf Wildenhues
* Jeff Squyres wrote on Fri, Sep 24, 2010 at 03:26:46PM CEST: > On Sep 23, 2010, at 2:15 PM, Ralf Wildenhues wrote: > >> Is the silent-rules clause in AM_INIT_AUTOMAKE exactly equivalent to > >> calling AM_SILENT_RULES? > > > > Yes. > > Weird -- when I do t

Re: [OMPI devel] Failure (libtool?) to build F90 bindings w/ XLC/PPC64 (1.5rc5 and 1.4.3rc1)

2010-10-14 Thread Ralf Wildenhues
[ http://www.open-mpi.org/community/lists/devel/2010/08/8398.php ] Hello Paul, sorry for the late reply. This issue you reported is valid; it is already fixed in upstream Libtool 2.2.8, with commit v2.2.6-201-g519bf91:

Re: [OMPI devel] "make check" (libtool) failure on Linux/ppc w/ XLC (1.5rc5 and 1.4.3rc1)

2010-10-14 Thread Ralf Wildenhues
h the requested files off-list. > -Paul > > > Ralf Wildenhues wrote: > >* Paul H. Hargrove wrote on Fri, Aug 27, 2010 at 03:54:54AM CEST: > >>>I am now looking at using IBM's XLC compilers for ILP32 builds on > >>>the same Linux/PPC64 platform for which I'

Re: [OMPI devel] Compiling problem in trunk?

2011-06-23 Thread Ralf Wildenhues
Hello, * Xin He wrote on Thu, Jun 23, 2011 at 01:23:53PM CEST: > make[3]: Entering directory `/home/ehhexxn/git/ompi/ompi/include' > FC mpif90-ext.lo > libtool: compile: unrecognized option `-c' > libtool: compile: Try `libtool --help' for more information. > make[3]: *** [mpif90-ext.lo]

Re: [OMPI devel] Tarball distribution

2011-06-27 Thread Ralf Wildenhues
Hi John, * John Esmet wrote on Sun, Jun 26, 2011 at 06:41:48AM CEST: > I went to untar the source code and the folders are mode 777. Call me OCD, > but I find this a little strange. What's up? Newer Automake releases should have that fixed:

Re: [OMPI devel] Tarball distribution

2011-06-27 Thread Ralf Wildenhues
.1 (for the v1.5 > series) may be tolerable. I'll check it out. > > > > On Jun 27, 2011, at 2:09 AM, Ralf Wildenhues wrote: > > > Hi John, > > > > * John Esmet wrote on Sun, Jun 26, 2011 at 06:41:48AM CEST: > >> I went to untar the source code and t

Re: [OMPI devel] MPI ABI on Linux

2008-09-09 Thread Ralf Wildenhues
Hello Jeff, all, if you allow me my two cents, * Jeff Squyres wrote on Mon, Sep 08, 2008 at 08:44:28PM CEST: > > At the MPI Forum meeting in Dublin, the MPI ABI meeting was... er... > shall we say, "spirited." :-) Both the benefits and drawbacks of an > MPI ABI are widely contended (it's a

Re: [OMPI devel] MPI ABI on Linux

2008-09-09 Thread Ralf Wildenhues
* Jeff Squyres wrote on Tue, Sep 09, 2008 at 03:07:24PM CEST: >> On Sep 9, 2008, at 6:23 AM, Jeff Squyres wrote: >>> On Sep 9, 2008, at 2:45 AM, Ralf Wildenhues wrote: >>> >>>> An MPI ABI will have to be versioned in >>>> the same way that th

Re: [OMPI devel] gdb libmpi.dylib on Leopard

2008-09-17 Thread Ralf Wildenhues
Hello Aurélien, * Aurélien Bouteiller wrote on Wed, Sep 17, 2008 at 06:32:11PM CEST: > I have been facing a weird problem for several month now (I guess since I > upgraded from Tiger to Leopard). I am unable to debug Open MPI using gdb > on my mac. The problem comes from gdb not being able to

Re: [OMPI devel] Upgrade GNU auto tools?

2008-09-19 Thread Ralf Wildenhues
Hello OpenMPI developers, on Darwin/OS X, recent Libtool has some debugging symbols issue fixed. I think that was even raised on this list a short while ago. Also, an issue with recent Intel compilers on Linux has been fixed. Absoft support is not yet in Libtool, but Lahey is. Hope that helps.

Re: [OMPI devel] gdb libmpi.dylib on Leopard

2008-09-19 Thread Ralf Wildenhues
* Aurélien Bouteiller wrote on Fri, Sep 19, 2008 at 08:02:40PM CEST: > Thanks Ralf for the support. I upgraded to libtool 2.2.6 and it didn't > solved the problem though. Still looking for somebody to confirm that > its working or not working on their Mac. Did you rerun autogen.sh? All I

Re: [OMPI devel] Should visibility and memchecker abort configure?

2008-10-05 Thread Ralf Wildenhues
Hello, if you allow me my 2 cents: At configure time, it is possible to distinguish between several different user inputs: - the user typed --enable-foo, - the user typed --disable-foo or --enable-foo=no, - the user typed --enable-foo=ARG (ARG is available for further inspection), - the user

Re: [OMPI devel] adding new functions to a BTL

2008-10-22 Thread Ralf Wildenhues
Hello Jeff, Eugene, > Jeff Squyres wrote: > >> We use lt_dlopen() to open the plugins (Libtool's wrapper for a >> portable dlopen). It opens all plugins (DSOs) in a private scope. >> That private scope is kept deep in the OPAL MCA base and not exposed >> elsewhere in the code base. So

Re: [OMPI devel] RFC: libopen-rte --> libompi-rte

2008-11-06 Thread Ralf Wildenhues
Hello, * Jeff Squyres wrote on Thu, Nov 06, 2008 at 07:49:23PM CET: > On Nov 6, 2008, at 1:13 PM, Brian W. Barrett wrote: > >>> WHY: ORTE is really quite specific to OMPI. We decided long ago >>> that ORTE would not split off from OMPI, and it has been >>> specifically tailored for OMPI.

Re: [OMPI devel] RFC: libopen-rte --> libompi-rte

2008-11-06 Thread Ralf Wildenhues
* Jeff Squyres wrote on Thu, Nov 06, 2008 at 08:48:44PM CET: > On Nov 6, 2008, at 2:42 PM, Ralf Wildenhues wrote: > >> Hmm, OpenMPI seems not to use versioning for its shared libraries. > > That was on the to-do list for this release, but it just didn't happen. > :-\ Oh

Re: [OMPI devel] RFC: Add SunStudio/Libtool helper script for post-configure

2008-11-19 Thread Ralf Wildenhues
Hello Ethan, * Ethan Mallove wrote on Wed, Nov 19, 2008 at 04:11:23PM CET: > There are a couple issues with SunStudio and Libtool: Which Libtool version are you using? If not 2.2.2 or newer, then please retry with 2.2.6. If the problem persists, then we should fix Libtool rather than patching

Re: [OMPI devel] RFC: merge windows branch into trunk

2008-11-20 Thread Ralf Wildenhues
I'm probably going to come across as ignorant, and I'm obviously biased on this matter, but: * Tim Mattox wrote on Thu, Nov 20, 2008 at 02:53:13PM CET: > > Although I don't use windows myself, I appreciate your > and others' efforts to expand the number of platforms > we can run on. Great work!

Re: [OMPI devel] RFC: Add SunStudio/Libtool helper script for post-configure

2008-11-20 Thread Ralf Wildenhues
Hello Ethan, * Ethan Mallove wrote on Wed, Nov 19, 2008 at 09:24:16PM CET: > > I'm seeing the same issue with the faulty "wl" Libtool > variable in 2.2.6 with Linux SunStudio: That's really weird, because this change should have fixed that:

Re: [OMPI devel] RFC: Add SunStudio/Libtool helper script for post-configure

2008-11-20 Thread Ralf Wildenhues
Our previous mails overlapped, sorry about that. * Ethan Mallove wrote on Thu, Nov 20, 2008 at 06:52:09PM CET: > > The above appears to be looking for a Fortran version string from the > C compiler, but it wouldn't match our version string anyway: > > $ f90 -V > f90: Sun Ceres Fortran 95

Re: [OMPI devel] RFC: Add SunStudio/Libtool helper script for post-configure

2008-11-21 Thread Ralf Wildenhues
Hello Ethan, all, * Ethan Mallove wrote on Thu, Nov 20, 2008 at 10:33:08PM CET: > On Thu, Nov/20/2008 07:00:31PM, Ralf Wildenhues wrote: > > > > Ah, ok. Please try the patch below instead of yours, thanks. > > Your patch seems to work, though I get this: > >libt

Re: [OMPI devel] RFC: Add SunStudio/Libtool helper script for post-configure

2008-11-23 Thread Ralf Wildenhues
* Ethan Mallove wrote on Fri, Nov 21, 2008 at 09:01:56PM CET: > On Fri, Nov/21/2008 01:02:12PM, Ralf Wildenhues wrote: > > IMHO OpenMPI can use > > the solaris_use_stlport4=yes until such a functionality is in place. > > Nice. This workaround works. I don't suppose there's a

Re: [OMPI devel] RFC: Add SunStudio/Libtool helper script for post-configure

2008-11-24 Thread Ralf Wildenhues
Hello Ralph, * Ralph Castain wrote on Mon, Nov 24, 2008 at 02:39:13PM CET: > On Nov 23, 2008, at 1:19 AM, Ralf Wildenhues wrote: >> >> While I suppose your patch works, I think in similar situations, >> OpenMPI has resorted to patching input files to configure (like >&

Re: [OMPI devel] Forwarding SIGTSTP and SIGCONT

2008-12-06 Thread Ralf Wildenhues
Hello Rolf, * Rolf Vandevaart wrote on Fri, Dec 05, 2008 at 08:00:42PM CET: > > One problem is that with SIGTSTP no longer delivering a stop signal to > mpirun, one cannot CTRL-Z at their terminal to stop mpirun. I am trying > to figure out how big a problem that is. Why not first deal with

Re: [OMPI devel] make dependency problem?

2008-12-07 Thread Ralf Wildenhues
Hello Eugene, Jeff, the interesting data points here would be the dependency tracking scheme selected by automake (CCDEPMODE in ompi/mca/bml/r2/Makefile), with and without --enable-dependency-tracking passed to configure. Also, the contents of ompi/mca/bml/r2/.deps/bml_r2.Plo, after ensuring

Re: [OMPI devel] [Pkg-openmpi-maintainers] Building with rpath disabled

2009-01-13 Thread Ralf Wildenhues
Hello Jeff, * Jeff Squyres wrote on Tue, Jan 13, 2009 at 03:39:28PM CET: > On Jan 13, 2009, at 4:54 AM, Manuel Prinz wrote: >> >> You have to pass --disable-rpath explicitely. Building with rpath is >> still the default. I verified by building without passing any option >> to configure and the

Re: [OMPI devel] [OMPI svn-full] svn:open-mpi r20568

2009-02-17 Thread Ralf Wildenhues
Hello, * Jeff Squyres wrote on Tue, Feb 17, 2009 at 07:01:01PM CET: > On Feb 17, 2009, at 11:18 AM, George Bosilca wrote: > >> I guess that if the free function supports the NULL pointer we should >> do the same... > > I'll agree with that if we know for sure that free(NULL) is universally >

Re: [OMPI devel] Fwd: RFC: proposed GPLv3 license exception draft

2009-04-25 Thread Ralf Wildenhues
ave a problem when configure.ac and acinclude.m4 are from a non-GPL > project such as OMPI. > Ralf Wildenhues, > While I believe Jeff is the one that brought this discussion to > ompi-devel, I know you've posted on ompi-devel in the past. Are you > seeing this? Yes, I am casually reading th

Re: [OMPI devel] Fwd: RFC: proposed GPLv3 license exception draft

2009-04-25 Thread Ralf Wildenhues
Hi Jeff, * Jeff Squyres wrote on Sat, Apr 25, 2009 at 01:27:24PM CEST: > We OMPI developers ask people to send the stdout/stderr of configure and > their config.log to us to help figure out problems > (http://www.open-mpi.org/community/help/). As I understand your > explanations, this is

Re: [OMPI devel] Fwd: RFC: proposed GPLv3 license exception draft

2009-04-25 Thread Ralf Wildenhues
Hello Ralph, * Ralph Castain wrote on Sat, Apr 25, 2009 at 05:09:01PM CEST: > Just to be clear, Ralf - I'm not advocating that we change build > systems. I agree it has been a good relationship, and your participation > has been welcome and extremely helpful. Understood; and thanks! > My

Re: [OMPI devel] Build failures on trunk? r21235

2009-05-14 Thread Ralf Wildenhues
Hello, Ashley, did you rebootstrap with Debian's Libtool? They enable link_all_deplibs=no in their Libtool which changes some things and can cause issues like this. Can't hurt to open a Debian bug report about it (targeted against libtool) so they know this issue exists. Can you try working

Re: [OMPI devel] Build failures on trunk? r21235

2009-05-14 Thread Ralf Wildenhues
Hello, * Jeff Squyres wrote on Thu, May 14, 2009 at 07:56:24PM CEST: > On May 14, 2009, at 1:46 PM, Ralf Wildenhues wrote: > >> A more permanent workaround could be in OpenMPI to list each library >> that is used *directly* by some other library as a dependency. Sigh. > >

Re: [OMPI devel] Build failures on trunk? r21235

2009-05-14 Thread Ralf Wildenhues
Hi Brian, * Brian W. Barrett wrote on Thu, May 14, 2009 at 08:22:58PM CEST: > > Actually, I think that was something else. Today, libopen-rte.la lists > libopen-pal.la as a dependency and libmpi.la lists libopen-rte.la. I had > removed the dependency of libmpi.la on libopen-pal.la because it

[OMPI devel] faster autogen.sh

2009-05-27 Thread Ralf Wildenhues
As part of a shameless advertising move I suggest this patch. While it won't make autogen.sh exactly fast, for me it shaves half a minute off its runtime. Cheers, Ralf HACKING: recommend parallel automake 1.11 execution. Index: HACKING

Re: [OMPI devel] Shared library versioning

2009-07-28 Thread Ralf Wildenhues
* Jeff Squyres wrote on Sat, Jul 25, 2009 at 07:59:25PM CEST: > On Jul 25, 2009, at 12:59 PM, Iain Bason wrote: > >> We have talked many times about doing proper versioning for > >> OMPI's .so libraries (e.g., libmpi.so -- *not* our component DSOs). > > > >Forgive me if this has been hashed out,

Re: [OMPI devel] trunk borked -- my fault

2009-08-11 Thread Ralf Wildenhues
not bracket the AC_PROG_F77 call, as they should. What you should do is move these lines to the required macro as well. The patch below ought to fix up these issues, as well as the scope push macro for C++. For clarity, you could also put that in another, separate macro, and AC_REQUIRE that.

Re: [OMPI devel] libtool issue with crs/self

2009-09-07 Thread Ralf Wildenhues
Hello, * Josh Hursey wrote on Wed, Aug 05, 2009 at 04:51:59PM CEST: > I noticed that the "-fvisibility=hidden" option when passed to > libltdl will cause it to fail in its configure test for: > "checking whether a program can dlopen itself" > This is because the symbol they are trying to look

Re: [OMPI devel] Dynamic languages, dlopen() issues, and symbol visibility of libtool ltdl API in current trunk

2009-09-21 Thread Ralf Wildenhues
As a workaround, Lisandro could just pre-seed the cache variables of the respective configure tests that come out wrong. ./configure lt_cv_dlopen_self=yes lt_cv_dlopen_self_static=yes HTH. Cheers, Ralf * Jeff Squyres wrote on Mon, Sep 21, 2009 at 02:45:28PM CEST: > Ick; I appreciate

Re: [OMPI devel] RFC: Adding -DOPEN_MPI=1 to mpif77 and mpif90

2010-02-11 Thread Ralf Wildenhues
Hi Jeff, * Jeff Squyres wrote on Wed, Feb 10, 2010 at 10:02:27PM CET: > WHAT: Add -DOPEN_MPI=1 to the mpif77 and mpif90 command lines > But we can put -DOPEN_MPI=1 in the argv that the wrapper adds. This > seems like a safe way to add it; it makes no difference whether the > Fortran file is set

Re: [OMPI devel] RFC: Adding -DOPEN_MPI=1 to mpif77 and mpif90

2010-02-12 Thread Ralf Wildenhues
* Jeff Squyres wrote on Thu, Feb 11, 2010 at 12:41:15PM CET: > On Feb 11, 2010, at 1:00 AM, Ralf Wildenhues wrote: > > * Jeff Squyres wrote on Wed, Feb 10, 2010 at 10:02:27PM CET: > > > WHAT: Add -DOPEN_MPI=1 to the mpif77 and mpif90 command lines > > > > It won't

Re: [OMPI devel] configure question

2010-02-17 Thread Ralf Wildenhues
Hello Greg, * Greg Watson wrote on Tue, Feb 16, 2010 at 07:03:30PM CET: > When I run configure under Snow Leopard (this is OMPI 1.3.4), I get the > following: > > checking if C and Fortran 77 are link compatible... no > ** > It

Re: [OMPI devel] RFC: ABI break between 1.4 and 1.5 / .so versioning

2010-02-17 Thread Ralf Wildenhues
Hello Jeff, * Jeff Squyres wrote on Wed, Feb 17, 2010 at 08:19:25PM CET: > The issue is that if the user has to specify -static to their linker, > they *also* have to specify --ompi:static, or Bad Things will happen. > Or, if they don't specify -static but *only* specify --ompi:static, > Bad

Re: [OMPI devel] RFC: ABI break between 1.4 and 1.5 / .so versioning

2010-02-18 Thread Ralf Wildenhues
* Jeff Squyres wrote on Wed, Feb 17, 2010 at 11:51:42PM CET: > On Feb 17, 2010, at 3:05 PM, Ralf Wildenhues wrote: > > > > The issue is that if the user has to specify -static to their linker, > > > they *also* have to specify --ompi:static, or Bad Things will happen.

Re: [OMPI devel] Migrate the OpenMPI to VxWorks

2010-04-16 Thread Ralf Wildenhues
* Ralph Castain wrote on Fri, Apr 16, 2010 at 05:35:37AM CEST: > I have not personally tried, but I am pretty sure that you can install > the autotools under VxWorks - have you tried to download the latest > autotool tarballs and build them? I don't know if that works well out of the box, but if

Re: [O-MPI devel] configure hangs in libtool..

2005-08-26 Thread Ralf Wildenhues
Hi Peter, * Peter Kjellström wrote on Fri, Aug 26, 2005 at 05:21:27PM CEST: > > I just checked out 7046 and my configure hangs at: > > configure: creating ./config.status > config.status: creating Makefile > config.status: creating config.h > config.status: executing depfiles commands >

Re: [O-MPI devel] configure hangs in libtool..

2005-08-26 Thread Ralf Wildenhues
* Ralf Wildenhues wrote on Fri, Aug 26, 2005 at 06:04:19PM CEST: > > Libtool version previous to 1.5.16 had a bug in the macro to detect > this; it was often wrong before. Now it should be pretty bogus. Gah. That should've been: Now it should be pretty good. Sorry.

Re: [O-MPI devel] OpenIB results

2005-08-27 Thread Ralf Wildenhues
Hi Troy, * Troy Benjegerdes wrote on Sat, Aug 27, 2005 at 04:38:02AM CEST: > On Fri, Aug 26, 2005 at 12:35:07PM -0400, Jeff Squyres wrote: > > On Aug 26, 2005, at 12:19 PM, Ralf Wildenhues wrote: > > > > > (It would be good to augment the autogen.sh script so that it hono

[O-MPI devel] tar file name length limit

2005-08-27 Thread Ralf Wildenhues
>From a recent ChangeLog entry: | Part 1 of 2 of a commit to reduce filenames in the romio component | (because we kept bumping up against the max filename limit in "tar" | when making tarballs, especially if the version number got long). If you can allow to limit developers to Automake >= 1.9,

[O-MPI devel] small shell quoting issue

2005-08-29 Thread Ralf Wildenhues
A small patch: On one hand, Bourne shells do not do word splitting after parameter expansion and command substitution, of stuff on the right hand side of an assignment. On the other hand, nested quotes within backquotes are not portable. (This is also documented in the Autoconf manual).

Re: [O-MPI devel] small shell quoting issue

2005-08-30 Thread Ralf Wildenhues
* Jeff Squyres wrote on Tue, Aug 30, 2005 at 12:45:32PM CEST: > Huh. And I always thought it was the other way around (you *had* to > put "" around it or they would be treated as separate words). They do it usually. They don't do it on the right hand side of an assignment (i.e., after "="),

[O-MPI devel] Small ltdl use update

2005-08-31 Thread Ralf Wildenhues
Please apply the first patch (or a similar solution) to include ltdl.h directly. This is both how it's documented and how it will work with Libtool 1.5.x and 2.x: the latter has other included files, which live one directory level further down. Below is another tiny patch to please "make

[O-MPI devel] "fix" for romio configure.in

2005-08-31 Thread Ralf Wildenhues
This is a rather subtle issue, and pretty ugly, unfortunately. For the curious reader, here is a rather technical explanation: Somewhere, inside some if test "$arch_..." branching construct (but not inside an Autoconf macro definition!), the configure.in script uses the macro AC_CHECK_HEADER.

Re: [O-MPI devel] Small ltdl use update

2005-08-31 Thread Ralf Wildenhues
Hi Jeff, * Jeff Squyres wrote on Wed, Aug 31, 2005 at 12:58:05PM CEST: > On Aug 31, 2005, at 2:48 AM, Ralf Wildenhues wrote: > > > Please apply the first patch (or a similar solution) to include > > ltdl.h directly. This is both how it's documented and how > > it will

Re: [O-MPI devel] ltdl.h problem

2005-09-01 Thread Ralf Wildenhues
Hi George, * George Bosilca wrote on Thu, Sep 01, 2005 at 05:54:15AM CEST: > Starting from yesterday I'm unable to compile on several clusters. I check > the version of libtool, automake and autoconf and they all are the latest. > However, in all the component I get similar errors: > > In file

Re: [O-MPI devel] ltdl.h problem

2005-09-01 Thread Ralf Wildenhues
Hi George, * George Bosilca wrote on Thu, Sep 01, 2005 at 06:49:48AM CEST: > > Now I see the reason behind this change. Anyway, few month ago we decide > to switch the compilation process, and to modify all the files in order to > start all the #include directives with the full path of the

Re: [O-MPI devel] IMPORTANT: Libtool version

2005-09-02 Thread Ralf Wildenhues
Hi Jeff, * Jeff Squyres wrote on Fri, Sep 02, 2005 at 12:23:35PM CEST: > Haven't heard back from any of the other core developers about their > versions of Libtool. I don't belong in this group, but FWIW: 1.5.20 (or CVS versions). > FAIR WARNING: If I don't hear back from anyone by COB today,

Re: [O-MPI devel] Small ltdl use update

2005-09-05 Thread Ralf Wildenhues
Hi Jeff, * Jeff Squyres wrote on Thu, Sep 01, 2005 at 02:45:41PM CEST: > On Aug 31, 2005, at 7:46 AM, Ralf Wildenhues wrote: > > >>> Please apply the first patch (or a similar solution) to include > >>> ltdl.h directly. This is both how it's documented and how &

Re: [O-MPI devel] rcache

2005-09-07 Thread Ralf Wildenhues
Hi George, (Note I know hardly anything about rcache, or mca for that matter, but a bit about Automake) * George Bosilca wrote on Wed, Sep 07, 2005 at 08:29:44PM CEST: > It can happpens that the compilation will fails after the rcache > commit. It's again a dependency problem. You just have to

Re: [O-MPI devel] rcache

2005-09-08 Thread Ralf Wildenhues
Hi George, * George Bosilca wrote on Wed, Sep 07, 2005 at 09:08:36PM CEST: > On Sep 7, 2005, at 2:47 PM, Ralf Wildenhues wrote: > > * George Bosilca wrote on Wed, Sep 07, 2005 at 08:29:44PM CEST: > > > >> It can happpens that the compilation will fails after the rcache

Re: [O-MPI devel] 64bit shared library problems

2005-09-13 Thread Ralf Wildenhues
Hi Nathan, Nathan DeBardeleben writes: I've been having this problem for a week or so and I've been asking other people to weigh in if they know what I'm doing wrong. I've gotten no where on this so I figure I'll finally drop it out on the list. First, here's the important info: The

Re: [O-MPI devel] error message on make

2005-09-16 Thread Ralf Wildenhues
Hi Jeff, Tim, James, * Jeff Squyres wrote on Thu, Sep 15, 2005 at 02:55:26AM CEST: > > There appear to be two problems: > > - I borked up the libnuma configure.m4 such that mpicc (and friends) > don't get the right flags for libnuma when you compile OMPI statically. > > - James' problem seems

Re: [O-MPI devel] why do we need the backward dependencies ?

2005-09-23 Thread Ralf Wildenhues
Hi George, Andrew, * Andrew Friedley wrote on Thu, Sep 22, 2005 at 09:09:11PM CEST: > I'm going to take a stab at this, though Jeff should be the definitive > authority on how this all works. Yes. FWIW, I believe you summarized it quite well. > On Sep 22, 2005, at 12:56 PM, George Bosilca

Re: [O-MPI devel] why do we need the backward dependencies ?

2005-09-23 Thread Ralf Wildenhues
Andrew, * Ralf Wildenhues wrote on Fri, Sep 23, 2005 at 10:42:34AM CEST: > * Andrew Friedley wrote on Thu, Sep 22, 2005 at 09:09:11PM CEST: > > On Sep 22, 2005, at 12:56 PM, George Bosilca wrote: > > > > > > Now we get this message for all .so file we generate: > >

Re: [O-MPI devel] why do we need the backward dependencies ?

2005-09-23 Thread Ralf Wildenhues
Hi George, * George Bosilca wrote on Fri, Sep 23, 2005 at 06:05:28PM CEST: > > But I still see a problem. **Just to refresh the memories, I'm the only > complaining on a regular base about the useless dependencies**. And > there are a lot. I know that most of the shared libraries in ompi use

Re: [O-MPI devel] Back to 32bit on 64bit machines...

2005-09-27 Thread Ralf Wildenhues
Hi Nathan, Jeff, * Jeff Squyres wrote on Tue, Sep 27, 2005 at 09:39:59PM CEST: > This looks like it *might* be a libtool problem -- it's picking up the > /usr/lib64/libstdc++.so when you're compiling in 32 bit mode (and > therefore barfing). Yep, I think it is. > Can you send the libtool

Re: [O-MPI devel] bproc question

2005-09-27 Thread Ralf Wildenhues
Hi Greg, * Greg Watson wrote on Tue, Sep 27, 2005 at 10:27:22PM CEST: > > Trying to install ompi on a bproc machine with no network filesystem. > I've copied the contents of the ompi lib directory into /tmp/ompi on > each node and set my LD_LIBRARY_PATH to /tmp/ompi. However when I run >

Re: [O-MPI devel] Dumb SVN question (was RE: Segfaults on startup?)

2005-10-24 Thread Ralf Wildenhues
Hi Troy, * Troy Benjegerdes wrote on Sun, Oct 23, 2005 at 09:07:05PM CEST: > > So.. I have a checkout of ompi/branches/v1.0 .. is there any easy way for > me do something like: > > 'svn up [UNKOWN FLAG] http://svn.open-mpi.org/svn/ompi/trunk' Yes: svn switch

Re: [O-MPI devel] ppc64 linux bustage?

2005-10-24 Thread Ralf Wildenhues
* Brian Barrett wrote on Tue, Oct 25, 2005 at 01:15:41AM CEST: > On Oct 24, 2005, at 6:07 PM, Troy Benjegerdes wrote: > > On Mon, Oct 24, 2005 at 10:40:39AM -0500, Brian Barrett wrote: > > > >> Can you build dynamically and run "ompi_info -all" and send the > >> results to the list? > > > > To

Re: [O-MPI devel] ppc64 linux bustage?

2005-10-25 Thread Ralf Wildenhues
Hi Troy, * Troy Benjegerdes wrote on Tue, Oct 25, 2005 at 03:30:46AM CEST: > On Mon, Oct 24, 2005 at 07:30:54PM -0500, Brian Barrett wrote: > > On Oct 24, 2005, at 6:56 PM, Troy Benjegerdes wrote: > > > > >> | configure: /bin/sh './configure' *failed* for opal/libltdl > > >> > > >> Troy, could

Re: [O-MPI devel] ppc64 linux bustage?

2005-10-29 Thread Ralf Wildenhues
Hi Troy, * Troy Benjegerdes wrote on Sat, Oct 29, 2005 at 08:01:08AM CEST: > > > > > Do you have a debian system you can remove the libltdl3 and libltdl3-dev > > > packages? > > > > Yes, I could try that tonight (my timezone), but.. (I can't try that, actually, without upgrading my sarge

[O-MPI devel] libtoolize --ltdl non-failure (was: ppc64 linux bustage?)

2005-10-29 Thread Ralf Wildenhues
only). ] > * Troy Benjegerdes wrote on Sat, Oct 29, 2005 at 08:01:08AM CEST: > [ reported this: ] * Ralf Wildenhues wrote on Sat, Oct 29, 2005 at 10:38:11AM CEST: > It's a bug when > libtoolize --ltdl > succeeds although it did not find the libltdl source files. To reproduce: uni

Re: [O-MPI devel] New build methodology

2005-11-15 Thread Ralf Wildenhues
Hi Ralph, * Ralph H. Castain wrote on Tue, Nov 15, 2005 at 03:12:38PM CET: > > While I generally find the new build methodology (i.e., reducing the > number of makefiles) has little impact on me, I have now encountered > one problem that causes a significant difficulty. In trying to work > on

Re: [O-MPI devel] ltdl.h problem

2005-11-23 Thread Ralf Wildenhues
Hi George, * George Bosilca wrote on Wed, Nov 23, 2005 at 08:15:30AM CET: > As I continue to have the same problem with the missing ltdl.h header I > reported few days ago, I spend some time today to dig a little bit inside > to find out what and how happens. Finally, I figure out the problem.

Re: [O-MPI devel] PGI configure failure..

2005-12-03 Thread Ralf Wildenhues
re what I wrote to them. > On Dec 3, 2005, at 10:30 AM, Ralf Wildenhues wrote: > > [1] wget \ > > http://savannah.gnu.org/cgi-bin/viewcvs/~checkout~/config/config/ > > config.sub \ > > http://savannah.gnu.org/cgi-bin/viewcvs/~checkout~/config/config/ > > config.g

Re: [O-MPI devel] Libtool 1.5.22

2005-12-20 Thread Ralf Wildenhues
* Craig Rasmussen wrote on Tue, Dec 20, 2005 at 04:36:39PM CET: > On Dec 20, 2005, at 7:34 AM, Jeff Squyres wrote: > > > If you are watching the commit logs, you'll notice that Libtool > > 1.5.22 has been released. It fixes some problems that some of our > > users have been running into, and

Re: [O-MPI devel] debugging methods

2006-01-05 Thread Ralf Wildenhues
* Craig Rasmussen wrote on Wed, Jan 04, 2006 at 05:45:55PM CET: > > The CCA people seemed to be worried that there was a long dead time > between releases and were wondering if they should give up on autoconf > and move to something else (cmake). I love (to hate) autoconf and was > hoping that

Re: [O-MPI devel] debugging methods

2006-01-09 Thread Ralf Wildenhues
Hi Brian, * Brian Barrett wrote on Thu, Jan 05, 2006 at 04:26:58PM CET: > On Jan 5, 2006, at 4:22 AM, Ralf Wildenhues wrote: > > > > Are the improvements/bugfixes you/the CCA people need already in CVS > > Autoconf? > For Open MPI, I can think of a couple of thin

Re: [O-MPI devel] configure warning

2006-01-10 Thread Ralf Wildenhues
* Greg Watson wrote on Tue, Jan 10, 2006 at 05:58:35PM CET: > Running configure from 1.0.2a3 on OSX 10.4.3: > > configure: WARNING: net/if.h: present but cannot be compiled > configure: WARNING: net/if.h: check for missing prerequisite > headers? Yes. The test is broken. You need to

Re: [O-MPI devel] configure warning

2006-01-11 Thread Ralf Wildenhues
* Brian Barrett wrote on Wed, Jan 11, 2006 at 05:28:55AM CET: > On Jan 10, 2006, at 12:15 PM, Ralf Wildenhues wrote: > > * Greg Watson wrote on Tue, Jan 10, 2006 at 05:58:35PM CET: > >> Running configure from 1.0.2a3 on OSX 10.4.3: > >> > >> configure: W

[O-MPI devel] f77_check.m4 changes

2006-01-13 Thread Ralf Wildenhues
Hi Brian, Did you mean this in your recent changes to the trunk? I'm not quite sure, I don't really understand the code at a glance. Without it, configure barfs over here because it contains if ...; then fi somewhere, which is a shell syntax error. Cheers, Ralf Index: config/f77_check.m4

Re: [O-MPI devel] f77_check.m4 changes

2006-01-13 Thread Ralf Wildenhues
* Ralf Wildenhues wrote on Fri, Jan 13, 2006 at 03:28:09PM CET: > > Did you mean this in your recent changes to the trunk? > I'm not quite sure, I don't really understand the code > at a glance. Hmm, another thing that fails here is that ompi_fortran_integer16_t gets set to "

Re: [O-MPI devel] f77_check.m4 changes

2006-01-13 Thread Ralf Wildenhues
* Brian Barrett wrote on Fri, Jan 13, 2006 at 03:53:33PM CET: > Yup - Jeff found this one this morning. Stupid me testing on x86 > only :(. Anyway, this and your other one were just fixed in SVN. Thank you very much, seems to work fine! Cheers, Ralf

[O-MPI devel] ompi_get_version

2006-01-18 Thread Ralf Wildenhues
Hello there, Proposed below is a patch to remove the redundant instance of the version algorithm, together with some cleanup (for unification of the two algorithms, which have diverged a little) and a micro bit more efficiency. One could add a rebuilding rule to config/Makefile.am, if you think

  1   2   >