Re: [OMPI devel] Mac OS X 10.4.x users?

2018-09-28 Thread Paul Hargrove
Even *I* don't attempt to support OS X that old. :wink: -Paul On Fri, Sep 28, 2018 at 11:41 AM Jeff Squyres (jsquyres) via devel < devel@lists.open-mpi.org> wrote: > Fun fact: we cause configure to fail for OS X <= 10.4 anyway: > >

Re: [OMPI devel] Mac OS X 10.4.x users?

2018-09-28 Thread Jeff Squyres (jsquyres) via devel
Fun fact: we cause configure to fail for OS X <= 10.4 anyway: https://github.com/open-mpi/ompi/blob/master/configure.ac#L328-L347 According to the comment, we do this because of a known-bad implementation of pty in the OS X kernel that causes kernel panics. So I think we're definitely safe

Re: [OMPI devel] Mac OS X 10.4.x users?

2018-09-28 Thread Ralph H Castain
Good lord - break away!! > On Sep 28, 2018, at 11:11 AM, Barrett, Brian via devel > wrote: > > All - > > In trying to clean up some warnings, I noticed one (around pack/unpack in > net/if.h) that is due to a workaround of a bug in MacOS X 10.4.x and earlier. > The simple way to remove the