Re: another i810 crash when switching bewteen X and text console

2007-11-04 Thread loic . mahe
 When you use 865patch, would you happen to be specifying its 'nocheck'
 parameter?

No, I don't use it.

Loïc

Re: another i810 crash when switching bewteen X and text console

2007-10-30 Thread Marc Aurele La France

On Mon, 29 Oct 2007, [EMAIL PROTECTED] wrote:


Correct me if I'm wrong, but these are not the correct logs.  None of

them

show a segfault, let alone an initially BIOS-reported VideoRAM value of

0.



Indeed. Here are now :



4) the logfile displaying the crash when you switch to the text console
and back (865patch not started - no VideoRam parameter)



5) the logfile when restarting X after the crash ; here you will find the
initially BIOS-reported VideoRAM value of 0



(II) I810(0): VESA VBE Total Mem: 0 kB


When you use 865patch, would you happen to be specifying its 'nocheck' 
parameter?


Thanks.

Marc.

+--+--+
|  Marc Aurele La France   |  work:   1-780-492-9310  |
|  Academic Information and|  fax:1-780-492-1729  |
|Communications Technologies   |  email:  [EMAIL PROTECTED] |
|  352 General Services Building   +--+
|  University of Alberta   |  |
|  Edmonton, Alberta   |Standard disclaimers apply|
|  T6G 2H1 |  |
|  CANADA  |  |
+--+--+
XFree86 developer and VP.  ATI driver and X server internals.
___
Devel mailing list
Devel@XFree86.Org
http://XFree86.Org/mailman/listinfo/devel


Re: another i810 crash when switching bewteen X and text console

2007-10-24 Thread loic . mahe
Sorry to be late, but I had to switch to another activity.

I made some tests with the lastest build (4.7.99.3). The PC (Dell GX270) 
is
cold-started between each test, since it seems that a simple reboot 
doesn't
reset the BIOS.

 (Christian)
 A question to the person who started this thread: Does setting the
 VideoRam option in the Device section of the XFree86 configuration
 file to 32000 and not running 865patch help?

Test with VideoRam set to 32000 in the config file and 865patch not 
started.
Here are the significant log lines (I can send the whole file upon demand) 
:

(II) I810(0): VESA VBE Total Mem: 8064 kB
(WW) I810(0): Detected stolen memory (8000 kB) doesn't match what the BIOS 
reports (8064 kB)
(II) I810(0): Will attempt to tell the BIOS that there is 12288 kB 
VideoRAM
(WW) I810(0): Extended BIOS function 0x5f11 not supported.
(II) I810(0): BIOS view of memory size can't be changed (this is not an 
error)
(**) I810(0): VideoRAM: 32000 kByte
(--) I810(0): Maximum frambuffer space: 31832 kByte
(--) I810(0): Maximum space available for video modes: 8064 kByte
(II) I810(0): VESA VBE Total Mem: 0 kB
(II) I810(0): BIOS call 0x5f05 not supported, setting refresh with VBE 3 
method.

What is strange here is the second VESA VBE Total Mem: line, which 
indicates 0 kB !!!

Then, if I switch to the text console and back, the crash is still here :

(WW) I810(0): PGTBL_ER is 0x0029

   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

Caught signal 11.
Stack trace:
 0: 0x808e796: 0x808e780 xf86ShowStackTrace + 0x16
Module /usr/X11R6/bin/XFree86
 1: 0x808e8a8: 0x808e820 xf86SigHandler + 0x88
Module /usr/X11R6/bin/XFree86
 2: 0x400828b8: cannot guess
 3: 0x40561734: 0x405615c0 I830BIOSEnterVT + 0x174
Module /usr/X11R6/lib/modules/drivers/i810_drv.o
Section .text
 4: 0x406eb307: 0x406eb2e0 XAAEnterVT + 0x27
Module /usr/X11R6/lib/modules/libxaa.a:xaaInit.o
Section .text
 5: 0x4073c41a: 0x4073c3f0 xf86CursorEnterVT + 0x2a
Module /usr/X11R6/lib/modules/libramdac.a:xf86Cursor.o
Section .text
 6: 0x810ca6e: 0x810ca40 CMapEnterVT + 0x2e
Module /usr/X11R6/bin/XFree86
 7: 0x810a7ec: 0x810a7c0 xf86XVEnterVT + 0x2c
Module /usr/X11R6/bin/XFree86
 8: 0x808eb9f: 0x808e8c0 xf86VTSwitch + 0x2df
Module /usr/X11R6/bin/XFree86
 9: 0x808e6ae: 0x808e4f0 xf86Wakeup + 0x1be
Module /usr/X11R6/bin/XFree86
10: 0x80c645c: 0x80c6420 WakeupHandler + 0x3c
Module /usr/X11R6/bin/XFree86
11: 0x80e196a: 0x80e15b0 WaitForSomething + 0x3ba
Module /usr/X11R6/bin/XFree86
12: 0x80c00b4: 0x80c0040 Dispatch + 0x74
Module /usr/X11R6/bin/XFree86
13: 0x80d10cb: 0x80d0b30 main + 0x59b
Module /usr/X11R6/bin/XFree86

Fatal server error:
Server aborting

After the crash (without reboot), X starts again (since it's respawned by 
init)
and here are again the significant log lines :

(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): VESA VBE Total Mem: 0 kB
(WW) I810(0): Detected stolen memory (8000 kB) doesn't match what the BIOS 
reports (0 kB)
(II) UnloadSubModule: int10
(II) Loading sub module int10
(II) I810(0): VESA VBE Total Mem: 12288 kB
(II) I810(0): Tweak BIOS image to 12288 kB VideoRAM
(==) I810(0): VideoRAM: 65536 kByte
(--) I810(0): Maximum frambuffer space: 65368 kByte
(--) I810(0): Maximum space available for video modes: 12288 kByte
(WW) I810(0): Extended BIOS function 0x5f05 failed.

So I think the 865patch is still need for the 865G on the Dell GX270.

This is not a problem for me, as I previoulsy stated, since at 
installation
time (RedHat's anaconda), the Video Memory isn't always correctly detected
(and it's perhaps to confusing for the end-user).
So I prefer not to use this configuration option and use the 865patch.

 (Marc)
 Indeed.  The problem is that zero isn't recognised as a valid
 TweakMemorySize() return.  The attached, which I've already committed,
 should fix this.

I'm not sure, since every time I don't use the 865patch, with or without
the VideoRam parameter, I get these messages on the second int10 launch
(before drmOpenDevice).

(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): VESA VBE Total Mem: 0 kB

And the crash still occurs after switch to text console and back.

Loïc

Re: another i810 crash when switching bewteen X and text console

2007-10-24 Thread Marc Aurele La France

On Wed, 24 Oct 2007, [EMAIL PROTECTED] wrote:


Sorry to be late, but I had to switch to another activity.



I made some tests with the lastest build (4.7.99.3). The PC (Dell GX270)
is
cold-started between each test, since it seems that a simple reboot
doesn't
reset the BIOS.



(Christian)
A question to the person who started this thread: Does setting the
VideoRam option in the Device section of the XFree86 configuration
file to 32000 and not running 865patch help?



Test with VideoRam set to 32000 in the config file and 865patch not
started.
Here are the significant log lines (I can send the whole file upon demand)
:



(II) I810(0): VESA VBE Total Mem: 8064 kB
(WW) I810(0): Detected stolen memory (8000 kB) doesn't match what the BIOS
reports (8064 kB)
(II) I810(0): Will attempt to tell the BIOS that there is 12288 kB
VideoRAM
(WW) I810(0): Extended BIOS function 0x5f11 not supported.
(II) I810(0): BIOS view of memory size can't be changed (this is not an
error)
(**) I810(0): VideoRAM: 32000 kByte
(--) I810(0): Maximum frambuffer space: 31832 kByte
(--) I810(0): Maximum space available for video modes: 8064 kByte
(II) I810(0): VESA VBE Total Mem: 0 kB
(II) I810(0): BIOS call 0x5f05 not supported, setting refresh with VBE 3
method.



What is strange here is the second VESA VBE Total Mem: line, which
indicates 0 kB !!!


Yes, that's what your prior logs reported.


Then, if I switch to the text console and back, the crash is still here :

(WW) I810(0): PGTBL_ER is 0x0029


This is new.


  *** If unresolved symbols were reported above, they might not
  *** be the reason for the server aborting.



Caught signal 11.
Stack trace:
0: 0x808e796: 0x808e780 xf86ShowStackTrace + 0x16
   Module /usr/X11R6/bin/XFree86
1: 0x808e8a8: 0x808e820 xf86SigHandler + 0x88
   Module /usr/X11R6/bin/XFree86
2: 0x400828b8: cannot guess
3: 0x40561734: 0x405615c0 I830BIOSEnterVT + 0x174
   Module /usr/X11R6/lib/modules/drivers/i810_drv.o
   Section .text
4: 0x406eb307: 0x406eb2e0 XAAEnterVT + 0x27
   Module /usr/X11R6/lib/modules/libxaa.a:xaaInit.o
   Section .text
5: 0x4073c41a: 0x4073c3f0 xf86CursorEnterVT + 0x2a
   Module /usr/X11R6/lib/modules/libramdac.a:xf86Cursor.o
   Section .text
6: 0x810ca6e: 0x810ca40 CMapEnterVT + 0x2e
   Module /usr/X11R6/bin/XFree86
7: 0x810a7ec: 0x810a7c0 xf86XVEnterVT + 0x2c
   Module /usr/X11R6/bin/XFree86
8: 0x808eb9f: 0x808e8c0 xf86VTSwitch + 0x2df
   Module /usr/X11R6/bin/XFree86
9: 0x808e6ae: 0x808e4f0 xf86Wakeup + 0x1be
   Module /usr/X11R6/bin/XFree86
10: 0x80c645c: 0x80c6420 WakeupHandler + 0x3c
   Module /usr/X11R6/bin/XFree86
11: 0x80e196a: 0x80e15b0 WaitForSomething + 0x3ba
   Module /usr/X11R6/bin/XFree86
12: 0x80c00b4: 0x80c0040 Dispatch + 0x74
   Module /usr/X11R6/bin/XFree86
13: 0x80d10cb: 0x80d0b30 main + 0x59b
   Module /usr/X11R6/bin/XFree86



Fatal server error:
Server aborting



After the crash (without reboot), X starts again (since it's respawned by
init)
and here are again the significant log lines :



(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): VESA VBE Total Mem: 0 kB
(WW) I810(0): Detected stolen memory (8000 kB) doesn't match what the BIOS
reports (0 kB)
(II) UnloadSubModule: int10
(II) Loading sub module int10
(II) I810(0): VESA VBE Total Mem: 12288 kB
(II) I810(0): Tweak BIOS image to 12288 kB VideoRAM
(==) I810(0): VideoRAM: 65536 kByte
(--) I810(0): Maximum frambuffer space: 65368 kByte
(--) I810(0): Maximum space available for video modes: 12288 kByte
(WW) I810(0): Extended BIOS function 0x5f05 failed.



So I think the 865patch is still need for the 865G on the Dell GX270.



This is not a problem for me, as I previoulsy stated, since at
installation
time (RedHat's anaconda), the Video Memory isn't always correctly detected
(and it's perhaps to confusing for the end-user).
So I prefer not to use this configuration option and use the 865patch.



(Marc)
Indeed.  The problem is that zero isn't recognised as a valid
TweakMemorySize() return.  The attached, which I've already committed,
should fix this.



I'm not sure, since every time I don't use the 865patch, with or without
the VideoRam parameter, I get these messages on the second int10 launch
(before drmOpenDevice).



(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): VESA VBE Total Mem: 0 kB



And the crash still occurs after switch to text console and back.


Please post the _complete_ log.

Marc.

+--+--+
|  Marc Aurele La France   |  work:   1-780-492-9310  |
|  Academic Information and|  fax:1-780-492-1729  |
|Communications Technologies   |  email:  [EMAIL PROTECTED] |
|  352 General Services Building   +--+
|  University of Alberta   |  |
|  Edmonton, Alberta   |Standard disclaimers apply|
|  T6G 2H1 |

Re: another i810 crash when switching bewteen X and text console

2007-10-03 Thread Marc Aurele La France

On Tue, 2 Oct 2007, Marc Aurele La France wrote:

On Mon, 1 Oct 2007 [EMAIL PROTECTED] wrote:

Complete logfiles are attached (I recall this is a Dell Optiplex GX270).



Thanks for the logs.



So it seems that the builtin patch doesn't work here.



Indeed.  The problem is that zero isn't recognised as a valid
TweakMemorySize() return.  The attached, which I've already committed,
should fix this.


The rest of the driver might not like saveBIOSMemSize being set to one, so 
here's a slight correction.


Marc.

+--+--+
|  Marc Aurele La France   |  work:   1-780-492-9310  |
|  Academic Information and|  fax:1-780-492-1729  |
|Communications Technologies   |  email:  [EMAIL PROTECTED] |
|  352 General Services Building   +--+
|  University of Alberta   |  |
|  Edmonton, Alberta   |Standard disclaimers apply|
|  T6G 2H1 |  |
|  CANADA  |  |
+--+--+
XFree86 developer and VP.  ATI driver and X server internals.

cvs-devel.diff.gz
Description: Binary data


Re: another i810 crash when switching bewteen X and text console

2007-10-02 Thread Marc Aurele La France
On Mon, 1 Oct 2007 [EMAIL PROTECTED] wrote:

 Complete logfiles are attached (I recall this is a Dell Optiplex GX270).

Thanks for the logs.

 So it seems that the builtin patch doesn't work here.

Indeed.  The problem is that zero isn't recognised as a valid 
TweakMemorySize() return.  The attached, which I've already committed, 
should fix this.

Thanks.

Marc.

+--+--+
|  Marc Aurele La France   |  work:   1-780-492-9310  |
|  Academic Information and|  fax:1-780-492-1729  |
|Communications Technologies   |  email:  [EMAIL PROTECTED] |
|  352 General Services Building   +--+
|  University of Alberta   |  |
|  Edmonton, Alberta   |Standard disclaimers apply|
|  T6G 2H1 |  |
|  CANADA  |  |
+--+--+
XFree86 developer and VP.  ATI driver and X server internals.

cvs-devel.diff.gz
Description: Binary data


Re Re: another i810 crash when switching bewteen X and text console

2007-09-27 Thread loic . mahe
Marc Aurele La France [EMAIL PROTECTED] :

 The driver already does this for some chips.  Can you produce a patch to 

 the driver that extends this to other chip revisions?  I have little 
 experience with this driver and no hardware that I could use to test 
such 
 a change.

Oops, I'm not sure to have the experience (and time ...) to do that.
I'm more a sysadmin that a programmer.
865patch is a userland program (used lrmi library) and is written in a
completely different way compared to the i810 driver.

Loïc

Re: another i810 crash when switching bewteen X and text console

2007-09-25 Thread Marc Aurele La France

On Wed, 12 Sep 2007, [EMAIL PROTECTED] wrote:


I've noticed this with the Intel 865G chipset (i810 driver) on XFree86
4.7.0
(Linux, 2.4.35 kernel).



I've got two different machines with this chipset. In both cases, the BIOS
is
set-up for using 8MB of VRAM (this memory is taken from the RAM).



1) industrial PC : 8085:2572 with subvendor/device 8086:4246 (Intel 865
GBF motherboard)



Here there is no crash.



2) Dell GX270 : 8086:2572 with subvendor/device 1028:0151 (Dell
motherboard)



Here X crashes when switching to text console and back to X.
It seems that the Dell BIOS mismanages something ...



The solution I found to avoid this crash is to use 865patch (available at
http://www.chzsoft.com.ar/855patch.html) and set the VRAM to 32000
(for example) before starting X.



I think this could be mentionned in the release-notes and/or i810 man
page.



IMHO the same information could be given for the Intel 845G (eg apply
845patch).


The driver already does this for some chips.  Can you produce a patch to 
the driver that extends this to other chip revisions?  I have little 
experience with this driver and no hardware that I could use to test such 
a change.


Thanks.

Marc.

+--+--+
|  Marc Aurele La France   |  work:   1-780-492-9310  |
|  Academic Information and|  fax:1-780-492-1729  |
|Communications Technologies   |  email:  [EMAIL PROTECTED] |
|  352 General Services Building   +--+
|  University of Alberta   |  |
|  Edmonton, Alberta   |Standard disclaimers apply|
|  T6G 2H1 |  |
|  CANADA  |  |
+--+--+
XFree86 developer and VP.  ATI driver and X server internals.
___
Devel mailing list
Devel@XFree86.Org
http://XFree86.Org/mailman/listinfo/devel