Re: [Development] QRegularExpression -- first round of API review

2012-01-17 Thread Thiago Macieira
On Tuesday, 17 de January de 2012 15.15.15, Giuseppe D'Angelo wrote: > 2012/1/17 Thiago Macieira : > > On Tuesday, 17 de January de 2012 02.43.33, Giuseppe D'Angelo wrote: > >> 1) Support for more pattern options and match options. Right now you > >> can see them commented in the .h (and there's no

Re: [Development] QRegularExpression -- first round of API review

2012-01-17 Thread Giuseppe D'Angelo
On 17 January 2012 13:10, Charley Bay wrote: >> > 3) Need a couple of better names for partial matching: >> > - partial match preferring a complete match >> > - partial match returning whatever match (partial or complete) is found >> > first >> > >> > PCRE uses Soft and Hard respectively (which ar

Re: [Development] QRegularExpression -- first round of API review

2012-01-17 Thread Giuseppe D'Angelo
2012/1/17 Thiago Macieira : > On Tuesday, 17 de January de 2012 02.43.33, Giuseppe D'Angelo wrote: >> 1) Support for more pattern options and match options. Right now you >> can see them commented in the .h (and there's no code for them), but >> adding them is trivial. Any opinions for just enablin

Re: [Development] QRegularExpression -- first round of API review

2012-01-17 Thread Giuseppe D'Angelo
2012/1/17 Thiago Macieira : > You have a method with two option flags: >   QRegularExpressionMatch match(const QString &subject, >                                  int offset                = 0, >                                  MatchType matchType       = NormalMatch, >                          

Re: [Development] QRegularExpression -- first round of API review

2012-01-17 Thread Charley Bay
> > > 3) Need a couple of better names for partial matching: > > - partial match preferring a complete match > > - partial match returning whatever match (partial or complete) is found > > first > > > > PCRE uses Soft and Hard respectively (which are quite meaningless to > > me). > > PreferComplete

Re: [Development] QRegularExpression -- first round of API review

2012-01-17 Thread Thiago Macieira
On Tuesday, 17 de January de 2012 02.43.33, Giuseppe D'Angelo wrote: > 1) Support for more pattern options and match options. Right now you > can see them commented in the .h (and there's no code for them), but > adding them is trivial. Any opinions for just enabling them or only > some? In particu

Re: [Development] QRegularExpression -- first round of API review

2012-01-17 Thread Thiago Macieira
On Tuesday, 17 de January de 2012 02.43.33, Giuseppe D'Angelo wrote: > 2) Support for named capturing groups with duplicated names. The point > is that this may require a couple of additional accessors inside > QRegularExpressionMatch to extract all the substrings captured by a > given name. > The

Re: [Development] QRegularExpression -- first round of API review

2012-01-17 Thread Thiago Macieira
On Tuesday, 17 de January de 2012 02.43.33, Giuseppe D'Angelo wrote: > 3) Need a couple of better names for partial matching: > - partial match preferring a complete match > - partial match returning whatever match (partial or complete) is found > first > > PCRE uses Soft and Hard respectively (whi

Re: [Development] QRegularExpression -- first round of API review

2012-01-17 Thread shane.kearns
> > 3) Need a couple of better names for partial matching: > - partial match preferring a complete match > - partial match returning whatever match (partial or complete) is found > first > > PCRE uses Soft and Hard respectively (which are quite meaningless to > me). PreferCompleteMatch / PreferFir

Re: [Development] QRegularExpression -- first round of API review

2012-01-16 Thread Giuseppe D'Angelo
Hi, hopefully this will be the last round :-) The updated header is available at [1], the code itself is also almost complete and I'm writing unit tests and documentation for it, in the meanwhile I've also updated some simple benchmarking results [2]. I've added a full iterator class (forward onl

Re: [Development] QRegularExpression -- first round of API review

2012-01-11 Thread Thiago Macieira
On Wednesday, 11 de January de 2012 16.43.11, Thiago Macieira wrote: > > "Subject" simply means "the string you're matching your regexp > > against", so there's no confusion when one talks about "strings" > > (there are the pattern string and the subject string). > > Ok. But then see below... It d

Re: [Development] QRegularExpression -- first round of API review

2012-01-11 Thread Thiago Macieira
On Wednesday, 11 de January de 2012 17.53.17, Giuseppe D'Angelo wrote: > 2012/1/11 Thiago Macieira : > > Hi, thanks for the reply. :) > > > First, you'll need to get a Nokian to import the PCRE sources. You cannot > > submit them to Gerrit (not even to the commit you made) because that > > violates

Re: [Development] QRegularExpression -- first round of API review

2012-01-11 Thread Giuseppe D'Angelo
2012/1/11 Thiago Macieira : Hi, thanks for the reply. :) > First, you'll need to get a Nokian to import the PCRE sources. You cannot > submit them to Gerrit (not even to the commit you made) because that violates > the CLA. You're not the author. Please don't submit the PCRE code again -- > just

Re: [Development] QRegularExpression -- first round of API review

2012-01-11 Thread Thiago Macieira
On Wednesday, 11 de January de 2012 12.49.27, Giuseppe D'Angelo wrote: > Up? > Nobody wants to discuss this? It's above the bikeshed threshold :-) First, you'll need to get a Nokian to import the PCRE sources. You cannot submit them to Gerrit (not even to the commit you made) because that violate

Re: [Development] QRegularExpression -- first round of API review

2012-01-11 Thread Giuseppe D'Angelo
Up? Nobody wants to discuss this? Cheers, -- Giuseppe D'Angelo ___ Development mailing list Development@qt-project.org http://lists.qt-project.org/mailman/listinfo/development

Re: [Development] QRegularExpression -- first round of API review

2012-01-06 Thread Giuseppe D'Angelo
Hi, following w00t's suggestion, I've started to publish some code on gerrit: (it took more to refactor after removing UTF-8, rather than doing it right the first time... that's life). It's still a WIP, and many things are still mis

Re: [Development] QRegularExpression -- first round of API review

2011-12-16 Thread Oswald Buddenhagen
On Fri, Dec 16, 2011 at 12:07:26AM +, ext Giuseppe D'Angelo wrote: > On 15 December 2011 19:45, Oswald Buddenhagen > wrote: > >>     void setPatternOptions(PatternOptions options, bool on = true); > >> > > i don't like that too much, because *un*setting options en masse sucks - > > you need t

Re: [Development] QRegularExpression -- first round of API review

2011-12-15 Thread Andre Somers
Op 16-12-2011 1:07, Giuseppe D'Angelo schreef: > >> fwiw, the usual elegant solution is having a value and a mask parameter. >> the mask could have two magic values meaning "un-/set all asserted in >> vlaue" to mean effectively what your bool means. the default argument >> would be the magic value

Re: [Development] QRegularExpression -- first round of API review

2011-12-15 Thread Giuseppe D'Angelo
2011/12/16 Thiago Macieira : > I did read most of your email :-) Thanks for the effort so far. Hero :-) Thank you for reading! > I'd like to start by saying I agree with Ossi: the test/set way of setting > flags is "un-Qt-ish". I know it exists in a few places, but they are the vast > minority. I

Re: [Development] QRegularExpression -- first round of API review

2011-12-15 Thread Giuseppe D'Angelo
On 15 December 2011 22:53, wrote: > Hi Giuseppe, Hi João, thanks for the comments. > I'll start by saying tl;dr. But I didn't stop because of your e-mail, I'm > actually referring to the API. > > I started looking at it and it seems too cluttered. Specially this early in > the process. It's h

Re: [Development] QRegularExpression -- first round of API review

2011-12-15 Thread Thiago Macieira
On Thursday, 15 de December de 2011 22.53.19, joao.abeca...@nokia.com wrote: > Hi Giuseppe, > > I'll start by saying tl;dr. But I didn't stop because of your e-mail, I'm > actually referring to the API. Hi as well Giuseppe I did read most of your email :-) Thanks for the effort so far. I'd like

Re: [Development] QRegularExpression -- first round of API review

2011-12-15 Thread Giuseppe D'Angelo
On 15 December 2011 19:45, Oswald Buddenhagen wrote: > On Thu, Dec 15, 2011 at 04:43:49PM +, ext Giuseppe D'Angelo wrote: >>    pos, matchedLength, endPos >> > inconsistent naming Well, pos and matchedLength come straight from QRegExp and I kept them. But please, any suggestion is welcome! (I

Re: [Development] QRegularExpression -- first round of API review

2011-12-15 Thread joao.abecasis
-bounces+joao.abecasis=nokia@qt-project.org] on behalf of ext Giuseppe D'Angelo [dange...@gmail.com] Sent: 15 December 2011 17:43 To: development@qt-project.org Subject: [Development] QRegularExpression -- first round of API review Hi everybody. Sorry for the length of thjis message, b

Re: [Development] QRegularExpression -- first round of API review

2011-12-15 Thread Oswald Buddenhagen
On Thu, Dec 15, 2011 at 04:43:49PM +, ext Giuseppe D'Angelo wrote: >pos, matchedLength, endPos > inconsistent naming > void setPatternOptions(PatternOptions options, bool on = true); > i don't like that too much, because *un*setting options en masse sucks - you need to make a "block"

[Development] QRegularExpression -- first round of API review

2011-12-15 Thread Giuseppe D'Angelo
Hi everybody. Sorry for the length of thjis message, but doing API reviews by mail is hard, and I needed to explain many decisions here and there (and, of course, the API itself). :-( Attached to this mail (and also here: -- if you don't want to d