Re: [Development] kdelibs coding style

2013-04-30 Thread Samuel Rødal
On 04/29/2013 10:31 PM, Olivier Goffart wrote: On Monday 29 April 2013 09:43:55 Thiago Macieira wrote: On segunda-feira, 29 de abril de 2013 17.16.49, Sergio Martins wrote: The thing is, I just discovered that the kdelibs style[1] has a little difference from Qt, it uses braces for one-line if

Re: [Development] QML - PathView not responding on drag event with touch

2013-04-30 Thread Matteo Brichese
PathView, like many QtQuick components that you might think of as touch-oriented, is actually only handling mouse events. So it works because it will get synthesized mouse events on devices that don't already provide them. (The upside is it should work the same with mouse and touch. The

Re: [Development] Qt5 combined source package - Perl dependency

2013-04-30 Thread Oswald Buddenhagen
On Mon, Apr 29, 2013 at 11:25:14AM -0700, Thiago Macieira wrote: Adding a random file somewhere *usually* isn't a problem. It is a problem only if the presence of a file changes the output of the build. And that's exactly what configure.exe and the include/ dir do: they change the output.

[Development] HEADS UP: renamed qtwebkit-examples-and-demos = qtwebkit-examples

2013-04-30 Thread Oswald Buddenhagen
moin, as proposed on http://lists.qt-project.org/pipermail/releasing/2013-March/001177.html (and approved on irc), i have now renamed the repository. this has some (somewhat minor) consequences: - the supermodule is currently broken, waiting for https://codereview.qt-project.org/55050 to

Re: [Development] kdelibs coding style

2013-04-30 Thread Charley Bay
Samuel sayeth: A good reason for using the Foo() : x(0) , y(0) { } syntax for initializer lists after all is to make diffs easier to read when adding or removing a member variable. The same argument could be made for permitting braces for one-line if-statements. +1, that's

Re: [Development] kdelibs coding style

2013-04-30 Thread Mitch Curtis
On 04/29/2013 10:31 PM, Olivier Goffart wrote: I support the change to optionally permit the braces. +1. Have always disliked this particular style. ___ Development mailing list Development@qt-project.org

Re: [Development] Qt5 combined source package - Perl dependency

2013-04-30 Thread Thiago Macieira
On terça-feira, 30 de abril de 2013 11.00.11, Oswald Buddenhagen wrote: On Mon, Apr 29, 2013 at 11:25:14AM -0700, Thiago Macieira wrote: Adding a random file somewhere *usually* isn't a problem. It is a problem only if the presence of a file changes the output of the build. And that's

Re: [Development] kdelibs coding style

2013-04-30 Thread Thiago Macieira
On terça-feira, 30 de abril de 2013 08.54.31, Samuel Rødal wrote: A good reason for using the Foo() : x(0) , y(0) This is extremely ugly and should be discouraged. -- Thiago Macieira - thiago.macieira (AT) intel.com Software Architect - Intel Open Source Technology Center

Re: [Development] kdelibs coding style

2013-04-30 Thread Axel Waggershauser
On Tue, Apr 30, 2013 at 5:13 PM, Thiago Macieira thiago.macie...@intel.com wrote: On terça-feira, 30 de abril de 2013 08.54.31, Samuel Rødal wrote: A good reason for using the Foo() : x(0) , y(0) This is extremely ugly and should be discouraged. If it is about the sum of all

Re: [Development] Qt5 combined source package - Perl dependency

2013-04-30 Thread Oswald Buddenhagen
On Tue, Apr 30, 2013 at 08:12:36AM -0700, Thiago Macieira wrote: On terça-feira, 30 de abril de 2013 11.00.11, Oswald Buddenhagen wrote: ones can simply delete include/ (and configure.exe) from the extracted source tree, They have to know that those exist in the first place and should be

Re: [Development] kdelibs coding style

2013-04-30 Thread Jocelyn Turcotte
On Tue, Apr 30, 2013 at 07:37:36AM -0600, Charley Bay wrote: Samuel sayeth: A good reason for using the Foo() : x(0) , y(0) { } syntax for initializer lists after all is to make diffs easier to read when adding or removing a member variable. The same argument could

Re: [Development] Qt5 combined source package - Perl dependency

2013-04-30 Thread Thiago Macieira
On terça-feira, 30 de abril de 2013 17.24.29, Oswald Buddenhagen wrote: Can we do it somehow less magically? Isn't there a way to do it if it needs to be done, and not do it if it doesn't need to be done? no, because latest on the second in-source build it would not be necessary any

Re: [Development] kdelibs coding style

2013-04-30 Thread Thiago Macieira
On segunda-feira, 29 de abril de 2013 23.30.59, André Pönitz wrote: The rules are ok as they are (pretty much as _any_ set of consistently applied and not-completely-weird rules). Opening them up only leads to more review bikeshedding. It's not that people actively change coding style in old

Re: [Development] Qt5 combined source package - Perl dependency

2013-04-30 Thread Oswald Buddenhagen
On Tue, Apr 30, 2013 at 08:59:47AM -0700, Thiago Macieira wrote: On terça-feira, 30 de abril de 2013 17.24.29, Oswald Buddenhagen wrote: Can we do it somehow less magically? Isn't there a way to do it if it needs to be done, and not do it if it doesn't need to be done? no, because

Re: [Development] kdelibs coding style

2013-04-30 Thread Oswald Buddenhagen
On Tue, Apr 30, 2013 at 09:01:51AM -0700, Thiago Macieira wrote: On segunda-feira, 29 de abril de 2013 23.30.59, André Pönitz wrote: The rules are ok as they are (pretty much as _any_ set of consistently applied and not-completely-weird rules). Opening them up only leads to more review

Re: [Development] kdelibs coding style

2013-04-30 Thread Thiago Macieira
On terça-feira, 30 de abril de 2013 18.47.33, Oswald Buddenhagen wrote: on a personal note, while i strongly sympathize with the diff minimization philosophy, i also feel quite a dislike for excess braces. adding to that the in this case pretty persuasive consideration of the status quo, i'd

Re: [Development] kdelibs coding style

2013-04-30 Thread Daniel Teske
On Tuesday 30 Apr 2013 19:44:45 Thiago Macieira wrote: On terça-feira, 30 de abril de 2013 18.47.33, Oswald Buddenhagen wrote: on a personal note, while i strongly sympathize with the diff minimization philosophy, i also feel quite a dislike for excess braces. adding to that the in this

Re: [Development] kdelibs coding style

2013-04-30 Thread Thiago Macieira
On terça-feira, 30 de abril de 2013 19.51.40, Daniel Teske wrote: So you suggest that KDE adopt the Qt style and Qt doesn't change anything? Why do they need to be the same? That was the request: can they be the same? They are identical except for the braces-on-if. I tried to compromise, but

Re: [Development] kdelibs coding style

2013-04-30 Thread Lorn Potter
On 01/05/2013, at 2:01 AM, Thiago Macieira thiago.macie...@intel.com wrote: On segunda-feira, 29 de abril de 2013 23.30.59, André Pönitz wrote: The rules are ok as they are (pretty much as _any_ set of consistently applied and not-completely-weird rules). Opening them up only leads to more

Re: [Development] kdelibs coding style

2013-04-30 Thread Lorn Potter
On 01/05/2013, at 2:47 AM, Oswald Buddenhagen oswald.buddenha...@digia.com wrote: On Tue, Apr 30, 2013 at 09:01:51AM -0700, Thiago Macieira wrote: On segunda-feira, 29 de abril de 2013 23.30.59, André Pönitz wrote: The rules are ok as they are (pretty much as _any_ set of consistently

Re: [Development] kdelibs coding style

2013-04-30 Thread Alan Alpert
On Tue, Apr 30, 2013 at 12:38 PM, Lorn Potter lorn.pot...@gmail.com wrote: On 01/05/2013, at 2:47 AM, Oswald Buddenhagen oswald.buddenha...@digia.com wrote: On Tue, Apr 30, 2013 at 09:01:51AM -0700, Thiago Macieira wrote: On segunda-feira, 29 de abril de 2013 23.30.59, André Pönitz wrote: