Re: [Dhis2-devs] [Bug 1320212] [NEW] Warning possibly relate to xerces library while migrating to dhis 2.14 to 2.15

2014-05-19 Thread Lars Helge Øverland
Hi Bob,

thanks for looking into this.

Morten, do you think you can comment on this?

I have excluded xercesImpl for now, I think it should be provided by the
container anyway so should not be a problem. We can put it back if
necessary.

Lars






On Fri, May 16, 2014 at 2:45 PM, Bob Jolliffe bobjolli...@gmail.com wrote:

 Yes I see that xercesImpl has crept back in again (this time as a
 dependency of openid4j).  I think we can just exclude it (just like
 jasperreports and geotools) in root pom.xml but I am reluctant to do it as
 I don't really have any scaffolding to test openid.

 Morten, maybe when you get the chance will you try?  Or anybody else who
 has been testing openid.

 Bob


 On 16 May 2014 13:33, Romain-Rolland Tohouri rom...@tohouri.com wrote:

  Public bug reported:
 
  Migrating a server from dhis2.14 form dhis2.15 i got the following
  warning in the log file and we think it may be related to xerces
  library.
 
  May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext log
  INFO: Initializing Spring FrameworkServlet 'webapi'
  Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property '
  http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
  recognized.
 
 
  Thanks,
 
  Romain
 
  ** Affects: dhis2
   Importance: Undecided
   Status: New
 
  --
  You received this bug notification because you are a member of DHIS 2
  developers, which is subscribed to DHIS.
  https://bugs.launchpad.net/bugs/1320212
 
  Title:
Warning possibly relate to xerces library while migrating to dhis 2.14
to 2.15
 
  Status in DHIS 2:
New
 
  Bug description:
Migrating a server from dhis2.14 form dhis2.15 i got the following
warning in the log file and we think it may be related to xerces
library.
 
May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext
 log
INFO: Initializing Spring FrameworkServlet 'webapi'
Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property
 '
  http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
  recognized.
 
 
Thanks,
 
Romain
 
  To manage notifications about this bug go to:
  https://bugs.launchpad.net/dhis2/+bug/1320212/+subscriptions
 
  ___
  Mailing list: https://launchpad.net/~dhis2-devs
  Post to : dhis2-devs@lists.launchpad.net
  Unsubscribe : https://launchpad.net/~dhis2-devs
  More help   : https://help.launchpad.net/ListHelp
 

 --
 You received this bug notification because you are a member of DHIS 2
 developers, which is subscribed to DHIS.
 https://bugs.launchpad.net/bugs/1320212

 Title:
   Warning possibly relate to xerces library while migrating to dhis 2.14
   to 2.15

 Status in DHIS 2:
   New

 Bug description:
   Migrating a server from dhis2.14 form dhis2.15 i got the following
   warning in the log file and we think it may be related to xerces
   library.

   May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext log
   INFO: Initializing Spring FrameworkServlet 'webapi'
   Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property '
 http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
 recognized.


   Thanks,

   Romain

 To manage notifications about this bug go to:
 https://bugs.launchpad.net/dhis2/+bug/1320212/+subscriptions

 ___
 Mailing list: https://launchpad.net/~dhis2-devs
 Post to : dhis2-devs@lists.launchpad.net
 Unsubscribe : https://launchpad.net/~dhis2-devs
 More help   : https://help.launchpad.net/ListHelp

___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Bug 1320212] [NEW] Warning possibly relate to xerces library while migrating to dhis 2.14 to 2.15

2014-05-19 Thread Morten Olav Hansen
I think it should be fine, as long as some kind of impl is provided by the
container.

--
Morten


On Mon, May 19, 2014 at 8:30 PM, Lars Helge Øverland larshe...@gmail.comwrote:

 Hi Bob,

 thanks for looking into this.

 Morten, do you think you can comment on this?

 I have excluded xercesImpl for now, I think it should be provided by the
 container anyway so should not be a problem. We can put it back if
 necessary.

 Lars






 On Fri, May 16, 2014 at 2:45 PM, Bob Jolliffe bobjolli...@gmail.comwrote:

 Yes I see that xercesImpl has crept back in again (this time as a
 dependency of openid4j).  I think we can just exclude it (just like
 jasperreports and geotools) in root pom.xml but I am reluctant to do it as
 I don't really have any scaffolding to test openid.

 Morten, maybe when you get the chance will you try?  Or anybody else who
 has been testing openid.

 Bob


 On 16 May 2014 13:33, Romain-Rolland Tohouri rom...@tohouri.com wrote:

  Public bug reported:
 
  Migrating a server from dhis2.14 form dhis2.15 i got the following
  warning in the log file and we think it may be related to xerces
  library.
 
  May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext log
  INFO: Initializing Spring FrameworkServlet 'webapi'
  Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property '
  http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
  recognized.
 
 
  Thanks,
 
  Romain
 
  ** Affects: dhis2
   Importance: Undecided
   Status: New
 
  --
  You received this bug notification because you are a member of DHIS 2
  developers, which is subscribed to DHIS.
  https://bugs.launchpad.net/bugs/1320212
 
  Title:
Warning possibly relate to xerces library while migrating to dhis 2.14
to 2.15
 
  Status in DHIS 2:
New
 
  Bug description:
Migrating a server from dhis2.14 form dhis2.15 i got the following
warning in the log file and we think it may be related to xerces
library.
 
May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext
 log
INFO: Initializing Spring FrameworkServlet 'webapi'
Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser:
 Property '
  http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
  recognized.
 
 
Thanks,
 
Romain
 
  To manage notifications about this bug go to:
  https://bugs.launchpad.net/dhis2/+bug/1320212/+subscriptions
 
  ___
  Mailing list: https://launchpad.net/~dhis2-devs
  Post to : dhis2-devs@lists.launchpad.net
  Unsubscribe : https://launchpad.net/~dhis2-devs
  More help   : https://help.launchpad.net/ListHelp
 

 --
 You received this bug notification because you are a member of DHIS 2
 developers, which is subscribed to DHIS.
 https://bugs.launchpad.net/bugs/1320212

 Title:
   Warning possibly relate to xerces library while migrating to dhis 2.14
   to 2.15

 Status in DHIS 2:
   New

 Bug description:
   Migrating a server from dhis2.14 form dhis2.15 i got the following
   warning in the log file and we think it may be related to xerces
   library.

   May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext log
   INFO: Initializing Spring FrameworkServlet 'webapi'
   Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property '
 http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
 recognized.


   Thanks,

   Romain

 To manage notifications about this bug go to:
 https://bugs.launchpad.net/dhis2/+bug/1320212/+subscriptions

 ___
 Mailing list: https://launchpad.net/~dhis2-devs
 Post to : dhis2-devs@lists.launchpad.net
 Unsubscribe : https://launchpad.net/~dhis2-devs
 More help   : https://help.launchpad.net/ListHelp



 ___
 Mailing list: https://launchpad.net/~dhis2-devs
 Post to : dhis2-devs@lists.launchpad.net
 Unsubscribe : https://launchpad.net/~dhis2-devs
 More help   : https://help.launchpad.net/ListHelp


___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Bug 1320212] [NEW] Warning possibly relate to xerces library while migrating to dhis 2.14 to 2.15

2014-05-19 Thread Bob Jolliffe
The parser impl should be provided by the java runtime.


On 19 May 2014 19:56, Morten Olav Hansen morte...@gmail.com wrote:

 I think it should be fine, as long as some kind of impl is provided by the
 container.

 --
 Morten


 On Mon, May 19, 2014 at 8:30 PM, Lars Helge Øverland 
 larshe...@gmail.comwrote:

 Hi Bob,

 thanks for looking into this.

 Morten, do you think you can comment on this?

 I have excluded xercesImpl for now, I think it should be provided by the
 container anyway so should not be a problem. We can put it back if
 necessary.

 Lars






 On Fri, May 16, 2014 at 2:45 PM, Bob Jolliffe bobjolli...@gmail.comwrote:

 Yes I see that xercesImpl has crept back in again (this time as a
 dependency of openid4j).  I think we can just exclude it (just like
 jasperreports and geotools) in root pom.xml but I am reluctant to do it
 as
 I don't really have any scaffolding to test openid.

 Morten, maybe when you get the chance will you try?  Or anybody else who
 has been testing openid.

 Bob


 On 16 May 2014 13:33, Romain-Rolland Tohouri rom...@tohouri.com wrote:

  Public bug reported:
 
  Migrating a server from dhis2.14 form dhis2.15 i got the following
  warning in the log file and we think it may be related to xerces
  library.
 
  May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext
 log
  INFO: Initializing Spring FrameworkServlet 'webapi'
  Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property
 '
  http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
  recognized.
 
 
  Thanks,
 
  Romain
 
  ** Affects: dhis2
   Importance: Undecided
   Status: New
 
  --
  You received this bug notification because you are a member of DHIS 2
  developers, which is subscribed to DHIS.
  https://bugs.launchpad.net/bugs/1320212
 
  Title:
Warning possibly relate to xerces library while migrating to dhis
 2.14
to 2.15
 
  Status in DHIS 2:
New
 
  Bug description:
Migrating a server from dhis2.14 form dhis2.15 i got the following
warning in the log file and we think it may be related to xerces
library.
 
May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext
 log
INFO: Initializing Spring FrameworkServlet 'webapi'
Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser:
 Property '
  http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
  recognized.
 
 
Thanks,
 
Romain
 
  To manage notifications about this bug go to:
  https://bugs.launchpad.net/dhis2/+bug/1320212/+subscriptions
 
  ___
  Mailing list: https://launchpad.net/~dhis2-devs
  Post to : dhis2-devs@lists.launchpad.net
  Unsubscribe : https://launchpad.net/~dhis2-devs
  More help   : https://help.launchpad.net/ListHelp
 

 --
 You received this bug notification because you are a member of DHIS 2
 developers, which is subscribed to DHIS.
 https://bugs.launchpad.net/bugs/1320212

 Title:
   Warning possibly relate to xerces library while migrating to dhis 2.14
   to 2.15

 Status in DHIS 2:
   New

 Bug description:
   Migrating a server from dhis2.14 form dhis2.15 i got the following
   warning in the log file and we think it may be related to xerces
   library.

   May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext
 log
   INFO: Initializing Spring FrameworkServlet 'webapi'
   Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property
 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
 recognized.


   Thanks,

   Romain

 To manage notifications about this bug go to:
 https://bugs.launchpad.net/dhis2/+bug/1320212/+subscriptions

 ___
 Mailing list: https://launchpad.net/~dhis2-devs
 Post to : dhis2-devs@lists.launchpad.net
 Unsubscribe : https://launchpad.net/~dhis2-devs
 More help   : https://help.launchpad.net/ListHelp



 ___
 Mailing list: https://launchpad.net/~dhis2-devs
 Post to : dhis2-devs@lists.launchpad.net
 Unsubscribe : https://launchpad.net/~dhis2-devs
 More help   : https://help.launchpad.net/ListHelp



 ___
 Mailing list: https://launchpad.net/~dhis2-devs
 Post to : dhis2-devs@lists.launchpad.net
 Unsubscribe : https://launchpad.net/~dhis2-devs
 More help   : https://help.launchpad.net/ListHelp


___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Bug 1320212] [NEW] Warning possibly relate to xerces library while migrating to dhis 2.14 to 2.15

2014-05-16 Thread Bob Jolliffe
Yes I see that xercesImpl has crept back in again (this time as a
dependency of openid4j).  I think we can just exclude it (just like
jasperreports and geotools) in root pom.xml but I am reluctant to do it as
I don't really have any scaffolding to test openid.

Morten, maybe when you get the chance will you try?  Or anybody else who
has been testing openid.

Bob


On 16 May 2014 13:33, Romain-Rolland Tohouri rom...@tohouri.com wrote:

 Public bug reported:

 Migrating a server from dhis2.14 form dhis2.15 i got the following
 warning in the log file and we think it may be related to xerces
 library.

 May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext log
 INFO: Initializing Spring FrameworkServlet 'webapi'
 Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property '
 http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
 recognized.


 Thanks,

 Romain

 ** Affects: dhis2
  Importance: Undecided
  Status: New

 --
 You received this bug notification because you are a member of DHIS 2
 developers, which is subscribed to DHIS.
 https://bugs.launchpad.net/bugs/1320212

 Title:
   Warning possibly relate to xerces library while migrating to dhis 2.14
   to 2.15

 Status in DHIS 2:
   New

 Bug description:
   Migrating a server from dhis2.14 form dhis2.15 i got the following
   warning in the log file and we think it may be related to xerces
   library.

   May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext log
   INFO: Initializing Spring FrameworkServlet 'webapi'
   Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property '
 http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not
 recognized.


   Thanks,

   Romain

 To manage notifications about this bug go to:
 https://bugs.launchpad.net/dhis2/+bug/1320212/+subscriptions

 ___
 Mailing list: https://launchpad.net/~dhis2-devs
 Post to : dhis2-devs@lists.launchpad.net
 Unsubscribe : https://launchpad.net/~dhis2-devs
 More help   : https://help.launchpad.net/ListHelp


-- 
You received this bug notification because you are a member of DHIS 2
developers, which is subscribed to DHIS.
https://bugs.launchpad.net/bugs/1320212

Title:
  Warning possibly relate to xerces library while migrating to dhis 2.14
  to 2.15

Status in DHIS 2:
  New

Bug description:
  Migrating a server from dhis2.14 form dhis2.15 i got the following
  warning in the log file and we think it may be related to xerces
  library.

  May 16, 2014 11:42:49 AM org.apache.catalina.core.ApplicationContext log
  INFO: Initializing Spring FrameworkServlet 'webapi'
  Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property 
'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not 
recognized.

  
  Thanks,

  Romain

To manage notifications about this bug go to:
https://bugs.launchpad.net/dhis2/+bug/1320212/+subscriptions

___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp