Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-31 Thread Bob Jolliffe
Version 2.31 will not

On Wed, 31 Oct 2018, 09:00 moses mwale,  wrote:

> Sorry just to interject, so dhis2 does not work with Postgres 9.5?
>
> On Wed, 31 Oct 2018 at 9:58 AM, Bjørn Sandvik  wrote:
>
>> Hi,
>>
>> PostGIS requirement is 2.2 or later.
>> AFAIK, this will still be the case for 2.31.
>>
>> Regards,
>> Bjørn
>>
>> --
>> Bjørn Sandvik
>> GIS developer, DHIS 2
>> University of Oslo
>> www.dhis2.org
>>
>> On Wed, Oct 31, 2018 at 8:18 AM Calle Hedberg 
>> wrote:
>>
>>> Hi,
>>>
>>> With regard to minimum pg requirements: Bjorn, what is the minimum
>>> version requirement for Postgis, and what is the recommended version?
>>> Again, postGIS 2.5 was released recently, so if people need to upgrade
>>> anyhow it makes sense to upgrade to the latest, tested version...
>>>
>>> Regards
>>> Calle
>>>
>>> On Wed, 31 Oct 2018 at 09:15, Calle Hedberg 
>>> wrote:
>>>
 Lars,

 With postgresql version 11 out - are there any specific reasons for NOT
 using pg 11? Many of the key features introduced in 10 - like table
 partitioning - have been further enhanced in 11.

 Regards
 Calle

 On Wed, 31 Oct 2018 at 08:04, stepho...@gmail.com 
 wrote:

> Thanks Lars.
>
> Just to be clear, Is that the minimum requirements for PostgreSQL?
>
> Sent from my HTC
>
> - Reply message -
> From: "Lars Helge Øverland" 
> To: "DHIS 2 Users list" , "DHIS 2
> Developers list" 
> Subject: [Dhis2-users] postgresql version 9.6 required for dhis
> version 2.31
> Date: Tue, Oct 30, 2018 23:33
>
> Hi all,
>
> heads up: for DHIS 2 version 2.31 we will require PostgreSQL version
> 9.6.
>
> This is in order to take advantage of certain SQL features introduced
> in that version. The current required version is 9.4.
>
> If you plan to upgrade your PostgreSQL version we recommend going
> straight to version 10, as it contains several great features and
> performance improvements. Also, we will eventually require this version 
> and
> so going directly to version 10 will avoid multiple successive upgrades.
>
>
> best regards,
>
> Lars
>
>
>
> Lars Helge Øverland
> Technical lead, DHIS 2
> University of Oslo
> l...@dhis2.org
> https://www.dhis2.org
>
> ___
> Mailing list: https://launchpad.net/~dhis2-devs
> Post to : dhis2-devs@lists.launchpad.net
> Unsubscribe : https://launchpad.net/~dhis2-devs
> More help   : https://help.launchpad.net/ListHelp
>


 --

 ***

 Calle Hedberg

 46D Alma Road, 7700 Rosebank, SOUTH AFRICA

 Tel/fax (home): +27-21-685-6472

 Cell: +27-82-853-5352

 Iridium SatPhone: +8816-315-19119

 Email: calle.hedb...@gmail.com

 Skype: calle_hedberg

 ***


>>>
>>> --
>>>
>>> ***
>>>
>>> Calle Hedberg
>>>
>>> 46D Alma Road, 7700 Rosebank, SOUTH AFRICA
>>>
>>> Tel/fax (home): +27-21-685-6472
>>>
>>> Cell: +27-82-853-5352
>>>
>>> Iridium SatPhone: +8816-315-19119
>>>
>>> Email: calle.hedb...@gmail.com
>>>
>>> Skype: calle_hedberg
>>>
>>> ***
>>>
>>>
>>
>> --
>> Bjørn Sandvik
>> GIS developer, DHIS 2
>> University of Oslo
>> www.dhis2.org
>> ___
>> Mailing list: https://launchpad.net/~dhis2-devs
>> Post to : dhis2-devs@lists.launchpad.net
>> Unsubscribe : https://launchpad.net/~dhis2-devs
>> More help   : https://help.launchpad.net/ListHelp
>>
> --
> developer_lusaka_systems
> ___
> Mailing list: https://launchpad.net/~dhis2-devs
> Post to : dhis2-devs@lists.launchpad.net
> Unsubscribe : https://launchpad.net/~dhis2-devs
> More help   : https://help.launchpad.net/ListHelp
>
___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-31 Thread Lars Helge Øverland
On Wed, 31 Oct 2018 at 07:03, stepho...@gmail.com 
wrote:

> Thanks Lars.
>
> Just to be clear, Is that the minimum requirements for PostgreSQL?
>
>
Correct. Version 9.6 or higher.

regards,

Lars



> Sent from my HTC
>
> - Reply message -
> From: "Lars Helge Øverland" 
> To: "DHIS 2 Users list" , "DHIS 2
> Developers list" 
> Subject: [Dhis2-users] postgresql version 9.6 required for dhis version
> 2.31
> Date: Tue, Oct 30, 2018 23:33
>
> Hi all,
>
> heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6.
>
> This is in order to take advantage of certain SQL features introduced in
> that version. The current required version is 9.4.
>
> If you plan to upgrade your PostgreSQL version we recommend going straight
> to version 10, as it contains several great features and performance
> improvements. Also, we will eventually require this version and so going
> directly to version 10 will avoid multiple successive upgrades.
>
>
> best regards,
>
> Lars
>
>
>
> Lars Helge Øverland
> Technical lead, DHIS 2
> University of Oslo
> l...@dhis2.org
> https://www.dhis2.org
>
>

-- 


Lars Helge Øverland
Technical lead, DHIS 2
University of Oslo
l...@dhis2.org
https://www.dhis2.org
___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-31 Thread Lars Helge Øverland
On Wed, 31 Oct 2018 at 09:00, moses mwale  wrote:

> Sorry just to interject, so dhis2 does not work with Postgres 9.5?
>

PostgreSQL 9.5 will work up to DHIS 2 version 2.30.

For DHIS 2.31 you will need PostgreSQL 9.6 or higher.

regards,

Lars


> On Wed, 31 Oct 2018 at 9:58 AM, Bjørn Sandvik  wrote:
>
>> Hi,
>>
>> PostGIS requirement is 2.2 or later.
>> AFAIK, this will still be the case for 2.31.
>>
>> Regards,
>> Bjørn
>>
>> --
>> Bjørn Sandvik
>> GIS developer, DHIS 2
>> University of Oslo
>> www.dhis2.org
>>
>> On Wed, Oct 31, 2018 at 8:18 AM Calle Hedberg 
>> wrote:
>>
>>> Hi,
>>>
>>> With regard to minimum pg requirements: Bjorn, what is the minimum
>>> version requirement for Postgis, and what is the recommended version?
>>> Again, postGIS 2.5 was released recently, so if people need to upgrade
>>> anyhow it makes sense to upgrade to the latest, tested version...
>>>
>>> Regards
>>> Calle
>>>
>>> On Wed, 31 Oct 2018 at 09:15, Calle Hedberg 
>>> wrote:
>>>
 Lars,

 With postgresql version 11 out - are there any specific reasons for NOT
 using pg 11? Many of the key features introduced in 10 - like table
 partitioning - have been further enhanced in 11.

 Regards
 Calle

 On Wed, 31 Oct 2018 at 08:04, stepho...@gmail.com 
 wrote:

> Thanks Lars.
>
> Just to be clear, Is that the minimum requirements for PostgreSQL?
>
> Sent from my HTC
>
> - Reply message -
> From: "Lars Helge Øverland" 
> To: "DHIS 2 Users list" , "DHIS 2
> Developers list" 
> Subject: [Dhis2-users] postgresql version 9.6 required for dhis
> version 2.31
> Date: Tue, Oct 30, 2018 23:33
>
> Hi all,
>
> heads up: for DHIS 2 version 2.31 we will require PostgreSQL version
> 9.6.
>
> This is in order to take advantage of certain SQL features introduced
> in that version. The current required version is 9.4.
>
> If you plan to upgrade your PostgreSQL version we recommend going
> straight to version 10, as it contains several great features and
> performance improvements. Also, we will eventually require this version 
> and
> so going directly to version 10 will avoid multiple successive upgrades.
>
>
> best regards,
>
> Lars
>
>
>
> Lars Helge Øverland
> Technical lead, DHIS 2
> University of Oslo
> l...@dhis2.org
> https://www.dhis2.org
>
> ___
> Mailing list: https://launchpad.net/~dhis2-devs
> Post to : dhis2-devs@lists.launchpad.net
> Unsubscribe : https://launchpad.net/~dhis2-devs
> More help   : https://help.launchpad.net/ListHelp
>


 --

 ***

 Calle Hedberg

 46D Alma Road, 7700 Rosebank, SOUTH AFRICA

 Tel/fax (home): +27-21-685-6472

 Cell: +27-82-853-5352

 Iridium SatPhone: +8816-315-19119

 Email: calle.hedb...@gmail.com

 Skype: calle_hedberg

 ***


>>>
>>> --
>>>
>>> ***
>>>
>>> Calle Hedberg
>>>
>>> 46D Alma Road, 7700 Rosebank, SOUTH AFRICA
>>>
>>> Tel/fax (home): +27-21-685-6472
>>>
>>> Cell: +27-82-853-5352
>>>
>>> Iridium SatPhone: +8816-315-19119
>>>
>>> Email: calle.hedb...@gmail.com
>>>
>>> Skype: calle_hedberg
>>>
>>> ***
>>>
>>>
>>
>> --
>> Bjørn Sandvik
>> GIS developer, DHIS 2
>> University of Oslo
>> www.dhis2.org
>> ___
>> Mailing list: https://launchpad.net/~dhis2-devs
>> Post to : dhis2-devs@lists.launchpad.net
>> Unsubscribe : https://launchpad.net/~dhis2-devs
>> More help   : https://help.launchpad.net/ListHelp
>>
> --
> developer_lusaka_systems
> ___
> Mailing list: https://launchpad.net/~dhis2-users
> Post to : dhis2-us...@lists.launchpad.net
> Unsubscribe : https://launchpad.net/~dhis2-users
> More help   : https://help.launchpad.net/ListHelp
>


-- 


Lars Helge Øverland
Technical lead, DHIS 2
University of Oslo
l...@dhis2.org
https://www.dhis2.org
___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-31 Thread Lars Helge Øverland
On Wed, 31 Oct 2018 at 08:15, Calle Hedberg  wrote:

> Lars,
>
> With postgresql version 11 out - are there any specific reasons for NOT
> using pg 11? Many of the key features introduced in 10 - like table
> partitioning - have been further enhanced in 11.
>
>
No reason that I am aware of and it will likely work fine.

The reason for recommending 10 is that DHIS 2 is *well tested* on that
version as the developers are using it and I am aware of many prod
installations using it.

regards,

Lars




> Regards
> Calle
>
> On Wed, 31 Oct 2018 at 08:04, stepho...@gmail.com 
> wrote:
>
>> Thanks Lars.
>>
>> Just to be clear, Is that the minimum requirements for PostgreSQL?
>>
>> Sent from my HTC
>>
>> - Reply message -
>> From: "Lars Helge Øverland" 
>> To: "DHIS 2 Users list" , "DHIS 2
>> Developers list" 
>> Subject: [Dhis2-users] postgresql version 9.6 required for dhis version
>> 2.31
>> Date: Tue, Oct 30, 2018 23:33
>>
>> Hi all,
>>
>> heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6.
>>
>> This is in order to take advantage of certain SQL features introduced in
>> that version. The current required version is 9.4.
>>
>> If you plan to upgrade your PostgreSQL version we recommend going
>> straight to version 10, as it contains several great features and
>> performance improvements. Also, we will eventually require this version and
>> so going directly to version 10 will avoid multiple successive upgrades.
>>
>>
>> best regards,
>>
>> Lars
>>
>>
>>
>> Lars Helge Øverland
>> Technical lead, DHIS 2
>> University of Oslo
>> l...@dhis2.org
>> https://www.dhis2.org
>>
>> ___
>> Mailing list: https://launchpad.net/~dhis2-devs
>> Post to : dhis2-devs@lists.launchpad.net
>> Unsubscribe : https://launchpad.net/~dhis2-devs
>> More help   : https://help.launchpad.net/ListHelp
>>
>
>
> --
>
> ***
>
> Calle Hedberg
>
> 46D Alma Road, 7700 Rosebank, SOUTH AFRICA
>
> Tel/fax (home): +27-21-685-6472
>
> Cell: +27-82-853-5352
>
> Iridium SatPhone: +8816-315-19119
>
> Email: calle.hedb...@gmail.com
>
> Skype: calle_hedberg
>
> ***
>
>

-- 


Lars Helge Øverland
Technical lead, DHIS 2
University of Oslo
l...@dhis2.org
https://www.dhis2.org
___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-31 Thread moses mwale
Sorry just to interject, so dhis2 does not work with Postgres 9.5?

On Wed, 31 Oct 2018 at 9:58 AM, Bjørn Sandvik  wrote:

> Hi,
>
> PostGIS requirement is 2.2 or later.
> AFAIK, this will still be the case for 2.31.
>
> Regards,
> Bjørn
>
> --
> Bjørn Sandvik
> GIS developer, DHIS 2
> University of Oslo
> www.dhis2.org
>
> On Wed, Oct 31, 2018 at 8:18 AM Calle Hedberg 
> wrote:
>
>> Hi,
>>
>> With regard to minimum pg requirements: Bjorn, what is the minimum
>> version requirement for Postgis, and what is the recommended version?
>> Again, postGIS 2.5 was released recently, so if people need to upgrade
>> anyhow it makes sense to upgrade to the latest, tested version...
>>
>> Regards
>> Calle
>>
>> On Wed, 31 Oct 2018 at 09:15, Calle Hedberg 
>> wrote:
>>
>>> Lars,
>>>
>>> With postgresql version 11 out - are there any specific reasons for NOT
>>> using pg 11? Many of the key features introduced in 10 - like table
>>> partitioning - have been further enhanced in 11.
>>>
>>> Regards
>>> Calle
>>>
>>> On Wed, 31 Oct 2018 at 08:04, stepho...@gmail.com 
>>> wrote:
>>>
 Thanks Lars.

 Just to be clear, Is that the minimum requirements for PostgreSQL?

 Sent from my HTC

 - Reply message -
 From: "Lars Helge Øverland" 
 To: "DHIS 2 Users list" , "DHIS 2
 Developers list" 
 Subject: [Dhis2-users] postgresql version 9.6 required for dhis version
 2.31
 Date: Tue, Oct 30, 2018 23:33

 Hi all,

 heads up: for DHIS 2 version 2.31 we will require PostgreSQL version
 9.6.

 This is in order to take advantage of certain SQL features introduced
 in that version. The current required version is 9.4.

 If you plan to upgrade your PostgreSQL version we recommend going
 straight to version 10, as it contains several great features and
 performance improvements. Also, we will eventually require this version and
 so going directly to version 10 will avoid multiple successive upgrades.


 best regards,

 Lars



 Lars Helge Øverland
 Technical lead, DHIS 2
 University of Oslo
 l...@dhis2.org
 https://www.dhis2.org

 ___
 Mailing list: https://launchpad.net/~dhis2-devs
 Post to : dhis2-devs@lists.launchpad.net
 Unsubscribe : https://launchpad.net/~dhis2-devs
 More help   : https://help.launchpad.net/ListHelp

>>>
>>>
>>> --
>>>
>>> ***
>>>
>>> Calle Hedberg
>>>
>>> 46D Alma Road, 7700 Rosebank, SOUTH AFRICA
>>>
>>> Tel/fax (home): +27-21-685-6472
>>>
>>> Cell: +27-82-853-5352
>>>
>>> Iridium SatPhone: +8816-315-19119
>>>
>>> Email: calle.hedb...@gmail.com
>>>
>>> Skype: calle_hedberg
>>>
>>> ***
>>>
>>>
>>
>> --
>>
>> ***
>>
>> Calle Hedberg
>>
>> 46D Alma Road, 7700 Rosebank, SOUTH AFRICA
>>
>> Tel/fax (home): +27-21-685-6472
>>
>> Cell: +27-82-853-5352
>>
>> Iridium SatPhone: +8816-315-19119
>>
>> Email: calle.hedb...@gmail.com
>>
>> Skype: calle_hedberg
>>
>> ***
>>
>>
>
> --
> Bjørn Sandvik
> GIS developer, DHIS 2
> University of Oslo
> www.dhis2.org
> ___
> Mailing list: https://launchpad.net/~dhis2-devs
> Post to : dhis2-devs@lists.launchpad.net
> Unsubscribe : https://launchpad.net/~dhis2-devs
> More help   : https://help.launchpad.net/ListHelp
>
-- 
developer_lusaka_systems
___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-31 Thread Bjørn Sandvik
Hi,

PostGIS requirement is 2.2 or later.
AFAIK, this will still be the case for 2.31.

Regards,
Bjørn

-- 
Bjørn Sandvik
GIS developer, DHIS 2
University of Oslo
www.dhis2.org

On Wed, Oct 31, 2018 at 8:18 AM Calle Hedberg 
wrote:

> Hi,
>
> With regard to minimum pg requirements: Bjorn, what is the minimum version
> requirement for Postgis, and what is the recommended version? Again,
> postGIS 2.5 was released recently, so if people need to upgrade anyhow it
> makes sense to upgrade to the latest, tested version...
>
> Regards
> Calle
>
> On Wed, 31 Oct 2018 at 09:15, Calle Hedberg 
> wrote:
>
>> Lars,
>>
>> With postgresql version 11 out - are there any specific reasons for NOT
>> using pg 11? Many of the key features introduced in 10 - like table
>> partitioning - have been further enhanced in 11.
>>
>> Regards
>> Calle
>>
>> On Wed, 31 Oct 2018 at 08:04, stepho...@gmail.com 
>> wrote:
>>
>>> Thanks Lars.
>>>
>>> Just to be clear, Is that the minimum requirements for PostgreSQL?
>>>
>>> Sent from my HTC
>>>
>>> - Reply message -
>>> From: "Lars Helge Øverland" 
>>> To: "DHIS 2 Users list" , "DHIS 2
>>> Developers list" 
>>> Subject: [Dhis2-users] postgresql version 9.6 required for dhis version
>>> 2.31
>>> Date: Tue, Oct 30, 2018 23:33
>>>
>>> Hi all,
>>>
>>> heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6.
>>>
>>> This is in order to take advantage of certain SQL features introduced in
>>> that version. The current required version is 9.4.
>>>
>>> If you plan to upgrade your PostgreSQL version we recommend going
>>> straight to version 10, as it contains several great features and
>>> performance improvements. Also, we will eventually require this version and
>>> so going directly to version 10 will avoid multiple successive upgrades.
>>>
>>>
>>> best regards,
>>>
>>> Lars
>>>
>>>
>>>
>>> Lars Helge Øverland
>>> Technical lead, DHIS 2
>>> University of Oslo
>>> l...@dhis2.org
>>> https://www.dhis2.org
>>>
>>> ___
>>> Mailing list: https://launchpad.net/~dhis2-devs
>>> Post to : dhis2-devs@lists.launchpad.net
>>> Unsubscribe : https://launchpad.net/~dhis2-devs
>>> More help   : https://help.launchpad.net/ListHelp
>>>
>>
>>
>> --
>>
>> ***
>>
>> Calle Hedberg
>>
>> 46D Alma Road, 7700 Rosebank, SOUTH AFRICA
>>
>> Tel/fax (home): +27-21-685-6472
>>
>> Cell: +27-82-853-5352
>>
>> Iridium SatPhone: +8816-315-19119
>>
>> Email: calle.hedb...@gmail.com
>>
>> Skype: calle_hedberg
>>
>> ***
>>
>>
>
> --
>
> ***
>
> Calle Hedberg
>
> 46D Alma Road, 7700 Rosebank, SOUTH AFRICA
>
> Tel/fax (home): +27-21-685-6472
>
> Cell: +27-82-853-5352
>
> Iridium SatPhone: +8816-315-19119
>
> Email: calle.hedb...@gmail.com
>
> Skype: calle_hedberg
>
> ***
>
>

-- 
Bjørn Sandvik
GIS developer, DHIS 2
University of Oslo
www.dhis2.org
___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-31 Thread Calle Hedberg
Hi,

With regard to minimum pg requirements: Bjorn, what is the minimum version
requirement for Postgis, and what is the recommended version? Again,
postGIS 2.5 was released recently, so if people need to upgrade anyhow it
makes sense to upgrade to the latest, tested version...

Regards
Calle

On Wed, 31 Oct 2018 at 09:15, Calle Hedberg  wrote:

> Lars,
>
> With postgresql version 11 out - are there any specific reasons for NOT
> using pg 11? Many of the key features introduced in 10 - like table
> partitioning - have been further enhanced in 11.
>
> Regards
> Calle
>
> On Wed, 31 Oct 2018 at 08:04, stepho...@gmail.com 
> wrote:
>
>> Thanks Lars.
>>
>> Just to be clear, Is that the minimum requirements for PostgreSQL?
>>
>> Sent from my HTC
>>
>> - Reply message -
>> From: "Lars Helge Øverland" 
>> To: "DHIS 2 Users list" , "DHIS 2
>> Developers list" 
>> Subject: [Dhis2-users] postgresql version 9.6 required for dhis version
>> 2.31
>> Date: Tue, Oct 30, 2018 23:33
>>
>> Hi all,
>>
>> heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6.
>>
>> This is in order to take advantage of certain SQL features introduced in
>> that version. The current required version is 9.4.
>>
>> If you plan to upgrade your PostgreSQL version we recommend going
>> straight to version 10, as it contains several great features and
>> performance improvements. Also, we will eventually require this version and
>> so going directly to version 10 will avoid multiple successive upgrades.
>>
>>
>> best regards,
>>
>> Lars
>>
>>
>>
>> Lars Helge Øverland
>> Technical lead, DHIS 2
>> University of Oslo
>> l...@dhis2.org
>> https://www.dhis2.org
>>
>> ___
>> Mailing list: https://launchpad.net/~dhis2-devs
>> Post to : dhis2-devs@lists.launchpad.net
>> Unsubscribe : https://launchpad.net/~dhis2-devs
>> More help   : https://help.launchpad.net/ListHelp
>>
>
>
> --
>
> ***
>
> Calle Hedberg
>
> 46D Alma Road, 7700 Rosebank, SOUTH AFRICA
>
> Tel/fax (home): +27-21-685-6472
>
> Cell: +27-82-853-5352
>
> Iridium SatPhone: +8816-315-19119
>
> Email: calle.hedb...@gmail.com
>
> Skype: calle_hedberg
>
> ***
>
>

-- 

***

Calle Hedberg

46D Alma Road, 7700 Rosebank, SOUTH AFRICA

Tel/fax (home): +27-21-685-6472

Cell: +27-82-853-5352

Iridium SatPhone: +8816-315-19119

Email: calle.hedb...@gmail.com

Skype: calle_hedberg

***
___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-31 Thread Calle Hedberg
Lars,

With postgresql version 11 out - are there any specific reasons for NOT
using pg 11? Many of the key features introduced in 10 - like table
partitioning - have been further enhanced in 11.

Regards
Calle

On Wed, 31 Oct 2018 at 08:04, stepho...@gmail.com 
wrote:

> Thanks Lars.
>
> Just to be clear, Is that the minimum requirements for PostgreSQL?
>
> Sent from my HTC
>
> - Reply message -
> From: "Lars Helge Øverland" 
> To: "DHIS 2 Users list" , "DHIS 2
> Developers list" 
> Subject: [Dhis2-users] postgresql version 9.6 required for dhis version
> 2.31
> Date: Tue, Oct 30, 2018 23:33
>
> Hi all,
>
> heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6.
>
> This is in order to take advantage of certain SQL features introduced in
> that version. The current required version is 9.4.
>
> If you plan to upgrade your PostgreSQL version we recommend going straight
> to version 10, as it contains several great features and performance
> improvements. Also, we will eventually require this version and so going
> directly to version 10 will avoid multiple successive upgrades.
>
>
> best regards,
>
> Lars
>
>
>
> Lars Helge Øverland
> Technical lead, DHIS 2
> University of Oslo
> l...@dhis2.org
> https://www.dhis2.org
>
> ___
> Mailing list: https://launchpad.net/~dhis2-devs
> Post to : dhis2-devs@lists.launchpad.net
> Unsubscribe : https://launchpad.net/~dhis2-devs
> More help   : https://help.launchpad.net/ListHelp
>


-- 

***

Calle Hedberg

46D Alma Road, 7700 Rosebank, SOUTH AFRICA

Tel/fax (home): +27-21-685-6472

Cell: +27-82-853-5352

Iridium SatPhone: +8816-315-19119

Email: calle.hedb...@gmail.com

Skype: calle_hedberg

***
___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-31 Thread stepho...@gmail.com
Thanks Lars.

Just to be clear, Is that the minimum requirements for PostgreSQL?

Sent from my HTC

- Reply message -
From: "Lars Helge Øverland" 
To: "DHIS 2 Users list" , "DHIS 2 Developers 
list" 
Subject: [Dhis2-users] postgresql version 9.6 required for dhis version 2.31
Date: Tue, Oct 30, 2018 23:33

Hi all,
heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6.

This is in order to take advantage of certain SQL features introduced in that 
version. The current required version is 9.4.

If you plan to upgrade your PostgreSQL version we recommend going straight to 
version 10, as it contains several great features and performance improvements. 
Also, we will eventually require this version and so going directly to version 
10 will avoid multiple successive upgrades.


best regards,

Lars



Lars Helge Øverland

Technical lead, DHIS 2
University of Oslo
l...@dhis2.org

https://www.dhis2.org___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp


Re: [Dhis2-devs] [Dhis2-users] postgresql version 9.6 required for dhis version 2.31

2018-10-30 Thread Dayo Adeyomoye
Beautiful.
Many thanks for sharing.
Kindest regards,
Adedayo

Sent from Yahoo Mail on Android 
 
  On Tue, 30 Oct 2018 at 22:34, Lars Helge Øverland wrote:   Hi 
all,
heads up: for DHIS 2 version 2.31 we will require PostgreSQL version 9.6.
This is in order to take advantage of certain SQL features introduced in that 
version. The current required version is 9.4.
If you plan to upgrade your PostgreSQL version we recommend going straight to 
version 10, as it contains several great features and performance improvements. 
Also, we will eventually require this version and so going directly to version 
10 will avoid multiple successive upgrades.

best regards,
Lars


Lars Helge Øverland
Technical lead, DHIS 2University of oslol...@dhis2.org
https://www.dhis2.org
___
Mailing list: https://launchpad.net/~dhis2-users
Post to    : dhis2-us...@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help  : https://help.launchpad.net/ListHelp
  
___
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-us...@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help   : https://help.launchpad.net/ListHelp
___
Mailing list: https://launchpad.net/~dhis2-devs
Post to : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp