Re: Implementing and optimizing a simple graph metric

2013-09-24 Thread Joseph Rushton Wakeling
On Wednesday, 18 September 2013 at 13:39:29 UTC, bearophile wrote: auto centrality = minimallyInitializedArray!(typeof(return))(g.vertexCount); centrality[] = T0; auto stack = new size_t[g.vertexCount]; auto sigma = minimallyInitializedArray!T(g.vertexCount); sigma[] = T0;

Re: DUnit: Advanced unit testing toolkit.

2013-09-24 Thread linkrope
On Monday, 23 September 2013 at 16:40:56 UTC, jostly wrote: I think it's great to see the D unit testing ecosystem growing. Since it's still relatively small, I think we have a good chance here to create interoperability between the different frameworks. As I see it, we have: 1. Running

Re: DUnit: Advanced unit testing toolkit.

2013-09-24 Thread linkrope
Same hint as for specd: have a look at 'assertOp'! http://d.puremagic.com/issues/show_bug.cgi?id=4653 alias assertOp! assertGreaterThan; alias assertOp!= assertGreaterThanOrEqual; alias assertOp! assertLessThan; alias assertOp!= assertLessThanOrEqual; avoids duplicate code. Maybe, you can do

Re: Implementing and optimizing a simple graph metric

2013-09-24 Thread bearophile
Joseph Rushton Wakeling: As an experiment I tried something along these lines -- using uninitializedArray for most of the arrays here and minimallyInitializedArray for p. minimallyInitializedArray is not stupid, if the specified type has no indirections, it's equivalent to using