Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-11 Thread Laurent Tréguier via Digitalmars-d-announce

On Tuesday, 10 April 2018 at 14:00:49 UTC, WebFreak001 wrote:

What about workspaces?

Multi workspaces in vscode aren't implemented yet though.


By multi workspaces, do you mean a multi-root workspace ? If so, 
multi-roots arrived with LSP 3.6.0 / vscode-languageclient 3.4.0 
(if you meant something else then nevermind this comment)




Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-10 Thread greatsam4sure via Digitalmars-d-announce

On Tuesday, 10 April 2018 at 03:37:59 UTC, evilrat wrote:

On Monday, 9 April 2018 at 19:10:46 UTC, Samson wrote:

[...]


Disable "normal" code-d, close VS, remove %appdata%/code-d, 
launch VS & enable code-d beta serve-d, enjoy.


[...]


Thanks, your suggestion work for me. Many thanks to you


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-10 Thread greatsam4sure via Digitalmars-d-announce

On Tuesday, 10 April 2018 at 03:37:59 UTC, evilrat wrote:

On Monday, 9 April 2018 at 19:10:46 UTC, Samson wrote:

[...]


Disable "normal" code-d, close VS, remove %appdata%/code-d, 
launch VS & enable code-d beta serve-d, enjoy.


[...]


Thanks your suggestion work for me. many thanks to you


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-10 Thread Johannes Loher via Digitalmars-d-announce
Am 10.04.2018 um 14:27 schrieb WebFreak001:
> On Monday, 9 April 2018 at 21:45:57 UTC, Johannes Loher wrote:
>> Am 04.04.2018 um 20:34 schrieb greatsam4sure:
>>> [...]
>> I just tried to get this to work, too, but I was not able to get it to
>> work correctly. It seems that running dub fails somehow:
>>
>> [...]
> 
> hm before it would have completely crashed workspace-d/serve-d to a
> point where nothing would work, now you basically only get stdlib and a
> guess of further import paths. Can you make a minimal test case where
> this happens? It is probably due to some dub.json settings. But as I use
> dub as a library it should work the same as just calling `dub build`

You are right, it indeed seems to be a dub problem. Running `dub build`
gives me "Could not resolv configuration for package vibe-d". The
strange thing is, it workls correctly on Linux / OS X with the same
dub/dmd versions...

I tried it with another project with a more simple dub.json and it works
fine out of the box. Very nice job!


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-10 Thread WebFreak001 via Digitalmars-d-announce

On Tuesday, 10 April 2018 at 13:11:16 UTC, evilrat wrote:

On Tuesday, 10 April 2018 at 11:54:47 UTC, WebFreak001 wrote:


fyi "deprecated" code-d beta and normal code-d is exactly the 
same plugin right now using exactly the same serve-d versions, 
except for the deprecation message.


I wouldn't be complaining if it's not the case. With normal 
code-d it does remove everything in %appdata%/code-d on start, 
re-setting config paths(even though for exapmle dub is in 
PATH), downloading git repo, fails to build, and repeat, while 
with beta there is no such issues.


I would also suggest you to add explicit --compiler=dmd switch 
to build invocation since for example in my case dmd was in 
PATH env after ldc and so ldc used by default, which of course 
doesn't have x86_mscoff arch. I also think it is probably 
better to add --build=release too, since users usually don't do 
debug on that binaries.


No dmd has an optimization issue that it removes code making the 
program completely broken and freeze on IO if compiled with -O, 
which is implied by --build=release. I will never use 
build=release with dmd.


What about workspaces? Let for exapmle have main project 
(really just a dub project with single app.d for testing 
library) and library project in one workspace. I don't get any 
autocompletion from both projects.
It also doesn't seems to work with dependency that has path 
property set, at least not when it's relative.

Is this ok?


Everything dub dependency related should work, I literally use 
dub as a library for this. Multi workspaces in vscode aren't 
implemented yet though.




Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-10 Thread evilrat via Digitalmars-d-announce

On Tuesday, 10 April 2018 at 11:54:47 UTC, WebFreak001 wrote:


fyi "deprecated" code-d beta and normal code-d is exactly the 
same plugin right now using exactly the same serve-d versions, 
except for the deprecation message.


I wouldn't be complaining if it's not the case. With normal 
code-d it does remove everything in %appdata%/code-d on start, 
re-setting config paths(even though for exapmle dub is in PATH), 
downloading git repo, fails to build, and repeat, while with beta 
there is no such issues.


I would also suggest you to add explicit --compiler=dmd switch to 
build invocation since for example in my case dmd was in PATH env 
after ldc and so ldc used by default, which of course doesn't 
have x86_mscoff arch. I also think it is probably better to add 
--build=release too, since users usually don't do debug on that 
binaries.


What about workspaces? Let for exapmle have main project (really 
just a dub project with single app.d for testing library) and 
library project in one workspace. I don't get any autocompletion 
from both projects.
It also doesn't seems to work with dependency that has path 
property set, at least not when it's relative.

Is this ok?


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-10 Thread WebFreak001 via Digitalmars-d-announce

On Monday, 9 April 2018 at 21:45:57 UTC, Johannes Loher wrote:

Am 04.04.2018 um 20:34 schrieb greatsam4sure:

[...]
I just tried to get this to work, too, but I was not able to 
get it to work correctly. It seems that running dub fails 
somehow:


[...]


hm before it would have completely crashed workspace-d/serve-d to 
a point where nothing would work, now you basically only get 
stdlib and a guess of further import paths. Can you make a 
minimal test case where this happens? It is probably due to some 
dub.json settings. But as I use dub as a library it should work 
the same as just calling `dub build`


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-10 Thread WebFreak001 via Digitalmars-d-announce

On Tuesday, 10 April 2018 at 03:37:59 UTC, evilrat wrote:

On Monday, 9 April 2018 at 19:10:46 UTC, Samson wrote:


Today I update code-d serve-d and vsc. After which I got the 
notification that
WebFreak001 has deprecate code-d serve-d beta and auto 
completion stop working. I saw code-d extension with the same 
icon as code-d serve-d beta so I install it. After which code 
hinting and auto completion don't still.


What is the solution to this problem?


Disable "normal" code-d, close VS, remove %appdata%/code-d, 
launch VS & enable code-d beta serve-d, enjoy.


We're in the same boat dude. I just did clean install of whole 
D ecosystem from 6 months old setup where everything was more 
or less working, and followed this treacherous deprecation 
message, got code-d 0.17.1 with betastream option instead of my 
trusty beta 0.17.9... OMG it is broken in so many ways...
it overwrites dub/serve-d paths settings, it messes with 
permissions, it removes already existing dub, dcd and serve-d 
executables!!!


well, don't store them in the code-d folder, it won't remove or 
mess up anything outside its own folder and it won't change the 
user settings if they point to valid executables either.


Reverted back to "deprecated" beta, at least it somewhat 
working, it is still incredibly slow on showing meaningful 
completions, doesn't seem to recognize half of the project, and 
seems to be completely not working with workspaces, but it is 
better than nothing.


Overall I've got an awful experience from code-d. Now, 
unfortunattely, there is even no adequate editor with decent 
performance & usability on Windows, I mean yeah there is still 
visual-d but it takes about 3 seconds to actually show 
completions, and code-d is completely broken right now.


fyi "deprecated" code-d beta and normal code-d is exactly the 
same plugin right now using exactly the same serve-d versions, 
except for the deprecation message.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-09 Thread evilrat via Digitalmars-d-announce

On Monday, 9 April 2018 at 19:10:46 UTC, Samson wrote:


Today I update code-d serve-d and vsc. After which I got the 
notification that
WebFreak001 has deprecate code-d serve-d beta and auto 
completion stop working. I saw code-d extension with the same 
icon as code-d serve-d beta so I install it. After which code 
hinting and auto completion don't still.


What is the solution to this problem?


Disable "normal" code-d, close VS, remove %appdata%/code-d, 
launch VS & enable code-d beta serve-d, enjoy.


We're in the same boat dude. I just did clean install of whole D 
ecosystem from 6 months old setup where everything was more or 
less working, and followed this treacherous deprecation message, 
got code-d 0.17.1 with betastream option instead of my trusty 
beta 0.17.9... OMG it is broken in so many ways...
it overwrites dub/serve-d paths settings, it messes with 
permissions, it removes already existing dub, dcd and serve-d 
executables!!!
Reverted back to "deprecated" beta, at least it somewhat working, 
it is still incredibly slow on showing meaningful completions, 
doesn't seem to recognize half of the project, and seems to be 
completely not working with workspaces, but it is better than 
nothing.


Overall I've got an awful experience from code-d. Now, 
unfortunattely, there is even no adequate editor with decent 
performance & usability on Windows, I mean yeah there is still 
visual-d but it takes about 3 seconds to actually show 
completions, and code-d is completely broken right now.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-09 Thread Johannes Loher via Digitalmars-d-announce
Am 04.04.2018 um 20:34 schrieb greatsam4sure:
> On Tuesday, 3 April 2018 at 23:02:42 UTC, WebFreak001 wrote:
>> new code-d (D extension for vscode) and serve-d (Language Server
>> Protocol server for it) release
>>
>> See the CHANGELOG in vscode, or on
>> https://github.com/Pure-D/code-d/blob/master/CHANGELOG.md
>>
>> Today massive improvements towards windows installation have been made
>> and it should be a lot more painless now.
>>
>> Big thanks to Mike Franklin for helping me debug the windows
>> installation, making this available very quickly and to p0nce for
>> compiling the windows release because my VM wasn't working for this
>> anymore.
>>
>> As now the extension is in stable and no longer requires the beta
>> branch a lot of issues have been fixed and old ones which are probably
>> no longer valid closed. If you find any issue please create a new one
>> or reopen if you have an old issue.
>>
>> Here are some of my personal highlights:
>>
>> https://wfr.moe/fmEfTw.png - documentation inside autocompletion
>> https://wfr.moe/fmq4Da.png - import timing
>> https://wfr.moe/fmqCNt.png https://wfr.moe/fmqh3H.png - simple
>> implement interface action
>> n/a - everything compiles and installs without reloads or cumbersome
>> dialogs, just install from marketplace, wait for the installation
>> which should be very quick, especially with prebuilt binaries and
>> start coding without any distractions!
>> https://wfr.moe/fmzcS8.png - dub dependency browser
>> n/a - automatic insertion of a module statement on rename and file
>> creation
>>
>> code-d beta and code-d are therefore on the same release right now,
>> but code-d beta will still be continuing to get features early.
>>
>> eager to hear your feedback, though gonna go to sleep for now.
>>
>> Planned for next release is internationalizing the final few messages
>> which are in the code-d part, all serve-d parts have already been
>> translated to German and Japanese and are determined by vscode language.
> 
> Thanks a lot! It works fine for me now in windows 10
> 
> steps
> 
> * I delete  C:\Users\Greatsam\AppData\Roaming\code-d folder
> **Restart visual studio code at least twice with internet connect on to
> enable code-d serve-d to download DCD
> It shows dcd successfully installed with many deprecation message
> ***I used sdl in my dub project with the flags: dflags
> "-transition=intpromote" platform="dmd"
> 
> I don't know if this have any effect. This help me to avoid some errors
> from the compilers
> 
> 
> 
> Thanks all who make this a success on windows. It is a great achievement
> in moving D forward.
I just tried to get this to work, too, but I was not able to get it to
work correctly. It seems that running dub fails somehow:

2018-04-09T23:40:19.281:source\app.d:main:196 Setting language to de
2018-04-09T23:40:19.281:source\app.d:main:205 Features fulfilled
2018-04-09T23:40:19.283:source\app.d:main:211 Started reading from stdin
2018-04-09T23:40:19.283:source\app.d:main:215 RPC started
2018-04-09T23:40:19.294:source\app.d:main:226 Has Message
2018-04-09T23:40:19.294:source\app.d:main:228 Message: RequestMessage(0,
"initialize",
{"capabilities":{"textDocument":{"codeAction":{"dynamicRegistration":true},"codeLens":{"dynamicRegistration":true},"completion":{"completionItem":{"commitCharactersSupport":true,"snippetSupport":true},"dynamicRegistration":true},"definition":{"dynamicRegistration":true},"documentHighlight":{"dynamicRegistration":true},"documentLink":{"dynamicRegistration":true},"documentSymbol":{"dynamicRegistration":true},"formatting":{"dynamicRegistration":true},"hover":{"dynamicRegistration":true},"onTypeFormatting":{"dynamicRegistration":true},"rangeFormatting":{"dynamicRegistration":true},"references":{"dynamicRegistration":true},"rename":{"dynamicRegistration":true},"signatureHelp":{"dynamicRegistration":true},"synchronization":{"didSave":true,"dynamicRegistration":true,"willSave":true,"willSaveWaitUntil":true}},"workspace":{"applyEdit":true,"didChangeConfiguration":{"dynamicRegistration":true},"didChangeWatchedFiles":{"dynamicRegistration":true},"executeCommand":{"dynamicRegistration":true},"symbol":{"dynamicRegistration":true}}},"processId":7464,"rootPath":"c:\\Users\\Johannes
Loher\\Development\\fsical-management","rootUri":"file:\/\/\/c%3A\/Users\/Johannes%20Loher\/Development\/fsical-management","trace":"off"})
2018-04-09T23:40:19.306:source\app.d:__lambda10:234 Processing as request
2018-04-09T23:40:19.306:source\app.d:processRequest:50 Initializing
2018-04-09T23:40:19.306:source\served\extension.d:initialize:143
Initializing serve-d for c:\Users\Johannes
Loher\Development\fsical-management
2018-04-09T23:40:19.306:source\served\extension.d:initialize:156
Starting dub...
2018-04-09T23:42:07.144:source\served\extension.d:safe:52
object.Exception@..\..\AppData\Local\dub\packages\dub-1.8.0\dub\source\dub\project.d(600):
Could not resolve configuration for package fsical-management

0x015C51EF
0x015C4FA2

Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-09 Thread Samson via Digitalmars-d-announce

On Sunday, 8 April 2018 at 07:40:34 UTC, Domain wrote:

On Wednesday, 4 April 2018 at 13:26:18 UTC, WebFreak001 wrote:

On Wednesday, 4 April 2018 at 11:08:09 UTC, Domain wrote:

On Tuesday, 3 April 2018 at 23:02:42 UTC, WebFreak001 wrote:

[...]


// >>> many Could not resolve location of module here <<<

Server: 
2018-04-04T19:04:39.205:..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\first.d:visit:418 Could not resolve location of module 'tango\io\device\File'


[...]


uh how much memory do you have? Also try the precompiled DCD 
on the serve-d release page now


8G RAM. I don't think that's memory problem. You can try DWT 
project.




Today I update code-d serve-d and vsc. After which I got the 
notification that
WebFreak001 has deprecate code-d serve-d beta and auto completion 
stop working. I saw code-d extension with the same icon as code-d 
serve-d beta so I install it. After which code hinting and auto 
completion don't still.


What is the solution to this problem?


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-08 Thread Domain via Digitalmars-d-announce

On Wednesday, 4 April 2018 at 13:26:18 UTC, WebFreak001 wrote:

On Wednesday, 4 April 2018 at 11:08:09 UTC, Domain wrote:

On Tuesday, 3 April 2018 at 23:02:42 UTC, WebFreak001 wrote:

[...]


// >>> many Could not resolve location of module here <<<

Server: 
2018-04-04T19:04:39.205:..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\first.d:visit:418 Could not resolve location of module 'tango\io\device\File'


[...]


uh how much memory do you have? Also try the precompiled DCD on 
the serve-d release page now


8G RAM. I don't think that's memory problem. You can try DWT 
project.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-07 Thread WebFreak001 via Digitalmars-d-announce

On Friday, 6 April 2018 at 19:12:32 UTC, Wulfklaue wrote:
Nice job WebFreak001 on the new changes. For the first time in 
years the code-d plugin works out of the box on Windows without 
any issues.


A small tip: associate the .d file extension in the Visual 
Studio Code marketplace with Code-d. Currently Code-D does not 
show up when VSC suggests plugins for the .d file extension.


uh I did do that though? Check the provides tab in the extension, 
it shows D


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-06 Thread Wulfklaue via Digitalmars-d-announce
Nice job WebFreak001 on the new changes. For the first time in 
years the code-d plugin works out of the box on Windows without 
any issues.


A small tip: associate the .d file extension in the Visual Studio 
Code marketplace with Code-d. Currently Code-D does not show up 
when VSC suggests plugins for the .d file extension.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-05 Thread WebFreak001 via Digitalmars-d-announce

On Thursday, 5 April 2018 at 08:11:39 UTC, Arredondo wrote:

On Wednesday, 4 April 2018 at 09:06:31 UTC, WebFreak001 wrote:

[...]


I can confirm that it seems to be working for me now. I 
installed git, downloaded the precompiled binaries and cleared 
the %APPDATA%/code-d/bin.


I feel like this informations needs to be readily accessible 
for newcomers, or just people trying out VS Code for the first 
time. For instance, I could not find anywhere in the Wiki the 
fact that in Windows, you either need to have git installed, or 
download some binaries yourself and paste them in a very 
specific location of your file system.


[...]


don't worry, all fixed and automatic now and release in a second, 
dcd is now precompiled on windows ^^


Also more helpful error messages if you still compile from source 
(in case download and install fails)


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-05 Thread Arredondo via Digitalmars-d-announce

On Wednesday, 4 April 2018 at 09:06:31 UTC, WebFreak001 wrote:
I now provide a precompiled DCD for windows, you can download 
it off the serve-d release page and just extract into 
%APPDATA%/code-d/bin (where the serve-d.exe is) and it will 
automatically find it. I am going to release a new release 
later which does this automatically.


I can confirm that it seems to be working for me now. I installed 
git, downloaded the precompiled binaries and cleared the 
%APPDATA%/code-d/bin.


I feel like this informations needs to be readily accessible for 
newcomers, or just people trying out VS Code for the first time. 
For instance, I could not find anywhere in the Wiki the fact that 
in Windows, you either need to have git installed, or download 
some binaries yourself and paste them in a very specific location 
of your file system.


On the other hand, this page is two clicks away (Resources menu > 
Visual D) from the homepage and describes in full detail the 
Visual-D plugin for Visual Studio:

http://rainers.github.io/visuald/visuald/StartPage.html

Given that VS Code is the favorite D editor according to the 
recent D Community Survey (#1 with 25% market share :) I feel 
like there should be a similar page explaining the several D 
extensions for VS Code, their relationships, and how to 
download/configure them, including the information in this thread.


Anyway, thanks for the amazing work.
Cheers,
Arredondo.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread greatsam4sure via Digitalmars-d-announce

On Tuesday, 3 April 2018 at 23:02:42 UTC, WebFreak001 wrote:
new code-d (D extension for vscode) and serve-d (Language 
Server Protocol server for it) release


See the CHANGELOG in vscode, or on 
https://github.com/Pure-D/code-d/blob/master/CHANGELOG.md


Today massive improvements towards windows installation have 
been made and it should be a lot more painless now.


Big thanks to Mike Franklin for helping me debug the windows 
installation, making this available very quickly and to p0nce 
for compiling the windows release because my VM wasn't working 
for this anymore.


As now the extension is in stable and no longer requires the 
beta branch a lot of issues have been fixed and old ones which 
are probably no longer valid closed. If you find any issue 
please create a new one or reopen if you have an old issue.


Here are some of my personal highlights:

https://wfr.moe/fmEfTw.png - documentation inside autocompletion
https://wfr.moe/fmq4Da.png - import timing
https://wfr.moe/fmqCNt.png https://wfr.moe/fmqh3H.png - simple 
implement interface action
n/a - everything compiles and installs without reloads or 
cumbersome dialogs, just install from marketplace, wait for the 
installation which should be very quick, especially with 
prebuilt binaries and start coding without any distractions!

https://wfr.moe/fmzcS8.png - dub dependency browser
n/a - automatic insertion of a module statement on rename and 
file creation


code-d beta and code-d are therefore on the same release right 
now, but code-d beta will still be continuing to get features 
early.


eager to hear your feedback, though gonna go to sleep for now.

Planned for next release is internationalizing the final few 
messages which are in the code-d part, all serve-d parts have 
already been translated to German and Japanese and are 
determined by vscode language.


Thanks a lot! It works fine for me now in windows 10

steps

* I delete  C:\Users\Greatsam\AppData\Roaming\code-d folder
**Restart visual studio code at least twice with internet connect 
on to enable code-d serve-d to download DCD

It shows dcd successfully installed with many deprecation message
***I used sdl in my dub project with the flags: dflags 
"-transition=intpromote" platform="dmd"


I don't know if this have any effect. This help me to avoid some 
errors from the compilers




Thanks all who make this a success on windows. It is a great 
achievement in moving D forward.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread WebFreak001 via Digitalmars-d-announce

On Wednesday, 4 April 2018 at 15:48:42 UTC, rumbu wrote:

On Tuesday, 3 April 2018 at 23:02:42 UTC, WebFreak001 wrote:
new code-d (D extension for vscode) and serve-d (Language 
Server Protocol server for it) release





dcd-server.exe remains active in memory after I quit VSCode. If 
I close/open VSCode several times, I have a lot of 
dcd-server.exe instances running, each one consuming around 
200k of memory and 2% of processor power (I wonder why since 
vscode is shut down).


Secondly, why is not dcd-server.exe 64 bit?

Note: this is not criticism, I really appreciate your work.


it should close itself since the latest update, not sure how you 
are seeing that... It should only be able to happen now if dcd 
hangs up


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread rumbu via Digitalmars-d-announce

On Tuesday, 3 April 2018 at 23:02:42 UTC, WebFreak001 wrote:
new code-d (D extension for vscode) and serve-d (Language 
Server Protocol server for it) release





dcd-server.exe remains active in memory after I quit VSCode. If I 
close/open VSCode several times, I have a lot of dcd-server.exe 
instances running, each one consuming around 200k of memory and 
2% of processor power (I wonder why since vscode is shut down).


Secondly, why is not dcd-server.exe 64 bit?

Note: this is not criticism, I really appreciate your work.



Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread WebFreak001 via Digitalmars-d-announce

On Wednesday, 4 April 2018 at 11:08:09 UTC, Domain wrote:

On Tuesday, 3 April 2018 at 23:02:42 UTC, WebFreak001 wrote:

[...]


// >>> many Could not resolve location of module here <<<

Server: 
2018-04-04T19:04:39.205:..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\first.d:visit:418 Could not resolve location of module 'tango\io\device\File'


[...]


uh how much memory do you have? Also try the precompiled DCD on 
the serve-d release page now


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread Domain via Digitalmars-d-announce

On Tuesday, 3 April 2018 at 23:02:42 UTC, WebFreak001 wrote:
new code-d (D extension for vscode) and serve-d (Language 
Server Protocol server for it) release


See the CHANGELOG in vscode, or on 
https://github.com/Pure-D/code-d/blob/master/CHANGELOG.md


Today massive improvements towards windows installation have 
been made and it should be a lot more painless now.


Big thanks to Mike Franklin for helping me debug the windows 
installation, making this available very quickly and to p0nce 
for compiling the windows release because my VM wasn't working 
for this anymore.


As now the extension is in stable and no longer requires the 
beta branch a lot of issues have been fixed and old ones which 
are probably no longer valid closed. If you find any issue 
please create a new one or reopen if you have an old issue.


Here are some of my personal highlights:

https://wfr.moe/fmEfTw.png - documentation inside autocompletion
https://wfr.moe/fmq4Da.png - import timing
https://wfr.moe/fmqCNt.png https://wfr.moe/fmqh3H.png - simple 
implement interface action
n/a - everything compiles and installs without reloads or 
cumbersome dialogs, just install from marketplace, wait for the 
installation which should be very quick, especially with 
prebuilt binaries and start coding without any distractions!

https://wfr.moe/fmzcS8.png - dub dependency browser
n/a - automatic insertion of a module statement on rename and 
file creation


code-d beta and code-d are therefore on the same release right 
now, but code-d beta will still be continuing to get features 
early.


eager to hear your feedback, though gonna go to sleep for now.

Planned for next release is internationalizing the final few 
messages which are in the code-d part, all serve-d parts have 
already been translated to German and Japanese and are 
determined by vscode language.


// >>> many Could not resolve location of module here <<<

Server: 
2018-04-04T19:04:39.205:..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\first.d:visit:418 Could not resolve location of module 'tango\io\device\File'



Server: 
2018-04-04T19:04:39.215:..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\first.d:visit:418 Could not resolve location of module 'tango\io\device\File'


Server: 2018-04-04T19:04:39.434:src\dcd\server\main.d:main:163 
Shutting down sockets...


Server: 2018-04-04T19:04:39.434:src\dcd\server\main.d:main:168 
Sockets shut down.


Server:

Server: 
core.exception.AssertError@..\..\..\..\Local\dub\packages\libdparse-0.8.0\libdparse\src\dparse\rollback_allocator.d(84): Assertion failure


Server: 

Server: 0x014F5533 in _d_assertp

Server: 0x0149A709 in dparse at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\libdparse-0.8.0\libdparse\src\dparse\parser.d(4101)


Server: 0x0142E89F in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\package.d(86)


Server: 0x0141B4E1 in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\modulecache.d(193)


Server: 0x014343AE in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\second.d(142)


Server: 0x0142ABF8 in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\second.d(62)


Server: 0x0142AC42 in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\second.d(77)


Server: 0x0141B56B in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\modulecache.d(202)


Server: 0x014343AE in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\second.d(142)


Server: 0x0142ABF8 in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\second.d(62)


Server: 0x0142AC42 in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\second.d(77)


Server: 0x0141B56B in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\modulecache.d(202)


Server: 0x014343AE in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\second.d(142)


Server: 0x0142ABF8 in dsymbol at 
C:\Users\Domain-Work\AppData\Roaming\code-d\bin\DCD\..\..\..\..\Local\dub\packages\dsymbol-0.3.0\dsymbol\src\dsymbol\conversion\second.d(62)


Server: 0x0142AC42 in 

Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread drug via Digitalmars-d-announce
Works for me very well out of box, much better than my previous attempts 
to use vscode. I'll test it more and probable I'll leave sublime text 3 
for vscode.

I appreciate your nice work!



Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread Arredondo via Digitalmars-d-announce
Thanks for all the feedback you guys. I'll try the different 
suggestions when I get home tonight and I'll let you know.


Cheers,
Arredondo.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread WebFreak001 via Digitalmars-d-announce

On Wednesday, 4 April 2018 at 06:36:41 UTC, WebFreak001 wrote:

On Tuesday, 3 April 2018 at 23:50:24 UTC, Arredondo wrote:
I could not get this to work for me in the past (I'm using 
Windows 10). I saw this announcement so I decided to try 
again. After reinstalling code-d I got this in the OUTPUT 
console:


Installing DCD
Installing into C:\Users\Wulfrick\AppData\Roaming\code-d\bin
 > git clone --recursive --depth=1 
https://github.com/Hackerpilot/DCD.git DCD

Failed to install DCD
std.process.ProcessException@std\process.d(753): Failed to 
spawn new process (The system cannot find the file specified.)


0x00384D1F
0x00384AD2
0x00382ADD


It looks like he doesn't have git installed... My extension 
still assumes you have git and that probably won't change until 
DCD provides precompiled binaries.


The syntax coloring seems wrong, go to definition doesn't 
work, and there are no completition suggestions (Ctr+Space 
just displays "Loading...").


Moreover, the extension is completely SPAMMING the output 
console, making it pop up constantly with endless messages 
like:


Yes without DCD many things will not work but formatting, code 
linting and outline and dub should still work. Loading... 
should not happen.


I now provide a precompiled DCD for windows, you can download it 
off the serve-d release page and just extract into 
%APPDATA%/code-d/bin (where the serve-d.exe is) and it will 
automatically find it. I am going to release a new release later 
which does this automatically.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread Seb via Digitalmars-d-announce

On Wednesday, 4 April 2018 at 06:36:41 UTC, WebFreak001 wrote:

On Tuesday, 3 April 2018 at 23:50:24 UTC, Arredondo wrote:
I could not get this to work for me in the past (I'm using 
Windows 10). I saw this announcement so I decided to try 
again. After reinstalling code-d I got this in the OUTPUT 
console:


Installing DCD
Installing into C:\Users\Wulfrick\AppData\Roaming\code-d\bin
 > git clone --recursive --depth=1 
https://github.com/Hackerpilot/DCD.git DCD

Failed to install DCD
std.process.ProcessException@std\process.d(753): Failed to 
spawn new process (The system cannot find the file specified.)


0x00384D1F
0x00384AD2
0x00382ADD


It looks like he doesn't have git installed... My extension 
still assumes you have git and that probably won't change until 
DCD provides precompiled binaries.


The syntax coloring seems wrong, go to definition doesn't 
work, and there are no completition suggestions (Ctr+Space 
just displays "Loading...").


Moreover, the extension is completely SPAMMING the output 
console, making it pop up constantly with endless messages 
like:


Yes without DCD many things will not work but formatting, code 
linting and outline and dub should still work. Loading... 
should not happen.


FYI the latest release of dfmt, dscanner and dcd comes with 
binaries for Linux.

The next release will have binaries for OSX:

https://github.com/dlang-community/DCD/pull/458

We are still trying to find the easiest way to build binaries for 
Window on our CIs, see e.g.


https://github.com/dlang-community/discussions/issues/9

But either AppVeyor or Wine should work.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-04 Thread WebFreak001 via Digitalmars-d-announce

On Tuesday, 3 April 2018 at 23:50:24 UTC, Arredondo wrote:
I could not get this to work for me in the past (I'm using 
Windows 10). I saw this announcement so I decided to try again. 
After reinstalling code-d I got this in the OUTPUT console:


Installing DCD
Installing into C:\Users\Wulfrick\AppData\Roaming\code-d\bin
 > git clone --recursive --depth=1 
https://github.com/Hackerpilot/DCD.git DCD

Failed to install DCD
std.process.ProcessException@std\process.d(753): Failed to 
spawn new process (The system cannot find the file specified.)


0x00384D1F
0x00384AD2
0x00382ADD


It looks like he doesn't have git installed... My extension still 
assumes you have git and that probably won't change until DCD 
provides precompiled binaries.


The syntax coloring seems wrong, go to definition doesn't work, 
and there are no completition suggestions (Ctr+Space just 
displays "Loading...").


Moreover, the extension is completely SPAMMING the output 
console, making it pop up constantly with endless messages like:


Yes without DCD many things will not work but formatting, code 
linting and outline and dub should still work. Loading... should 
not happen.


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-03 Thread Mike Franklin via Digitalmars-d-announce

On Tuesday, 3 April 2018 at 23:50:24 UTC, Arredondo wrote:
I could not get this to work for me in the past (I'm using 
Windows 10). I saw this announcement so I decided to try again.


I have a little more experience to share...

std.process.ProcessException@std\process.d(753): Failed to 
spawn new process (The system cannot find the file specified.)


0x00384D1F
0x00384AD2
0x00382ADD


This seems to appear due to the import timing feature.  You can 
disable it in your settings with `"d.enableDMDImportTiming": 
false`


Moreover, the extension is completely SPAMMING the output 
console, making it pop up constantly with endless messages like:


The spam to the output console is normal (I think).  It's 
actually quite useful when troubleshooting, and I don't think the 
popup window should show up uninvited.  It doesn't for me, anyway.


Mike






Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-03 Thread Mike Franklin via Digitalmars-d-announce

On Tuesday, 3 April 2018 at 23:50:24 UTC, Arredondo wrote:
I could not get this to work for me in the past (I'm using 
Windows 10). I saw this announcement so I decided to try again.


I'm using it in Windows 10 right now, but I did have trouble 
trying to upgrade an existing installation.  To remedy that, try 
to first delete the %appdata%\code-d directory, and then open VS 
Code again.  It should try to re-install serve-d, and I believe 
it will then succeed.


mike


Re: code-d 0.17.0 + serve-d 0.1.2

2018-04-03 Thread Arredondo via Digitalmars-d-announce
I could not get this to work for me in the past (I'm using 
Windows 10). I saw this announcement so I decided to try again. 
After reinstalling code-d I got this in the OUTPUT console:


Installing DCD
Installing into C:\Users\Wulfrick\AppData\Roaming\code-d\bin
 > git clone --recursive --depth=1 
https://github.com/Hackerpilot/DCD.git DCD

Failed to install DCD
std.process.ProcessException@std\process.d(753): Failed to spawn 
new process (The system cannot find the file specified.)


0x00384D1F
0x00384AD2
0x00382ADD

The syntax coloring seems wrong, go to definition doesn't work, 
and there are no completition suggestions (Ctr+Space just 
displays "Loading...").


Moreover, the extension is completely SPAMMING the output 
console, making it pop up constantly with endless messages like:



2018-04-04T01:33:46.184:source\served\jsonrpc.d:send:66 
{"id":27,"jsonrpc":"2.0","result":{"command":{"arguments":[],"command":"","title":"~30ms for importing this"},"data":{"code":"import std.algorithm.iteration : sum;","module":"std.algorithm.iteration","type":"importcompilecheck"},"range":{"end":{"character":4,"line":245},"start":{"character":4,"line":245

2018-04-04T01:33:46.184:source\app.d:main:226 Has Message
2018-04-04T01:33:46.184:source\app.d:main:228 Message: 
RequestMessage(28, "codeLens/resolve", {"data":{"code":"import 
std.algorithm.comparison : 
max;","module":"std.algorithm.comparison","type":"importcompilecheck"},"range":{"end":{"character":4,"line":250},"start":{"character":4,"line":250}}})
2018-04-04T01:33:46.200:source\app.d:__lambda10:234 Processing as 
request
2018-04-04T01:33:46.200:source\app.d:processRequest:77 Calling 
resolveCodeLens
2018-04-04T01:33:46.200:source\app.d:__lambda10:236 Responding 
with: ResponseMessage(28, 
{"command":{"arguments":[],"command":"","title":"~280ms for 
importing this"},"data":{"code":"import std.algorithm.comparison 
: 
max;","module":"std.algorithm.comparison","type":"importcompilecheck"},"range":{"end":{"character":4,"line":250},"start":{"character":4,"line":250}}}, null(ResponseError))
2018-04-04T01:33:46.200:source\served\jsonrpc.d:send:66 
{"id":28,"jsonrpc":"2.0","result":{"command":{"arguments":[],"command":"","title":"~280ms for importing this"},"data":{"code":"import std.algorithm.comparison : max;","module":"std.algorithm.comparison","type":"importcompilecheck"},"range":{"end":{"character":4,"line":250},"start":{"character":4,"line":250

2018-04-04T01:33:46.200:source\app.d:main:226 Has Message
2018-04-04T01:33:46.200:source\app.d:main:228 Message: 
RequestMessage(29, "codeLens/resolve", {"data":{"code":"import 
std.range : 
iota;","module":"std.range","type":"importcompilecheck"},"range":{"end":{"character":4,"line":251},"start":{"character":4,"line":251}}})
2018-04-04T01:33:46.216:source\app.d:__lambda10:234 Processing as 
request
2018-04-04T01:33:46.216:source\app.d:processRequest:77 Calling 
resolveCodeLens
2018-04-04T01:33:46.216:source\app.d:__lambda10:236 Responding 
with: ResponseMessage(29, 
{"command":{"arguments":[],"command":"","title":"~290ms for 
importing this"},"data":{"code":"import std.range : 
iota;","module":"std.range","type":"importcompilecheck"},"range":{"end":{"character":4,"line":251},"start":{"character":4,"line":251}}}, null(ResponseError))






... and it goes like this for a while. This is at the very bottom:





[Info  - 1:33:54 AM] Connection to server got closed. Server will 
restart.

[Error - 1:33:54 AM] Request textDocument/codeLens failed.
Error: Connection got disposed.
	at Object.dispose 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-jsonrpc\lib\main.js:825:25)
	at Object.dispose 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-languageclient\lib\client.js:57:35)
	at LanguageClient.handleConnectionClosed 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-languageclient\lib\client.js:1864:38)
	at LanguageClient.handleConnectionClosed 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-languageclient\lib\main.js:106:15)
	at closeHandler 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-languageclient\lib\client.js:1852:18)
	at CallbackList.invoke 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-jsonrpc\lib\events.js:71:39)
	at Emitter.fire 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-jsonrpc\lib\events.js:135:36)
	at closeHandler 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-jsonrpc\lib\main.js:221:26)
	at CallbackList.invoke 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-jsonrpc\lib\events.js:71:39)
	at Emitter.fire 
(C:\Users\Wulfrick\.vscode\extensions\webfreak.code-d-0.17.0\node_modules\vscode-jsonrpc\lib\events.js:135:36)

[Error - 1:33:54 AM] Request textDocument/codeAction failed.
Error: