[Issue 9760] PIC code uses variable and thus needs a stack frame

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9760 --- Comment #2 from Martin Nowak c...@dawg.eu 2013-03-19 23:17:05 PDT --- The GOT loading code sequence doesn't work because I have no detailed control about the emitted relocations. This uses a R_386_GOT32 relocation instead of the needed

[Issue 9758] Ddoc: empty ddoc comment and unittest block generates no Examples section

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9758 Andrej Mitrovic andrej.mitrov...@gmail.com changed: What|Removed |Added Status|NEW |RESOLVED

[Issue 9764] New: Ddoc: Ddoc file name is incorrectly emphasized

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9764 Summary: Ddoc: Ddoc file name is incorrectly emphasized Product: D Version: D2 Platform: All OS/Version: All Status: NEW Keywords: ddoc Severity: regression

[Issue 9760] PIC code uses variable and thus needs a stack frame

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9760 --- Comment #3 from Walter Bright bugzi...@digitalmars.com 2013-03-19 23:46:44 PDT --- The inline assembler doesn't give access to the complete set of relocation types. For those, it's best not to use naked and let the compiler set it up for

[Issue 9764] Ddoc: Ddoc file name is incorrectly emphasized

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9764 Kenji Hara k.hara...@gmail.com changed: What|Removed |Added Keywords||pull --- Comment #1

[Issue 9765] New: Error message with __error with struct literal dotvar expression

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9765 Summary: Error message with __error with struct literal dotvar expression Product: D Version: D2 Platform: All OS/Version: All Status: NEW Severity:

[Issue 9760] asm docs should say PIC code uses variable and thus needs a stack frame

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9760 Don clugd...@yahoo.com.au changed: What|Removed |Added Keywords||spec

[Issue 7176] Lambda = syntax for function and methods too

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7176 --- Comment #15 from bearophile_h...@eml.cc 2013-03-20 06:13:22 PDT --- After having used Scala a little, I now have changed my mind a little again. In Scala you write: def f3(x: Int, y: Int): Int = if (x == 0) x else x * y This is current

[Issue 4705] Redesign of std.algorithm.max()/min() + mins()/maxs()

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=4705 --- Comment #15 from bearophile_h...@eml.cc 2013-03-20 06:16:14 PDT --- In Haskell the reduce!min and reduce!max are named minimum and maximum. -- Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email --- You are

[Issue 7176] Lambda = syntax for function and methods too

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7176 Nick Treleaven ntrel-pub...@yahoo.co.uk changed: What|Removed |Added CC|

[Issue 9730] Allow ddoc unittests to remotely reference declaration

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9730 --- Comment #2 from hst...@quickfur.ath.cx 2013-03-20 07:23:40 PDT --- I like this idea. Now that we have UDAs, let's make good use of them! -- Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email --- You are

[Issue 7176] Lambda = syntax for function and methods too

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7176 --- Comment #17 from Kenji Hara k.hara...@gmail.com 2013-03-20 08:21:44 PDT --- I don't like this feature. Because: 1. it would reduce code readability. class LibClass { int foo() { return 1; } string bar() = hi; } Mixing

[Issue 9766] New: align(n) with n compile-time constant

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9766 Summary: align(n) with n compile-time constant Product: D Version: D2 Platform: x86 OS/Version: Windows Status: NEW Keywords: rejects-valid Severity: normal

[Issue 9767] New: Confusing compiler error generated when names collide across modules.

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9767 Summary: Confusing compiler error generated when names collide across modules. Product: D Version: D2 Platform: All OS/Version: All Status: NEW Severity:

[Issue 9763] @contended and @contended(groupName)

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9763 --- Comment #1 from bearophile_h...@eml.cc 2013-03-20 11:53:59 PDT --- A current workaround is to use align (with a value, because of Issue 9766 ): align(128) struct Test3 { int field1; int field2; } pragma(msg, Test3:); pragma(msg,

[Issue 9760] asm docs should say PIC code uses variable and thus needs a stack frame

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9760 --- Comment #5 from Martin Nowak c...@dawg.eu 2013-03-20 13:19:46 PDT --- (In reply to comment #3) The inline assembler doesn't give access to the complete set of relocation types. For those, it's best not to use naked and let the compiler

[Issue 7176] Lambda = syntax for function and methods too

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7176 --- Comment #18 from timon.g...@gmx.ch 2013-03-20 13:33:49 PDT --- (In reply to comment #17) I don't like this feature. Because: 1. it would reduce code readability. On the contrary! It also increases language consistency. class

[Issue 9474] Ddoc'd unittests should work correctly with interspersed version(none)

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9474 Andrej Mitrovic andrej.mitrov...@gmail.com changed: What|Removed |Added AssignedTo|andrej.mitrov...@gmail.com

[Issue 9631] Error message not using fully qualified name when appropriate.

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9631 Andrej Mitrovic andrej.mitrov...@gmail.com changed: What|Removed |Added CC|

[Issue 9768] New: No line number for wrong foreach type

2013-03-20 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=9768 Summary: No line number for wrong foreach type Product: D Version: D2 Platform: x86 OS/Version: Windows Status: NEW Keywords: diagnostic Severity: major