[Issue 7365] [Regression after 2.057] AAs broken for Object keys and values with opEquals

2012-01-30 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7365



--- Comment #2 from github-bugzi...@puremagic.com 2012-01-30 12:35:44 PST ---
Commit pushed to master at https://github.com/D-Programming-Language/dmd

https://github.com/D-Programming-Language/dmd/commit/ba943d54d4f97ec98261d5d00631aecbea7cdbea
add test case for issue 7365

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
--- You are receiving this mail because: ---


[Issue 7365] [Regression after 2.057] AAs broken for Object keys and values with opEquals

2012-01-30 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7365


Walter Bright bugzi...@digitalmars.com changed:

   What|Removed |Added

 Status|NEW |RESOLVED
 CC||bugzi...@digitalmars.com
 Resolution||WORKSFORME


--- Comment #3 from Walter Bright bugzi...@digitalmars.com 2012-01-30 
12:36:36 PST ---
It works for me, but I added a test case for it anyway to the test suite.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
--- You are receiving this mail because: ---


[Issue 7365] [Regression after 2.057] AAs broken for Object keys and values with opEquals

2012-01-30 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7365



--- Comment #4 from klickverbot c...@klickverbot.at 2012-01-30 12:48:27 PST 
---
Seems to WORKSFORME now as well, not sure when it was fixed or what the problem
was beforeā€¦

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
--- You are receiving this mail because: ---


[Issue 7365] [Regression after 2.057] AAs broken for Object keys and values with opEquals

2012-01-30 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7365


klickverbot c...@klickverbot.at changed:

   What|Removed |Added

 Status|RESOLVED|REOPENED
 Resolution|WORKSFORME  |


--- Comment #5 from klickverbot c...@klickverbot.at 2012-01-30 12:51:10 PST 
---
Ah, screw it, now the auto-tester fails because of it as well:
http://d.puremagic.com/test-results/test_data.ghtml?dataid=146136. Must have
inadvertently introduced a workaround in my original client code, sorry for the
noise.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
--- You are receiving this mail because: ---


[Issue 7365] [Regression after 2.057] AAs broken for Object keys and values with opEquals

2012-01-30 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7365


Walter Bright bugzi...@digitalmars.com changed:

   What|Removed |Added

 Status|REOPENED|RESOLVED
 Resolution||FIXED


-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
--- You are receiving this mail because: ---


[Issue 7365] [Regression after 2.057] AAs broken for Object keys and values with opEquals

2012-01-30 Thread d-bugmail
http://d.puremagic.com/issues/show_bug.cgi?id=7365



--- Comment #6 from github-bugzi...@puremagic.com 2012-01-30 16:31:00 PST ---
Commit pushed to master at https://github.com/D-Programming-Language/druntime

https://github.com/D-Programming-Language/druntime/commit/048caceac7c678b16ccd0f602a6a622a5ba3
fix Issue 7365 - [Regression after 2.057] AAs broken for Object keys and values
with opEquals

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
--- You are receiving this mail because: ---