Re: Dub version

2019-08-09 Thread Andre Pany via Digitalmars-d-learn
On Friday, 9 August 2019 at 15:41:08 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 14:15:36 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 13:59:51 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 13:01:51 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 12:10:21 UTC,

Re: Dub version

2019-08-09 Thread GreatSam4sure via Digitalmars-d-learn
On Friday, 9 August 2019 at 14:15:36 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 13:59:51 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 13:01:51 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 12:10:21 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 09:01:54 UTC, Andre

Re: Dub version

2019-08-09 Thread Andre Pany via Digitalmars-d-learn
On Friday, 9 August 2019 at 13:59:51 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 13:01:51 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 12:10:21 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 09:01:54 UTC, Andre Pany wrote: [...] I am at lost here. Before I can run

Re: Dub version

2019-08-09 Thread GreatSam4sure via Digitalmars-d-learn
On Friday, 9 August 2019 at 13:01:51 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 12:10:21 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 09:01:54 UTC, Andre Pany wrote: [...] I am at lost here. Before I can run my D project using dub.1.11.0 executable install on my system

Re: Dub version

2019-08-09 Thread Andre Pany via Digitalmars-d-learn
On Friday, 9 August 2019 at 12:10:21 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 09:01:54 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 08:30:49 UTC, GreatSam4sure wrote: [...] My assumption is, you have several dub executables on your computer. A recent one, bundled with

Re: Dub version

2019-08-09 Thread GreatSam4sure via Digitalmars-d-learn
On Friday, 9 August 2019 at 09:01:54 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 08:30:49 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 03:52:11 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 01:36:43 UTC, greatsam4sure wrote: On Friday, 9 August 2019 at 01:18:12 UTC,

Re: Dub version

2019-08-09 Thread Andre Pany via Digitalmars-d-learn
On Friday, 9 August 2019 at 08:30:49 UTC, GreatSam4sure wrote: On Friday, 9 August 2019 at 03:52:11 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 01:36:43 UTC, greatsam4sure wrote: On Friday, 9 August 2019 at 01:18:12 UTC, Elronnd wrote: [...] dub fetch dub Fetching dub 1.16.0...

Re: Dub version

2019-08-09 Thread GreatSam4sure via Digitalmars-d-learn
On Friday, 9 August 2019 at 03:52:11 UTC, Andre Pany wrote: On Friday, 9 August 2019 at 01:36:43 UTC, greatsam4sure wrote: On Friday, 9 August 2019 at 01:18:12 UTC, Elronnd wrote: [...] dub fetch dub Fetching dub 1.16.0... Please note that you need to use `dub run ` or add it to

Re: Dub version

2019-08-08 Thread Andre Pany via Digitalmars-d-learn
On Friday, 9 August 2019 at 01:36:43 UTC, greatsam4sure wrote: On Friday, 9 August 2019 at 01:18:12 UTC, Elronnd wrote: Dub add is not supported in dub 1.11.0 Use 'dub fetch'. dub fetch dub Fetching dub 1.16.0... Please note that you need to use `dub run ` or add it to dependencies of

Re: Dub version

2019-08-08 Thread greatsam4sure via Digitalmars-d-learn
On Friday, 9 August 2019 at 01:18:12 UTC, Elronnd wrote: Dub add is not supported in dub 1.11.0 Use 'dub fetch'. dub fetch dub Fetching dub 1.16.0... Please note that you need to use `dub run ` or add it to dependencies of your package to actually use/run it. dub does not do actual

Re: Dub version

2019-08-08 Thread Elronnd via Digitalmars-d-learn
Dub add is not supported in dub 1.11.0 Use 'dub fetch'.

Dub version

2019-08-08 Thread GreatSam4sure via Digitalmars-d-learn
Which version of dub support dub add library name? Dub add is not supported in dub 1.11.0 Besides I could not run rdmd on my windows 10 core i7. It days this app cannot run on this machine What is the way out? Where can I get window binary for dub that is higher than dub 1.11.0

Re: nice-curses releases / dub version git?

2019-01-12 Thread H. S. Teoh via Digitalmars-d-learn
On Sat, Jan 12, 2019 at 05:38:09PM +, Neia Neutuladh via Digitalmars-d-learn wrote: > On Sat, 12 Jan 2019 12:10:25 +, Droggl wrote: [...] > > 3. How is everyone in general using curses with D? Is there maybe a > > different library I should checkout instead? Are you using latest > > git?

Re: nice-curses releases / dub version git?

2019-01-12 Thread Neia Neutuladh via Digitalmars-d-learn
On Sat, 12 Jan 2019 12:10:25 +, Droggl wrote: > 2. Is there a way to get a certain git-version (eg. commit or maybe even > just "latest") for a package in dub? git submodule and path-based dependencies, if you need a particular version. > 3. How is everyone in general using curses with D?

Re: nice-curses releases / dub version git?

2019-01-12 Thread 0xEAB via Digitalmars-d-learn
On Saturday, 12 January 2019 at 12:10:25 UTC, Droggl wrote: 2. Is there a way to get a certain git-version (eg. commit or maybe even just "latest") for a package in dub? JSON: "nice-curses": "~master" SDL: dependency "nice-curses" version="~master" 3. How is everyone in general using curses

nice-curses releases / dub version git?

2019-01-12 Thread Droggl via Digitalmars-d-learn
Hey there D community! After a a bunch of years absence I'm getting back into D and its quite fun so far :-) I'm working on a little project that is uses nice-curses and now I stumbled across a bug that makes building impossible on Windows for me. Luckily that was fixed 3 months ago, but the