Re: [dm-devel] [PATCH v4 00/11] Zoned block device support improvements

2018-10-15 Thread Damien Le Moal
Martin, Mike, On 2018/10/16 11:34, Jens Axboe wrote: > On 10/14/18 6:45 PM, Damien Le Moal wrote: >> Jens, >> >> On 2018/10/14 7:43, Jens Axboe wrote: >>> On 10/12/18 4:08 AM, Damien Le Moal wrote: This series improves zoned block device support (reduce overhead) and introduces many

Re: [dm-devel] [PATCH v4 00/11] Zoned block device support improvements

2018-10-15 Thread Jens Axboe
On 10/14/18 6:45 PM, Damien Le Moal wrote: > Jens, > > On 2018/10/14 7:43, Jens Axboe wrote: >> On 10/12/18 4:08 AM, Damien Le Moal wrote: >>> This series improves zoned block device support (reduce overhead) and >>> introduces many simplifications to the code (overall, there are more >>>

Re: [dm-devel] [PATCH v4 02/11] scsi: sd_zbc: Reduce boot device scan and revalidate time

2018-10-15 Thread Martin K. Petersen
Damien, > Handling checks of ZBC device capacity using the max_lba field of the > REPORT ZONES command reply for disks with rc_basis == 0 can be done > using the same report zones command reply used to check the "same" > field. > > Avoid executing a report zones command solely to check the disk

Re: [dm-devel] [PATCH v4 03/11] scsi: sd_zbc: Fix sd_zbc_check_zones() error checks

2018-10-15 Thread Martin K. Petersen
Damien, > The unsigned 32 bits overflow check for the zone size value is already > done within sd_zbc_check_zones() with the test: > > } else if (logical_to_sectors(sdkp->device, zone_blocks) > UINT_MAX) { > > so there is no need to check again for an out of range value in >

Re: [dm-devel] [PATCH v4 01/11] scsi: sd_zbc: Rearrange code

2018-10-15 Thread Martin K. Petersen
Damien, > Move the urswrz check out of sd_zbc_read_zones() and into > sd_zbc_read_zoned_characteristics() where that value is obtained (read > from the disk zoned characteristics VPD page). Since this function now > does more than simply reading the VPD page, rename it to >

Re: [dm-devel] [PATCH v4 11/11] block: Introduce blk_revalidate_disk_zones()

2018-10-15 Thread Martin K. Petersen
Damien, > Drivers exposing zoned block devices have to initialize and maintain > correctness (i.e. revalidate) of the device zone bitmaps attached to > the device request queue (seq_zones_bitmap and seq_zones_wlock). > > To simplify coding this, introduce a generic helper function >

Re: [dm-devel] [PATCH v4 10/11] block: add a report_zones method

2018-10-15 Thread Martin K. Petersen
Damien, > Dispatching a report zones command through the request queue is a > major pain due to the command reply payload rewriting necessary. Given > that blkdev_report_zones() is executing everything synchronously, > implement report zones as a block device file operation instead, > allowing