Re: [DNG] udisks2 - who uses it? (not a poll)

2019-09-10 Thread fsmithred via Dng

On 9/10/19 5:11 AM, Daniel Reurich wrote:

On 08/09/19 07:37, fsmithred via Dng wrote:

On 9/7/19 1:33 PM, Ismael L. Donis Garcia wrote:

- Original Message - From: "fsmithred via Dng"

To: "dng" 
Sent: Friday, September 06, 2019 9:23 AM
Subject: [DNG] udisks2 - who uses it? (not a poll)



In ascii, udisks2 has been devuanized to remove a dependency on
libpam-systemd (and maybe libsystemd0, too.)

The version of udisks2 in beowulf is very old compared to what's in
buster.

The version in buster depends on libpam-systemd OR libpam-elogind.
(Also libsystemd0 OR libelogind0) Since we have libpam-elogind and
libelogind0 in the repos, we don't really need to devuanize udisks2
anymore. Do we?

Does anyone use udisks2 who doesn't want libpam-elogind or
libelogind0 with it?

fsmithred (looking to reduce the work load)



I use udisks2, but I also use libpam-elogind and libelogind0

Right now I am needing this update to install other packages.

Best Regards
--
Ismael



Thanks.

Things are moving slowly now, and I have no idea when we will get the
newer version into the repo. For now, I suggest you download udisks2 and
libudisks2-0 from packages.debian.org and install them manually.
https://packages.debian.org/buster/udisks2

If you wait for us, you'll get the exact same packages, only it will be
later.

fsmithred


fsmithred - do we need to drop udisks2 forked package from unstable and
beowulf?




Yes. Nobody has objected to that, and it will fix the problem. Here's the 
current landscape:


  Version table:
 2.8.4-1 500
500 http://debian.csail.mit.edu/debian sid/main amd64 Packages
 2.8.1-4 10
 10 http://debian.csail.mit.edu/debian buster/main amd64 Packages
 2.1.8-1+devuan2 500
500 http://deb.devuan.org/merged ascii/main amd64 Packages
500 http://auto.mirror.devuan.org/merged ascii/main amd64 Packages
 2.1.8-1 10
 10 http://debian.csail.mit.edu/debian stretch/main amd64 Packages
 2.1.3-5+devuan2 50
 50 http://deb.devuan.org/merged beowulf/main amd64 Packages
 50 http://pkgmaster.devuan.org/merged ceres/main amd64 Packages
___
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng


Re: [DNG] udisks2 - who uses it? (not a poll)

2019-09-10 Thread Daniel Reurich
On 08/09/19 07:37, fsmithred via Dng wrote:
> On 9/7/19 1:33 PM, Ismael L. Donis Garcia wrote:
>> - Original Message - From: "fsmithred via Dng"
>> 
>> To: "dng" 
>> Sent: Friday, September 06, 2019 9:23 AM
>> Subject: [DNG] udisks2 - who uses it? (not a poll)
>>
>>
>>> In ascii, udisks2 has been devuanized to remove a dependency on
>>> libpam-systemd (and maybe libsystemd0, too.)
>>>
>>> The version of udisks2 in beowulf is very old compared to what's in
>>> buster.
>>>
>>> The version in buster depends on libpam-systemd OR libpam-elogind.
>>> (Also libsystemd0 OR libelogind0) Since we have libpam-elogind and
>>> libelogind0 in the repos, we don't really need to devuanize udisks2
>>> anymore. Do we?
>>>
>>> Does anyone use udisks2 who doesn't want libpam-elogind or
>>> libelogind0 with it?
>>>
>>> fsmithred (looking to reduce the work load)
>>>
>>
>> I use udisks2, but I also use libpam-elogind and libelogind0
>>
>> Right now I am needing this update to install other packages.
>>
>> Best Regards
>> -- 
>> Ismael
>>
> 
> Thanks.
> 
> Things are moving slowly now, and I have no idea when we will get the
> newer version into the repo. For now, I suggest you download udisks2 and
> libudisks2-0 from packages.debian.org and install them manually.
> https://packages.debian.org/buster/udisks2
> 
> If you wait for us, you'll get the exact same packages, only it will be
> later.
> 
> fsmithred

fsmithred - do we need to drop udisks2 forked package from unstable and
beowulf?


-- 
Daniel Reurich
Centurion Computer Technology (2005) Ltd.
021 797 722



signature.asc
Description: OpenPGP digital signature
___
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng


Re: [DNG] udisks2 - who uses it? (not a poll)

2019-09-07 Thread Alessandro Selli
On 06/09/19 at 15:23, fsmithred via Dng wrote:
> In ascii, udisks2 has been devuanized to remove a dependency on
> libpam-systemd (and maybe libsystemd0, too.)
>
> The version of udisks2 in beowulf is very old compared to what's in
> buster.

  Really?  I'm on beowulf now, and I have:

ii  udisks2    2.8.1-4  amd64    D-Bus service to access and
manipulate storage devices

Same as Debian 10 (buster):

https://packages.debian.org/stable/allpackages

udisks2 (2.8.1-4)
D-Bus service to access and manipulate storage devices

  Latest version upstream is 2.8.4, released in Jul 22, 2019:

https://github.com/storaged-project/udisks/releases

2.8.1 was released in Sep 26, 2018.


> The version in buster depends on libpam-systemd OR libpam-elogind.
> (Also libsystemd0 OR libelogind0) Since we have libpam-elogind and
> libelogind0 in the repos, we don't really need to devuanize udisks2
> anymore. Do we?
>
> Does anyone use udisks2 who doesn't want libpam-elogind or libelogind0
> with it?

  I have them both, and I have nothing against them.

  Bye,


Alessandro




signature.asc
Description: OpenPGP digital signature
___
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng


Re: [DNG] udisks2 - who uses it? (not a poll)

2019-09-07 Thread fsmithred via Dng

On 9/7/19 1:33 PM, Ismael L. Donis Garcia wrote:

- Original Message - From: "fsmithred via Dng" 
To: "dng" 
Sent: Friday, September 06, 2019 9:23 AM
Subject: [DNG] udisks2 - who uses it? (not a poll)


In ascii, udisks2 has been devuanized to remove a dependency on 
libpam-systemd (and maybe libsystemd0, too.)


The version of udisks2 in beowulf is very old compared to what's in buster.

The version in buster depends on libpam-systemd OR libpam-elogind. (Also 
libsystemd0 OR libelogind0) Since we have libpam-elogind and libelogind0 
in the repos, we don't really need to devuanize udisks2 anymore. Do we?


Does anyone use udisks2 who doesn't want libpam-elogind or libelogind0 
with it?


fsmithred (looking to reduce the work load)



I use udisks2, but I also use libpam-elogind and libelogind0

Right now I am needing this update to install other packages.

Best Regards
--
Ismael



Thanks.

Things are moving slowly now, and I have no idea when we will get the 
newer version into the repo. For now, I suggest you download udisks2 and 
libudisks2-0 from packages.debian.org and install them manually.

https://packages.debian.org/buster/udisks2

If you wait for us, you'll get the exact same packages, only it will be later.

fsmithred


___
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng


Re: [DNG] udisks2 - who uses it? (not a poll)

2019-09-07 Thread Ismael L. Donis Garcia
- Original Message - 
From: "fsmithred via Dng" 

To: "dng" 
Sent: Friday, September 06, 2019 9:23 AM
Subject: [DNG] udisks2 - who uses it? (not a poll)


In ascii, udisks2 has been devuanized to remove a dependency on 
libpam-systemd (and maybe libsystemd0, too.)


The version of udisks2 in beowulf is very old compared to what's in 
buster.


The version in buster depends on libpam-systemd OR libpam-elogind. (Also 
libsystemd0 OR libelogind0) Since we have libpam-elogind and libelogind0 
in the repos, we don't really need to devuanize udisks2 anymore. Do we?


Does anyone use udisks2 who doesn't want libpam-elogind or libelogind0 
with it?


fsmithred (looking to reduce the work load)



I use udisks2, but I also use libpam-elogind and libelogind0

Right now I am needing this update to install other packages.

Best Regards
--
Ismael


___
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng


Re: [DNG] udisks2 - who uses it? (not a poll)

2019-09-06 Thread Alessandro Selli
On 07/09/19 at 01:58, Alessandro Selli wrote:
> On 07/09/19 at 00:34, fsmithred via Dng wrote:
>> On 9/6/19 5:43 PM, Alessandro Selli wrote:
>>> On 06/09/19 at 15:23, fsmithred via Dng wrote:
 In ascii, udisks2 has been devuanized to remove a dependency on
 libpam-systemd (and maybe libsystemd0, too.)

 The version of udisks2 in beowulf is very old compared to what's in
 buster.
>>>    Really?  I'm on beowulf now, and I have:
>>>
>>> ii  udisks2    2.8.1-4  amd64    D-Bus service to access and
>>> manipulate storage devices
>>>
>>> Same as Debian 10 (buster):
>>>
>>
>> Where did you get it? That version is not in devuan. I'm still running
>> the ascii version in my beowulf, because the beowulf/ceres version is
>> older.
>>
> [alessandro@wkstn02 ~]$ apt-cache policy udisks2
> udisks2:
>   Installed: 2.8.1-4
>   Candidate: 2.8.1-4
>   Version table:
>  *** 2.8.1-4 100
>     100 /var/lib/dpkg/status
>  2.1.3-5+devuan2 500
>     500 https://pkgmaster.devuan.org/merged beowulf/main amd64 Packages
>     500 http://packages.devuan.org/merged beowulf/main amd64 Packages
> [alessandro@wkstn02 ~]$
>
>
>   Greetings,
>
>
> Alessandro


  Which means the package I have does come from Debian, like most (all?)
Devuan packages that did not need to be hacked to take systemd out of it.

[alessandro@wkstn02 ~]$ grep -iR debian /etc/apt/sources.list*
[alessandro@wkstn02 ~]$


  Bye,


-- 
Alessandro Selli 
VOIP SIP: dhatarat...@ekiga.net
Chiave firma e cifratura PGP/GPG signing and encoding key:
  BA651E4050DDFC31E17384BABCE7BD1A1B0DF2AE




signature.asc
Description: OpenPGP digital signature
___
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng


Re: [DNG] udisks2 - who uses it? (not a poll)

2019-09-06 Thread Alessandro Selli
On 07/09/19 at 00:34, fsmithred via Dng wrote:
> On 9/6/19 5:43 PM, Alessandro Selli wrote:
>> On 06/09/19 at 15:23, fsmithred via Dng wrote:
>>> In ascii, udisks2 has been devuanized to remove a dependency on
>>> libpam-systemd (and maybe libsystemd0, too.)
>>>
>>> The version of udisks2 in beowulf is very old compared to what's in
>>> buster.
>>
>>    Really?  I'm on beowulf now, and I have:
>>
>> ii  udisks2    2.8.1-4  amd64    D-Bus service to access and
>> manipulate storage devices
>>
>> Same as Debian 10 (buster):
>>
>
>
> Where did you get it? That version is not in devuan. I'm still running
> the ascii version in my beowulf, because the beowulf/ceres version is
> older.
>

[alessandro@wkstn02 ~]$ apt-cache policy udisks2
udisks2:
  Installed: 2.8.1-4
  Candidate: 2.8.1-4
  Version table:
 *** 2.8.1-4 100
    100 /var/lib/dpkg/status
 2.1.3-5+devuan2 500
    500 https://pkgmaster.devuan.org/merged beowulf/main amd64 Packages
    500 http://packages.devuan.org/merged beowulf/main amd64 Packages
[alessandro@wkstn02 ~]$


  Greetings,


Alessandro


-- 
Alessandro Selli 
VOIP SIP: dhatarat...@ekiga.net
Chiave firma e cifratura PGP/GPG signing and encoding key:
  BA651E4050DDFC31E17384BABCE7BD1A1B0DF2AE




signature.asc
Description: OpenPGP digital signature
___
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng


Re: [DNG] udisks2 - who uses it? (not a poll)

2019-09-06 Thread fsmithred via Dng

On 9/6/19 5:43 PM, Alessandro Selli wrote:

On 06/09/19 at 15:23, fsmithred via Dng wrote:

In ascii, udisks2 has been devuanized to remove a dependency on
libpam-systemd (and maybe libsystemd0, too.)

The version of udisks2 in beowulf is very old compared to what's in
buster.


   Really?  I'm on beowulf now, and I have:

ii  udisks2    2.8.1-4  amd64    D-Bus service to access and
manipulate storage devices

Same as Debian 10 (buster):




Where did you get it? That version is not in devuan. I'm still running the 
ascii version in my beowulf, because the beowulf/ceres version is older.


udisks2:
  Installed: 2.1.8-1+devuan2
  Candidate: 2.1.8-1+devuan2
  Version table:
 2.8.1-4 10
 10 http://debian.csail.mit.edu/debian buster/main amd64 Packages
 *** 2.1.8-1+devuan2 100
100 /var/lib/dpkg/status
 2.1.3-5+devuan2 500
500 http://deb.devuan.org/merged beowulf/main amd64 Packages
 50 http://deb.devuan.org/merged ceres/main amd64 Packages

I do have the buster version in one beowulf install, but I got that from 
outside of devuan.


fsmithred
___
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng


Re: [DNG] udisks2 - who uses it? (not a poll)

2019-09-06 Thread Alessandro Selli
On 06/09/19 at 15:23, fsmithred via Dng wrote:
> In ascii, udisks2 has been devuanized to remove a dependency on
> libpam-systemd (and maybe libsystemd0, too.)
>
> The version of udisks2 in beowulf is very old compared to what's in
> buster.

  Really?  I'm on beowulf now, and I have:

ii  udisks2    2.8.1-4  amd64    D-Bus service to access and
manipulate storage devices

Same as Debian 10 (buster):

https://packages.debian.org/stable/allpackages

udisks2 (2.8.1-4)
D-Bus service to access and manipulate storage devices

  Latest version upstream is 2.8.4, released in Jul 22, 2019:

https://github.com/storaged-project/udisks/releases

2.8.1 was released in Sep 26, 2018.


> The version in buster depends on libpam-systemd OR libpam-elogind.
> (Also libsystemd0 OR libelogind0) Since we have libpam-elogind and
> libelogind0 in the repos, we don't really need to devuanize udisks2
> anymore. Do we?
>
> Does anyone use udisks2 who doesn't want libpam-elogind or libelogind0
> with it?

  I have them both, and I have nothing against them.

  Bye,


Alessandro


-- 
Alessandro Selli 
VOIP SIP: dhatarat...@ekiga.net
Chiave firma e cifratura PGP/GPG signing and encoding key:
  BA651E4050DDFC31E17384BABCE7BD1A1B0DF2AE



signature.asc
Description: OpenPGP digital signature
___
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng