[Dnsmasq-discuss] Stumped

2018-11-01 Thread Petr Mensik
Hi Peter, did you check what "pkg-config --libs nettle hogweed" returns in your environment? If you want to prefer your own libraries, I think the simplest way is to remove nettle-devel package, unless you want to build your own package. Environment variables PKG_CONFIG_LIBDIR and PKG_CONFIG_PATH

Re: [Dnsmasq-discuss] Stumped

2018-10-31 Thread Simon Kelley
I'm confused by the references to openssl in your description. Dnsmasq with DNSSEC does NOT depend on openSSL. You just need libnettle and libhogweed installed in the standard way, and accessible via pkg-config. version 3.4 should be fine. Cheers, Simon. On 31/10/2018 03:21, Peter Nehem

[Dnsmasq-discuss] Stumped

2018-10-30 Thread Peter Nehem
Hello All,  I'm stumped I've been trying to compile dnsmasq for Centos 7.5 because the version for Centos 7.5 doesn't have any of the extra features turned on, namely dnssec and several others. But I keep getting this error message no matter what I do: ccache gcc -Wall -W -O2   -DVERSION='"2.76"'