Re: [DQSD-Users] comx /dilbert access denied

2009-01-09 Thread tom . corcoran
hey Shawn,

Happy new year! Not wanting to put any pressure on you, but I know I'm  
not the only one excited about your pending fix!

Cheers,

Tom.

Re: [DQSD-Users] comx /dilbert access denied
From: Shawn K. Hall sh...@re... - 2008-11-11 04:03
That's exactly the same error.


The only thing that jumps out at me is that the code in comx is using
synchronous XML-HTTP transfers, it isn't changing the UA, and isn't
checking for errors, which can all cause issues.

If the UA isn't changed you may end up where the server flat-out rejects
attempts to connect from the MS XmlHttp object (mine does).

Synchronous transfers can cause stale or broken connections if the
connection is refused or for any other reason the server doesn't return
content. Finally, without error trapping, there's no way to tell what
the error could be.

I'm going to put this on my short list for rewriting it to make it do
all of the above. It's a lot of code though, so no guarantees it'll
happen right away. On the plus side, it'll be more modular, so new
comics should be a lot easier to add. ;)


Meanwhile, if you look at the rssx search I wrote (lines 42-56), which
comx is based on, you'll see a much better way to handle the remoting
aspects.

-Shawn

--
Check out the new SourceForge.net Marketplace.
It is the best place to buy or sell services for
just about anything Open Source.
http://p.sf.net/sfu/Xq1LFB
___
To unsubscribe visit:
https://lists.sourceforge.net/lists/listinfo/dqsd-users
DQSD-Users@lists.sourceforge.net
http://sourceforge.net/mailarchive/forum.php?forum_id=8601


Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE window when web address is entered

2009-01-09 Thread Michael Kairys
When I launch a search.

 -Original Message-
 From: Kim Gräsman [mailto:kim.gras...@gmail.com]
 Sent: Friday, January 09, 2009 1:59 AM
 To: kai...@comcast.net; DQSD users mailing list
 Subject: Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE
window
 when web address is entered
 
 Hi Michael,
 
 Thanks for the extra information. When, specifically, do you get the
 search.htm error with launchmode=0? At startup, or when you launch a
 search?
 
 Thanks,
 - Kim



--
Check out the new SourceForge.net Marketplace.
It is the best place to buy or sell services for
just about anything Open Source.
http://p.sf.net/sfu/Xq1LFB
___
To unsubscribe visit:
https://lists.sourceforge.net/lists/listinfo/dqsd-users
DQSD-Users@lists.sourceforge.net
http://sourceforge.net/mailarchive/forum.php?forum_id=8601


Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE window when web address is entered

2009-01-09 Thread Kim Gräsman
Hi James,

As it happens, we just bought a new laptop for Christmas, and it came
with Vista. I just managed to install DQSD for tinkering...

I've tried these steps, and I got the same results, but ONLY when
running with launchmode = 0, so it doesn't match your settings,
strangely enough.

I also get the AppDataDirectory error that Michael mentions after I
change to launchmode=0, but it shows immediately when I restart the
bar. Weird.

I'll see if I can find some time to follow up on these issues during
the weekend. Thanks for your reports.

- Kim

On Tue, Jan 6, 2009 at 18:09, James Nix ni...@charter.net wrote:
 Kim,

 Well it seems DQSD IS starting SOME windows in Protected Mode (PM)
 correctly and some blank windows in UnProtected Mode (UPM) incorrectly, or
 so it seems.  Try this sequence if you are setup to do so (Vista 32 bit, IE7
 in Tabbed Mode, DQSD reuseBrowserWindowMode = 0).

 With Protected Mode ON in Internet Options Security tab.

 1)  DQSD entry test search 1 creates PM Google Window 1 with search field
 test search 1
 2)  DQSD entry test search 2 creates PM Google New Tab Window in Window 1
 with search field test search 2
 3)  DQSD entry gg newegg.com creates PM Google New Tab Window in Window 1
 with search field newegg.com
 4)  DQSD entry av newegg.com creates PM Alta Vista New Tab Window in
 Window 1 with search field newegg.com
 5)  DQSD entry newegg.com creates blank UPM Window 2 and reuses AV Tab
 Window from step 4 with WWW.NEWEGG.COM
 6)  DQSD entry cnn.com creates blank UPM Window 3 and reuses Tab Window
 from step 4 with WWW.CNN.COM
 7)  DQSD entry test search 3 creates PM Google New Tab Window in Window 1
 with search field test search 3

 ... and so on...

 Like I said earlier, I can live with it by simply turning PM OFF on IE
 Security Options.  But I won't turn PM off for end users and I am not even
 going to try to explain the 'rules' governing the sequence above to them.

 Jim


 -Original Message-
 From: Kim Gräsman [mailto:kim.gras...@gmail.com]
 Sent: Tuesday, January 06, 2009 10:16 AM
 To: kai...@comcast.net; DQSD users mailing list
 Subject: Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE window
 when web address is entered

 Hi Michael,

 Thanks for that tidbit, I guess that makes sense. DQSD's taskbar
 instance of IE can't run in protected mode, so any window it launches
 will probably inherit the non-protectedness.

 I don't know of a way to force IE into protected mode -- even if it's
 launched via double-click on a .html file, it gets Protected Mode:
 Off, presumably because a local file is considered safer.

 Maybe if there is a way to configure which sites require Protected
 Mode, you can add DQSD's %PROGRAMFILES%\Quick Search
 Deskbar\search.htm or the launch path used for the launchMode where we
 write out a .html file to your temp dir.

 Just some random thoughts,
 - Kim

 On Tue, Jan 6, 2009 at 03:35, Michael Kairys kai...@comcast.net wrote:
 I reported this over a year ago. The replies I got were along the lines of
 LITW (Life Is That Way). The problem is indeed caused by IE Protected
 Mode;
 note that the blank window has Protected Mode off while the window with
 content has it on.

 -Original Message-
 From: James Nix [mailto:ni...@charter.net]
 Sent: Monday, January 05, 2009 4:43 PM
 To: 'DQSD users mailing list'
 Cc: sh...@reliableanswers.com
 Subject: Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE
 window when web address is entered - cause found.

 I have the cause/effect but can't explain why/what.

 Brief Update of Symptom:  DQSD entered specific addresses (i.e.
 www.newegg.com) opens additional blank page for each entry.

 Currently using:

 Vista Home Premium 32 Bit SP1 with IE7 in Tabbed Mode.
 Dqsd-400-rc3

 Problem Cause/Solution:  IE7 was running with Protected Mode enabled.
 Disabling Protected Mode caused DQSD to behave
 as expected when localprefs.js set to:

 *
 *  0=new window always [default]
 *  1=single window for all
 *  2=single window for each search type
 */
 reuseBrowserWindowMode = 0;

 Note that I had tried disabling all IE7 add-ons as well as various
 spyware/adware tools (AVG Free Edition, Spybot Resident Shiels and
 Tea=timer) with no luck.

 Seems like DQSD did not behave this way when I first upgraded to Vista
 Sp1.
 Maybe a new Vista IE7 security patch?

 Has no one else noticed this?  I mean I like feeling special but
 jez not like this! :)





 --
 
 ___
 To unsubscribe visit:
 https://lists.sourceforge.net/lists/listinfo/dqsd-users
 DQSD-Users@lists.sourceforge.net
 http://sourceforge.net/mailarchive/forum.php?forum_id=8601



 
 --
 ___
 To unsubscribe visit:
 https://lists.sourceforge.net/lists/listinfo/dqsd-users
 

Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE window when web address is entered

2009-01-09 Thread James Nix
Kim,


I am glad you have a platform to emulate the problem(s).  

I am a little unclear on your description.  Are you saying that with
launchmode=1, DQSD behaves correctly?

Also, it has occurred to me that I am doing one other variation with Vista.
I use the TWEAKUAC utility  ( http://www.tweak-uac.com/home/ ) 
to set the Vista UAC into Silent mode to suppress some of the annoying
Are you sure questions.

It is not the cause of the problem though as DQSD exhibited the same
symptoms on a new clean Vista install that I completed recently.

Later! 


-Original Message-
From: Kim Gräsman [mailto:kim.gras...@gmail.com] 
Sent: Friday, January 09, 2009 11:28 AM
To: DQSD users mailing list
Subject: Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE window
when web address is entered

Hi James,

As it happens, we just bought a new laptop for Christmas, and it came
with Vista. I just managed to install DQSD for tinkering...

I've tried these steps, and I got the same results, but ONLY when
running with launchmode = 0, so it doesn't match your settings,
strangely enough.

I also get the AppDataDirectory error that Michael mentions after I
change to launchmode=0, but it shows immediately when I restart the
bar. Weird.

I'll see if I can find some time to follow up on these issues during
the weekend. Thanks for your reports.

- Kim

On Tue, Jan 6, 2009 at 18:09, James Nix ni...@charter.net wrote:
 Kim,

 Well it seems DQSD IS starting SOME windows in Protected Mode (PM)
 correctly and some blank windows in UnProtected Mode (UPM) incorrectly, or
 so it seems.  Try this sequence if you are setup to do so (Vista 32 bit,
IE7
 in Tabbed Mode, DQSD reuseBrowserWindowMode = 0).

 With Protected Mode ON in Internet Options Security tab.

 1)  DQSD entry test search 1 creates PM Google Window 1 with search
field
 test search 1
 2)  DQSD entry test search 2 creates PM Google New Tab Window in Window
1
 with search field test search 2
 3)  DQSD entry gg newegg.com creates PM Google New Tab Window in Window
1
 with search field newegg.com
 4)  DQSD entry av newegg.com creates PM Alta Vista New Tab Window in
 Window 1 with search field newegg.com
 5)  DQSD entry newegg.com creates blank UPM Window 2 and reuses AV Tab
 Window from step 4 with WWW.NEWEGG.COM
 6)  DQSD entry cnn.com creates blank UPM Window 3 and reuses Tab Window
 from step 4 with WWW.CNN.COM
 7)  DQSD entry test search 3 creates PM Google New Tab Window in Window
1
 with search field test search 3

 ... and so on...

 Like I said earlier, I can live with it by simply turning PM OFF on IE
 Security Options.  But I won't turn PM off for end users and I am not even
 going to try to explain the 'rules' governing the sequence above to them.

 Jim


 -Original Message-
 From: Kim Gräsman [mailto:kim.gras...@gmail.com]
 Sent: Tuesday, January 06, 2009 10:16 AM
 To: kai...@comcast.net; DQSD users mailing list
 Subject: Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE
window
 when web address is entered

 Hi Michael,

 Thanks for that tidbit, I guess that makes sense. DQSD's taskbar
 instance of IE can't run in protected mode, so any window it launches
 will probably inherit the non-protectedness.

 I don't know of a way to force IE into protected mode -- even if it's
 launched via double-click on a .html file, it gets Protected Mode:
 Off, presumably because a local file is considered safer.

 Maybe if there is a way to configure which sites require Protected
 Mode, you can add DQSD's %PROGRAMFILES%\Quick Search
 Deskbar\search.htm or the launch path used for the launchMode where we
 write out a .html file to your temp dir.

 Just some random thoughts,
 - Kim

 On Tue, Jan 6, 2009 at 03:35, Michael Kairys kai...@comcast.net wrote:
 I reported this over a year ago. The replies I got were along the lines
of
 LITW (Life Is That Way). The problem is indeed caused by IE Protected
 Mode;
 note that the blank window has Protected Mode off while the window with
 content has it on.

 -Original Message-
 From: James Nix [mailto:ni...@charter.net]
 Sent: Monday, January 05, 2009 4:43 PM
 To: 'DQSD users mailing list'
 Cc: sh...@reliableanswers.com
 Subject: Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE
 window when web address is entered - cause found.

 I have the cause/effect but can't explain why/what.

 Brief Update of Symptom:  DQSD entered specific addresses (i.e.
 www.newegg.com) opens additional blank page for each entry.

 Currently using:

 Vista Home Premium 32 Bit SP1 with IE7 in Tabbed Mode.
 Dqsd-400-rc3

 Problem Cause/Solution:  IE7 was running with Protected Mode enabled.
 Disabling Protected Mode caused DQSD to behave
 as expected when localprefs.js set to:

 *
 *  0=new window always [default]
 *  1=single window for all
 *  2=single window for each search type
 */
 reuseBrowserWindowMode = 0;

 Note that I had tried disabling all IE7 add-ons as well as various
 spyware/adware tools (AVG Free 

Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE window when web address is entered

2009-01-09 Thread Michael Kairys
 I use the TWEAKUAC utility  ( http://www.tweak-uac.com/home/ )
 to set the Vista UAC into Silent mode to suppress some of the annoying
 Are you sure questions.

I do as well :)


--
Check out the new SourceForge.net Marketplace.
It is the best place to buy or sell services for
just about anything Open Source.
http://p.sf.net/sfu/Xq1LFB
___
To unsubscribe visit:
https://lists.sourceforge.net/lists/listinfo/dqsd-users
DQSD-Users@lists.sourceforge.net
http://sourceforge.net/mailarchive/forum.php?forum_id=8601


Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE window when web address is entered

2009-01-09 Thread James Nix
Kim,

So, in your testing, DQSD is NOT behaving correctly when Vista/IE7 PM is on
regardless of launchmode/reusewindow mode settings, correct (Y/N) ?

But like I said, if it can start a Google or Alta-Vista search window
correctly in PM it should be able to start a URL without the UPM blank
window, or so it seems to me.

-Original Message-
From: Kim Gräsman [mailto:kim.gras...@gmail.com] 
Sent: Friday, January 09, 2009 4:08 PM
To: DQSD users mailing list
Subject: Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE window
when web address is entered

Hi James,

On Fri, Jan 9, 2009 at 20:16, James Nix ni...@charter.net wrote:

 I am a little unclear on your description.  Are you saying that with
 launchmode=1, DQSD behaves correctly?

Ah, I forgot to mention the other option... With launchmode=1, DQSD
uses a temporary .html file to launch the browser. and that was
started in UPM, and with an infobar warning about ActiveX activity on
the page.

Interestingly, starting URLs from DQSD directly worked without a hitch.

 Also, it has occurred to me that I am doing one other variation with
Vista.
 I use the TWEAKUAC utility  ( http://www.tweak-uac.com/home/ )
 to set the Vista UAC into Silent mode to suppress some of the annoying
 Are you sure questions.

 It is not the cause of the problem though as DQSD exhibited the same
 symptoms on a new clean Vista install that I completed recently.

OK, good to know, but it sounds like it doesn't help/hinder...

Thanks,
- Kim


--
Check out the new SourceForge.net Marketplace.
It is the best place to buy or sell services for
just about anything Open Source.
http://p.sf.net/sfu/Xq1LFB
___
To unsubscribe visit:
https://lists.sourceforge.net/lists/listinfo/dqsd-users
DQSD-Users@lists.sourceforge.net
http://sourceforge.net/mailarchive/forum.php?forum_id=8601

No virus found in this incoming message.
Checked by AVG - http://www.avg.com 
Version: 8.0.176 / Virus Database: 270.10.5/1884 - Release Date: 1/9/2009
8:38 AM


--
Check out the new SourceForge.net Marketplace.
It is the best place to buy or sell services for
just about anything Open Source.
http://p.sf.net/sfu/Xq1LFB
___
To unsubscribe visit:
https://lists.sourceforge.net/lists/listinfo/dqsd-users
DQSD-Users@lists.sourceforge.net
http://sourceforge.net/mailarchive/forum.php?forum_id=8601


Re: [DQSD-Users] Dave's Quick Search Opens extra BLANK PAGE window when web address is entered

2009-01-09 Thread Kim Gräsman
Hi James,

On Fri, Jan 9, 2009 at 22:53, James Nix ni...@charter.net wrote:

 So, in your testing, DQSD is NOT behaving correctly when Vista/IE7 PM is on
 regardless of launchmode/reusewindow mode settings, correct (Y/N) ?

Y.

 But like I said, if it can start a Google or Alta-Vista search window
 correctly in PM it should be able to start a URL without the UPM blank
 window, or so it seems to me.

Of course. I'm not disputing that, I'm trying to get to the bottom of
why there's a difference between our machines, as that may lead us to
a core problem, and maybe a clean workaround.

Hope that helps,
- Kim

--
Check out the new SourceForge.net Marketplace.
It is the best place to buy or sell services for
just about anything Open Source.
http://p.sf.net/sfu/Xq1LFB
___
To unsubscribe visit:
https://lists.sourceforge.net/lists/listinfo/dqsd-users
DQSD-Users@lists.sourceforge.net
http://sourceforge.net/mailarchive/forum.php?forum_id=8601