Re: [PATCH 00/17] drm/mgag200: Convert to atomic modesetting

2020-04-30 Thread Thomas Zimmermann
Hi John Am 30.04.20 um 02:11 schrieb John Donnelly: > On 4/29/20 9:32 AM, Thomas Zimmermann wrote: >> This patchset converts mgag200 to atomic modesetting. It uses simple >> KMS helpers and SHMEM. >> >> Patches 1 to 4 simplifies the driver before the conversion. For example, >> the HW cursor is

Re: [PATCH 07/17] drm/mgag200: Move mode-setting code into separate helper function

2020-04-30 Thread Thomas Zimmermann
Hi Am 29.04.20 um 20:24 schrieb Sam Ravnborg: > On Wed, Apr 29, 2020 at 04:32:28PM +0200, Thomas Zimmermann wrote: >> The mode-setting code is now located in mgag200_set_mode_regs(), sans >> a few flags that will be moved in a later patch for clarity. >> >> Signed-off-by: Thomas Zimmermann >

Re: [PATCH 05/17] drm/mgag200: Clean up mga_set_start_address()

2020-04-30 Thread Thomas Zimmermann
Hi Am 29.04.20 um 20:20 schrieb Sam Ravnborg: > Hi Thomas, > > On Wed, Apr 29, 2020 at 04:32:26PM +0200, Thomas Zimmermann wrote: >> All register names and fields are now named according to the >> MGA programming manuals. The function doesn't need the CRTC, so >> callers pass in the device

Re: [PATCH 01/17] drm/mgag200: Remove HW cursor

2020-04-30 Thread Thomas Zimmermann
Hi Sam Am 29.04.20 um 19:51 schrieb Sam Ravnborg: > On Wed, Apr 29, 2020 at 04:32:22PM +0200, Thomas Zimmermann wrote: >> The HW cursor of Matrox G200 cards only supports a 16-color palette >> format. Univeral planes require at least ARGB or a similar component- >> based format. Converting a

Re: [PATCH v7 08/12] arm: dts: s5pv210: Add node for SGX 540

2020-04-30 Thread Maxime Ripard
Hi, On Tue, Apr 28, 2020 at 03:58:03PM -0700, Jonathan Bakker wrote: > On 2020-04-28 2:39 p.m., Jonathan Bakker wrote: > > On 2020-04-27 8:46 a.m., Krzysztof Kozlowski wrote: > >> On Sun, Apr 26, 2020 at 07:57:12AM -0700, Jonathan Bakker wrote: > >>> Hi Paul, > >>> > >>> On 2020-04-26 5:56 a.m.,

Re: Msg "PM: pci_pm_suspend(): ast_pm_suspend+0x0/0x40 [ast] returns -22" after migrating to V5.6.7 kernel from v5.5.10.

2020-04-30 Thread Cary Garrett
Hello Thomas, Good news! After applying the patch and regenerating the ast kernel module, the system will successfully go into suspend state. Thanks for the fast turnaround. Glad I could help. Regards, Cary. On Wed, 2020-04-29 at 11:14 +0200, Thomas Zimmermann wrote: > Hi Cary, > > thanks

[PATCH] video: fbdev: valkyriefb.c: fix warning comparing pointer to 0

2020-04-30 Thread Jason Yan
Fix the following coccicheck warning: drivers/video/fbdev/valkyriefb.c:348:10-11: WARNING comparing pointer to 0, suggest !E drivers/video/fbdev/valkyriefb.c:334:12-13: WARNING comparing pointer to 0 drivers/video/fbdev/valkyriefb.c:348:10-11: WARNING comparing pointer to 0 Signed-off-by: Jason

[PATCH 1/3] drm/amdgpu: remove set but not used variable 'priority'

2020-04-30 Thread Zheng Bin
Fixes gcc '-Wunused-but-set-variable' warning: drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c:1211:26: warning: variable ‘priority’ set but not used It is not used since commit 33abcb1f5a17 ("drm/amdgpu: set compute queue priority at mqd_init") Reported-by: Hulk Robot Signed-off-by: Zheng Bin ---

[PATCH -next] drm/amd/display: Fix unsigned comparison to zero

2020-04-30 Thread Zou Wei
Fixes coccicheck warning: drivers/gpu/drm/amd/display/dc/dcn21/dcn21_resource.c:1398:60-61: WARNING: Unsigned expression compared with zero: j >= 0 Fixes: 238387774232 ("drm/amd/display: fix rn soc bb update") Reported-by: Hulk Robot Signed-off-by: Zou Wei ---

Re: [PATCH v8 0/2] Add initial support for slimport anx7625

2020-04-30 Thread Xin Ji
Hi Sam, On Mon, Apr 27, 2020 at 08:53:20PM +0200, Sam Ravnborg wrote: > Hi Xin Ji > > On Mon, Apr 27, 2020 at 02:16:49PM +0800, Xin Ji wrote: > > Hi all, > > > > The following series add support for the Slimport ANX7625 transmitter, a > > ultra-low power Full-HD 4K MIPI to DP transmitter

Re: [PATCH v7 08/12] arm: dts: s5pv210: Add node for SGX 540

2020-04-30 Thread Paul Cercueil
Hi Jonathan, Le mar. 28 avril 2020 à 15:58, Jonathan Bakker a écrit : Hi all, On 2020-04-28 2:39 p.m., Jonathan Bakker wrote: Hi Krzysztof, On 2020-04-27 8:46 a.m., Krzysztof Kozlowski wrote: On Sun, Apr 26, 2020 at 07:57:12AM -0700, Jonathan Bakker wrote: Hi Paul, On 2020-04-26

[PATCH 2/4] drm/amd/display: remove set but not used variable 'pixel_width'

2020-04-30 Thread Zheng Bin
Fixes gcc '-Wunused-but-set-variable' warning: drivers/gpu/drm/amd/display/dc/dcn10/dcn10_dpp.c:137:11: warning: variable ‘pixel_width’ set but not used [-Wunused-but-set-variable] It is introduced by commit 70ccab604049 ("drm/amdgpu/display: Add core dc support for DCN"), but never used, so

Re: [PATCH v3 -next] drm/mediatek: Fix Kconfig warning

2020-04-30 Thread Enric Balletbo i Serra
Hi YueHaibing, Thank you for your patch. On 29/4/20 9:13, YueHaibing wrote: > WARNING: unmet direct dependencies detected for MTK_MMSYS > Depends on [n]: (ARCH_MEDIATEK [=y] || COMPILE_TEST [=n]) && > COMMON_CLK_MT8173_MMSYS [=n] > Selected by [y]: > - DRM_MEDIATEK [=y] && HAS_IOMEM [=y]

[PATCH] video: pxafb: Fix the function used to balance a 'dma_alloc_coherent()' call

2020-04-30 Thread Christophe JAILLET
'dma_alloc_coherent()' must be balanced by a call to 'dma_free_coherent()' not 'dma_free_wc()'. The correct dma_free_ function is already used in the error handling path of the probe function. Fixes: 77e196752bdd ("[ARM] pxafb: allow video memory size to be configurable") Signed-off-by:

[PATCH 0/4] drm/amd/display: remove set but not used variables

2020-04-30 Thread Zheng Bin
Zheng Bin (4): drm/amd/display: remove set but not used variable 'dc' drm/amd/display: remove set but not used variable 'pixel_width' drm/amd/display: remove set but not used variable 'speakers' in dce_stream_encoder.c drm/amd/display: remove set but not used variable 'speakers' in

Re: [PATCH v8 2/2] drm/bridge: anx7625: Add anx7625 MIPI DSI/DPI to DP bridge driver

2020-04-30 Thread Xin Ji
Hi Sam, On Mon, Apr 27, 2020 at 10:00:44PM +0200, Sam Ravnborg wrote: > Hi Xin Ji > > On Mon, Apr 27, 2020 at 02:18:44PM +0800, Xin Ji wrote: > > The ANX7625 is an ultra-low power 4K Mobile HD Transmitter designed > > for portable device. It converts MIPI DSI/DPI to DisplayPort 1.3 4K. > > > >

Re: [PATCH v8 2/2] drm/bridge: anx7625: Add anx7625 MIPI DSI/DPI to DP bridge driver

2020-04-30 Thread Xin Ji
On Wed, Apr 29, 2020 at 10:10:05AM +0800, Nicolas Boichat wrote: > On Mon, Apr 27, 2020 at 2:18 PM Xin Ji wrote: > > > > The ANX7625 is an ultra-low power 4K Mobile HD Transmitter designed > > for portable device. It converts MIPI DSI/DPI to DisplayPort 1.3 4K. > > > > The ANX7625 can support

[PATCH -next] drm/amdgpu: Fix warning Comparison to bool

2020-04-30 Thread Zou Wei
fix below warnings reported by coccicheck drivers/gpu/drm/amd/amdgpu/sdma_v5_0.c:630:5-11: WARNING: Comparison to bool Reported-by: Hulk Robot Signed-off-by: Zou Wei --- drivers/gpu/drm/amd/amdgpu/sdma_v5_0.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH] drm/qxl: qxl_release use after free

2020-04-30 Thread Vasily Averin
qxl_release should not be accesses after qxl_push_*_ring_release() calls: userspace driver can process submitted command quickly, move qxl_release into release_ring, generate interrupt and trigger garbage collector. It can lead to crashes in qxl driver or trigger memory corruption in some

Re:Re: [PATCH] drm/mediatek: cleanup coding style in mediatek a bit

2020-04-30 Thread Bernard
发件人:Chun-Kuang Hu 发送日期:2020-04-29 22:22:50 收件人:Bernard Zhao 抄送人:Chun-Kuang Hu ,Philipp Zabel ,David Airlie ,Daniel Vetter ,Matthias Brugger ,DRI Development ,Linux ARM ,"moderated list:ARM/Mediatek SoC support" ,linux-kernel ,opensource.ker...@vivo.com 主题:Re: [PATCH] drm/mediatek:

[PATCH 1/4] drm/amd/display: remove set but not used variable 'dc'

2020-04-30 Thread Zheng Bin
Fixes gcc '-Wunused-but-set-variable' warning: drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c:8665:13: warning: variable ‘dc’ set but not used [-Wunused-but-set-variable] It is not used since commit d1ebfdd8d0fc ("drm/amd/display: Unify psr feature flags") Reported-by: Hulk Robot

[PATCH 0/3] drm/amdgpu: remove set but not used variables

2020-04-30 Thread Zheng Bin
Zheng Bin (3): drm/amdgpu: remove set but not used variable 'priority' drm/amdgpu: remove set but not used variable 'direct_poll' in vcn_v2_0.c drm/amdgpu: remove set but not used variable 'direct_poll' in vcn_v2_5.c drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c | 2 --

Re:Re: [PATCH 1/1] drm/qxl: add mutex_lock/mutex_unlock to ensure theorder in which resources are rele

2020-04-30 Thread 蔡兆鹏
hiI am sorry that I have not responded to your emails during those days. I was quarantined for 14 days for suspected 2019-ncov pneumonia,I‘m free now. On 4/21/20 11:43 AM, Gerd Hoffmann wrote:> On Sat, Apr 18, 2020 at 02:39:17PM +0800, Caicai wrote:>> When a qxl resource is released, the list that

[PATCH -next] drm/dp_mst: use false for bool variable

2020-04-30 Thread Zou Wei
Fixes coccicheck warning: drivers/gpu/drm/drm_dp_mst_topology.c:2229:6-13: WARNING: Assignment of 0/1 to bool variable Reported-by: Hulk Robot Signed-off-by: Zou Wei --- drivers/gpu/drm/drm_dp_mst_topology.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH 3/3] drm/amdgpu: remove set but not used variable 'direct_poll' in vcn_v2_5.c

2020-04-30 Thread Zheng Bin
Fixes gcc '-Wunused-but-set-variable' warning: drivers/gpu/drm/amd/amdgpu/vcn_v2_5.c:1170:39: warning: variable ‘direct_poll’ set but not used [-Wunused-but-set-variable] It is introduced by commit 7daaebfea5e5 ("drm/amdgpu: add VCN2.5 sriov start for Arctrus"), but never used, so remove it.

[PATCH 4/4] drm/amd/display: remove set but not used variable 'speakers' in dcn10_stream_encoder.c

2020-04-30 Thread Zheng Bin
Fixes gcc '-Wunused-but-set-variable' warning: drivers/gpu/drm/amd/display/dc/dcn10/dcn10_stream_encoder.c:1277:11: warning: variable ‘speakers’ set but not used [-Wunused-but-set-variable] It is introduced by commit 0c41891c81c0 ("drm/amd/display: Refactor stream encoder for HW review"), but

Re: Linux GOP initialization is wrong

2020-04-30 Thread David Santamaría Rogado
Hi Hans, I also found something interesting with that tests, the bgrt is not painted in the same position when doing the EFI Shell rotation, the firmware seems to take into account to position it. That solved me one thing I could not understand, Windows recovery system uses the incorrect

Re: [PATCH hmm 2/5] mm/hmm: make hmm_range_fault return 0 or -1

2020-04-30 Thread Jason Gunthorpe
On Wed, Apr 22, 2020 at 07:52:29AM +0200, Christoph Hellwig wrote: > On Tue, Apr 21, 2020 at 09:21:43PM -0300, Jason Gunthorpe wrote: > > From: Jason Gunthorpe > > > > hmm_vma_walk->last is supposed to be updated after every write to the > > pfns, so that it can be returned by hmm_range_fault().

re: [PATCH 00/17] drm/mgag200: Convert to atomic modesetting

2020-04-30 Thread John Donnelly
On 4/29/20 9:32 AM, Thomas Zimmermann wrote: This patchset converts mgag200 to atomic modesetting. It uses simple KMS helpers and SHMEM. Patches 1 to 4 simplifies the driver before the conversion. For example, the HW cursor is not usable with the way universal planes work. A few data structures

Re: Linux GOP initialization is wrong

2020-04-30 Thread David Santamaría Rogado
Anyway, what you say is what I thought, goo video mode is not being modified by the kernel, but, the problem is that we take then the first available mode we can found, so the problem is we take, in devices where the default video mode is not the first one in order, the wrong mode. So efifb is

Re: Linux GOP initialization is wrong

2020-04-30 Thread David Santamaría Rogado
I'm thinking also about the i915 part. Could be something different that Intel does in the Windows version of their driver? Seem very strange that Microsoft could patch something because of this particular hardwares. El mar., 28 abr. 2020 a las 10:45, Hans de Goede () escribió: > > Hi David, > >

[PATCH v3 -next] drm/mediatek: Fix Kconfig warning

2020-04-30 Thread YueHaibing
WARNING: unmet direct dependencies detected for MTK_MMSYS Depends on [n]: (ARCH_MEDIATEK [=y] || COMPILE_TEST [=n]) && COMMON_CLK_MT8173_MMSYS [=n] Selected by [y]: - DRM_MEDIATEK [=y] && HAS_IOMEM [=y] && DRM [=y] && (ARCH_MEDIATEK [=y] || ARM && COMPILE_TEST [=n]) && COMMON_CLK [=y] &&

Re: [PATCH] video: fbdev: pxa3xx_gcu: Fix some resource leak in an error handling path in 'pxa3xx_gcu_probe()'

2020-04-30 Thread Christophe JAILLET
Le 29/04/2020 à 14:25, Dan Carpenter a écrit : On Wed, Apr 29, 2020 at 06:34:38AM +0200, Christophe JAILLET wrote: If an error occurs in the loop where we call 'pxa3xx_gcu_add_buffer()', any resource already allocated should be freed. In order to fix it, add a call to

Re: [PATCH] dma-buf: Documentation: fix: `make htmldocs` warnings

2020-04-30 Thread Randy Dunlap
On 4/29/20 6:59 PM, Vitor Massaru Iha wrote: > Add missed ":" on kernel-doc function parameter. > > This patch fixes this warnings from `make htmldocs`: > ./drivers/dma-buf/dma-buf.c:678: warning: Function parameter or member > 'importer_ops' not described in 'dma_buf_dynamic_attach' >

Re: [PATCH v7 2/2] drm/bridge: anx7625: Add anx7625 MIPI DSI/DPI to DP bridge driver

2020-04-30 Thread Xin Ji
On Tue, Apr 28, 2020 at 12:05:08PM +0200, Daniel Vetter wrote: > On Fri, Apr 24, 2020 at 08:12:04PM +0800, Nicolas Boichat wrote: > > On Fri, Apr 24, 2020 at 2:51 PM Xin Ji wrote: > > > > > > On Thu, Apr 23, 2020 at 07:55:15PM +0800, Nicolas Boichat wrote: > > > > Hi, > > > > > > > > Just

Re: [PATCH 8/8] dt-bindings: display: Convert ingenic, lcd.txt to YAML

2020-04-30 Thread Paul Cercueil
This one patch will need a V2, I messed up with the clocks. -Paul Le dim. 26 avril 2020 à 20:58, Paul Cercueil a écrit : Convert the ingenic,lcd.txt to a new ingenic,lcd.yaml file. In the process, the new ingenic,jz4780-lcd compatible string has been added. Signed-off-by: Paul Cercueil

[PATCH 3/4] drm/amd/display: remove set but not used variable 'speakers' in dce_stream_encoder.c

2020-04-30 Thread Zheng Bin
Fixes gcc '-Wunused-but-set-variable' warning: drivers/gpu/drm/amd/display/dc/dce/dce_stream_encoder.c:1339:11: warning: variable ‘speakers’ set but not used [-Wunused-but-set-variable] It is introduced by commit 4562236b3bc0 ("drm/amd/dc: Add dc display driver (v2)"), but never used, so remove

Re: [PATCH v2] drm: make drm_file use keyed wakeups

2020-04-30 Thread kl
April 28, 2020 5:14 PM, "Daniel Vetter" wrote: > On Fri, Apr 24, 2020 at 06:26:15PM +0200, Kenny Levinsen wrote: > >> Some processes, such as systemd, are only polling for EPOLLERR|EPOLLHUP. >> As drm_file uses unkeyed wakeups, such a poll can receive many spurious >> wakeups from uninteresting

Re: [PATCH hmm 5/5] mm/hmm: remove the customizable pfn format from hmm_range_fault

2020-04-30 Thread Jason Gunthorpe
On Wed, Apr 22, 2020 at 01:52:32PM -0400, Felix Kuehling wrote: > [+Philip Yang] > > Am 2020-04-21 um 8:21 p.m. schrieb Jason Gunthorpe: > > From: Jason Gunthorpe > > > > Presumably the intent here was that hmm_range_fault() could put the data > > into some HW specific format and thus avoid some

[PATCH v2] drm/qxl: lost qxl_bo_kunmap_atomic_page in qxl_image_init_helper()

2020-04-30 Thread Vasily Averin
v2: removed TODO reminder Signed-off-by: Vasily Averin --- drivers/gpu/drm/qxl/qxl_image.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/qxl/qxl_image.c b/drivers/gpu/drm/qxl/qxl_image.c index 43688ecdd8a0..60ab7151b84d 100644 ---

Re: [PATCH v8 1/2] dt-bindings: drm/bridge: anx7625: MIPI to DP transmitter binding

2020-04-30 Thread Xin Ji
Hi Sam, thanks for your comments. On Mon, Apr 27, 2020 at 08:49:09PM +0200, Sam Ravnborg wrote: > Hi Xin Ji > > On Mon, Apr 27, 2020 at 02:17:46PM +0800, Xin Ji wrote: > > The ANX7625 is an ultra-low power 4K Mobile HD Transmitter designed > > for portable device. It converts MIPI to DisplayPort

[PATCH] drm/ast: remove duplicate assignment of ast_crtc_funcs member

2020-04-30 Thread Jason Yan
The struct member 'set_config' was assigned twice: static const struct drm_crtc_funcs ast_crtc_funcs = { .reset = ast_crtc_reset, .set_config = drm_crtc_helper_set_config, .. .set_config = drm_atomic_helper_set_config, .. }; Since the second one is

[PATCH 2/3] drm/amdgpu: remove set but not used variable 'direct_poll' in vcn_v2_0.c

2020-04-30 Thread Zheng Bin
Fixes gcc '-Wunused-but-set-variable' warning: drivers/gpu/drm/amd/amdgpu/vcn_v2_0.c:1848:39: warning: variable ‘direct_poll’ set but not used [-Wunused-but-set-variable] It is introduced by commit dd26858a9cd8 ("drm/amdgpu: implement initialization part on VCN2.0 for SRIOV"), but never used,

Re: [PATCH 01/17] drm/mgag200: Remove HW cursor

2020-04-30 Thread Gerd Hoffmann
On Wed, Apr 29, 2020 at 07:51:07PM +0200, Sam Ravnborg wrote: > On Wed, Apr 29, 2020 at 04:32:22PM +0200, Thomas Zimmermann wrote: > > The HW cursor of Matrox G200 cards only supports a 16-color palette > > format. Univeral planes require at least ARGB or a similar component- > > based format.

Re: [PATCH v8 2/2] drm/bridge: anx7625: Add anx7625 MIPI DSI/DPI to DP bridge driver

2020-04-30 Thread Sam Ravnborg
Hi Xin Ji. > > > +static void anx7625_power_on_init(struct anx7625_data *ctx) > > > +{ > > > + int retry_count, i; > > > + int ret; > > > + struct device *dev = >client->dev; > > > + > > > + for (retry_count = 0; retry_count < 3; retry_count++) { > > > + anx7625_power_on(ctx); > > > +

<    1   2