[PATCH] drm/bridge: anx7625: Use common macros for DP power sequencing commands

2023-01-15 Thread Chen-Yu Tsai
The DRM DP code has macros for the DP power sequencing commands. Use them in the anx7625 driver instead of raw numbers. Fixes: 548b512e144f ("drm/bridge: anx7625: send DPCD command to downstream") Fixes: 27f26359de9b ("drm/bridge: anx7625: Set downstream sink into normal status") Signed-off-by:

[PATCH] drm/bridge: anx7625: Drop device lock before drm_helper_hpd_irq_event()

2023-01-15 Thread Chen-Yu Tsai
The device lock is used to serialize the low level power sequencing operations. Since drm_helper_hpd_irq_event() could end up calling .atomic_enable, which also calls power sequencing functions through runtime PM, this results in a real deadlock. This was observed on an MT8192-based Chromebook's

[PATCH 3/3] drm/msm/dpu: simplify blend configuration

2023-01-15 Thread Dmitry Baryshkov
Rewrite dpu_hw_ctl_setup_blendstage() to use static data configuration rather than using a switch-case. This simplifies adding support for new pipes. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_ctl.c | 156 ++--- 1 file changed, 45 insertions(+), 111

[PATCH 2/3] drm/msm/dpu: simplify ctl_setup_blendstage calculation

2023-01-15 Thread Dmitry Baryshkov
Extract the common expression in the dpu_hw_ctl_setup_blendstage() function. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_ctl.c | 38 +++--- 1 file changed, 19 insertions(+), 19 deletions(-) diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_ctl.c

[PATCH 1/3] drm/msm/dpu: fix blend setup for DMA4 and DMA5 layers

2023-01-15 Thread Dmitry Baryshkov
SM8550 uses new register to map SSPP_DMA4 and SSPP_DMA5 units to blend stages. Add proper support for this register to allow using these two planes for image processing. Fixes: efcd0107727c ("drm/msm/dpu: add support for SM8550") Cc: Neil Armstrong Signed-off-by: Dmitry Baryshkov ---

Re: [PATCH 2/2] drm/i915/gvt: Avoid full proxy f_ops for vgpu_status debug attributes

2023-01-15 Thread Zhenyu Wang
On 2023.01.10 13:49:57 -0500, Rodrigo Vivi wrote: > On Wed, Jan 11, 2023 at 12:00:12AM +0530, Deepak R Varma wrote: > > Using DEFINE_SIMPLE_ATTRIBUTE macro with the debugfs_create_file() > > function adds the overhead of introducing a proxy file operation > > functions to wrap the original

[PATCH] drm/msm/dpu: enable sourcesplit for sc7180/sc7280

2023-01-15 Thread Dmitry Baryshkov
According to the vendor dts files, both sc7180 and sc7280 support the source split mode (using two LMs for a single output). Change these two platforms to use MIXER_SDM845_MASK, which includes DPU_MIXER_SOURCESPLIT. Rename MIXER_SC7180_MASK to MIXER_QCM2290_MASK, since this platform doesn't seem

Re: [PATCH 1/2] drm/ttm: Check ttm_debugfs_root before creating files under it

2023-01-15 Thread Ma, Jun
On 1/13/2023 5:37 PM, Christian König wrote: > Am 13.01.23 um 06:34 schrieb Ma Jun: >> Check the ttm_debugfs_root before creating files under it. >> If the ttm_debugfs_root is NULL, all the files created for >> ttm/ will be placed in the /sys/kerne/debug/ but not >> /sys/kernel/debug/ttm/ > >

Re: [PATCH 2/2] drm/ttm: Use debugfs_remove_recursive to remove ttm directory

2023-01-15 Thread Ma, Jun
On 1/13/2023 5:38 PM, Christian König wrote: > Am 13.01.23 um 06:34 schrieb Ma Jun: >> Use debugfs_remove_recursive to remove the /sys/kernel/debug/ttm >> directory for better compatibility. Becuase debugfs_remove fails >> on older kernel. > > Again NAK for upstreaming. > > The upstream

RE: [PATCH 0/3] drm/amd/pm/powerplay: use bitwise or for bitmasks addition

2023-01-15 Thread Quan, Evan
[AMD Official Use Only - General] Series is reviewed-by: Evan Quan > -Original Message- > From: Deepak R Varma > Sent: Sunday, January 15, 2023 3:16 PM > To: Quan, Evan ; Deucher, Alexander > ; Koenig, Christian > ; Pan, Xinhui ; David > Airlie ; Daniel Vetter ; amd- >

linux-next: manual merge of the fbdev tree with the drm-misc tree

2023-01-15 Thread Stephen Rothwell
Hi all, Today's linux-next merge of the fbdev tree got a conflict in: include/linux/fb.h between commit: 5b6373de4351 ("drm/fbdev: Remove aperture handling and FBINFO_MISC_FIRMWARE") from the drm-misc tree and commit: 72ac3535c2c5 ("fbdev: fb.h: Replace 0-length array with flexible

linux-next: manual merge of the amdgpu tree with the drm-misc tree

2023-01-15 Thread Stephen Rothwell
Hi all, Today's linux-next merge of the amdgpu tree got a conflict in: drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c between commit: a6276e92a037 ("drm: Include where needed") from the drm-misc tree and commit: a98cdd8c4856 ("drm/amd/display: refactor ddc logic from dc_link_ddc to

Re: [REGRESSION] GM20B probe fails after commit 2541626cfb79

2023-01-15 Thread David Airlie
On Thu, Dec 29, 2022 at 12:58 AM Diogo Ivo wrote: > > Hello, > > Commit 2541626cfb79 breaks GM20B probe with > the following kernel log: > > [2.153892] [ cut here ] > [2.153897] WARNING: CPU: 1 PID: 36 at > drivers/gpu/drm/nouveau/nvkm/subdev/mmu/vmmgf100.c:273 >

Re: [PATCH v2] video: fbdev: omapfb: Use kstrtobool() instead of strtobool()

2023-01-15 Thread Helge Deller
On 1/14/23 09:54, Christophe JAILLET wrote: strtobool() is the same as kstrtobool(). However, the latter is more used within the kernel. In order to remove strtobool() and slightly simplify kstrtox.h, switch to the other function name. While at it, include the corresponding header file ()

Re: [PATCH] drm/amd/display: Simplify same effect if/else blocks

2023-01-15 Thread Joe Perches
On Sun, 2023-01-15 at 15:30 +0530, Deepak R Varma wrote: > The if / else block code has same effect irrespective of the logical > evaluation. Hence, simply the implementation by removing the unnecessary > conditional evaluation. While at it, also fix the long line checkpatch > complaint. Issue

Re: [PATCH] fbdev: fbmon: fix function name in kernel-doc

2023-01-15 Thread Helge Deller
On 1/13/23 07:36, Randy Dunlap wrote: Fix a kernel-doc warning by correcting the function name in the kernel-doc comment: drivers/video/fbdev/core/fbmon.c:1073: warning: expecting prototype for fb_get_hblank_by_freq(). Prototype was for fb_get_hblank_by_hfreq() instead Signed-off-by: Randy

Re: [PATCH] fbdev/g364fb: Fix a compilation issue

2023-01-15 Thread Helge Deller
Hi Xurui, On 1/9/23 11:04, Geert Uytterhoeven wrote: This time with the new linux-mips mailing list address... On Mon, Jan 9, 2023 at 11:01 AM Geert Uytterhoeven wrote: Hi Xurui, On Thu, Jan 5, 2023 at 10:45 AM xurui wrote: drivers/video/fbdev/g364fb.c:202:4: error: cast to pointer from

Re: [PATCH 1/6] drm/amdgpu: Generalize KFD dmabuf import

2023-01-15 Thread Felix Kuehling
Am 2023-01-15 um 11:43 schrieb Christian König: Am 14.01.23 um 00:15 schrieb Felix Kuehling: On 2023-01-13 18:00, Chen, Xiaogang wrote: On 1/13/2023 4:26 PM, Felix Kuehling wrote: On 2023-01-12 17:41, Chen, Xiaogang wrote: On 1/11/2023 7:31 PM, Felix Kuehling wrote: Use proper

Re: [PATCH 1/6] drm/amdgpu: Generalize KFD dmabuf import

2023-01-15 Thread Christian König
Am 14.01.23 um 00:15 schrieb Felix Kuehling: On 2023-01-13 18:00, Chen, Xiaogang wrote: On 1/13/2023 4:26 PM, Felix Kuehling wrote: On 2023-01-12 17:41, Chen, Xiaogang wrote: On 1/11/2023 7:31 PM, Felix Kuehling wrote: Use proper amdgpu_gem_prime_import function to handle all kinds of

Re: [PATCH 2/2] Docs: Add some missing SPDX license identifiers of subsystem docs

2023-01-15 Thread Alex Deucher
On Sat, Jan 14, 2023 at 2:48 PM SeongJae Park wrote: > > Some subsystem documents are missing SPDX license identifiers. Add > those. It would be good to split this up per subsystem. > > Signed-off-by: SeongJae Park > --- > Documentation/crypto/index.rst | 2 ++ >

Re: [PATCH 0/3] drm/msm/dpu: several fixes for UBWC setup

2023-01-15 Thread Dmitry Baryshkov
On 13/01/2023 23:43, Abhinav Kumar wrote: On 12/7/2022 6:28 AM, Dmitry Baryshkov wrote: Several small corrections for the UBWC setup and related data. I am assuming this series will be dropped in favor of the RFC: https://patchwork.freedesktop.org/series/111751/ Right? No, they cover

[RFC PATCH] drm/msm/dpu: enable DPU_MDP_AUDIO_SELECT for sc8180x

2023-01-15 Thread Dmitry Baryshkov
According to the discussion ([1]) on the mailing list, platforms before sm8250 (and derivatives) should program HDMI_DP_CORE_SELECT register to route audio to the DP ports. Enable DPU_MDP_AUDIO_SELECT on sc8180x to program correponding register. [1]

[PATCH 2/2] drm/msm/dpu: don't use DPU_CLK_CTRL_CURSORn for DMA SSPP clocks

2023-01-15 Thread Dmitry Baryshkov
DPU driver has been using the DPU_CLK_CTRL_CURSOR prefix for the DMA SSPP blocks used for the cursor planes. This has lead to the confusion at least for the MSM8998 platform. In preparation to supporting the cursor SSPP blocks, use proper enum values to index DMA SSPP clock controls.

[PATCH 1/2] drm/msm/dpu: fix clocks settings for msm8998 SSPP blocks

2023-01-15 Thread Dmitry Baryshkov
DMA2 and DMA3 planes on msm8998 should use corresponding DMA2 and DMA3 clocks rather than CURSOR0/1 clocks (which are used for the CURSOR planes). Correct corresponding SSPP declarations. Fixes: 94391a14fc27 ("drm/msm/dpu1: Add MSM8998 to hw catalog") Cc: AngeloGioacchino Del Regno Cc: Jami

[PATCH] drm/amd/display: Simplify same effect if/else blocks

2023-01-15 Thread Deepak R Varma
The if / else block code has same effect irrespective of the logical evaluation. Hence, simply the implementation by removing the unnecessary conditional evaluation. While at it, also fix the long line checkpatch complaint. Issue identified using cond_no_effect.cocci Coccinelle semantic patch

[PATCH] drm/amd/display: avoid variable reinitialization

2023-01-15 Thread Deepak R Varma
The member variable set_odm_combine is already initialized and hence the reinitialization instruction can be removed. Issue identified using the dubleinit.cocci Coccinelle semantic patch script. Signed-off-by: Deepak R Varma --- drivers/gpu/drm/amd/display/dc/dcn314/dcn314_optc.c | 1 - 1 file

[PATCH] drm/amd/display: use swap() helper macro in bios_parser

2023-01-15 Thread Deepak R Varma
Use swap() helper macro instead of open coded swap instructions. The change also facilitates code cleanup and realignment for improved readability. Issue identified using swap.cocci Coccinelle semantic patch script. Signed-off-by: Deepak R Varma ---